Fedora Linux Support Community & Resources Center
  #1  
Old 18th December 2013, 07:51 PM
pkands Offline
Registered User
 
Join Date: Aug 2004
Posts: 150
linuxfirefox
Fedora 20 AMD catalyst driver

I now have a graphics card that might benefit from using the AMD catalyst driver.
Does anyone have a guess when akmod-catalyst for F20 might arrive?
Reply With Quote
  #2  
Old 18th December 2013, 08:05 PM
leigh123linux
Guest
 
Posts: n/a
linuxfirefox
Re: Fedora 20 AMD catalyst driver

Quote:
Originally Posted by pkands View Post
I now have a graphics card that might benefit from using the AMD catalyst driver.
Does anyone have a guess when akmod-catalyst for F20 might arrive?
NEVER, I orphaned it, no one else volunteered to maintain it so it's been removed.
Reply With Quote
  #3  
Old 18th December 2013, 08:24 PM
digiscuro Offline
Registered User
 
Join Date: Aug 2013
Location: Los Angeles
Posts: 13
windows_7firefox
Re: Fedora 20 AMD catalyst driver

Has anyone been able to get the AMD binary install working? They used to work for me in FC19, but now I get a black screen on boot.
Reply With Quote
  #4  
Old 19th December 2013, 08:39 AM
kkshethin Offline
Registered User
 
Join Date: Dec 2009
Location: India
Posts: 427
linuxfirefox
Re: Fedora 20 AMD catalyst driver

This is really sad news for me as i am going to patiently wait for akmod-catalyst.
In fedora 19 it was must for my laptop. Please refer to my thread "http://forums.fedoraforum.org/showthread.php?t=295541".

I know that leigh may be overburdned. But I was hoping. I could not help in as much i have had no programing knowledge, otherwise i could have offered to maintain it.

In any cae, thanks leigh atleast for maintaining it upto fedora19.
Reply With Quote
  #5  
Old 19th December 2013, 10:11 AM
SCosimo Offline
Registered User
 
Join Date: Jan 2013
Location: Italy
Posts: 3
windows_98_nt_2000chrome
Re: Fedora 20 AMD catalyst driver

I upgraded to Fedora 20 and got black screen. How to fix it?
Reply With Quote
  #6  
Old 19th December 2013, 10:14 AM
leigh123linux
Guest
 
Posts: n/a
linuxfirefox
Re: Fedora 20 AMD catalyst driver

Quote:
Originally Posted by kkshethin View Post
This is really sad news for me as i am going to patiently wait for akmod-catalyst.
In fedora 19 it was must for my laptop. Please refer to my thread "http://forums.fedoraforum.org/showthread.php?t=295541".

I know that leigh may be overburdned. But I was hoping. I could not help in as much i have had no programing knowledge, otherwise i could have offered to maintain it.

In any cae, thanks leigh atleast for maintaining it upto fedora19.

You could try the F19 catalyst packages in F20
Reply With Quote
  #7  
Old 19th December 2013, 12:53 PM
Maxtorete Offline
Registered User
 
Join Date: Jan 2010
Posts: 48
linuxfirefox
Re: Fedora 20 AMD catalyst driver

Quote:
Originally Posted by leigh123linux View Post
You could try the F19 catalyst packages in F20
That is not a good idea, because he will get a black screen. There is a problem with Catalyst and F20 Wayland support on Gnome Shell, as described in this thread:

http://forums.fedoraforum.org/showthread.php?t=295259

At the moment if you want to use Catalyst drivers you must continue with F19.

PS: I haven't tried new Catalyst 13.12 drivers, but I don't hope that they will work on F20.
Reply With Quote
  #8  
Old 19th December 2013, 01:02 PM
leigh123linux
Guest
 
Posts: n/a
linuxfirefox
Re: Fedora 20 AMD catalyst driver

Quote:
Originally Posted by Maxtorete View Post
That is not a good idea, because he will get a black screen. There is a problem with Catalyst and F20 Wayland support on Gnome Shell, as described in this thread:

http://forums.fedoraforum.org/showthread.php?t=295259

At the moment if you want to use Catalyst drivers you must continue with F19.

PS: I haven't tried new Catalyst 13.12 drivers, but I don't hope that they will work on F20.

I wouldn't know as I haven't had any ATI hardware for two years, being unable to test is why I orphaned catalyst at rpmfusion.
It should work in theory as the kernel and xorg versions are the same as F19.
Reply With Quote
  #9  
Old 19th December 2013, 01:48 PM
Maxtorete Offline
Registered User
 
Join Date: Jan 2010
Posts: 48
linuxfirefox
Re: Fedora 20 AMD catalyst driver

Quote:
Originally Posted by leigh123linux View Post
I wouldn't know as I haven't had any ATI hardware for two years, being unable to test is why I orphaned catalyst at rpmfusion.
It should work in theory as the kernel and xorg versions are the same as F19.
I didn't want to be rude with you, I was an entusiast user of your packages and forum posts for years!

It works fine with the Xorg server and the kernel, but Gnome doesn't work. II think the problem is on the EGL side, as it is not supported by Catalystand and has been enabled by default in F20 Gnome packages.
Reply With Quote
  #10  
Old 19th December 2013, 01:57 PM
leigh123linux
Guest
 
Posts: n/a
linuxfirefox
Re: Fedora 20 AMD catalyst driver

Quote:
Originally Posted by Maxtorete View Post
I didn't want to be rude with you, I was an entusiast user of your packages and forum posts for years!

It works fine with the Xorg server and the kernel, but Gnome doesn't work. II think the problem is on the EGL side, as it is not supported by Catalystand and has been enabled by default in F20 Gnome packages.

It could be EGL, there is a patch to add support to catalyst package

https://bugzilla.rpmfusion.org/show_bug.cgi?id=2914


You could rebuild this modified srpm.

https://dl.dropboxusercontent.com/u/...2.fc19.src.rpm

Last edited by leigh123linux; 19th December 2013 at 03:10 PM.
Reply With Quote
  #11  
Old 19th December 2013, 03:13 PM
pkands Offline
Registered User
 
Join Date: Aug 2004
Posts: 150
unknownfirefox
Re: Fedora 20 AMD catalyst driver

Has anyone using Mate tried the driver?
Does mate use EGL..?
Reply With Quote
  #12  
Old 19th December 2013, 03:19 PM
leigh123linux
Guest
 
Posts: n/a
linuxfirefox
Re: Fedora 20 AMD catalyst driver

Quote:
Originally Posted by pkands View Post
Has anyone using Mate tried the driver?
Does mate use EGL..?
From the reports it only affect apps and DE using cogl and clutter, Mate doesn't use cogl or clutter.


Code:
# repoquery --whatrequires mesa-libEGL
bijiben-0:3.10.1-1.fc20.x86_64
cairo-0:1.13.1-0.1.git337ab1f.fc20.i686
cairo-0:1.13.1-0.1.git337ab1f.fc20.x86_64
cairo-gobject-0:1.13.1-0.1.git337ab1f.fc20.i686
cairo-gobject-0:1.13.1-0.1.git337ab1f.fc20.x86_64
caribou-0:0.4.13-1.fc20.i686
caribou-0:0.4.13-1.fc20.x86_64
cheese-2:3.10.2-1.fc20.x86_64
cheese-libs-2:3.10.2-1.fc20.i686
cheese-libs-2:3.10.2-1.fc20.x86_64
cinnamon-0:2.0.13-3.fc20.x86_64
cinnamon-0:2.0.14-4.fc20.x86_64
clutter-0:1.16.2-1.fc20.i686
clutter-0:1.16.2-1.fc20.x86_64
clutter-gst-0:1.6.0-8.fc20.i686
clutter-gst-0:1.6.0-8.fc20.x86_64
clutter-gst2-0:2.0.8-1.fc20.i686
clutter-gst2-0:2.0.8-1.fc20.x86_64
clutter-gtk-0:1.4.4-3.fc20.i686
clutter-gtk-0:1.4.4-3.fc20.x86_64
cogl-0:1.16.0-2.fc20.i686
cogl-0:1.16.0-2.fc20.x86_64
empathy-0:3.10.2-1.fc20.x86_64
empathy-0:3.10.2-2.fc20.x86_64
eog-plugins-0:3.10.1-1.fc20.x86_64
gnome-boxes-0:3.10.2-1.fc20.x86_64
gnome-color-manager-0:3.10.1-1.fc20.x86_64
gnome-color-manager-0:3.10.1-2.fc20.x86_64
gnome-contacts-0:3.10.1-1.fc20.x86_64
gnome-nibbles-0:3.10.1-1.fc20.x86_64
gnome-shell-0:3.10.2.1-2.fc20.x86_64
gnome-shell-0:3.10.2.1-3.fc20.x86_64
gpx-viewer-0:0.3.0-2.fc20.x86_64
gpx-viewer-0:0.4.0-1.fc20.x86_64
gstreamer1-plugins-bad-free-0:1.2.1-2.fc20.i686
gstreamer1-plugins-bad-free-0:1.2.1-2.fc20.x86_64
kde-workspace-0:4.11.3-1.fc20.x86_64
kde-workspace-0:4.11.3-5.fc20.x86_64
kde-workspace-libs-0:4.11.3-1.fc20.i686
kde-workspace-libs-0:4.11.3-1.fc20.x86_64
kde-workspace-libs-0:4.11.3-5.fc20.i686
kde-workspace-libs-0:4.11.3-5.fc20.x86_64
kwin-gles-0:4.11.3-1.fc20.x86_64
kwin-gles-0:4.11.3-5.fc20.x86_64
kwin-gles-libs-0:4.11.3-1.fc20.i686
kwin-gles-libs-0:4.11.3-1.fc20.x86_64
kwin-gles-libs-0:4.11.3-5.fc20.i686
kwin-gles-libs-0:4.11.3-5.fc20.x86_64
libmash-0:0.2.0-11.fc20.i686
libmash-0:0.2.0-11.fc20.x86_64
libmx-0:1.4.7-9.fc20.i686
libmx-0:1.4.7-9.fc20.x86_64
libva-0:1.2.1-2.fc20.i686
libva-0:1.2.1-2.fc20.x86_64
libwebkit2gtk-0:2.2.2-2.fc20.i686
libwebkit2gtk-0:2.2.2-2.fc20.x86_64
libwebkit2gtk-0:2.2.3-1.fc20.i686
libwebkit2gtk-0:2.2.3-1.fc20.x86_64
lightsoff-0:3.10.1-1.fc20.x86_64
media-explorer-0:0.4.4-4.fc20.i686
media-explorer-0:0.4.4-4.fc20.x86_64
mesa-libEGL-devel-0:9.2.3-1.20131114.fc20.i686
mesa-libEGL-devel-0:9.2.3-1.20131114.fc20.x86_64
mesa-libEGL-devel-0:9.2.4-1.20131128.fc20.i686
mesa-libEGL-devel-0:9.2.4-1.20131128.fc20.x86_64
mplayer-0:1.1-16.20131125svn.fc20.x86_64
mplayer-gui-0:1.1-16.20131125svn.fc20.x86_64
muffin-0:2.0.5-1.fc20.i686
muffin-0:2.0.5-1.fc20.x86_64
muffin-devel-0:2.0.5-1.fc20.i686
muffin-devel-0:2.0.5-1.fc20.x86_64
mutter-0:3.10.2-2.fc20.i686
mutter-0:3.10.2-2.fc20.x86_64
mutter-wayland-0:3.10.1-1.fc20.i686
mutter-wayland-0:3.10.1-1.fc20.x86_64
nemo-preview-0:2.0.0-0.3.git6c86726.fc20.x86_64
pcsx2-0:1.1.0-5.fc20.i686
pinpoint-0:0.1.4-15.fc20.x86_64
presence-0:0.4.8-8.fc20.x86_64
qt5-qtbase-gui-0:5.2.0-0.7.beta1.20131108_141.fc20.i686
qt5-qtbase-gui-0:5.2.0-0.7.beta1.20131108_141.fc20.x86_64
quadrapassel-0:3.10.2-1.fc20.x86_64
rhythmbox-0:3.0-3.fc20.i686
rhythmbox-0:3.0-3.fc20.x86_64
snappy-player-0:0.3.7-2.20131121git0bd0c0c3.fc20.x86_64
sushi-0:3.10.0-1.fc20.x86_64
swell-foop-0:3.10.1-1.fc20.x86_64
totem-1:3.10.1-1.fc20.i686
totem-1:3.10.1-1.fc20.x86_64
totem-lirc-1:3.10.1-1.fc20.x86_64
totem-mozplugin-1:3.10.1-1.fc20.x86_64
webkitgtk-0:2.2.2-1.fc20.i686
webkitgtk-0:2.2.2-1.fc20.x86_64
webkitgtk-0:2.2.3-1.fc20.i686
webkitgtk-0:2.2.3-1.fc20.x86_64
webkitgtk3-0:2.2.2-2.fc20.i686
webkitgtk3-0:2.2.2-2.fc20.x86_64
webkitgtk3-0:2.2.3-1.fc20.i686
webkitgtk3-0:2.2.3-1.fc20.x86_64
weston-0:1.2.0-2.fc20.x86_64
xorg-x11-glamor-0:0.5.1-1.20131009gitba209eee.fc20.i686
xorg-x11-glamor-0:0.5.1-1.20131009gitba209eee.fc20.x86_64
My previous post has a modified catalyst srpm with EGL support
Reply With Quote
  #13  
Old 19th December 2013, 07:59 PM
Maxtorete Offline
Registered User
 
Join Date: Jan 2010
Posts: 48
linuxfirefox
Re: Fedora 20 AMD catalyst driver

Quote:
Originally Posted by leigh123linux View Post
It could be EGL, there is a patch to add support to catalyst package

https://bugzilla.rpmfusion.org/show_bug.cgi?id=2914


You could rebuild this modified srpm.

https://dl.dropboxusercontent.com/u/...2.fc19.src.rpm
The SRPM doesn't work either
Reply With Quote
  #14  
Old 19th December 2013, 08:22 PM
castagna Offline
Registered User
 
Join Date: Sep 2005
Posts: 8
linuxchrome
Re: Fedora 20 AMD catalyst driver

I've tried to remove the wayland support by recompiling the rpms as suggested in the third post of

http://forums.fedoraforum.org/showthread.php?t=295259

Unfortunately the method above no longer works since, I guess, the wayland patch has been included in the current package. Any cue?
Reply With Quote
  #15  
Old 20th December 2013, 11:09 AM
fadamsxii Offline
Registered User
 
Join Date: Dec 2013
Location: Orlando
Posts: 4
linuxfirefox
Unhappy Re: Fedora 20 AMD catalyst driver

I had to register just to say this: if Fedora won't support a major graphics driver, the project is going to lose a hell of alot of mindshare. And why haven't any officials from the project said anything about this? This is a pretty major issue, quite a number of people use Catalyst and other distros have it as well. Too bad the Binary doesn't work.

Honestly, I would have never upgraded (which to be honest is feeling like a Windows 8 style downgrade since AMD users are forced to use mesa now, no matter what, apparently. So much for freedom of choice, eh?) if I had known that Catalyst was orphaned and wont get a release on Fedora 20.

I don't blame you for quitting Leigh, with no support and a different hardware vendor than what you were working on, I'd have done the same. And thank you for working on this for as long as you did.
Reply With Quote
Reply

Tags
amd, catalyst, driver, fedora

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
how to install AMD Catalyst driver in fedora Jam 19 bhatta Installation, Upgrades and Live Media 2 9th August 2013 08:02 AM
AMD Catalyst Driver on F18 64-bit Louisda16th Hardware & Laptops 2 20th January 2013 05:17 PM
AMD Catalyst 11.9 Driver Is Now Available Dutchy Hardware & Laptops 5 3rd October 2011 10:16 AM
AMD Catalyst 11.6 Driver released johnrdavisjr Hardware & Laptops 1 18th June 2011 05:21 PM
AMD Dropping R300-R500 Support In Catalyst Driver Demz Using Fedora 28 6th March 2009 09:47 PM


Current GMT-time: 07:22 (Tuesday, 30-08-2016)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat