Fedora Linux Support Community & Resources Center
  #1  
Old 19th November 2009, 08:01 AM
LinuxDanP's Avatar
LinuxDanP Offline
Registered User
 
Join Date: May 2009
Location: CA, USA
Age: 24
Posts: 73
linuxfedorafirefox
slow KDE menu after nVidia install

I just install Fedora 12 x86_64 from the Live CD. KDE and all was just fine until I installed the nVidia drivers. Now when I click on the menu launcher on the bottom-left corner of the panel, the menu takes around ten seconds to come up. I can make do with the Application Launcher widget, but it's a little annoying since it's up all the time. Everything else seems fine. Any suggestions?

Thanks
LinuxDanP
Reply With Quote
  #2  
Old 19th November 2009, 11:49 AM
denisk
Guest
 
Posts: n/a
linuxfedorafirefox
I have the same problem but I upgraded from Fedora 11 so I didn't know what could be the cause. Thanks for info.
Reply With Quote
  #3  
Old 19th November 2009, 12:33 PM
Freddyx Offline
Registered User
 
Join Date: Nov 2009
Posts: 1
linuxsafari
similar problem for me, i upgraded with preupgrade and install 190.42 nvidia driver, when i click on the menu launcher system freeze for 1 minutes about
Reply With Quote
  #4  
Old 19th November 2009, 01:14 PM
tas0s Offline
Registered User
 
Join Date: Jul 2009
Posts: 8
linuxfedorafirefox
It has been reported in another thread.Its a nvidia driver issue.Please look the release notes.If I remember right,somewhere at the bottom is says for Nvidia + kde
Reply With Quote
  #5  
Old 19th November 2009, 03:32 PM
lethologica Offline
Registered User
 
Join Date: Jun 2009
Posts: 19
windows_vistaie
Yep same problem here. Here is the link to the release notes

https://fedoraproject.org/wiki/Commo...ly_with_KDE.29

With the default driver I was not able to get my monitors native resolution (1920x1080). What drivers can I use for my GeForce 8400 which will also allow me to use my native resolution? I don't care about 3D performance at this time, just desktop performance.
Reply With Quote
  #6  
Old 19th November 2009, 06:20 PM
denisk
Guest
 
Posts: n/a
linuxfedorafirefox
I switched to nouveau driver on my Quadro NVS 320M and everything works fine, Well, except 3D but I can live without it for a couple of days.
Reply With Quote
  #7  
Old 19th November 2009, 06:28 PM
josue2009 Offline
Registered User
 
Join Date: Nov 2009
Posts: 1
windows_xp_2003firefox
hi

Quote:
Originally Posted by denisk View Post
I have the same problem but I upgraded from Fedora 11 so I didn't know what could be the cause. Thanks for info.
can somebody tell me please, like he/she settles, fedora 12 live cd kde, doesn't one eat to enter to the desk, doesn't it happen to me of the login menu, where he/she says live user????
Reply With Quote
  #8  
Old 19th November 2009, 06:44 PM
denisk
Guest
 
Posts: n/a
linuxfedorafirefox
Quote:
Originally Posted by josue2009 View Post
can somebody tell me please, like he/she settles, fedora 12 live cd kde, doesn't one eat to enter to the desk, doesn't it happen to me of the login menu, where he/she says live user????
hi,
I must say I don't quite understand you...sorry. I never tried live CD anyway, I installed from DVD.
But live CD shouldn't use nvidia proprietary drivers. right?
I mean I'm sure you won't have this nvidia/Xorg problems if you use Fedora live KDE CD

Last edited by denisk; 19th November 2009 at 06:51 PM.
Reply With Quote
  #9  
Old 19th November 2009, 07:45 PM
chepioq's Avatar
chepioq Offline
Registered User
 
Join Date: Jun 2007
Location: Aubagne France
Age: 62
Posts: 652
linuxfirefox
I have same problem when I use fedora12 rawhide and nvidia 190.42.
It is not a problem with the nvidia driver, but with the xorg-x11-server, who is 1.7.1.7 version in the install of F12.
I solve the problem by downgrading xorg-x11-server-Xorg and xorg-x11-server-common to 1.7.1.3 version.
You find it in koji here: http://koji.fedoraproject.org/koji/b...buildID=139659
Reply With Quote
  #10  
Old 19th November 2009, 08:53 PM
denisk
Guest
 
Posts: n/a
linuxfedorafirefox
Thanks for the link chepioq, I'll give it a try when I feel like playing vegastrike or urban terror In the meantime I will try to setup nuoveau on dual monitor when I get back to work.
Reply With Quote
  #11  
Old 19th November 2009, 09:18 PM
tas0s Offline
Registered User
 
Join Date: Jul 2009
Posts: 8
linuxfedorafirefox
Did you have any Xorg crashes with segmentation fault?From version 1.7.1.3 and after, X keeps crashing with seg faults at random times.
With nouveau all its ok,so I think that again is nvidia fault :S
Reply With Quote
  #12  
Old 19th November 2009, 10:14 PM
denisk
Guest
 
Posts: n/a
linuxfedorafirefox
no crashes, KDE was just annoyingly slow and unresponsive (especially 'start' menu which, when pressed, halted the machine for 10-15 seconds. But X never segfaulted. I switched soon to IceWM which worked fine. Now KDE is usable again with nouveau.
Maybe it is KDE's fault
Reply With Quote
  #13  
Old 19th November 2009, 11:46 PM
LinuxDanP's Avatar
LinuxDanP Offline
Registered User
 
Join Date: May 2009
Location: CA, USA
Age: 24
Posts: 73
linuxfedorafirefox
That seems likely. The only two problems I've discovered so far are the slow menu, and the device notifier. The work around to both of those problems is the application launcher widget and the device notifier widget. Both of those work fine for me, but they do take up desk space.
Reply With Quote
  #14  
Old 19th November 2009, 11:58 PM
AdamW's Avatar
AdamW Offline
Fedora QA Community Monkey
 
Join Date: Dec 2008
Location: Vancouver, BC
Posts: 4,327
linuxfedorafirefox
the common bugs explains the practical impact of this. You can either use the nouveau driver, or you can use the scratch build of xorg-x11-server - available from the bug report - which works around this issue.

The ultimate underlying bug here, as pointed out by NVIDIA, is actually elsewhere in the X server (libfb):

https://bugs.freedesktop.org/show_bug.cgi?id=25136

the patch which initially exposes the issue is, in itself, correct.
__________________
Adam Williamson | awilliam AT redhat DOT com
Fedora QA Community Monkey
IRC: adamw | Twitter: AdamW_Fedora | identi.ca: adamwfedora
http://www.happyassassin.net
Reply With Quote
  #15  
Old 20th November 2009, 04:31 AM
Milena's Avatar
Milena Offline
Registered User
 
Join Date: Mar 2009
Location: Europe
Posts: 304
linuxfedorafirefox
open xorg.conf and add:

Code:
Option "UseEvents" "false"
to the device section, see if it works with either false or true.

http://forums.fedoraforum.org/showthread.php?p=1287354

its on nvidia forums as well.

http://www.nvnews.net/vbulletin/showthread.php?t=140821
Reply With Quote
Reply

Tags
install , kde , menu , nvidia , slow

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Slow menu pop-ups... hardware, or software? buccaneere Linux Chat 4 27th September 2009 04:42 PM
Desktop effects = slow gnome menu CopyrightPhilly Using Fedora 1 7th April 2008 11:07 PM
slow Nvidia graphics martypants Using Fedora 6 23rd March 2008 11:46 AM
Nvidia SATA - Slow on 2.6.22? wahman143 Using Fedora 1 12th September 2007 05:46 PM
Fedora Core 4 Menu Slow glennzo Using Fedora 2 3rd August 2005 05:03 PM


Current GMT-time: 13:45 (Saturday, 21-10-2017)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat