Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Fedora Resources > Guides & Solutions (Not For Questions)
FedoraForum Search

Forgot Password? Join Us!

Guides & Solutions (Not For Questions) Post your guides here (No links to Blogs accepted). You can also append your comments/questions to a guide, but don't start a new thread to ask a question. Use another forum for that.

Thread Tools Search this Thread Display Modes
Old 4th January 2009, 11:35 PM
oystercatcher Offline
Registered User
Join Date: Jul 2004
Posts: 289
how to input japanese hiragana or katakana characters

This document assumes that you are using a graphical X
display with gnome instead of kde.
It also assumes that you have a locale which does not
normally support the characters you want to input.
Finally there is the assumption you have installed at
least some other language besides english.

We begin by checking the locale on your fc10 system.

Open a terminal window
Applications -> System Tools -> Terminal

Type on the command line locale
a list of settings will be displayed and in my case the
first is LANG=en_US.UTF-8 which means I have a
US english locale and UTF-8 encoding which is a set of
unicode characters designed for unix systems which won't
interfere with ascii non print characters like newline

Character Map method

This is most likely the simplest method of all

01. on the menu bar go to the character map

Applications -> Accessories -> Character Map

The left hand side has a scrolling list of
languages which you can mouse click on to
display the character table. The english
locale default is Latin and you can use the
right hand side scroll bar to see the full
list. A mouse click on any single character
displays the Unicode and the key combination
to input for that character.

If you double click the letter it will go into
the bottom box called Text to copy. You can then
copy a letter or string of letters into the
application document you are editing.

SCIM method

This next input method lays out the steps to get
scim up and running and briefly how to use it.
For details go to http://www.scim-im.org/

01. It is assumed that you have an installed fc10 system
Begin by checking for prerequisite rpm packages.

Open a terminal window
Applications -> System Tools -> Terminal

You do not have to be root to run these commands
in a terminal window.

rpm -qa | grep scim

here is the list on my system


If you have any problems with starting or
using scim check the list here and install
any missing rpms.

02. in a terminal window check if scim is started
probably not as yet, so don't worry if you don't
see the list as I have shown.

ps aux | grep scim

here is the list from my fc10 system after I had
enabled scim.

user 5634 0.0 0.1 6104 1296 ? S 07:35 0:00 /usr/bin/scim
user 5644 0.0 3.8 81200 29760 ? Ss 07:35 0:00 /usr/lib/scim-1.0/scim-launcher -d -c simple -e all -f socket --no-stay
user 5645 0.0 0.4 23124 3164 ? S 07:35 0:00 /usr/lib/scim-1.0/scim-launcher -c socket -e socket -f x11
user 5648 0.0 0.2 19572 2084 ? Ss 07:35 0:00 /usr/lib/scim-1.0/scim-helper-manager
user 5649 0.1 1.5 49208 11776 ? Ssl 07:35 0:15 /usr/lib/scim-1.0/scim-panel-gtk --display :0.0 -c socket -d --no-stay
user 5661 0.0 3.9 81788 30504 ? S 07:35 0:05 scim-bridge
user 9201 0.0 0.5 19012 4628 ? Ss 07:40 0:00 /usr/lib/scim-1.0/scim-helper-launcher --daemon --config socket --display :0.0 anthy-imengine-helper 24a65e2b-10a8-4d4c-adc9-266678cb1a38
user 15075 0.0 0.0 4212 708 pts/1 S+ 10:38 0:00 grep scim

03. From the desktop menu bar select

System -> Preferences -> Personal -> Input Method

This should open a window titled
IM Chooser - Input Method

click the box - Enable input method feature
and the box - Show the status icon

I noticed the terminal window became unresponsive
while typing and I had to open another tty to kill
scim so I could close this document.
On fc8 it was necessary to logout and login to use
scim so that may explain the odd behavior.

04. On the desktop menu bar there should be two new icons
The scim bridge looks like a square. Left clicking
on it brings up a list of languages for input and
right clicking on it a menu with checkboxes.

The other icon looks a bit like a microphone or
perhaps something else. Left clicking on it shows
a status message as to whether input method is
active or not. Right clicking brings up the

For the moment you do not need to do anything with
these icons.

05. To trigger the input method use ctrl + spacebar

To test this open the character map application
and find a character to input I am going to try
hiragana which is a japanese character set.

Clicking the top left character in the character
table shows on the bottom of the window

so to input this character just press the letter a

To avoid fouling up anything else you might be
working on, open a new terminal window, get focus
on it and type anything to insure you are still
in normal mode. Then press ctrl + spacebar
also called ctrl + space. Either left ctrl or
right ctrl key will work. In case the key
combination is not entirely clear you will press
and hold the ctrl key then press the spacebar
and release both keys. The trigger key combination
is a toggle so the applet will open or close each
time the trigger is used.

A desktop applet should popup; on my system near the
bottom right of the screen.

The default setting is to hide the applet when the
input application loses focus. So if you move
your mouse away from the terminal window the applet
hides itself and when you move the mouse back to
the terminal window it reappears.

06. If the applet does not show up it may be a bit
delayed if your system is slow or short on
memory like mine.

The applet has multiple buttons and the number can
change depending on the language chosen for input.

The first left hand button opens a menu when you
right click on it. Left clicking on it allows the
applet to be moved around on the desktop.

The second button from the left allows you to choose
an input language. I noticed the default language on
the button was the first on the list inscript and
was not able to remove it from the top set of

Right click brings up the menu again and left click
brings up a list of languages. Clicking on a language
adds it to the top list of preferences. You may
have to click it again once it is in the top list
to have it show up on the applet. I choose japanese
which changes the list of buttons on the applet

The second button should now look like a crown and
the text should be anthy. A left click on the next
button to the right selects the input character set
hiragana, katakana and some other options.

07. OK we are ready to input japanese characters, in the
character map window you can see the keyboard
character or characters you need to type which results
in the hiragana character. I am going to enter the
characters for fedora, which appears to be a bit of
a problem as I couldn't find a character for fe so
I used fu and added e afterwards.

fu e do ra

I should mention an anomaly here, I was using a pdf
chart found on the internet which has the romaji
vowel sound associated with the hiragana character
and to my surprise the character fu has more than
one form. The one in the fedora character map differs
from that shown in the random house japanese-english
dictionary by seigo nakao and also in the berlitz
essential japanese by lynee strugnell. It was the
same character in japanese verbs by tim matheson.

08. If you want to enter raw unicode you can change the
input language to raw code and just enter the numbers
for the desired characters. So for hiragan fu enter
3075 a window pops open with samples just click the
hiragana character. I believe this is primarily
available for developer testing.

09. After you are done typing press ctrl + spacebar
to turn off the im applet.
Reply With Quote

characters, hiragana, input, japanese, katakana

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
kakasi (japanese kanji to hiragana conversion) problems gogalago Using Fedora 1 19th October 2008 07:34 AM
SCIM - Japanese/Korean messy characters PantsuJanai Using Fedora 1 9th June 2007 06:08 AM
Writing Japanese characters code_astronomer Using Fedora 3 13th January 2006 05:56 PM
Japanese Characters ewdi Using Fedora 2 27th September 2004 11:21 PM
Invalid Unicode on HDD & Japanese characters on web page Deja Vu Hardware & Laptops 3 25th February 2004 05:52 AM

Current GMT-time: 02:10 (Saturday, 23-09-2017)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat