Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Fedora Resources > Guides & Solutions (Not For Questions)
FedoraForum Search

Forgot Password? Join Us!

Guides & Solutions (Not For Questions) Post your guides here (No links to Blogs accepted). You can also append your comments/questions to a guide, but don't start a new thread to ask a question. Use another forum for that.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 21st February 2007, 05:36 AM
Duli Offline
Registered User
 
Join Date: Jul 2006
Location: Sao Paulo, SP - Brazil
Age: 37
Posts: 712
How to Dell Latitude D520 + FC6

Hello,

I've recently bought a Dell Latitude D520 laptop and after some struggle I have managed to put it in a usable way with Fedora Core 6 (i386 version).

In order to avoid other people's suffering, I've decided to write this little how to.

Main info about my machine:

cpu: model name: Intel(R) Celeron(R) M CPU 430 @ 1.73GHz

MemTotal: 505452 kB

video: 00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/940GML Express Integrated Graphics Controller (rev 03)

wireless: 0c:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)

smbus: 00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 01)

Kernel tested:
Code:
[root@localhost ~]# uname -rm
2.6.19-1.2911.fc6 i686
MAIN STEPS

BIOS preparation: Since this computer does not have a hardware switch to turn on or off the wireless, you should want to disable the hotkey feature from the BIOS, so the wireless stays always on. To do that, simply hit F2 when the computer boots and do a:

Wireless > Wireless hotkey > none

Exit and save

If you don't do it, your wireless will be always off and the only way to turn it on from Fedora is manually, as described below.


INSTALLING:

01 - Download the fedora unity's fc6 re-spin version from:

http://torrent.fedoraunity.org/unity...1.torrent/view

02 - Install and apply all updates with (as root):
Code:
yum update -y
03 - Reboot

Your system should be runnig in a standard manner.


FIX TO SATA DVD/CD DRIVE

Your SATA DVD/CD will be recognized as an IDE drive and will run terribly slow (because the DMA feature won't be turned on). You won't even be able to watch DVD movies on it.

More explanation about the issue here:

01 - To check if your drive was recognized as an IDE drive, type:

Code:
ll /dev/cdrom
It should read something starting with sc and hot hd.

02 - In order to fix that, edit your menu.lst file (as root):

Code:
gedit /boot/grub/menu.lst
And add the following to all of your kernel lines: combined_mode=libata

The result should be something like:

Code:
title Fedora Core (2.6.19-1.2911.fc6)
	root (hd0,0)
	kernel /vmlinuz-2.6.19-1.2911.fc6 ro root=/dev/VolGroup00/LogVol00 rhgb quiet combined_mode=libata
	initrd /initrd-2.6.19-1.2911.fc6.img
title Fedora Core (2.6.19-1.2895.fc6)
	root (hd0,0)
	kernel /vmlinuz-2.6.19-1.2895.fc6 ro root=/dev/VolGroup00/LogVol00 rhgb quiet combined_mode=libata
	initrd /initrd-2.6.19-1.2895.fc6.img
03 - Reboot

04 - Type the ll /dev/cdrom again and check if the drive reads as sc:

Code:
[root@localhost ~]# ll /dev/cdrom
lrwxrwxrwx 1 root root 4 Fev 21 01:17 /dev/cdrom -> scd0
05 - When you update your kernel to newer versions, try to remove the option mentioned to check if the problem has been solved.


GETTING WIRELESS TO WORK

The driver for the Intel PRO/Wireless 3945ABG already comes with FC6. You are just a few steps to get the whole thing up and running.

01 - Make sure you've prepared the BIOS to let the wireless card always on, as described above.

02 - Proceed as follows (as root):

Code:
yum install -y dkms
rpm --import http://freshrpms.net/RPM-GPG-KEY-freshrpms
03 - Manually download these packages from freshrpms:

http://ftp.freshrpms.net/pub/freshrp...1-1.noarch.rpm

http://ftp.freshrpms.net/pub/freshrp....22-4.i386.rpm

http://ftp.freshrpms.net/pub/freshrp...2-1.noarch.rpm


04 - Go to the folder where you've just downloaded the packages and manually install the three packages (as root):

Code:
yum localinstall dkms-ipw3945-1.2.0-1.noarch.rpm ipw3945d-1.7.22-4.i386.rpm ipw3945-firmware-1.13-1.noarch.rpm
The yum program will automatically download some dependencies from extras and updates.

PS: If you want to automatically check for ipw3945 updates, but do not want entirely use the freshrpms repo, then you should normally add freshrpms repo to your system, then edit the file /etc/yum.repos.d/freshrpms.repo and add the following line:

Code:
includepkgs=*ipw3945*
This will cause yum to get only the necessary packages from freshrpms and it will maintain your livna setup clean.

05 - Reboot

06 - Enable the NetworkManager services:

Code:
chkconfig NetworkManager on --level 35
chkconfig NetworkManagerDispatcher on --level 35
07 - Reboot

08 - Now your NetworkManager icon should be in your workbar and you'll have the option to select the wireless network to connect to. It will ask you to create a keyring and stuff. Just proceed and everything should be working. For me, I had to manually select the type of encryption. Leaving "auto" didn't work at all.

09 - After creating a default key to unlock the keyring, if you do not want to be asked again to unlock the keyring when you login a new session, proceed like this:

Code:
yum install -y pam_keyring
And add the following lines to your /etc/pam.d/gdm file:

Code:
auth optional pam_keyring.so try_first_pass
session optional pam_keyring.so
The result should be something like this:

Code:
#%PAM-1.0
auth       required    pam_env.so
auth optional pam_keyring.so try_first_pass
auth       include     system-auth
account    required    pam_nologin.so
account    include     system-auth
password   include     system-auth
session    optional    pam_keyinit.so force revoke
session    include     system-auth
session    required    pam_loginuid.so
session    optional    pam_console.so
session optional pam_keyring.so
PS: It works ok if the defined key to unlock the keyring is the same you use as password to login your session. If they are different, then you should read instructions here.


To manually enable the wireless card (as turn on the wireless switch) (as root):

Code:
echo 0 > /sys/devices/pci0000:00/0000:00:1c.1/0000:0c:00.0/rf_kill
To manually disable it (as turn off the wireless switch):

Code:
echo 1 > /sys/devices/pci0000:00/0000:00:1c.1/0000:0c:00.0/rf_kill

There's a script here about getting the wireless running automatically after a hibernate/suspend. I haven't checked it yet.


** PS: If you´re running F7, then maybe you should take a look here.



BERYL WHITE MAXIMIZED BORDERS FIX

Beryl has worked right away. I didn't have to change anything in xorg.conf file. Just installed it and run beryl-manager.

The only problem I had was maximized windows. The borders got white. To fix that:

01 - Install driconf:

Code:
yum install -y driconf
02 - Run driconf as root:

Code:
su -
driconf
03 - Don't need to change anything. Click Expert Mode and hit "save".

04 - Now edit the file drirc:

Code:
gedit /etc/drirc
05 - Input the following line in it (<option name="allow_large_textures" value="2" />):

Code:
<driconf>
    <device screen="0" driver="i915">
        <application name="all">
		<option name="allow_large_textures" value="2" />
        </application>
    </device>
</driconf>
06 - Exit session and login.

07 - Maximize any window to see if the white borders went away.

More info: http://bugs.beryl-project.org/ticket/37

PS: I set up more memory for the video, but it's not necessary. Edit your xorg.conf file and add "Videoram 28672" (for 28MB) under the "Device" section.


MPLAYER XV DRIVER/BLUE SCREEN WHEN MOVING FIX

When I move mplayer or vlc windows, the video stucks (stays at the same place, but running), and I get blue spaces around it.

The problem seems to be with the xv driver:

http://www.fedoraforum.org/forum/sho...d.php?t=147741

So a workaround is to change the xv driver for the x11 (XShm). Launch mplayer, go to prefrences and go to the "Video" tab. Then under "Video drivers" make sure that "x11 (XShm)" is highlighted. In Xine, open the setup window and click the Video tab. Change the video driver to "xshm", click Apply, and restart Xine. VLC has also a preferences menu under Video to change this. (http://wiki.beryl-project.org/wiki/T...transformed.21).

The videos become a lot worse with the x11 driver. I'm still looking for a solution to play videos with the xv driver in this computer. Suggestions are welcome. See this thread also. I've tried the 915resolution package but it didn't help.


THAT'S IT

Well, if you have any comments, corrections etc., please, post here!

I don't know how to control the Fn keys in Fedora (change LCD brightness and stuff). If you know, please help!!

Cheers,
Duli

Last edited by Duli; 8th June 2007 at 02:07 PM.
Reply With Quote
  #2  
Old 16th May 2007, 01:47 AM
souptoy Offline
Registered User
 
Join Date: Jan 2007
Location: Long Beach, CA
Age: 34
Posts: 4
hey i kinda started your tutorial after having followed some of the ieee80211 instructions and one of them said to remove old 80211 files and then use %make followed by #make install....problem is that it says this now:

[root@localhost ~]# chkconfig NetworkManger on --level 35
error reading information on service NetworkManger: No such file or directory
[root@localhost ~]# chkconfig NetworkMangerDispatcher on --level 35
error reading information on service NetworkMangerDispatcher: No such file or directory

the 80211 instructions said the following:
%tar xzvf ieee*
%cd ieee*
%make
******ASKS ME TO REMOVE OLD FILES SO I SAID NO****** but then it gives instructions to run %sudo make check_old and answer yes to all prompts....erasing the files...now i dont know what to do besides reimage and start from scratch =[ anyone help?
Reply With Quote
  #3  
Old 16th May 2007, 06:22 PM
Duli Offline
Registered User
 
Join Date: Jul 2006
Location: Sao Paulo, SP - Brazil
Age: 37
Posts: 712
Quote:
Originally Posted by souptoy
hey i kinda started your tutorial after having followed some of the ieee80211 instructions and one of them said to remove old 80211 files and then use %make followed by #make install....problem is that it says this now:

[root@localhost ~]# chkconfig NetworkManger on --level 35
error reading information on service NetworkManger: No such file or directory
[root@localhost ~]# chkconfig NetworkMangerDispatcher on --level 35
error reading information on service NetworkMangerDispatcher: No such file or directory

the 80211 instructions said the following:
%tar xzvf ieee*
%cd ieee*
%make
******ASKS ME TO REMOVE OLD FILES SO I SAID NO****** but then it gives instructions to run %sudo make check_old and answer yes to all prompts....erasing the files...now i dont know what to do besides reimage and start from scratch =[ anyone help?
Hum, sorry.... Can´t help you except by suggesting you do the reimage from scratch and then folow my how-to....

Duli
Reply With Quote
  #4  
Old 7th June 2007, 09:56 AM
Malachai Offline
Registered User
 
Join Date: Jan 2006
Location: USA
Posts: 275
Hey Bro the links are broken for the rpm to download... Can you repost...


Thanks
Reply With Quote
  #5  
Old 8th June 2007, 02:08 PM
Duli Offline
Registered User
 
Join Date: Jul 2006
Location: Sao Paulo, SP - Brazil
Age: 37
Posts: 712
Quote:
Originally Posted by Malachai
Hey Bro the links are broken for the rpm to download... Can you repost...


Thanks
Okay, just did it. They´re working again.

Tks
Duli
Reply With Quote
  #6  
Old 8th June 2007, 11:47 PM
Malachai Offline
Registered User
 
Join Date: Jan 2006
Location: USA
Posts: 275
Quote:
Originally Posted by Duli
Okay, just did it. They´re working again.

Tks
Duli

Thank you for the update. I was wondering since I'm using KDE, and I know that Networkmanager does not work on that... What other can I use to detect wifi connection?

NetworkManagerDispatch is the icon I believe that shows up on the toolbar.
Reply With Quote
  #7  
Old 9th June 2007, 05:23 PM
Duli Offline
Registered User
 
Join Date: Jul 2006
Location: Sao Paulo, SP - Brazil
Age: 37
Posts: 712
Doesn't work on KDE??? I didn't know that... In that case, maybe you could try to use the command line..

Code:
[root@localhost ~]# iw
iwconfig  iwevent   iwgetid   iwlist    iwpriv    iwspy
Sorry I can't be of anymore help!!! :-(

Duli
Reply With Quote
  #8  
Old 11th June 2007, 01:24 AM
Duli Offline
Registered User
 
Join Date: Jul 2006
Location: Sao Paulo, SP - Brazil
Age: 37
Posts: 712
Quote:
Originally Posted by Malachai
Thank you for the update. I was wondering since I'm using KDE, and I know that Networkmanager does not work on that... What other can I use to detect wifi connection?

NetworkManagerDispatch is the icon I believe that shows up on the toolbar.
Hello, have you tried out knetworkmanager?

Code:
[duli@localhost ~]$ yum info knetworkmanager
Loading "installonlyn" plugin
Installed Packages
Name   : knetworkmanager
Arch   : i386
Version: 0.1
Release: 0.9.svn20070409.fc7
Size   : 890 k
Repo   : installed
Summary: KDE applet for Network Manager

Description:
KNetworkManager is a system tray applet for controlling network
connections on systems that use the NetworkManager daemon.
I think it does the same in KDE.

Duli
Reply With Quote
  #9  
Old 15th June 2007, 05:32 AM
SideshowMel Offline
Registered User
 
Join Date: Feb 2007
Location: Denver, CO
Posts: 220
I followed these instructions precisely on a fresh FC6 install from start to finish. The wireless setup is the only place I had a problem:

Everything looks good except that when I try to connect to the wireless network, I select the SSID and the encryption type (WPA) and choose the correct encryption (TKIP) and i type the PSK and it keeps coming back to the password prompt. I am freaking positive I have typed the passphrase correctly. I even logged into my windows partion and deleted the network and re-typed the key to make sure.

Anybody have this problem and know of a possible solution?

Inspiron e1505
3945abg
2.6.20-1.2952.fc6
dkms-ipw3945-1.2.1-1.noarch.rpm
ipw3945-firmware-1.14.2-1.noarch.rpm
ipw3945d-1.7.22-4.i386.rpm

Thanks.
Reply With Quote
  #10  
Old 15th June 2007, 03:40 PM
Duli Offline
Registered User
 
Join Date: Jul 2006
Location: Sao Paulo, SP - Brazil
Age: 37
Posts: 712
Quote:
Originally Posted by SideshowMel
I followed these instructions precisely on a fresh FC6 install from start to finish. The wireless setup is the only place I had a problem:

Everything looks good except that when I try to connect to the wireless network, I select the SSID and the encryption type (WPA) and choose the correct encryption (TKIP) and i type the PSK and it keeps coming back to the password prompt. I am freaking positive I have typed the passphrase correctly. I even logged into my windows partion and deleted the network and re-typed the key to make sure.

Anybody have this problem and know of a possible solution?

Inspiron e1505
3945abg
2.6.20-1.2952.fc6
dkms-ipw3945-1.2.1-1.noarch.rpm
ipw3945-firmware-1.14.2-1.noarch.rpm
ipw3945d-1.7.22-4.i386.rpm

Thanks.
Pretty trick, uh?! The same thing happens to me sometimes, but after a few entries, it connects. It asks for the password two or three times, but eventually it goes.

I don´t really know how to help you...

Maybe you could try to upgrade to F7. It is supposed to natively support the ipw39445 chipset.

duli
Reply With Quote
  #11  
Old 15th June 2007, 04:29 PM
SideshowMel Offline
Registered User
 
Join Date: Feb 2007
Location: Denver, CO
Posts: 220
I've already tried Fedora 7 and had so many problems... got any suggestions?

I noticed when I posted the thread below that my wireless card on there says 3945ULD, but the shipping inventory sheet and the hardware manager in Windoze both say it's a 3945ABG. Are they the same?

Here's my post:

http://forums.fedoraforum.org/showth...220#post811220
Reply With Quote
  #12  
Old 15th June 2007, 04:34 PM
SideshowMel Offline
Registered User
 
Join Date: Feb 2007
Location: Denver, CO
Posts: 220
I should also mention that I tried retyping the passphrase SO MANY times. At one point (and only once) it asked me to create a keyring, which I did, but I set a password different from the WPA passphrase. This was before I noticed your little thing saying to make it the same. So I guess, how do I delete that keyring and start over?

Also, I should mention that even unprotected wi-fi networks that work under Windows don't even work, even though the card sees them and everything, they just never connect.
Reply With Quote
  #13  
Old 16th June 2007, 03:06 AM
SideshowMel Offline
Registered User
 
Join Date: Feb 2007
Location: Denver, CO
Posts: 220
So I connected to an unprotected netwrok all of a sudden, and I was very surprised.

I still couldn't connect to the WPA network, so I on a whim, I just went into the Network Configuration...

I had to create a device profile for the wireless card in the Network Configuration and bingo!

Even after doing that, the passkey authentication is spotty. I sometimes have to type the passphrase several times before it will work.

So I created a keyring and set the password to be the same as the wifi passphrase, but it still asks (perhaps because I, as well, have to manually select TKIP) for the keyring password.

Is there any way you know of to make it just automatically try to keep reconnecting every minute or two after boot-up and assume that any valid local user is allowed access to the wifi network? Or should I just count my blessings and move back to trying to get Fedora 7 working?
Reply With Quote
  #14  
Old 16th June 2007, 07:08 AM
Duli Offline
Registered User
 
Join Date: Jul 2006
Location: Sao Paulo, SP - Brazil
Age: 37
Posts: 712
SideshowMel: The only thing I can tell you by now is I never had to mess with the network settings. When I did that, it would go wrong. The only relevant parts for me was really getting the appropriate rpms and then starting networkmanager... Anything else...
Reply With Quote
Reply

Tags
d520, dell, fc6, latitude

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Dell Latitude D520 + F9 : Internet issues (Broadcom card) DoubleVision Hardware & Laptops 6 29th June 2008 05:44 PM
Dell Latitude 830 & FC5 peers Hardware & Laptops 8 12th August 2007 01:03 AM
wireless on dell latitude d520 fedora 7 frenzy Hardware & Laptops 2 2nd August 2007 10:07 AM
HELP: Problem with enabling Intel 3945 Wireless Card on Dell D520 marvell Servers & Networking 6 16th April 2007 06:58 PM


Current GMT-time: 23:48 (Saturday, 23-09-2017)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat