Fedora Linux Support Community & Resources Center
Old 16th June 2006, 04:28 PM
pobman Offline
Registered User
Join Date: Oct 2005
Posts: 41
vsftpd stop users from deleteing files


I am trying to set up a secure ftp server but am having some problems please can someone help.

I want to be able to log in as ftp1 and see a chrooted enviroment where I can upload and download from but not delete, no mater how I change the umask setting I still can delete.

If I log on as ftp2 I get a different chrooted area with again no permmison to delete.

The config I have is as follows

# Example config file /etc/vsftpd/vsftpd.conf
# The default compiled in settings are fairly paranoid. This sample file
# loosens things up a bit, to make the ftp daemon more usable.
# Please see vsftpd.conf.5 for all compiled in defaults.
# READ THIS: This example file is NOT an exhaustive list of vsftpd options.
# Please read the vsftpd.conf.5 manual page to get a full idea of vsftpd's
# capabilities.
# Allow anonymous FTP? (Beware - allowed by default if you comment this out).
# Uncomment this to allow local users to log in.
# Uncomment this to enable any form of FTP write command.
# Default umask for local users is 077. You may wish to change this to 022,
# if your users expect that (022 is used by most other ftpd's)
# Uncomment this to allow the anonymous FTP user to upload files. This only
# has an effect if the above global write enable is activated. Also, you will
# obviously need to create a directory writable by the FTP user.
# Uncomment this if you want the anonymous FTP user to be able to create
# new directories.
# Activate directory messages - messages given to remote users when they
# go into a certain directory.
# Activate logging of uploads/downloads.
# Make sure PORT transfer connections originate from port 20 (ftp-data).
# If you want, you can arrange for uploaded anonymous files to be owned by
# a different user. Note! Using "root" for uploaded files is not
# recommended!
# You may override where the log file goes if you like. The default is shown
# below.
# If you want, you can have your log file in standard ftpd xferlog format
# You may change the default value for timing out an idle session.
# You may change the default value for timing out a data connection.
# It is recommended that you define on your system a unique user which the
# ftp server can use as a totally isolated and unprivileged user.
# Enable this and the server will recognise asynchronous ABOR requests. Not
# recommended for security (the code is non-trivial). Not enabling it,
# however, may confuse older FTP clients.
# By default the server will pretend to allow ASCII mode but in fact ignore
# the request. Turn on the below options to have the server actually do ASCII
# mangling on files when in ASCII mode.
# Beware that turning on ascii_download_enable enables malicious remote parties
# to consume your I/O resources, by issuing the command "SIZE /big/file" in
# ASCII mode.
# These ASCII options are split into upload and download because you may wish
# to enable ASCII uploads (to prevent uploaded scripts etc. from breaking),
# without the DoS risk of SIZE and ASCII downloads. ASCII mangling should be
# on the client anyway..
# You may fully customise the login banner string:
ftpd_banner=This is MYFTP.
# You may specify a file of disallowed anonymous e-mail addresses. Apparently
# useful for combatting certain DoS attacks.
# (default follows)
# You may specify an explicit list of local users to chroot() to their home
# directory. If chroot_local_user is YES, then this list becomes a list of
# users to NOT chroot().
# (default follows)
# You may activate the "-R" option to the builtin ls. This is disabled by
# default to avoid remote users being able to cause excessive I/O on large
# sites. However, some broken FTP clients such as "ncftp" and "mirror" assume
# the presence of the "-R" option, so there is a strong case for enabling it.

#enable for standalone mode
ftp's home dir is /ftp/ftp1
ftp2's dir is /ftp/ftp2

I am also using the vsftp.user_list
to allow only ftp1 and ftp2

permissions on /ftp/ftp1 and /ftp/ftp2 are
drwxrwxrwx 2 ftp1 ftp1 4096 Jun 16 16:02 ftp1
drwxrwxrwx 2 ftp2 ftp2 4096 Jun 16 16:02 ftp2

I have tried using g+s and chaging the group to root
I also tried setting vsftpd to chmod & umask on conf but it does not work either.

Is there any other way of doing this??
Fedora 8 / 1GB / AMD Athlon(tm) 64 Processor 3000+

Rebooting is a sign of weakness!
Reply With Quote
Old 19th June 2006, 08:24 AM
pobman Offline
Registered User
Join Date: Oct 2005
Posts: 41
Does Anyone have any ideas on this?
Fedora 8 / 1GB / AMD Athlon(tm) 64 Processor 3000+

Rebooting is a sign of weakness!
Reply With Quote

deleteing, files, stop, users, vsftpd

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
vsftpd: will not allow ftp users to create, modify, or delete files giftiger_wunsch Using Fedora 5 5th June 2009 12:18 PM
Stop GDM from displaying users arro Using Fedora 2 13th August 2008 01:49 AM
aMSN deleteing users imfromwales Using Fedora 4 19th December 2007 10:21 PM

Current GMT-time: 13:11 (Tuesday, 22-08-2017)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat