Fedora Linux Support Community & Resources Center
  #1  
Old 6th June 2017, 02:35 PM
pccobbler Offline
Registered User
 
Join Date: Jun 2016
Location: USA
Posts: 24
windows_7firefox
kernel not configured for semaphore

Maybe half of the time I see a page of messages that include "kernel not configured for semaphore ... System V IPC ... not using udev synchronization code" at shutdown, and the rest of the time I see only one line of the message. The messages go by so fast that I cannot read the rest and it's possible I made an error in what I posted here. In the old days, I could read system logs as plain text, but now I need to use journalctl, I think, but I do not see the semaphore messages in that list. This is F25 Cinnamon.

The hardware is old: Intel DH67 board, Sandy Bridge processor, and Crucial SSD. No wireless or graphics cards are installed, but it does have a Creative sound card. I tried Korora and saw the same messages.

I have two questions:

1) If the messages are not available via journalctl, how do I view them?

2) I realize I have not given the entire message, but does anyone have a suggestion as to what the problem could be?

Last edited by pccobbler; 6th June 2017 at 02:43 PM.
Reply With Quote
  #2  
Old 7th June 2017, 01:02 AM
nsnbm Offline
Registered User
 
Join Date: Dec 2007
Location: Australia
Posts: 1,569
linuxfedorafirefox
Re: kernel not configured for semaphore

For plain text logs you could check out /var/log/messages. You may need to install rsyslog which writes to /var/log/messages. In my case, /var/log/messages records unmountings, deactivations, removings, stoppings and more until the system shuts down. I don't have any messages currently on semaphores, presumably because there are no issues on that score. journalctl and rsyslog show very similar messages on my system.

Last edited by nsnbm; 7th June 2017 at 08:43 AM.
Reply With Quote
  #3  
Old 7th June 2017, 10:45 AM
nobody Offline
Banned
 
Join Date: Mar 2012
Location: München, Deutschland
Posts: 863
windows_98_nt_2000chrome
Question Re: kernel not configured for semaphore

https://bugzilla.redhat.com/show_bug.cgi?id=1359352
https://bugzilla.redhat.com/show_bug.cgi?id=1385432

https://fedoraproject.org/wiki/Fedor...ugs_and_issues (1385432)

Interesting bug... Connected with encrypted LVM file system. Also present in Fedora 26.

Quote:
Originally Posted by Andrej Podzimek 2017-06-03 10:31:53 EDT
The same thing here, on Fedora 26. It’s not just aesthetically poor, but it prevents the computer from shutting down at random, which is a problem an order of magnitude more serious. I’m using Btrfs on LVM on LUKS on LVM, which also qualifies as “encrypted LVM”.
_nobody_
Reply With Quote
  #4  
Old 7th June 2017, 03:32 PM
pccobbler Offline
Registered User
 
Join Date: Jun 2016
Location: USA
Posts: 24
windows_7firefox
Re: kernel not configured for semaphore

Thanks to both nsnbm and nobody for their assistance.

/var/log/messages does not contain the semaphore messages, which is strange because it seems to include every other startup and shutdown message.

I saw the redhat threads after I posted, so this is an old problem. Still in F26? That's not good. I have spare time, so I'm going to wipe the drive and reinstall and not use LVM, even though I was not using encryption.
Reply With Quote
  #5  
Old 7th June 2017, 07:39 PM
pccobbler Offline
Registered User
 
Join Date: Jun 2016
Location: USA
Posts: 24
windows_7firefox
Re: kernel not configured for semaphore

nobody is correct, it has to do with LVM partitions. I rebuilt my system with standard partitions and the error message no longer appears.

As usual, the Fedora community is great.
Reply With Quote
  #6  
Old 8th June 2017, 12:09 PM
nobody Offline
Banned
 
Join Date: Mar 2012
Location: München, Deutschland
Posts: 863
windows_98_nt_2000chrome
Thumbs up Re: kernel not configured for semaphore

Quote:
Originally Posted by pccobbler View Post
As usual, the Fedora community is great.
https://bugzilla.redhat.com/show_bug.cgi?id=1385432#c47

Code:
niemand 2017-06-08 07:06:09 EDT
Hello to all,

Here is the proof that this bug has everything to do with encrypted LVM (Fedora 25):
[SOLVED] kernel not configured for semaphore
http://www.forums.fedoraforum.org/showthread.php?t=314465

Lukas (Vrabec/Sparrow),

Could you, please, explain to us the fix you did to correct this bug? Or point to it somewhere to the kernel/selinux policy git patch fixing it? :-)

Thank you in advance,
_nobody_


_nobody_
Reply With Quote
  #7  
Old 8th June 2017, 07:07 PM
dd_wizard Online
Registered User
 
Join Date: Sep 2009
Posts: 2,101
linuxfedorafirefox
Re: kernel not configured for semaphore

The bug report points to this bodhi entry, which points to the new package in koji. I'm downloading and installing it now.

dd_wizard
Reply With Quote
  #8  
Old 9th June 2017, 05:24 AM
nobody Offline
Banned
 
Join Date: Mar 2012
Location: München, Deutschland
Posts: 863
windows_98_nt_2000chrome
Talking Re: kernel not configured for semaphore

Quote:
Originally Posted by dd_wizard View Post
The bug report points to this bodhi entry, which points to the new package in koji. I'm downloading and installing it now.

dd_wizard
Information for building: selinux-policy-3.13.1-225.18.fc25!

Quote:
Originally Posted by selinux-policy-3.13.1-225.18.fc25
Changelog * Thu Jun 08 2017 Lukas Vrabec <lvrabec@redhat.com> - 3.13.1-225.18
- Add a boolean to enable the use of dac_override
- Add support for userns for sandbox domains
- Allow zabbix_t to kill zabbix_script_t processes
- Allow kdumpgui to read removable disk device
- Allow virtlogd_t to execute itself
- Allow keepalived to read/write usermodehelper state
- Allow named_t to bind on udp 4321 port
- Fix interface tlp_manage_pid_files()
- Allow collectd domain read lvm config files. BZ(1459097)
- Allow abrt_dump_oops_t to execute bin_t
- udev wants this when unconfined disabled
- Hide broken symptoms when machine is configured with network bounding.
Seems that one (patch) in RED fixes these problems.

_nobody_
Reply With Quote
  #9  
Old 9th June 2017, 09:38 PM
nobody Offline
Banned
 
Join Date: Mar 2012
Location: München, Deutschland
Posts: 863
windows_98_nt_2000chrome
Wink Re: kernel not configured for semaphore

For Fedora 26, the (?/potential) solution: https://bugzilla.redhat.com/show_bug.cgi?id=1322625#c53
Quote:
Originally Posted by F26
Fedora Update System 2017-06-08 07:10:57 EDT
selinux-policy-3.13.1-257.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/upda...017-6a43388229
For Fedora 25, the (?/potential) solution: https://bugzilla.redhat.com/show_bug.cgi?id=1385432#c48
Quote:
Originally Posted by F25
Fedora Update System 2017-06-08 07:30:00 EDT
selinux-policy-3.13.1-225.18.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/upda...017-45ca9bfcb6
_nobody_
Reply With Quote
  #10  
Old 12th June 2017, 08:16 AM
nobody Offline
Banned
 
Join Date: Mar 2012
Location: München, Deutschland
Posts: 863
windows_98_nt_2000chrome
Talking Re: kernel not configured for semaphore

Quote:
Originally Posted by pccobbler View Post
nobody is correct, it has to do with LVM partitions. I rebuilt my system with standard partitions and the error message no longer appears.
Indeed, here is the new report, AFTER selinux-policy.noarch 3.13.1-225.18.fc25 @updates-testing:

Quote:
Originally Posted by Gerardo Rosales 2017-06-11 09:17:04 EDT
I just provided feedback on the bodhi website. Copying here just in case.

On a lenovo thinkpad x201, no encryption on the LVM groups, the "Kernel not configured for semaphores (System V IPC)" can still be seen when shutting down.

Currently running Fedora 25 xfce spin.

Last metadata expiration check: 9:14:19 ago on Sat Jun 10 21:53:09 2017.
Installed Packages selinux-policy.noarch 3.13.1-225.18.fc25 @updates-testing
NOT solved (period)

_nobody_
Reply With Quote
  #11  
Old 14th September 2017, 03:01 PM
syquus Offline
Registered User
 
Join Date: Sep 2017
Location: Spain
Posts: 1
linuxfedorachrome
Re: kernel not configured for semaphore

Just to confirm that I'm having the same errors (very annoying on shutdown) with:
· FC 26
· Kernel 4.12.11-300
· LVM encrypted partitions.
· selinux-policy-3.13.1-260.8.fc26.noarch

Still NOT solved
Reply With Quote
Reply

Tags
kernel, semaphore, udev

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
bad area no semaphore Dadzmad Using Fedora 3 23rd May 2010 10:37 PM
kernel: codec_read 0: semaphore is not ready for register 0x2c / Sound wprauchholz Hardware & Laptops 4 29th November 2007 10:13 PM
Kernel source not configured??? andyfish Installation, Upgrades and Live Media 6 27th November 2006 04:57 PM
Semaphore Arrays LackeyLad Programming & Packaging 2 5th November 2004 06:51 AM


Current GMT-time: 00:25 (Saturday, 23-09-2017)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat