Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Fedora Resources > Guides & Solutions (Not For Questions)
FedoraForum Search

Forgot Password? Join Us!

Guides & Solutions (Not For Questions) Post your guides here (No links to Blogs accepted). You can also append your comments/questions to a guide, but don't start a new thread to ask a question. Use another forum for that.

View Poll Results: Did it work for you
Yes 459 48.57%
No 343 36.30%
Nearly worked 143 15.13%
Voters: 945. You may not vote on this poll

Reply
 
Thread Tools Search this Thread Display Modes
  #151  
Old 21st June 2007, 07:43 PM
DanMachado Offline
Registered User
 
Join Date: Jun 2007
Location: U.K
Age: 43
Posts: 74
Confusion...

Hi,

I am nearly to install FC6 in a lapto with a 32-bit architecture (intel core, dual, etc processor) I do not have any experience of installing OS...

So, will I have the problem about the wrong kernel?

Does "When the booting the CD (or DVD) enter the following at the boot prompt: linux i686" (http://www.mjmwired.net/resources/mj....html#problems) mean that in some moment of the installation the option will appear, and then I have to type "linux i686"?

Regards.

DanMachado
Reply With Quote
  #152  
Old 21st June 2007, 07:50 PM
ramasees
Guest
 
Posts: n/a
i think if i remember correctly press f2 then type linux i686 then enter
Reply With Quote
  #153  
Old 21st June 2007, 08:12 PM
DanMachado Offline
Registered User
 
Join Date: Jun 2007
Location: U.K
Age: 43
Posts: 74
Well well I hope that you have a good memory!

Cheers!
Reply With Quote
  #154  
Old 21st June 2007, 08:17 PM
leigh123linux
Guest
 
Posts: n/a
Quote:
Originally Posted by DanMachado
Well well I hope that you have a good memory!

Cheers!
Well his memory is good
Reply With Quote
  #155  
Old 21st June 2007, 08:43 PM
ramasees
Guest
 
Posts: n/a
thanks leigh and thats after a beer,have you had any flooding there pretty wet here in mids
Reply With Quote
  #156  
Old 21st June 2007, 08:47 PM
leigh123linux
Guest
 
Posts: n/a
Quote:
Originally Posted by ramasees
thanks leigh and thats after a beer,have you had any flooding there pretty wet here in mids
It's been dry here today but will had quite a bad storm at the weekend but no flooding.
Reply With Quote
  #157  
Old 22nd June 2007, 02:02 PM
swa_1101 Offline
Registered User
 
Join Date: Jun 2007
Posts: 22
Hi, but have any kmod-fglrx working with kernel x86_64 3228 ?
I have install ati-driver from freshrpm, when it finished, reboot computer and I can not start X, error occur, It auto change xorg.conf back as fresh xorg.conf.
Reply With Quote
  #158  
Old 22nd June 2007, 03:49 PM
leigh123linux
Guest
 
Posts: n/a
Quote:
Originally Posted by swa_1101
Hi, but have any kmod-fglrx working with kernel x86_64 3228 ?
I have install ati-driver from freshrpm, when it finished, reboot computer and I can not start X, error occur, It auto change xorg.conf back as fresh xorg.conf.
I will try and compile some for the new kernel and post them on post #2

I didn't need to compile any , I managed to find some for you

http://mirror.atrpms.net/livna/fedora/testing/7/x86_64/

Last edited by leigh123linux; 22nd June 2007 at 05:07 PM.
Reply With Quote
  #159  
Old 22nd June 2007, 05:07 PM
leigh123linux
Guest
 
Posts: n/a
Quote:
Originally Posted by swa_1101
Hi, but have any kmod-fglrx working with kernel x86_64 3228 ?
I have install ati-driver from freshrpm, when it finished, reboot computer and I can not start X, error occur, It auto change xorg.conf back as fresh xorg.conf.
Here you go ( I found some )

http://mirror.atrpms.net/livna/fedora/testing/7/x86_64/


Code:
su
mkdir /home/*/livna
cd /home/*/livna
wget http://mirror.atrpms.net/livna/fedora/testing/7/x86_64/kmod-fglrx-8.37.6-2.2.6.21_1.3228.fc7.x86_64.rpm
wget http://mirror.atrpms.net/livna/fedora/testing/7/x86_64/xorg-x11-drv-fglrx-8.37.6-1.lvn7.x86_64.rpm
wget http://mirror.atrpms.net/livna/fedora/testing/7/x86_64/xorg-x11-drv-fglrx-libs-32bit-8.37.6-1.lvn7.x86_64.rpm
wget http://mirror.atrpms.net/livna/fedora/7/x86_64/livna-config-display-0.0.12-1.lvn7.noarch.rpm
rpm -i *
service fglrx restart
fglrx-config-display enable

Last edited by leigh123linux; 22nd June 2007 at 05:21 PM.
Reply With Quote
  #160  
Old 22nd June 2007, 06:09 PM
swa_1101 Offline
Registered User
 
Join Date: Jun 2007
Posts: 22
Code:
[root@localhost SWA]# service fglrx restart
bash: service: command not found
I could not continue!

When I restart computer it is not start X, same as my last post!
Reply With Quote
  #161  
Old 22nd June 2007, 06:19 PM
leigh123linux
Guest
 
Posts: n/a
Quote:
Originally Posted by swa_1101
Code:
[root@localhost SWA]# service fglrx restart
bash: service: command not found
I could not continue!

When I restart computer it is not start X, same as my last post!
sorry you need to be full root

su -
service fglrx restart
fglrx-config-display enable

1. Did you edit your xorg.conf as described in section 3 ? of post #1
2. Did you remember to downgrade xorg . ?

if the above steps fail post the output from

cat /var/log/Xorg.0.log | grep EE


and


cat /var/log/Xorg.0.log | grep WW

Last edited by leigh123linux; 22nd June 2007 at 06:23 PM.
Reply With Quote
  #162  
Old 22nd June 2007, 06:44 PM
swa_1101 Offline
Registered User
 
Join Date: Jun 2007
Posts: 22
Wink

All is Done but It is same!

Code:
[root@localhost SWA]# cat /var/log/Xorg.0.log | grep EE
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(II) Loading extension MIT-SCREEN-SAVER
(EE) AIGLX: Screen 0 is not DRI capable
[root@localhost SWA]# cat /var/log/Xorg.0.log | grep WW
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(WW) No monitor specified for screen "Screen0".
(WW) No FontPath specified.  Using compiled-in default.
(WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
(WW) RADEON(0): Unknown DDCType 5 found
(WW) RADEON(0): LCD DDC Info Table found!
(WW) RADEON(0): Failed to detect secondary monitor, MergedFB/Clone mode disabled
(WW) RADEON(0): Direct rendering disabled
(WW) <default pointer>: No Device specified, looking for one...
Reply With Quote
  #163  
Old 22nd June 2007, 06:48 PM
swa_1101 Offline
Registered User
 
Join Date: Jun 2007
Posts: 22
Here is my xorg.conf before I reboot computer

Code:
# Xorg configuration created by system-config-display

Section "ServerLayout"
	Identifier     "single head configuration"
	Screen      0  "Screen0" 0 0
	InputDevice    "Keyboard0" "CoreKeyboard"
	InputDevice    "Synaptics" "CorePointer"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "us"
EndSection

Section "InputDevice"
	Identifier  "Synaptics"
	Driver      "synaptics"
	Option	    "Device" "/dev/input/mice"
	Option	    "Protocol" "auto-dev"
	Option	    "Emulate3Buttons" "yes"
EndSection

Section "Device"
	Identifier  "Videocard0"
	Driver      "fglrx"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection

Section "Extensions"
Option "Composite" "False"
EndSection


Section "ServerFlags"
Option "AIGLX" "off"
EndSection

Section "DRI"
Mode 0666
EndSection
Reply With Quote
  #164  
Old 22nd June 2007, 07:11 PM
leigh123linux
Guest
 
Posts: n/a
Quote:
Originally Posted by swa_1101
Here is my xorg.conf before I reboot computer

Code:
# Xorg configuration created by system-config-display

Section "ServerLayout"
	Identifier     "single head configuration"
	Screen      0  "Screen0" 0 0
	InputDevice    "Keyboard0" "CoreKeyboard"
	InputDevice    "Synaptics" "CorePointer"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "us"
EndSection

Section "InputDevice"
	Identifier  "Synaptics"
	Driver      "synaptics"
	Option	    "Device" "/dev/input/mice"
	Option	    "Protocol" "auto-dev"
	Option	    "Emulate3Buttons" "yes"
EndSection

Section "Device"
	Identifier  "Videocard0"
	Driver      "fglrx"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection

Section "Extensions"
Option "Composite" "False"
EndSection


Section "ServerFlags"
Option "AIGLX" "off"
EndSection

Section "DRI"
Mode 0666
EndSection

Ok try this xorg.conf

Quote:
# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Synaptics" "CorePointer"
EndSection

Section "ServerFlags"
Option "AIGLX" "off"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Synaptics"
Driver "synaptics"
Option "Device" "/dev/input/mice"
Option "Protocol" "auto-dev"
Option "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "auto"
ModelName "auto"
Option "DPMS"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "fglrx"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection

Section "Extensions"
Option "Composite" "False"
EndSection

This should say fglrx not radeon

Quote:
WW) RADEON(0): Unknown DDCType 5 found
(WW) RADEON(0): LCD DDC Info Table found!
(WW) RADEON(0): Failed to detect secondary monitor, MergedFB/Clone mode disabled
(WW) RADEON(0): Direct rendering disabled
Reply With Quote
  #165  
Old 22nd June 2007, 07:27 PM
swa_1101 Offline
Registered User
 
Join Date: Jun 2007
Posts: 22
Hi, I have try to replace your xorg.conf but it is also failed!

I have a question: I can not do this because I have a new version 1.2.0-9 that can not remove

rpm -U --oldpackage xorg-x11-server-Xorg-1.2.0-6.fc7.x86_64.rpm

So if I do not try it, have any wrong about can not start X?
Reply With Quote
Reply

Tags
ati, fglrx, howto

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ATI Catalyst fglrx driver manual install on Fedora 12 Jeff72 Guides & Solutions (Not For Questions) 15 13th August 2010 09:17 PM
ATI Catalyst™ Display Driver v9.12 rich52 Hardware & Laptops 1 31st December 2009 05:59 AM
HOWTO - make less noise from video card while using fglrx driver multescugeorge@ Guides & Solutions (Not For Questions) 2 3rd October 2009 08:02 AM
ATI Catalyst 9.x fglrx driver manual install on Fedora 11 Jeff72 Guides & Solutions (Not For Questions) 25 30th August 2009 08:29 PM


Current GMT-time: 05:43 (Saturday, 23-09-2017)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat