Fedora Linux Support Community & Resources Center
  #1  
Old 5th April 2017, 07:48 AM
wintonian Offline
Registered User
 
Join Date: Jul 2013
Location: UK
Posts: 213
linuxfedorafirefox
No HDMI sound using nouveau or Nvidia

Yesterday I changed the sound output to headphone and now when I switch back to HDMI in phonon I have no sound. However if I swirch to any other HDMI profile other than the correct one (HDMI2) I get sound through the headphones. I am using an Nvidia card andKDE.

I have tried undoing the last system update in case that was the issue but am unable to do so, due to some random package being unavalible (it changes each time)

Code:
user-001@elrond ~$ sudo dnf history undo 367

No package libreoffice-data-1:5.2.6.2-4.fc25.noarch available.
Error: An operation cannot be undone

user-001@elrond ~$ sudo dnf history undo 367

No package chromium-0:56.0.2924.87-3.fc25.x86_64 available.
Error: An operation cannot be undone

user-001@elrond ~$ sudo dnf history undo 367

No package gvfs-mtp-0:1.30.3-1.fc25.x86_64 available.
Error: An operation cannot be undone

user-001@elrond ~$ sudo dnf history undo 367 -force
Last metadata expiration check: 0:59:38 ago on Wed Apr  5 06:44:42 2017.
Found more than one transaction ID!
Error: Failed history undo
Changing from the (correct) HDMI2 profile to another one results in the following:
Quote:
Switching to the audio playback device GK104 HDMI Audio Controller Digital Stereo (HDMI 2)
which has higher preference or is specifically configured for this stream.
The audio playback device GK104 HDMI Audio Controller Digital Stereo (HDMI 2) does not work.
Falling back to Built-in Audio Analog Stereo.
I have also tried installing the Nvidia driver which makes no difference, nither does using a different kernel.

journalctl output.

Last edited by wintonian; 5th April 2017 at 08:03 AM.
Reply With Quote
  #2  
Old 5th April 2017, 08:17 AM
wintonian Offline
Registered User
 
Join Date: Jul 2013
Location: UK
Posts: 213
linuxfedorafirefox
Re: No HDMI sound using nouveau or Nvidia

Never mind turning the speakers on and off solved the problem. :-|
Reply With Quote
Reply

Tags
sound

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FC22, nouveau, nvidia chipset: No sound from HDMI StefanJ Installation, Upgrades and Live Media 11 5th December 2015 04:29 AM
f18 nvidia hdmi sound b4time Using Fedora 1 4th April 2013 12:12 PM
[SOLVED] No sound when using Nvidia hdmi nathan082000 Hardware & Laptops 19 6th June 2012 10:08 PM
[SOLVED] Nvidia HDMI audio/sound jtang613 Hardware & Laptops 6 23rd September 2010 07:19 PM
sound thru nvidia hdmi rhiakath Hardware & Laptops 2 18th April 2010 10:13 AM


Current GMT-time: 03:48 (Tuesday, 24-10-2017)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat