Fedora Linux Support Community & Resources Center
  #1  
Old 28th May 2006, 12:58 PM
bjourn Offline
Registered User
 
Join Date: May 2006
Posts: 4
su -c 'yum update' gives errors

Hi. I'm very new at this. Have read the FAQ's and Docs and seem to have this common problem stopping anything working except web browsing.
When I try this:
su -c 'yum update'

I get this:
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
dries [1/7]
http://ftp.belnet.be/packages/dries....ta/repomd.xml: [Errno 4] IOError: <urlopen error (97, 'Address family not supported by protocol')>
Trying other mirror.
Cannot open/read repomd.xml file for repository: dries
failure: repodata/repomd.xml from dries: [Errno 256] No more mirrors to try.
Error: failure: repodata/repomd.xml from dries: [Errno 256] No more mirrors to try.

This happens all the time.
Help, in very elementary terms please?
Reply With Quote
  #2  
Old 28th May 2006, 01:27 PM
Effie04's Avatar
Effie04 Offline
Registered User
 
Join Date: May 2006
Age: 38
Posts: 110
try to clean up the yum

yum clean cache will clear the repository cache
yum clean all - will clean package in cache , and header files

if dont know about it - install yumex - its a nice and easy gui frontend for yum
__________________
Desktop: FC6 || Laptop: WinXP+FC6
Reply With Quote
  #3  
Old 29th May 2006, 12:12 AM
bjourn Offline
Registered User
 
Join Date: May 2006
Posts: 4
Hi. Thank you for your reply. I tried to clean up yum. If I'm interpreting things correctly, yum clean cache did nothing but yum clean all removed 2 metadata files. Full terminal text below. Unfortunately this did not fix the problem because when I tried to install yumex (which is about item 5 on my list of things I want to install if only I could), I get the same sort of errors.
I have tried reinstallation (from a PC world DVD) which didnt seem to do much.
Any suggestions?

yum clean cache
Loading "installonlyn" plugin
Cleaning up pickled cache
0 cache files removed
[root@localhost ~]# yum clean all
Loading "installonlyn" plugin
Cleaning up Everything
0 headers removed
0 packages removed
2 metadata files removed
0 cache files removed
0 cache files removed
[root@localhost ~]# yum install yumex
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
dries [1/7]
http://ftp.belnet.be/packages/dries....ta/repomd.xml: [Errno 4] IOError: <urlopen error (97, 'Address family not supported by protocol')>
Trying other mirror.
Cannot open/read repomd.xml file for repository: dries
failure: repodata/repomd.xml from dries: [Errno 256] No more mirrors to try.
Error: failure: repodata/repomd.xml from dries: [Errno 256] No more mirrors to try.
[root@localhost ~]#
Reply With Quote
  #4  
Old 29th May 2006, 12:19 AM
jbannon Offline
Registered User
 
Join Date: Dec 2005
Posts: 909
Disable the dries repo using --disablerepo=dries and try again.
__________________
Best regards,
Jim Bannon
(Registered Linux User #405603 :) )
Reply With Quote
  #5  
Old 29th May 2006, 12:21 AM
u-noneinc-s's Avatar
u-noneinc-s Offline
Registered User
 
Join Date: Jul 2005
Location: Wine Country, California
Posts: 2,850
if you click on the actual URL, you'll find
Quote:
Not Found

The requested URL /packages/dries.ulyssis.org/fedora/linux/5/i386/dries/RPMS/repodata/repomd.xml: was not found on this server.
So, try
Code:
yum --disablerepo=dries install yumex
, Then you'll need to find out what's wron with your dries repo. Maybe dries is/was down maybe you got a bad repo.
You might need to reinstall dries.repo. Try the --disable first.

EDIT: Too slow again
Reply With Quote
Reply

Tags
errors , update , yum

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Update Errors liquidfunk Installation, Upgrades and Live Media 0 19th June 2009 03:18 PM
Update Errors metatron Alpha, Beta & Snapshots Discussions (Fedora 11 Only) 1 17th April 2009 04:53 AM
errors in yum update maalamaal Using Fedora 0 5th February 2009 03:02 AM
Update Errors and Errors When Installing New Software fluxxuate Using Fedora 9 25th January 2007 12:22 PM


Current GMT-time: 22:29 (Monday, 23-10-2017)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat