Fedora Linux Support Community & Resources Center
  #1  
Old 19th February 2011, 05:03 PM
zkab Offline
Registered User
 
Join Date: Oct 2009
Posts: 71
linuxchrome
CUPS problem with F14

I have migrated from Debian to Fedora 14 (2.6.35.11-83.fc14.x86_64).
Problem is that I can't get my networked printer to work (which it did with Debian).
The printer is Samsung ML-3561ND and I got all he drivers & PPD from Samsung support.
I prefer to install the printer with CUPS and not with Samsung Unified Linux install software.
Appreciate any help since I really need the printer ... right now I have to send my documents to a user's Windows workstation and print from there ... not a good solution.
I have googled a lot but have not found any solution.

CUPS tells me: "/usr/lib/cups/filter/rastertosamsungspl failed"

ls -la /usr/lib/cups/filter/rastertosamsungspl gives:
-rwxr-xr-x. 1 root root 80608 Sep 17 2008 rastertosamsungspl

CUPS sees the printer as follows:
Description: Samsung_3561ND
Location:
Driver: Samsung ML-3560 Series (SPL II) (grayscale, 2-sided printing)
Connection: socket://printer:9100
Defaults: job-sheets=none, none media=iso_a4_210x297mm sides=one-sided

CUPS error log looks like:

E [19/Feb/2011:16:41:31 +0100] [Job 27] Job stopped due to filter errors; please consult the error_log file for details.
D [19/Feb/2011:16:41:31 +0100] [Job 27] The following messages were recorded from 04:41:31 PM to 04:41:31 PM
D [19/Feb/2011:16:41:31 +0100] [Job 27] Adding start banner page "none".
D [19/Feb/2011:16:41:31 +0100] [Job 27] Adding end banner page "none".
D [19/Feb/2011:16:41:31 +0100] [Job 27] File of type application/vnd.cups-banner queued by "raivo".
D [19/Feb/2011:16:41:31 +0100] [Job 27] hold_until=0
D [19/Feb/2011:16:41:31 +0100] [Job 27] Queued on "Samsung_3561ND" by "raivo".
D [19/Feb/2011:16:41:31 +0100] [Job 27] job-sheets=none,none
D [19/Feb/2011:16:41:31 +0100] [Job 27] argv[0]="Samsung_3561ND"
D [19/Feb/2011:16:41:31 +0100] [Job 27] argv[1]="27"
D [19/Feb/2011:16:41:31 +0100] [Job 27] argv[2]="raivo"
D [19/Feb/2011:16:41:31 +0100] [Job 27] argv[3]="Test Page"
D [19/Feb/2011:16:41:31 +0100] [Job 27] argv[4]="1"
D [19/Feb/2011:16:41:31 +0100] [Job 27] argv[5]="job-uuid=urn:uuid:8f55abb0-ceff-3bac-7b55-9929d8b2221e job-originating-host-name=localhost time-at-creation=1298130091 time-at-processing=1298130091 AP_D_InputSlot="
D [19/Feb/2011:16:41:31 +0100] [Job 27] argv[6]="/var/spool/cups/d00027-001"
D [19/Feb/2011:16:41:31 +0100] [Job 27] envp[0]="CUPS_CACHEDIR=/var/cache/cups"
D [19/Feb/2011:16:41:31 +0100] [Job 27] envp[1]="CUPS_DATADIR=/usr/share/cups"
D [19/Feb/2011:16:41:31 +0100] [Job 27] envp[2]="CUPS_DOCROOT=/usr/share/cups/www"
D [19/Feb/2011:16:41:31 +0100] [Job 27] envp[3]="CUPS_FONTPATH=/usr/share/cups/fonts"
D [19/Feb/2011:16:41:31 +0100] [Job 27] envp[4]="CUPS_REQUESTROOT=/var/spool/cups"
D [19/Feb/2011:16:41:31 +0100] [Job 27] envp[5]="CUPS_SERVERBIN=/usr/lib/cups"
D [19/Feb/2011:16:41:31 +0100] [Job 27] envp[6]="CUPS_SERVERROOT=/etc/cups"
D [19/Feb/2011:16:41:31 +0100] [Job 27] envp[7]="CUPS_STATEDIR=/var/run/cups"
D [19/Feb/2011:16:41:31 +0100] [Job 27] envp[8]="HOME=/var/spool/cups/tmp"
D [19/Feb/2011:16:41:31 +0100] [Job 27] envp[9]="PATH=/usr/lib/cups/filter:/usr/lib64/cups/filter:/usr/bin:/usr/sbin:/bin:/usr/bin"
D [19/Feb/2011:16:41:31 +0100] [Job 27] envp[10]="SERVER_ADMIN=root@zkab"
D [19/Feb/2011:16:41:31 +0100] [Job 27] envp[11]="SOFTWARE=CUPS/1.4.6"
D [19/Feb/2011:16:41:31 +0100] [Job 27] envp[12]="TMPDIR=/var/spool/cups/tmp"
D [19/Feb/2011:16:41:31 +0100] [Job 27] envp[13]="USER=root"
D [19/Feb/2011:16:41:31 +0100] [Job 27] envp[14]="CUPS_SERVER=/var/run/cups/cups.sock"
D [19/Feb/2011:16:41:31 +0100] [Job 27] envp[15]="CUPS_ENCRYPTION=IfRequested"
D [19/Feb/2011:16:41:31 +0100] [Job 27] envp[16]="IPP_PORT=631"
D [19/Feb/2011:16:41:31 +0100] [Job 27] envp[17]="CHARSET=utf-8"
D [19/Feb/2011:16:41:31 +0100] [Job 27] envp[18]="LANG=en_US.UTF-8"
D [19/Feb/2011:16:41:31 +0100] [Job 27] envp[19]="PPD=/etc/cups/ppd/Samsung_3561ND.ppd"
D [19/Feb/2011:16:41:31 +0100] [Job 27] envp[20]="RIP_MAX_CACHE=8m"
D [19/Feb/2011:16:41:31 +0100] [Job 27] envp[21]="CONTENT_TYPE=application/vnd.cups-banner"
D [19/Feb/2011:16:41:31 +0100] [Job 27] envp[22]="DEVICE_URI=socket://printer:9100"
D [19/Feb/2011:16:41:31 +0100] [Job 27] envp[23]="PRINTER_INFO=Samsung_3561ND"
D [19/Feb/2011:16:41:31 +0100] [Job 27] envp[24]="PRINTER_LOCATION="
D [19/Feb/2011:16:41:31 +0100] [Job 27] envp[25]="PRINTER=Samsung_3561ND"
D [19/Feb/2011:16:41:31 +0100] [Job 27] envp[26]="CUPS_FILETYPE=document"
D [19/Feb/2011:16:41:31 +0100] [Job 27] envp[27]="FINAL_CONTENT_TYPE=printer/Samsung_3561ND"
D [19/Feb/2011:16:41:31 +0100] [Job 27] Started filter /usr/lib/cups/filter/bannertops (PID 8548)
D [19/Feb/2011:16:41:31 +0100] [Job 27] Started filter /usr/lib/cups/filter/pstops (PID 8549)
D [19/Feb/2011:16:41:31 +0100] [Job 27] Started filter /usr/lib/cups/filter/rastertosamsungspl (PID 8550)
D [19/Feb/2011:16:41:31 +0100] [Job 27] Started backend /usr/lib/cups/backend/socket (PID 8551)
D [19/Feb/2011:16:41:31 +0100] [Job 27] /usr/lib/cups/filter/rastertosamsungspl: Permission denied
D [19/Feb/2011:16:41:31 +0100] [Job 27] load_banner(filename="/var/spool/cups/d00027-001")
D [19/Feb/2011:16:41:31 +0100] [Job 27] Page = 595x842; 12,12 to 582,830
D [19/Feb/2011:16:41:31 +0100] [Job 27] STATE: +connecting-to-device
D [19/Feb/2011:16:41:31 +0100] [Job 27] Looking up "printer"...
D [19/Feb/2011:16:41:31 +0100] [Job 27] Connecting to printer:9100
D [19/Feb/2011:16:41:31 +0100] [Job 27] Connecting to printer...
D [19/Feb/2011:16:41:31 +0100] [Job 27] Page = 595x842; 12,12 to 582,830
D [19/Feb/2011:16:41:31 +0100] [Job 27] slow_collate=0, slow_duplex=0, slow_order=0
D [19/Feb/2011:16:41:31 +0100] [Job 27] Before copy_comments - %!PS-Adobe-3.0
D [19/Feb/2011:16:41:31 +0100] [Job 27] %!PS-Adobe-3.0
D [19/Feb/2011:16:41:31 +0100] [Job 27] %%BoundingBox: 12 12 582 830
D [19/Feb/2011:16:41:31 +0100] [Job 27] %cupsRotation: 0
D [19/Feb/2011:16:41:31 +0100] [Job 27] %%Creator: bannertops/CUPS v1.4.6
D [19/Feb/2011:16:41:31 +0100] [Job 27] %%CreationDate: Sat 19 Feb 2011 04:41:31 PM CET
D [19/Feb/2011:16:41:31 +0100] [Job 27] %%LanguageLevel: 2
D [19/Feb/2011:16:41:31 +0100] [Job 27] %%DocumentData: Clean7Bit
D [19/Feb/2011:16:41:31 +0100] [Job 27] %%Title: (Test Page)
D [19/Feb/2011:16:41:31 +0100] [Job 27] %%For: (raivo)
D [19/Feb/2011:16:41:31 +0100] [Job 27] %%Pages: 1
D [19/Feb/2011:16:41:31 +0100] [Job 27] %%DocumentSuppliedResources: font Monospace
D [19/Feb/2011:16:41:31 +0100] [Job 27] %%+ font Monospace-Bold
D [19/Feb/2011:16:41:31 +0100] [Job 27] %%+ font Monospace-BoldOblique
D [19/Feb/2011:16:41:31 +0100] [Job 27] %%+ font Monospace-Oblique
D [19/Feb/2011:16:41:31 +0100] [Job 27] %%EndComments
D [19/Feb/2011:16:41:31 +0100] [Job 27] Before copy_prolog - %%BeginProlog
D [19/Feb/2011:16:41:31 +0100] [Job 27] STATE: -connecting-to-device
D [19/Feb/2011:16:41:31 +0100] [Job 27] Connected to printer...
D [19/Feb/2011:16:41:31 +0100] [Job 27] Connected to 192.168.0.7:9100 (IPv4)...
D [19/Feb/2011:16:41:31 +0100] [Job 27] hrDeviceDesc="Unknown"
D [19/Feb/2011:16:41:31 +0100] [Job 27] prtGeneralCurrentLocalization type is 5, expected 2!
D [19/Feb/2011:16:41:31 +0100] [Job 27] backendRunLoop(print_fd=0, device_fd=5, snmp_fd=6, addr=0x7ff30479b898, use_bc=1, side_cb=0x7ff303886d30)
D [19/Feb/2011:16:41:31 +0100] [Job 27] Print file sent, waiting for printer to finish...
D [19/Feb/2011:16:41:31 +0100] [Job 27] Ready to print.
D [19/Feb/2011:16:41:31 +0100] [Job 27] End of messages
D [19/Feb/2011:16:41:31 +0100] [Job 27] printer-state=3(idle)
D [19/Feb/2011:16:41:31 +0100] [Job 27] printer-state-message="Ready to print."
D [19/Feb/2011:16:41:31 +0100] [Job 27] printer-state-reasons=none
Reply With Quote
  #2  
Old 25th February 2011, 05:56 AM
robertdaleweir Offline
Registered User
 
Join Date: Oct 2005
Location: British Columbia, Canada
Posts: 847
linuxfedorafirefox
Re: CUPS problem with F14

Hi zkab
I have been installing printers on Fedora using CUPS for years. I now find that I am having a problem with Printing under F14. I am using the same driver choices as under F12 and yet no joy.
I will keep trying but I feel that I have followed all the proper procedures and something seems different. If I get a resolution I will post here. Good luck...
__________________
Robert :)
Kernel 4.11.12-100.fc24.x86_64 Gnome Software 3.20
CPU AMD FX-6300 Six Core AM3+
MoBo Gigabyte 78LMT-USB3 AMD760G AM3+ MicroATX
Memory 8 Gigs Gskill Ripjaw DDR3-1333 PC-10666
Reply With Quote
  #3  
Old 25th February 2011, 12:16 PM
SiliconSlick's Avatar
SiliconSlick Offline
Registered User
 
Join Date: Aug 2009
Location: College Station, TX
Posts: 502
linuxfedorafirefox
Re: CUPS problem with F14

I'd recommend using system-config-printer (System->Administration->Printing) vs. the CUPS web interface (assuming that is what you mean when you say you prefer to use CUPS to configure).

In the past, the CUPS web interface would write config files that were incompatible with the rest of the Fedora/Redhat printing system. Not sure if that is still the case. But the above tool usually does a pretty good job.

SS
Reply With Quote
  #4  
Old 26th February 2011, 01:32 PM
zkab Offline
Registered User
 
Join Date: Oct 2009
Posts: 71
linuxchrome
Re: CUPS problem with F14

I have also tried 'system-config-printer' but I didn't get the printer working ... when printing 'test page' I got following:

Samsung-ML-3560-28 Test Page raivo 1k Unknown pending since Sat 26 Feb 2011 01:23:39 PM CET
"Empty print file!"
Reply With Quote
  #5  
Old 26th February 2011, 04:25 PM
marko's Avatar
marko Offline
Registered User
 
Join Date: Jun 2004
Location: Laurel, MD USA
Posts: 7,131
linuxfedorafirefox
Re: CUPS problem with F14

Quote:
Originally Posted by zkab View Post
.............
I have googled a lot but have not found any solution.
.................
CUPS sees the printer as follows:
Description: Samsung_3561ND
Location:
Driver: Samsung ML-3560 Series (SPL II) (grayscale, 2-sided printing)
Connection: socket://printer:9100
Defaults: job-sheets=none, none media=iso_a4_210x297mm sides=one-sided

CUPS error log looks like:
....................
D [19/Feb/2011:16:41:31 +0100] [Job 27] Connected to printer...
D [19/Feb/2011:16:41:31 +0100] [Job 27] Connected to 192.168.0.7:9100 (IPv4)...
I see it's using socket 9100 which is HP Jetdirect, are you sure you're supposed to be using an HP
protocol with your Samsung printer?

UPDATE:
All I see that looks good for this printer is:

http://www.openprinting.org/printer/...amsung-ML-3560
http://splix.ap2c.org/ Home page for SPLIX driver

Last edited by marko; 26th February 2011 at 04:34 PM.
Reply With Quote
  #6  
Old 27th February 2011, 01:56 PM
zkab Offline
Registered User
 
Join Date: Oct 2009
Posts: 71
linuxchrome
Re: CUPS problem with F14

I have tried all the other protocols ... the same sad result.
Which protocol do you recommend me to focus at ?
Have also tried SPLIX 2.0.0 driver but receive error during 'make':

[raivo@zkab splix-2.0.0]$ make
+---------------------------------------------+
| COMPILATION PARAMETERS SUMMARY |
+---------------------------------------------+
| THREADS = enabled |
| THREADS Nr = 2 |
| CACHESIZE = 30 |
| JBIG = enabled |
| BLACK OPTIM = enabled |
+---------------------------------------------+
(Do a "make clean" before updating these values)

CXX src/rastertoqpdl.cpp
CXX src/request.cpp
CXX src/printer.cpp
CXX src/qpdl.cpp
src/qpdl.cpp: In function ‘bool _renderBand(const Request&, const Band*, bool)’:
src/qpdl.cpp:115:35: warning: dereferencing type-punned pointer will break strict-aliasing rules
CXX src/document.cpp
src/document.cpp: In member function ‘Page* Document::getNextRawPage(const Request&)’:
src/document.cpp:84:10: warning: ‘unsigned int cupsRasterReadHeader(cups_raster_t*, cups_page_header_t*)’ is deprecated (declared at /usr/include/cups/raster.h:339)
src/document.cpp:84:47: warning: ‘unsigned int cupsRasterReadHeader(cups_raster_t*, cups_page_header_t*)’ is deprecated (declared at /usr/include/cups/raster.h:339)
CXX src/core.cpp
CXX src/compress.cpp
CXX src/algorithm.cpp
CXX src/ppdfile.cpp
src/ppdfile.cpp:285:40: error: ‘PPDFile::Value::Value’ names the constructor, not the type
src/ppdfile.cpp:285:63: error: ISO C++ forbids declaration of ‘val’ with no type
src/ppdfile.cpp:285:6: error: prototype for ‘void PPDFile::Value::operator=(const int&)’ does not match any in class ‘PPDFile::Value’
include/ppdfile.h:199:25: error: candidate is: void PPDFile::Value::operator=(const PPDFile::Value&)
make: *** [optimized/src/ppdfile.o] Error 1

------------------------------------------------------------------------------------------------------
I installed the driver - 2.0.0 (RPM for LSB 3.2) - from http://www.openprinting.org/printer/...amsung-ML-3560 and now it works just fine

Last edited by zkab; 27th February 2011 at 02:27 PM. Reason: Update
Reply With Quote
Reply

Tags
cups , f14 , problem

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba/Cups printing error caused by /etc/cups/mime.types rioguia Servers & Networking 1 19th June 2006 03:32 AM


Current GMT-time: 04:49 (Sunday, 22-10-2017)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat