Fedora Linux Support Community & Resources Center
  #1  
Old 16th August 2017, 07:54 PM
Empress Offline
Registered User
 
Join Date: Aug 2017
Location: USA
Posts: 4
linuxfedorachrome
Fedora 26 - Gnome crashes on login with monitor in display port

Hello.

I've been having an issue with Fedora on my Dell Precision M4800 Laptop that my colleagues using the same hardware have not been having.

This is a fresh format and install of Fedora 26 with upgrades in place. If I have a monitor plugged into the display port, each time I login it does a couple of things.

1: It logs in, but the monitor on the display port is not functional, but I can see the mouse on it.
In this scenario I adjust the display settings to rotate the monitor and put it back, it will either crash back to the login page, or start working.

2: It tries to start, and cycles back to the login screen. Sometimes there are artifacts on the dell port monitor. I've had my laptop hardware swapped out for a completely different machine, and my co-workers use it with the same model to no issue.

It's getting frustrating as one might imagine as I try to move in and out of meetings, if I leave it in place it works fine but if I have to unplug and reconnect it's back to cycling.

Some machine information :

Linux myuser-m4800 4.12.5-300.fc26.x86_64 #1 SMP Mon Aug 7 15:27:25 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux


lspci -nnk |grep -A 3 -i vga
00:02.0 VGA compatible controller [0300]: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller [8086:0416] (rev 06)
Subsystem: Dell Device [1028:05cc]
Kernel driver in use: i915
Kernel modules: i915
--
01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Venus XT [Radeon HD 8870M / R9 M270X/M370X] [1002:6821]
Subsystem: Dell FirePro M5100 [1028:05cc]
Kernel driver in use: radeon
Kernel modules: radeon

rpm -qa |grep -i xorg-x11-drv
xorg-x11-drv-openchrome-0.5.0-3.fc26.x86_64
xorg-x11-drv-nouveau-1.0.15-1.fc26.x86_64
xorg-x11-drv-ati-7.9.0-1.fc26.x86_64
xorg-x11-drv-intel-2.99.917-28.20160929.fc26.x86_64
xorg-x11-drv-vmware-13.2.1-2.fc26.x86_64
xorg-x11-drv-evdev-2.10.5-2.fc26.x86_64
xorg-x11-drv-libinput-0.25.1-2.fc26.x86_64
xorg-x11-drv-wacom-0.34.2-1.fc26.x86_64
xorg-x11-drv-amdgpu-1.3.0-1.fc26.x86_64
xorg-x11-drv-fbdev-0.4.3-26.fc26.x86_64
xorg-x11-drv-vesa-2.3.2-26.fc26.x86_64
xorg-x11-drv-qxl-0.1.5-3.fc26.x86_64





Below please find the core dump. If there's anything else I can provide to better assist please let me know?


PID: 10110 (Xorg)
UID: 1000 (myuser)
GID: 1000 (myuser)
Signal: 6 (ABRT)
Timestamp: Wed 2017-08-16 10:58:28 CDT (1h 49min ago)
Command Line: /usr/libexec/Xorg vt2 -displayfd 3 -auth /run/user/1000/gdm/Xauthority -nolisten tcp -ba
Executable: /usr/libexec/Xorg
Control Group: /user.slice/user-1000.slice/session-18.scope
Unit: session-18.scope
Slice: user-1000.slice
Session: 18
Owner UID: 1000 (myuser)
Boot ID: 7a55c599f70545139b42fa9821d57f0a
Machine ID: 0b07a34bbafd4ce7bfec2fc72aaf8e67
Hostname: myuser-m4800
Storage: /var/lib/systemd/coredump/core.Xorg.1000.7a55c599f70545139b42fa9821d57f0a.10 110.15028991
Message: Process 10110 (Xorg) of user 1000 dumped core.

Stack trace of thread 10110:
#0 0x00007f451eca466b raise (libc.so.6)
#1 0x00007f451eca6470 abort (libc.so.6)
#2 0x000000000059f49e OsAbort (Xorg)
#3 0x0000000000479aac ddxGiveUp (Xorg)
#4 0x00000000005a4f32 AbortServer (Xorg)
#5 0x00000000005a5d55 FatalError (Xorg)
#6 0x000000000059c56e OsSigHandler (Xorg)
#7 0x00007f451f0512c0 n/a (libpthread.so.0)

Stack trace of thread 10111:
#0 0x00007f451f04c81b pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0)
#1 0x00007f4516de264b util_queue_thread_func (radeonsi_dri.so)
#2 0x00007f4516de2387 impl_thrd_routine (radeonsi_dri.so)
#3 0x00007f451f04636d start_thread (libpthread.so.0)
#4 0x00007f451ed7eb8f __clone (libc.so.6)

Stack trace of thread 10113:
#0 0x00007f451f04c81b pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0)
#1 0x00007f4516de264b util_queue_thread_func (radeonsi_dri.so)
#2 0x00007f4516de2387 impl_thrd_routine (radeonsi_dri.so)
#3 0x00007f451f04636d start_thread (libpthread.so.0)
#4 0x00007f451ed7eb8f __clone (libc.so.6)

Stack trace of thread 10114:
#0 0x00007f451f04c81b pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0)
#1 0x00007f4516de264b util_queue_thread_func (radeonsi_dri.so)
#2 0x00007f4516de2387 impl_thrd_routine (radeonsi_dri.so)
#3 0x00007f451f04636d start_thread (libpthread.so.0)
#4 0x00007f451ed7eb8f __clone (libc.so.6) Stack trace of thread 10115:
#0 0x00007f451f04c81b pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0)
#1 0x00007f4516de264b util_queue_thread_func (radeonsi_dri.so)
#2 0x00007f4516de2387 impl_thrd_routine (radeonsi_dri.so)
#3 0x00007f451f04636d start_thread (libpthread.so.0)
#4 0x00007f451ed7eb8f __clone (libc.so.6)

Stack trace of thread 10112:
#0 0x00007f451f04c81b pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0)
#1 0x00007f4516de264b util_queue_thread_func (radeonsi_dri.so)
#2 0x00007f4516de2387 impl_thrd_routine (radeonsi_dri.so)
#3 0x00007f451f04636d start_thread (libpthread.so.0)
#4 0x00007f451ed7eb8f __clone (libc.so.6)

Stack trace of thread 10116:
#0 0x00007f451f04c81b pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0)
#1 0x00007f4516de264b util_queue_thread_func (radeonsi_dri.so)
#2 0x00007f4516de2387 impl_thrd_routine (radeonsi_dri.so)
#3 0x00007f451f04636d start_thread (libpthread.so.0)
#4 0x00007f451ed7eb8f __clone (libc.so.6)

Stack trace of thread 10118:
#0 0x00007f451f04ffad __lll_lock_wait (libpthread.so.0)
#1 0x00007f451f048e88 pthread_mutex_lock (libpthread.so.0)
#2 0x000000000059a6e0 input_lock (Xorg)
#4 0x00007f451ed7eb8f __clone (libc.so.6)

Stack trace of thread 10112:
#0 0x00007f451f04c81b pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0)
#1 0x00007f4516de264b util_queue_thread_func (radeonsi_dri.so)
#2 0x00007f4516de2387 impl_thrd_routine (radeonsi_dri.so)
#3 0x00007f451f04636d start_thread (libpthread.so.0)
#4 0x00007f451ed7eb8f __clone (libc.so.6)

Stack trace of thread 10116:
#0 0x00007f451f04c81b pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0)
#1 0x00007f4516de264b util_queue_thread_func (radeonsi_dri.so)
#2 0x00007f4516de2387 impl_thrd_routine (radeonsi_dri.so)
#3 0x00007f451f04636d start_thread (libpthread.so.0)
#4 0x00007f451ed7eb8f __clone (libc.so.6)

Stack trace of thread 10118:
#0 0x00007f451f04ffad __lll_lock_wait (libpthread.so.0)
#1 0x00007f451f048e88 pthread_mutex_lock (libpthread.so.0)
#2 0x000000000059a6e0 input_lock (Xorg)
#3 0x000000000059a971 InputReady (Xorg)
#4 0x000000000059cff1 ospoll_wait (Xorg)
#5 0x000000000059a7ce InputThreadDoWork (Xorg)
#6 0x00007f451f04636d start_thread (libpthread.so.0)
#7 0x00007f451ed7eb8f __clone (libc.so.6)
Reply With Quote
  #2  
Old 16th August 2017, 08:10 PM
antikythera Offline
Administrator
 
Join Date: Dec 2013
Location: United Kingdom
Posts: 5,073
linuxchrome
Re: Fedora 26 - Gnome crashes on login with monitor in display port

do you happen to know which gpu is in use when the crash happens? Intel or discrete AMD? it looks from the dump like a radeon driver issue. while someone here may be able to offer a workaround for now, you should strongly consider searching for and reporting this issue if none the same are found at https://bugzilla.redhat.com
__________________
Download, Install and Share Fedora - Official ISO Torrents | Live ISO Respins containing post-release updates
Reply With Quote
  #3  
Old 16th August 2017, 09:01 PM
Empress Offline
Registered User
 
Join Date: Aug 2017
Location: USA
Posts: 4
windows_98_nt_2000chrome
Re: Fedora 26 - Gnome crashes on login with monitor in display port

I would imagine it's the AMD, as the internal driver is the intel which works dandy if no monitor is connected.
Reply With Quote
  #4  
Old 17th August 2017, 02:47 AM
lsatenstein Online
Registered User
 
Join Date: Jun 2005
Location: Montreal, Que, Canada
Posts: 4,277
linuxfedorafirefox
Re: Fedora 26 - Gnome crashes on login with monitor in display port

you mentioned that the problem is with the logon, after the password was entered.

Have you installed any Gnome extensions? If so, one or more of them is causing your problem.

One way to resolve this to an extension (or not). If you enter ctl-alt-F4 can you open a command line terminal?

If you can do this terminal mode successfully, run as root. then run top and check if gnome-shell is the topdog that is stuck in a loop. with the system cpu running at 100 %.

With gnome-shell as the culprit, issue the kill command (from top),
do it until gnome-shell is aborted.

Then try to relog to Gnome a second time.

Let us know what has transpired.
__________________
Leslie in Montreal

Interesting web sites list
http://forums.fedoraforum.org/showth...40#post1697840
Reply With Quote
  #5  
Old 17th August 2017, 07:18 PM
Empress Offline
Registered User
 
Join Date: Aug 2017
Location: USA
Posts: 4
linuxfedorachrome
Re: Fedora 26 - Gnome crashes on login with monitor in display port

I checked to see if gnome was running during a login sequence issue, I checked htop and there were no cpu's maxed out, gnome was not the top utilizer (htop was)



Following are my extensions

Installed Extensions
AlternateTab by fmuellner ONOFF
System extension
Substitute Alt-Tab with a window based switcher that does not group by application.
Applications Menu by fmuellner ONOFF
System extension
Add a category-based menu for applications.
Background Logo ONOFF
System extension
Overlay a tasteful logo on the background to enhance the user experience
Gnome Shell Audio Output Switcher by kgaut ONOFF
Gnome-Shell Extension: Easily switch between your audio outputs from the system menu.
Launch new instance by fmuellner ONOFF
System extension
Always launch a new instance when clicking in the dash or the application view.
Places Status Indicator by fmuellner ONOFF
System extension
Add a menu for quickly navigating places in the system.
User Themes by fmuellner ONOFF
System extension
Load shell themes from user directory.
Window List by fmuellner ONOFF
System extension
Display a window list at the bottom of the screen.
Reply With Quote
  #6  
Old 18th August 2017, 09:04 AM
Gallock Offline
Registered User
 
Join Date: Aug 2017
Location: Sweden
Posts: 2
windows_7mozilla
Re: Fedora 26 - Gnome crashes on login with monitor in display port

I have the same or a similar problem and experience problems similar to that Empress already has described.
I also use a Dell Precision M4800 Laptop with Fedora 26 at work, and there is no problems until I try to attach it to my docking station with 2 displays attached via DP.
The problem accrues both when I put my laptop into the docking station in a running state, and when I power the computer on in the docking station.

I´ve pick up this error message from the boot messages:

[ 176.091945] [drm:radeon_dp_link_train [radeon]] *ERROR* displayport link status failed
[ 176.096633] [drm:radeon_dp_link_train [radeon]] *ERROR* clock recovery failed
[ 176.307667] [drm:radeon_dp_link_train [radeon]] *ERROR* displayport link status failed
[ 176.312256] [drm:radeon_dp_link_train [radeon]] *ERROR* clock recovery failed
[ 176.557220] [drm:radeon_dp_link_train [radeon]] *ERROR* displayport link status failed
[ 176.561861] [drm:radeon_dp_link_train [radeon]] *ERROR* clock recovery failed
[ 176.765699] [drm:radeon_dp_link_train [radeon]] *ERROR* displayport link status failed
[ 176.767108] [drm:radeon_dp_link_train [radeon]] *ERROR* clock recovery failed

I can also see an related issue in the Xorg.0.log:

[ 318.218] (II) AIGLX: Suspending AIGLX clients for VT switch
[ 318.370] (II) systemd-logind: got pause for 226:1
[ 318.370] (II) systemd-logind: got pause for 13:75
[ 318.370] (II) systemd-logind: got pause for 13:72
[ 318.370] (II) systemd-logind: got pause for 13:76
[ 318.370] (II) systemd-logind: got pause for 13:69
[ 318.370] (II) systemd-logind: got pause for 13:74
[ 318.370] (II) systemd-logind: got pause for 13:70
[ 318.370] (II) systemd-logind: got pause for 13:67
[ 318.370] (II) systemd-logind: got pause for 226:0
[ 318.370] (II) systemd-logind: got pause for 13:65
[ 318.370] (II) systemd-logind: got pause for 13:68
[ 318.370] (II) systemd-logind: got pause for 13:73
[ 318.370] (II) systemd-logind: got pause for 13:71
[ 318.370] (II) systemd-logind: got pause for 13:66
[ 377.392] (II) systemd-logind: got resume for 226:1
[ 377.402] (II) systemd-logind: got resume for 13:75
[ 377.414] (II) systemd-logind: got resume for 13:72
[ 377.422] (II) systemd-logind: got resume for 13:76
[ 377.430] (II) systemd-logind: got resume for 13:69
[ 377.438] (II) systemd-logind: got resume for 13:74
[ 377.446] (II) systemd-logind: got resume for 13:70
[ 377.454] (II) systemd-logind: got resume for 13:67
[ 380.690] (II) systemd-logind: got resume for 226:0
[ 380.691] (II) AIGLX: Resuming AIGLX clients after VT switch
[ 380.745] (II) modeset(0): EDID vendor "LGD", prod id 812
[ 380.745] (II) modeset(0): Printing DDC gathered Modelines:
[ 380.745] (II) modeset(0): Modeline "1920x1080"x0.0 139.00 1920 1952 2016 2080 1080 1083 1089 1111 -hsync -vsync (66.8 kHz eP)
[ 380.745] (II) modeset(0): Modeline "1920x1080"x0.0 128.50 1920 2080 2320 2608 1080 1094 1102 1230 -hsync -vsync (49.3 kHz e)
[ 380.759] (EE) RADEON(G0): failed to set mode: No space left on device
[ 380.759] (EE)
Fatal server error:
[ 380.759] (EE) EnterVT failed for gpu screen 0
[ 380.759] (EE)
[ 380.759] (EE)
Please consult the Fedora Project support
at http://wiki.x.org
for help.
[ 380.759] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[ 380.759] (EE)
[ 380.760] (II) AIGLX: Suspending AIGLX clients for VT switch
[ 380.783] (EE) Server terminated with error (1). Closing log file.
Reply With Quote
  #7  
Old 18th August 2017, 03:14 PM
Empress Offline
Registered User
 
Join Date: Aug 2017
Location: USA
Posts: 4
linuxfedorachrome
Re: Fedora 26 - Gnome crashes on login with monitor in display port

https://bugzilla.redhat.com/show_bug.cgi?id=1482986

Tracked in two places now.

---------- Post added at 09:14 AM ---------- Previous post was at 09:14 AM ----------

Also found this digging deeper



This is from the /home/myuser/.local/share/xorg/Xorg.1.log


218.309] (EE)
[ 218.309] (EE) Backtrace:
[ 218.309] (EE) 0: /usr/libexec/Xorg (OsLookupColor+0x139) [0x59c629]
[ 218.309] (EE) 1: /lib64/libpthread.so.0 (funlockfile+0x50) [0x7f4deee2a30f]
[ 218.310] (EE) 2: ? (?+0x50) [0x50]
[ 218.310] (EE)
[ 218.310] (EE) Segmentation fault at address 0x0
[ 218.310] (EE)
Fatal server error:
[ 218.310] (EE) Caught signal 11 (Segmentation fault). Server aborting
[ 218.310] (EE)
[ 218.310] (EE)
Please consult the Fedora Project support
at http://wiki.x.org
for help.
[ 218.310] (EE) Please also check the log file at "/home/myuser/.local/share/xorg/Xorg.1.log" for additional information.
[ 218.310] (EE)
[ 218.310] (II) AIGLX: Suspending AIGLX clients for VT switch
[ 218.331] (EE) Server terminated with error (1). Closing log file.
Reply With Quote
  #8  
Old 8th September 2017, 03:12 PM
Gallock Offline
Registered User
 
Join Date: Aug 2017
Location: Sweden
Posts: 2
linuxfedorachrome
Re: Fedora 26 - Gnome crashes on login with monitor in display port

Hi,

My problem was that Switchable Graphics was enabled.

How to fix it on a Dell Precision m4800
Access System Setup by pressing <F2> key under boot up
Expand - Video
Mark Switchable Graphics and uncheck the checkbox "Enable Switchable Graphics"
Then Apply and exit.… boot up you computer again.

Now fedora 26 works just fine for me with booth HDMI/DP and my docking station.
Reply With Quote
  #9  
Old 12th September 2017, 06:58 AM
AliceCeaser Offline
Registered User
 
Join Date: Sep 2017
Location: USA
Posts: 1
windows_7chrome
Re: Fedora 26 - Gnome crashes on login with monitor in display port

Hello guys, I have no idea about it because I don't have face such type of problem but I want to know about it for future.
Reply With Quote
Reply

Tags
crashes, display, fedora, gnome, login, monitor, port

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
KWin crashes when not connectd to external monitor at login Kirys Fedora Spins & Remixes 1 10th April 2015 11:06 PM
GNOME crashes on login onuhwt Using Fedora 4 15th May 2012 05:07 PM
Gnome-Shell crashes at first login katastrophal F16 Development 43 24th October 2011 06:33 PM
Gnome 3.2 crashes after fingerprint login monkeyape F16 Development 5 22nd October 2011 06:16 AM
glipper crashes on F10 gnome login wu_qso Using Fedora 0 10th February 2009 02:41 AM


Current GMT-time: 22:28 (Friday, 22-09-2017)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat