Fedora Linux Support Community & Resources Center
  #1  
Old 9th November 2016, 01:41 AM
Rogue Vendetta Offline
Registered User
 
Join Date: Nov 2016
Location: United States
Posts: 11
linuxchrome
Accidentally set f24 to legacy boot and now can't boot windows

The bootloader now only shows Fedora, I think because windows used UEFI and Fedora uses Legacy. I didn't realize the importance of keeping them the same. When I go into the BIOS and boot using UEFI it just comes up with an error message. I have tried to find someone who did the same thing but didn't find anything so I'm sorry if it has been discussed before. But my question is simple, how do I boot into windows, and once I get that figured out, how do I get windows onto the bootloader so I can choose which to boot into?
Reply With Quote
  #2  
Old 9th November 2016, 11:15 AM
antikythera Offline
Administrator
 
Join Date: Dec 2013
Location: United Kingdom
Posts: 5,073
linuxchrome
Re: Accidentally set f24 to legacy boot and now can't boot windows

typically setting the PC to legacy for Fedora 64-bit installation isn't necessary. Fedora is compatible with UEFI and SecureBoot although sometimes it still manages to screw up the chainloader entry in GRUB2.

please try the following when grub menu appears. type c to get to the command line and then type exit, followed by hitting enter/return.

if the windows bootloader is still present and functional you should boot into windows.
__________________
Download, Install and Share Fedora - Official ISO Torrents | Live ISO Respins containing post-release updates
Reply With Quote
  #3  
Old 9th November 2016, 02:59 PM
nobody Offline
Banned
 
Join Date: Mar 2012
Location: München, Deutschland
Posts: 863
windows_98_nt_2000chrome
Thumbs up Re: Accidentally set f24 to legacy boot and now can't boot windows

Quote:
Originally Posted by Apetrie View Post
The bootloader now only shows Fedora, I think because windows used UEFI and Fedora uses Legacy. I didn't realize the importance of keeping them the same. When I go into the BIOS and boot using UEFI it just comes up with an error message. I have tried to find someone who did the same thing but didn't find anything so I'm sorry if it has been discussed before. But my question is simple, how do I boot into windows, and once I get that figured out, how do I get windows onto the bootloader so I can choose which to boot into?
http://www.forums.fedoraforum.org/sh...d.php?t=312002
http://www.forums.fedoraforum.org/sh...d.php?t=311937



_nobody_
Reply With Quote
  #4  
Old 30th November 2016, 01:59 AM
Rogue Vendetta Offline
Registered User
 
Join Date: Nov 2016
Location: United States
Posts: 11
linuxfedorachrome
Re: Accidentally set f24 to legacy boot and now can't boot windows

I have followed the links provided (thank you) and was not able to solve the issue. They said to turn csm off, but I could not find that in my BIOS settings. I found something that said it was the same as Legacy, which I have tried to do to no avail. Does this mean that I have lost windows? (It is notable that windows boot loader does show up when I switch my BIOS to use UEFI but it just doesn't work...)

Thank you all for the help!
Reply With Quote
  #5  
Old 30th November 2016, 08:38 AM
nobody Offline
Banned
 
Join Date: Mar 2012
Location: München, Deutschland
Posts: 863
windows_98_nt_2000chrome
Question Re: Accidentally set f24 to legacy boot and now can't boot windows

Quote:
Originally Posted by Apetrie View Post
I have followed the links provided (thank you) and was not able to solve the issue. They said to turn csm off, but I could not find that in my BIOS settings. I found something that said it was the same as Legacy, which I have tried to do to no avail. Does this mean that I have lost windows? (It is notable that windows boot loader does show up when I switch my BIOS to use UEFI but it just doesn't work...)

Thank you all for the help!
Hello Apetrie,

I need from you few answers (since it is very hard for me to envision/visualize your problem domain), so we can proceed and try to solve this problem... If?

Shall we?

[1] If I correctly understood, you got your BIOS back to CSM=OFF state, which says that you now have UEFI bootable BIOS (?!). In this lieu, could you, please, boot to F24 (if possible???), open the xterm, and do the following for me (needless to say, however you do boot to F24 kernel and user space, please, post for me the results): df

Example from my F25 Virtual Machine:
Code:
[user@localhost]$ df
Filesystem              1K-blocks     Used Available Use% Mounted on
devtmpfs                  4066764        0   4066764   0% /dev
tmpfs                     4078216      352   4077864   1% /dev/shm
tmpfs                     4078216     4524   4073692   1% /run
tmpfs                     4078216        0   4078216   0% /sys/fs/cgroup
/dev/mapper/fedora-root  94820188 52309948  37670612  59% /
tmpfs                     4078216      212   4078004   1% /tmp
/dev/sda1                 3997376   266344   3504936   8% /boot
tmpfs                      815640       16    815624   1% /run/user/42
tmpfs                      815640     4928    810712   1% /run/user/1000
[user@localhost]$
[2] Could you, please, post snapshot of your GRUB2 screen, where you see WIN entry (if, since I did understand that you see WIN UEFI from BIOS, but could not boot?) and post it here (if possible?)?

We go from here (only if I get answers)... Further!

Thank you,
_nobody_
Reply With Quote
  #6  
Old 1st December 2016, 01:04 AM
Rogue Vendetta Offline
Registered User
 
Join Date: Nov 2016
Location: United States
Posts: 11
windows_7chrome
Re: Accidentally set f24 to legacy boot and now can't boot windows

Quote:
Originally Posted by nobody View Post
[1] If I correctly understood, you got your BIOS back to CSM=OFF state, which says that you now have UEFI bootable BIOS (?!). In this lieu, could you, please, boot to F24 (if possible???), open the xterm, and do the following for me (needless to say, however you do boot to F24 kernel and user space, please, post for me the results): df



[2] Could you, please, post snapshot of your GRUB2 screen, where you see WIN entry (if, since I did understand that you see WIN UEFI from BIOS, but could not boot?) and post it here (if possible?)?

We go from here (only if I get answers)... Further!

Thank you,
_nobody_
Okay so It is not possible to boot f24 from UEFI, when I try to use UEFI it just fails immediately and goes to an error screen. I assume this is because I used Legacy when originally setting up f24.

And sadly it is not from the GRUB2 screen that I see the windows bootloader, it is just in the BIOS, GRUB2 only shows the versions of fedora that I have installed.

Does this answer your questions?
Reply With Quote
  #7  
Old 1st December 2016, 07:50 AM
nobody Offline
Banned
 
Join Date: Mar 2012
Location: München, Deutschland
Posts: 863
windows_98_nt_2000chrome
Talking Re: Accidentally set f24 to legacy boot and now can't boot windows

Quote:
Originally Posted by Apetrie View Post
Does this answer your questions?
Yes, it does. Everything is now very clear. At least, to me.

Here is what I'll propose. Since your WIN is very important to you, forget about F24.

Please, return BIOS to UEFI mode (however you do it), and try to boot to UEFI WIN. If you are not able (and you are not), insert UEFI WIN bootable DVD or bootable USB with UEFI WIN .iso.

Please, repair WIN, and let it again re-install WIN boot-loader. Then verify if it does work. Should!

Then, after having that done, you will be able to install UEFI F24 distro, where Fedora will recognize your UEFI WIN and insert it as one of GRUB2 entries.

Good Luck!

_nobody_
Reply With Quote
  #8  
Old 2nd December 2016, 02:10 AM
Rogue Vendetta Offline
Registered User
 
Join Date: Nov 2016
Location: United States
Posts: 11
windows_7chrome
Re: Accidentally set f24 to legacy boot and now can't boot windows

Quote:
Originally Posted by nobody View Post
Yes, it does. Everything is now very clear. At least, to me.

Here is what I'll propose. Since your WIN is very important to you, forget about F24.

Please, return BIOS to UEFI mode (however you do it), and try to boot to UEFI WIN. If you are not able (and you are not), insert UEFI WIN bootable DVD or bootable USB with UEFI WIN .iso.

Please, repair WIN, and let it again re-install WIN boot-loader. Then verify if it does work. Should!

Then, after having that done, you will be able to install UEFI F24 distro, where Fedora will recognize your UEFI WIN and insert it as one of GRUB2 entries.

Good Luck!

_nobody_
Okay. I tried to do that. I managed to get the computer to boot into the bootable usb with a WIN10 iso on it and I tried to repair it, but it failed. Time and time again. So I tried to do a fresh install because that option was given, but that didn't work either. I literally have 3 separate installments of WIN10 on that computer and none of them will boot. What I don't understand is why won't it boot even after a fresh install? F24 still boots fine when in legacy mode...

Honestly at this point I am considering using DBAN to wipe the drive and start fresh with f25 and forget about WIN10 entirely.

Thoughts?
Reply With Quote
  #9  
Old 2nd December 2016, 02:37 AM
nobody Offline
Banned
 
Join Date: Mar 2012
Location: München, Deutschland
Posts: 863
windows_98_nt_2000chrome
Exclamation Re: Accidentally set f24 to legacy boot and now can't boot windows

Apetrie,

So, at the end, this does not work for you at all, correct?
http://www.forums.fedoraforum.org/sh...62&postcount=4

Then I'll suggest to you to do the following: to use whatever disk formatter (GPARTED, or something else) and wipe out the entire disk. Then to go to BIOS and set properly UEFI mode (CSM=OFF, however you use it). Then to install WIN10 64 Pro using rufus (set as following):
http://www.forums.fedoraforum.org/sh...71&postcount=6

So, after WIN10 installed and verified, to install UEFI F25 (64), so you can have dual boot (should be from both - UEFI BIOS, as well as from GRUB2).

_nobody_
Reply With Quote
  #10  
Old 2nd December 2016, 02:44 AM
Rogue Vendetta Offline
Registered User
 
Join Date: Nov 2016
Location: United States
Posts: 11
windows_7chrome
Re: Accidentally set f24 to legacy boot and now can't boot windows

Quote:
Originally Posted by nobody View Post
Apetrie,

So, at the end, this does not work for you at all, correct?
http://www.forums.fedoraforum.org/sh...62&postcount=4

Then I'll suggest to you to do the following: to use whatever disk formatter (GPARTED, or something else) and wipe out the entire disk. Then to go to BIOS and set properly UEFI mode (CSM=OFF, however you use it). Then to install WIN10 64 Pro using rufus (set as following):
http://www.forums.fedoraforum.org/sh...71&postcount=6

So, after WIN10 installed and verified, to install UEFI F25 (64), so you can have dual boot (from GRUB2).

_nobody_
Correct, it does not work at all. Thank you that is what I will do. It does bring up another question, could you please direct me to a thread (if there is one, I have searched but found no solution that works) that will allow me to launch gparted? I never tried in f24 so I don't know if the same issue would have been present there. But when I try to do so it prompts me for my root password, but after I enter it it does nothing. So then I tried to launch it from the terminal and I get the whole GTK-WARNING **: cannot open display: :0

I have found other people who had the same problem but none of their solutions have worked for me.

Sorry for going off the topic of the thread.
Reply With Quote
  #11  
Old 2nd December 2016, 02:57 AM
nobody Offline
Banned
 
Join Date: Mar 2012
Location: München, Deutschland
Posts: 863
windows_98_nt_2000chrome
Arrow Re: Accidentally set f24 to legacy boot and now can't boot windows

Quote:
Originally Posted by Apetrie View Post
Correct, it does not work at all. Thank you that is what I will do. It does bring up another question, could you please direct me to a thread (if there is one, I have searched but found no solution that works) that will allow me to launch gparted?
You need to make one, on your USB stick, and here is how you make UEFI bootable GPARTED on USB (with all instruction where to download it - you need 64bit version):

Again, your BIOS must be set for this USB to UEFI (CSM=OFF) mode!
http://forums.fedoraforum.org/showpo...2&postcount=11

Then, you'll boot GPARTED from USB. you need to enter CMOS BIOS and select GPARTED USB to boot. Then after, the rest is upon you.

Good Luck!
_nobody_
Reply With Quote
  #12  
Old 6th December 2016, 11:36 PM
Rogue Vendetta Offline
Registered User
 
Join Date: Nov 2016
Location: United States
Posts: 11
linuxchrome
Re: Accidentally set f24 to legacy boot and now can't boot windows

Thank you for all the help!
I managed to wipe the drive and of course being totally new to all this am having even more problems, but I will start a new thread for those as it is getting off the topic of this thread. Thank you!
Reply With Quote
  #13  
Old 7th December 2016, 07:00 AM
nobody Offline
Banned
 
Join Date: Mar 2012
Location: München, Deutschland
Posts: 863
windows_98_nt_2000chrome
Question Re: Accidentally set f24 to legacy boot and now can't boot windows

I, myself, found here problem which I could not anticipate and, further down the road, comprehend!

I found that lot of people (several posts about this problem on Fedora Forum scattered around) use happily UEFI BIOS (CSM=OFF) with WIN10, and then by mistake (while trying to make dual-boot machines) switch UEFI BIOS to emulate Legacy BIOS (CSM=ON) by improperly configured as legacy USB .iso with Fedora 24 or Fedora 25. Legacy BIOS recognizes legacy USB Fedora installer, and installs it, using MBR. All Cool, WIN10 is screwed, and it could not boot.

And, then, while trying to go back and SET true UEFI BIOS mode again, understanding that WIN10 is killed by legacy Fedora (e.g. by implanting legacy MBR), they realize that WIN10 would not boot. Again, All Cool with that.

In this phase of the game, I am pretty certain that I, hacking UEFI BIOS (with CSM=OFF) into EFI Shell 2.3.1 or 2.4.0 could start WIN10 from /boot/efi/EFI/BOOT/bootx64.efi , so everything is there preserved, except that somehow fresh installed MBR severed link between BIOS boot menu and WIN10 boot-loader. I did this several times, proving that WIN10 boot-loader and WIN10 itself are intact. All Cool up to this point.

Now, here is TRUE PROBLEM: why these people, using original UEFI WIN10 USB installer (with which they initially installed WIN10 on UEFI BIOS), could NOT repair WIN10???

WTH/WTF?

_nobody_
Reply With Quote
  #14  
Old 7th December 2016, 08:12 AM
blende8 Offline
Registered User
 
Join Date: Dec 2015
Location: Germany
Posts: 7
linuxfirefox
Re: Accidentally set f24 to legacy boot and now can't boot windows

@nobody:
I do not understand your message. I read it twice.
What do you want to say?
What exactly is the problem and how can one solve it?
Reply With Quote
  #15  
Old 7th December 2016, 11:31 AM
nobody Offline
Banned
 
Join Date: Mar 2012
Location: München, Deutschland
Posts: 863
windows_98_nt_2000chrome
Question Re: Accidentally set f24 to legacy boot and now can't boot windows

Quote:
Originally Posted by blende8 View Post
@nobody:
I do not understand your message. I read it twice.
What do you want to say?
What exactly is the problem and how can one solve it?
Blende,

I am considering buying one used Lenovo T440 (with Intel Core i5-4300U 1.9GHz, since this exactly matches my HP Elite Book 840 G1 laptop).

Then I can try myself all of these combinations, since I NEVER installed multi-boot on UEFI BIOSes (ONLY on Legacy ones... Last 5 years I use on my laptops WIN OS as native, and all others Linuxes as VMs). For the HW testing I use single native Fedora XY (since Fedora 14). Usually I port Fedoras on INTEL bare metal with FW: UEFI BIOSes.

This I should/MUST do... Since I do not believe what I see with my own eyes!?

_nobody_
Reply With Quote
Reply

Tags
accidentally, boot, f24, legacy, set, windows

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
grub rescue> Boot fails: Example commands to boot+fix Windows 10 + Linux dual boot Jeff72 Guides & Solutions (Not For Questions) 4 17th December 2016 03:34 PM
Accidentally Changed Boot System, Need a Fix sse11791 Installation, Upgrades and Live Media 4 5th August 2012 03:39 AM
Accidentally formated my /boot partition RafaelGP Installation, Upgrades and Live Media 4 14th November 2009 12:05 AM
Help: Accidentally resized an LVM partition, FC3 now fails to boot PikoMedia EOL (End Of Life) Versions 0 27th March 2005 04:59 PM
Dual Boot probl Win XP and FC 3: no boot menu and automatical boot to windows siwask Installation, Upgrades and Live Media 1 18th February 2005 04:57 AM


Current GMT-time: 12:32 (Thursday, 21-09-2017)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat