Fedora Linux Support Community & Resources Center
  #1  
Old 15th November 2011, 01:40 AM
kanato Offline
Registered User
 
Join Date: Dec 2008
Posts: 28
linuxfirefox
using EPEL in Fedora 16

Is there a way to use EPEL in Fedora 16?

Following the instructions here: http://fedoraproject.org/wiki/EPEL/F..._repository.3F

I run this command
Code:
su -c 'rpm -Uvh http://download.fedora.redhat.com/pub/epel/6/i386/epel-release-6-5.noarch.rpm'
But I get the result
Code:
error: Failed dependencies:
	fedora-release conflicts with epel-release-6-5.noarch
Not sure what to do here...
Reply With Quote
  #2  
Old 21st November 2011, 11:10 PM
DollarSoup Offline
Registered User
 
Join Date: Nov 2011
Posts: 1
macoschrome
Re: using EPEL in Fedora 16

This seems to be an issue with every new release of Fedora. I googled for "fedora-release conflicts with epel-release" and found this page:
http://www.geekdevs.com/2011/09/solv...-on-fedora-15/
...which is specific to Fedora 15, but those directions worked for my instance of Fedora 16. All the rpm does, apparently, is write some conf files to /etc/yum.repos.d/ and import a GPG key. The linked page shows you how to do this manually.
Reply With Quote
  #3  
Old 21st November 2011, 11:36 PM
leigh123linux
Guest
 
Posts: n/a
linuxfirefox
Re: using EPEL in Fedora 16

Why do you want EPEL? , theres nothing additional to the fedora repos there.
Reply With Quote
  #4  
Old 22nd November 2011, 12:34 AM
kanato Offline
Registered User
 
Join Date: Dec 2008
Posts: 28
linuxfirefox
Re: using EPEL in Fedora 16

h5py is not in the fedora repos. I tried downloading and installing the h5py package from EPEL but it has dependencies on older versions of stuff in the fedora repo (don't remember which). So I just built from source. Not my ideal solution but it works.
Reply With Quote
  #5  
Old 22nd November 2011, 02:16 AM
angryfirelord Offline
Registered User
 
Join Date: Dec 2006
Location: Pennsylvania
Posts: 382
linuxfirefox
Re: using EPEL in Fedora 16

According to rpm.pbone.net, h5py is only available for RHEL 6 and Mandrivia. Chances are, it's pulling the RHEL version, so the libraries for Fedora 16 are too new. Yeah yeah, the wonders of Linux backwards compatibility.....

It looks likes it needs Python 2.6 specifically for some odd reason.
Reply With Quote
  #6  
Old 27th November 2011, 06:26 PM
nirik Offline
Registered User
 
Join Date: Mar 2009
Location: Broomfield, CO
Posts: 438
macosmidori
Re: using EPEL in Fedora 16

EPEL is add on packages for RHEL and clones. It will not work at all on Fedora. We specifically added the conflicts there to prevent people messing up their machines.

You can always file a bug asking for Fedora support...
Reply With Quote
Reply

Tags
epel, fedora

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Announcing EPEL 6 - Kevin Fenzi bob News 0 20th January 2011 06:34 PM
Using EPEL Repo on Fedora: Problems tc@cs Using Fedora 4 29th January 2010 03:11 PM
How to enable EPEL on CentOS 5.4 bendib Linux Chat 6 22nd November 2009 01:46 AM
EPEL Problem Metropolis Linux Chat 11 9th September 2009 06:43 PM
Problem with epel.repo TommyV Using Fedora 1 29th June 2009 10:50 PM


Current GMT-time: 12:32 (Thursday, 21-09-2017)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat