Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > The Dungeon > Archived (Click Header To See Sub-Forums) > Alpha - Beta (Fedora 9 Only)
FedoraForum Search

Forgot Password? Join Us!

Alpha - Beta (Fedora 9 Only) Post Development Version comments and questions that don't belong in Bugzilla here. These posts will be moved or deleted once the Final version is released

 
 
Thread Tools Search this Thread Display Modes
  #151  
Old 30th May 2008, 01:28 PM
chalsall Offline
Registered User
 
Join Date: May 2008
Posts: 5
Hey All.

I'm *dying* to get my 3D acceleration back under FC9. Running on a Dell Precision M65.

However, the above did *not* work for me. I haven't "downgraded", so simply added the livna repository, and then ran the yum install (kmod-nvidia xorg-x11-drv-nvidia xorg-x11-drv-nvidia-lib), and then the "nvidia-config-display enable".

However, when I try to "startx" (I boot into init 3 as a precaution), I get the following error: "dlopen: /usr/lib/xorg/modules/extensions//libglx.so: undefined symbol: _nv001471gl".

Any thoughts?

Thanks for all your efforts here.
  #152  
Old 30th May 2008, 04:25 PM
notageek's Avatar
notageek Offline
Registered User
 
Join Date: Jan 2008
Location: N/A
Posts: 2,148
Please post

1. uname -r
2. ls /boot
__________________
Robot Nite - Designated device drivers drink free
  #153  
Old 30th May 2008, 04:38 PM
notageek's Avatar
notageek Offline
Registered User
 
Join Date: Jan 2008
Location: N/A
Posts: 2,148
Please note that the kernel module (driver) of Nvidia available at Livna is for the 2.6.25.3-18.fc9 kernel. If you're still unable to get Nvidia working then

1. Check the kernel version you're running on (by running uname -r)
2. ls /boot will show you the list of kernels available (files starting with vmlinuz-xxx)
3. Edit /boot/grub/grub.conf to make sure the correct kernel is booting.
__________________
Robot Nite - Designated device drivers drink free
  #154  
Old 30th May 2008, 04:43 PM
hammel's Avatar
hammel Offline
Registered User
 
Join Date: May 2005
Location: Downforest, Confoederatio Helvetica
Posts: 222
kmod-nvidia from livna is working like a charme with latest xorg here.

i have an 7900GS.
__________________
Registered Linux User 406188
  #155  
Old 31st May 2008, 12:57 AM
chalsall Offline
Registered User
 
Join Date: May 2008
Posts: 5
Quote:
Originally Posted by notageek
Please note that the kernel module (driver) of Nvidia available at Livna is for the 2.6.25.3-18.fc9 kernel. If you're still unable to get Nvidia working then

1. Check the kernel version you're running on (by running uname -r)
2. ls /boot will show you the list of kernels available (files starting with vmlinuz-xxx)
3. Edit /boot/grub/grub.conf to make sure the correct kernel is booting.
Hi notageek.

Thanks for your suggestions, but it does appear that I'm running the correct version.

Code:
[chalsall@burrow ~]$ uname -r
2.6.25.3-18.fc9.i686
[chalsall@burrow ~]$ ls /boot
config-2.6.25-14.fc9.i686      initrd-2.6.25.3-18.fc9.i686.img
config-2.6.25.3-18.fc9.i686    System.map-2.6.25-14.fc9.i686
efi                            System.map-2.6.25.3-18.fc9.i686
grub                           vmlinuz-2.6.25-14.fc9.i686
initrd-2.6.25-14.fc9.i686.img  vmlinuz-2.6.25.3-18.fc9.i686
Any tests / experiments anyone can suggest?

Thanks!!!
  #156  
Old 31st May 2008, 03:03 AM
TalioGladius Offline
Registered User
 
Join Date: May 2008
Posts: 4
Has anyone seen this?

http://news.softpedia.com/news/Insta...-9-86757.shtml



Since not having dual monitors was a deal breaker for me, I went to Ubuntu 8.04. Which in turn my wireless card on my laptop doesn't work with it. I can't catch a linux break for anything.
  #157  
Old 31st May 2008, 03:45 AM
leigh123linux
Guest
 
Posts: n/a
Quote:
Originally Posted by TalioGladius
Has anyone seen this?

http://news.softpedia.com/news/Insta...-9-86757.shtml



Since not having dual monitors was a deal breaker for me, I went to Ubuntu 8.04. Which in turn my wireless card on my laptop doesn't work with it. I can't catch a linux break for anything.
Try PCLinux

http://distrowatch.com/table.php?distribution=pclinuxos
  #158  
Old 31st May 2008, 10:59 AM
demuytree's Avatar
demuytree Offline
Registered User
 
Join Date: Jan 2008
Location: Ho Chi Minh city VIETNAM
Age: 30
Posts: 47
I have a problem when finish install...can not enable desktop effect
/usr/sbin/nvidia-config-display enable
Driver already enabled.

glxinfo
name of display: :0.0
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual or fbconfig

Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
3 GLXFBConfigs:
visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
Segmentation fault
  #159  
Old 31st May 2008, 11:07 AM
leigh123linux
Guest
 
Posts: n/a
Quote:
Originally Posted by demuytree
I have a problem when finish install...can not enable desktop effect
/usr/sbin/nvidia-config-display enable
Driver already enabled.

glxinfo
name of display: :0.0
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual or fbconfig

Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
3 GLXFBConfigs:
visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
Segmentation fault


post

Code:
cat /etc/X11/xorg.conf
  #160  
Old 31st May 2008, 11:42 AM
stefan1975's Avatar
stefan1975 Offline
"Stefan the converted" -- forum Macintosh® Glee Club leader
 
Join Date: May 2007
Location: 127.0.0.1
Age: 42
Posts: 1,247
Quote:
Originally Posted by chalsall
Hey All.

I'm *dying* to get my 3D acceleration back under FC9. Running on a Dell Precision M65.
i have a precision m65 too and for me it is not working either, not on OpenSuSe11 either. If I understand correctly it is a bug in the nvidia driver that they recognized but are uncertain if/how/when it will be solved:

http://www.nvnews.net/vbulletin/show...ghlight=quadro

i do not know why it applies to certain nvidia cards and not to others but the quadro seems to be suffering from this. maybe i will try the 173.08 beta once again

stefan
__________________
"$ su - bofh"
OS: Mac OSX Snow Leopard (x64 by default), W7_Enterprise_X64, F12_x64_KDE
Hardware: late 2009 Macbook 13", MSI Wind 10"
Browser: Opera 10.10, Safari 4
Registered linux user #459910
  #161  
Old 31st May 2008, 02:40 PM
demuytree's Avatar
demuytree Offline
Registered User
 
Join Date: Jan 2008
Location: Ho Chi Minh city VIETNAM
Age: 30
Posts: 47
I successfully Installed new Nvidia Driver...^^...I forgot to remove Xorg....haha.. It work fine now but my compiz fusion have a new problem...It's just provide me only rotate desktop cube..and wobble windows in desktop effect and emerald windows...So I can't use other effect in my compiz-manager...(...have someone else have the same problem to me ??
  #162  
Old 31st May 2008, 02:54 PM
Firewing1's Avatar
Firewing1 Offline
Registered User
 
Join Date: Dec 2004
Location: Canada
Age: 26
Posts: 9,224
You can install "compizconfig-backend-gconf" and "ccsm" to configure Compiz with extra (3rd party?) plugins, although this is unsupported. I've tried this on 3 machines and confirmed that Compiz will crash every time you open a new window... It did work when I only enabled the 'water' and the extra switcher plugins though. Anything else seems to start the new-window-crash bug.
Firewing1
__________________
[+] My open source software and blog
[+] Some of my howtos: (for full list, click here)
  #163  
Old 31st May 2008, 03:12 PM
weitjong's Avatar
weitjong Offline
Registered User
 
Join Date: Oct 2006
Location: Singapore, 新加坡
Posts: 989
I have waited patiently for this day. I have not downgraded my X. After following Leigh's instruction in this thread: http://forums.fedoraforum.org/forum/...d.php?t=190240, everything seems to work in a perfect harmony. I only deviated slightly from his instruction. I install the 64-bit kmod-nvidia package instead of akmod.

I have not tried all the compiz-fusion bell and whistle, but at least the one that I did try seems to work nicely though.

In case someone is wondering, I have MSI 7900GTX.
  #164  
Old 31st May 2008, 03:47 PM
leigh123linux
Guest
 
Posts: n/a
Quote:
Originally Posted by demuytree
I successfully Installed new Nvidia Driver...^^...I forgot to remove Xorg....haha.. It work fine now but my compiz fusion have a new problem...It's just provide me only rotate desktop cube..and wobble windows in desktop effect and emerald windows...So I can't use other effect in my compiz-manager...(...have someone else have the same problem to me ??

Use fusion-icon instead to launch compiz-fusion !
  #165  
Old 31st May 2008, 03:57 PM
Firewing1's Avatar
Firewing1 Offline
Registered User
 
Join Date: Dec 2004
Location: Canada
Age: 26
Posts: 9,224
Edit: Ignore this post, I had a thinko. Can't use Compiz when I've switched to the Vesa driver!

Quote:
Originally Posted by leigh123@linux
Use fusion-icon instead to launch compiz-fusion !
Doesn't work for fglrx
Quote:
compiz (core) - Fatal: No GLXFBConfig for default depth, this isn't going to work.
compiz (core) - Error: Failed to manage screen: 0
compiz (core) - Fatal: No manageable screens found on display :0.0
Any way to pass LIBGL_ALWAYS_INDIRECT to fusion-icon?
Firewing1
__________________
[+] My open source software and blog
[+] Some of my howtos: (for full list, click here)

Last edited by Firewing1; 31st May 2008 at 04:02 PM.
 

Tags
fedora, nvidia, opengl

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenGL doesn't work, nvidia does Xx r3negade Hardware & Laptops 6 9th March 2008 08:18 AM
help please (nvidia/OpenGl problems) tapke Using Fedora 21 2nd January 2008 02:09 PM
nVidia - no opengl after upgrade to FC6 akbowbender Hardware & Laptops 2 2nd November 2006 04:33 AM
Nvidia Drivers and OpenGL Chupacabra Using Fedora 10 2nd September 2006 11:06 PM
FC4: Nvidia and OpenGL Supa Troopa Hardware & Laptops 2 2nd July 2005 02:04 AM


Current GMT-time: 10:47 (Tuesday, 26-09-2017)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat