Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > The Dungeon > Archived (Click Header To See Sub-Forums) > Alpha - Beta (Fedora 9 Only)
FedoraForum Search

Forgot Password? Join Us!

Alpha - Beta (Fedora 9 Only) Post Development Version comments and questions that don't belong in Bugzilla here. These posts will be moved or deleted once the Final version is released

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 16th May 2008, 04:20 PM
lottc Offline
Registered User
 
Join Date: Dec 2006
Location: Florida
Age: 37
Posts: 22
Fedora 9 (F9) and Nvidia 173.08 with OpenGL!

Please refer to post #135 and follow the instructions in the "TO INSTALL NEW" section.
http://forums.fedoraforum.org/showpo...&postcount=135

THE FOLLOWING IS NO LONGER NEEDED!!!



Two weeks ago, I purchased my first speed demon...well for personal use anyways. I have setup and currently maintain countless quad-core and dual-quad-core servers all over the country. But this one for me!

It is using the new 780i EVGA board with a Q6700 and an Nvidia 9600GT (yes I know the 8800 has more shaders).

But like countless others out there, I was remiss to find that I was dead in the water...not only with the 9600GT, but also with my 7600GT...because Nvidia will not release a driver for Xorg 1.4.99x and Fedora decided to use a prerelease.

So how do we fix this? There really is no way to get Nvidia 173.08 working with Xorg 1.4.99x with 3D/OpenGL, yes you can get 2D working by using -ignoreABI...but really, what is the point! The only remaining solution is to downgrade Xorg...and this scares the living ***** out of people...so lets do it!

So, what does this do???
1. Allows you to use 3D, Composite and Compiz with Nvidia graphics cards and Fedora 9.
2. Allows you to use Geforce 9000 series graphics cards, in addition to 7000 series, 8000 series and mobile variants.

Here we go...
(Standard disclaimer should apply...don't blame me if you kill your system.)

Login as root.
Code:
su -
Remove the Xorg server and mesa libraries.
Code:
yum -y remove xorg-x11-server-Xorg xorg-x11-server-common
rpm -e --nodeps --allmatches mesa-libGL mesa-libGLU mesa-libGL-devel mesa-libGLU-devel glx-utils
Download fedora8.repo and modify fedora.repo.
Note: The modified fedora.repo only adds an "exclude" line to ignore the unwanted Xorg Xserver 1.4
Code:
cd /etc/yum.repos.d
wget http://www.linux-ati-drivers.homecall.co.uk/fedora8.repo
perl -i -pe "s/(\[.*\])/\1\nexclude=xorg* linuxwacom* rhpxl* mesa*/"  fedora.repo
perl -i -pe "s/(\[.*\])/\1\nexclude=xorg* linuxwacom* rhpxl* mesa*/" fedora-updates.repo
Install Development Tools/Libraries
Code:
yum -y groupinstall "Development Tools" "Development Libraries"
yum -y install kernel-devel
Now, you are ready to install Xorg 1.3!
Code:
yum -y groupinstall "X Window System"
yum -y install mesa-libGL mesa-libGLU mesa-libGL-devel mesa-libGLU-devel synaptics

# Optional, re-install compiz.
yum -y install compiz-gnome compiz-fusion* gnome-compiz-manager ccsm
Now, just install the Nvidia drivers.

32-bit Nvidia drivers
Code:
cd /tmp
wget http://www.dfm.uninsubria.it/compiz/nvidia/nvidia-x11-drv-173.08-1.fc9.i386.rpm
yum --nogpgcheck localinstall nvidia-x11-drv-173.08-1.fc9.i386.rpm
/usr/sbin/nvidia-config-display enable
reboot
64-bit Nvidia drivers
Code:
cd /tmp
wget http://www.dfm.uninsubria.it/compiz/nvidia/nvidia-x11-drv-173.08-1.fc9.x86_64.rpm
wget http://www.dfm.uninsubria.it/compiz/nvidia/nvidia-x11-drv-32bit-173.08-1.fc9.x86_64.rpm
yum --nogpgcheck localinstall nvidia-x11-drv-173.08-1.fc9.x86_64.rpm nvidia-x11-drv-32bit-173.08-1.fc9.x86_64.rpm
/usr/sbin/nvidia-config-display enable
reboot
And thats it!

Nvidia 173.08, F9 and Xorg Server 1.3 all seem to play nice with both of my Nvidia cards, the 7600GT and the 9600GT...but I make no promises here. The safest thing to do would be to wait until Xorg Server 1.5 is released and pray that Fedora decides to include it in the F9 updates (which probably wont happen).



Oh! To reverse the changes:
Edit /etc/yum.repos.d/fedora.repo and /etc/yum.repos.d/fedora-updates.repo
Remove this line:
Code:
exclude=xorg* linuxwacom* rhpxl* mesa*
Remove the fedora8.repo we created and update your Xorg RPMs.
Code:
rm /etc/yum.repos.d/fedora8.repo
yum update

I hope this helps all of you Nvidia fans on the bleeding edge of Fedora...

- Lott Caskey
lottc AT fugitol DOT com

Last edited by lottc; 29th May 2008 at 04:36 AM.
 

Tags
fedora, nvidia, opengl

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenGL doesn't work, nvidia does Xx r3negade Hardware & Laptops 6 9th March 2008 08:18 AM
help please (nvidia/OpenGl problems) tapke Using Fedora 21 2nd January 2008 02:09 PM
nVidia - no opengl after upgrade to FC6 akbowbender Hardware & Laptops 2 2nd November 2006 04:33 AM
Nvidia Drivers and OpenGL Chupacabra Using Fedora 10 2nd September 2006 11:06 PM
FC4: Nvidia and OpenGL Supa Troopa Hardware & Laptops 2 2nd July 2005 02:04 AM


Current GMT-time: 23:14 (Wednesday, 16-08-2017)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat