Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Fedora Resources > Guides & Solutions (Not For Questions)
FedoraForum Search

Forgot Password? Join Us!

Guides & Solutions (Not For Questions) Post your guides here (No links to Blogs accepted). You can also append your comments/questions to a guide, but don't start a new thread to ask a question. Use another forum for that.

View Poll Results: Did it work for you
Yes 459 48.57%
No 343 36.30%
Nearly worked 143 15.13%
Voters: 945. You may not vote on this poll

Reply
 
Thread Tools Search this Thread Display Modes
  #16  
Old 25th May 2007, 12:50 AM
Zero-Override Offline
Registered User
 
Join Date: May 2005
Posts: 741
Code:
[Alex@localhost ~]$ fglrxinfo
Xlib:  extension "XFree86-DRI" missing on display ":0.0".
display: :0.0  screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.4 (1.5 Mesa 6.5.2)






[Alex@localhost ~]$ glxinfo
name of display: :0.0
Xlib:  extension "XFree86-DRI" missing on display ":0.0".
display: :0  screen: 0
direct rendering: No
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
    GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
    GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, GLX_OML_swap_method,
    GLX_SGI_make_current_read, GLX_SGIS_multisample, GLX_SGIX_hyperpipe,
    GLX_SGIX_swap_barrier, GLX_SGIX_fbconfig, GLX_MESA_copy_sub_buffer
client glx vendor string: ATI
client glx version string: 1.3
client glx extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
    GLX_ARB_get_proc_address, GLX_SGI_video_sync, GLX_ARB_multisample,
    GLX_ATI_pixel_format_float, GLX_ATI_render_texture
GLX version: 1.2
GLX extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
    GLX_ARB_multisample
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.4 (1.5 Mesa 6.5.2)
OpenGL extensions:
    GL_ARB_imaging, GL_ARB_multitexture, GL_ARB_texture_border_clamp,
    GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
    GL_ARB_texture_env_combine, GL_ARB_texture_env_dot3,
    GL_ARB_transpose_matrix, GL_EXT_abgr, GL_EXT_blend_color,
    GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_texture_env_add,
    GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3,
    GL_EXT_texture_lod_bias

   visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
 id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------
0x22 24 tc  0 24  0 r  y  .  8  8  8  0  0 16  0  0  0  0  0  0 0 None
0x23 24 tc  0 24  0 r  y  .  8  8  8  0  0 16  8 16 16 16  0  0 0 None
0x24 24 tc  0 32  0 r  y  .  8  8  8  8  0 16  8 16 16 16 16  0 0 None
0x25 24 tc  0 32  0 r  .  .  8  8  8  8  0 16  8 16 16 16 16  0 0 None
0x3d 32 tc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None
these are my fglrxinfo and glxinfo outputs, maybe that helps anything
__________________
LINUX NUMBER 389596
machine number 290131
Reply With Quote
  #17  
Old 25th May 2007, 12:54 AM
leigh123linux
Guest
 
Posts: n/a
Quote:
Originally Posted by Zero-Override
i must have fudged up somewhere

okay here is what i did and have:

i have a fully operational and fresh install of fc7test4
i have the i686 kernel
i have yum and downloaded the packages,

what i don have
i don't have the the namechange from mesa to ati in the xorg.conf
when i tell it to do "service fglrx restart" it says
Code:
 bash: service: command not found
when i reboot it tells me that itś enabling the fglrx and that it may take a while, that works out okay and passes, then whenit should load my xserver it fails and says i fudged something up and that it will repair it =/

what would you suggest i do next?


oh btw, i have my xorg.conf exactly like described

I have not tried FC7 test4 yet ( I am going to wait for the final release ) and don't know if the XGL script will work for FC7.

As for the livna driver did you use the right release key.?
Can you also post the output from these commands

cat /var/log/Xorg.0.log | grep EE


and


cat /var/log/Xorg.0.log | grep WW

Last edited by leigh123linux; 25th May 2007 at 12:57 AM.
Reply With Quote
  #18  
Old 25th May 2007, 12:59 AM
Zero-Override Offline
Registered User
 
Join Date: May 2005
Posts: 741
i get an error roughly saying thta i don't have fc7 yet (it is officially 6.93) so it won't load up

to game (just WoW) is there anything i can do at this point?

thanks for the lightning responsetime btw


Code:
[Alex@localhost ~]$ cat /var/log/Xorg.0.log | grep EE
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(II) Loading extension MIT-SCREEN-SAVER
[Alex@localhost ~]$ cat /var/log/Xorg.0.log | grep WW
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(WW) No monitor specified for screen "Screen0".
(WW) The core pointer device wasn't specified explicitly in the layout.
(WW) No FontPath specified.  Using compiled-in default.
(WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
(WW) VESA(0): Option "UseFastTLS" is not used
(WW) VESA(0): Option "BlockSignalsOnLock" is not used
(WW) VESA(0): Option "ForceGenericCPU" is not used
(WW) VESA(0): Option "KernelModuleParm" is not used
(WW) <default pointer>: No Device specified, looking for one...
[Alex@localhost ~]$
__________________
LINUX NUMBER 389596
machine number 290131
Reply With Quote
  #19  
Old 25th May 2007, 01:08 AM
leigh123linux
Guest
 
Posts: n/a
Ok try this as I dont think FC6 packages will work


su -
yum remove kmod-fglrx xorg-x11-drv-fglrx xorg-x11-drv-fglrx-libs-32bit
wget http://rpm.livna.org/fedora/6.93/i38...4.fc7.i686.rpm
wget http://rpm.livna.org/fedora/6.93/i38....lvn7.i386.rpm
rpm -i kmod-fglrx-8.36.5-3.2.6.21_1.3194.fc7.i686.rpm xorg-x11-drv-fglrx-8.36.5-3.lvn7.i386.rpm

Can you post any errors from the rpm command

Last edited by leigh123linux; 27th May 2007 at 06:25 PM.
Reply With Quote
  #20  
Old 25th May 2007, 01:22 AM
Zero-Override Offline
Registered User
 
Join Date: May 2005
Posts: 741
it says i need the 8.36.5 >= is needed of fglrx-kmod-common after looking that up it should have been in the http://rpm.livna.org/fedora/7/i386/x....lvn7.i386.rpm file but thatś not a high enogh version

off to my bed (2.19 am here, got an important day tomorrow =/ ) but iĺl read any comment tomorrow and thanks for the help so far man! i appreciate it a lot
__________________
LINUX NUMBER 389596
machine number 290131
Reply With Quote
  #21  
Old 25th May 2007, 01:40 AM
leigh123linux
Guest
 
Posts: n/a
Quote:
Originally Posted by Zero-Override
it says i need the 8.36.5 >= is needed of fglrx-kmod-common after looking that up it should have been in the http://rpm.livna.org/fedora/7/i386/x....lvn7.i386.rpm file but thatś not a high enogh version

off to my bed (2.19 am here, got an important day tomorrow =/ ) but iĺl read any comment tomorrow and thanks for the help so far man! i appreciate it a lot
I have just looked at both repositories ( 6.93 & 7 ) and the fglrx driver versions dont match the kernel modules .
I will have a word with the person responsible and see if he can correct it.
Reply With Quote
  #22  
Old 25th May 2007, 07:59 AM
Zero-Override Offline
Registered User
 
Join Date: May 2005
Posts: 741
omg O_O
influance...

that would be so great if you could manage to do that!!!!!
__________________
LINUX NUMBER 389596
machine number 290131
Reply With Quote
  #23  
Old 25th May 2007, 04:08 PM
leigh123linux
Guest
 
Posts: n/a
Quote:
Originally Posted by Zero-Override
omg O_O
influance...

that would be so great if you could manage to do that!!!!!
I have been told that this will be corrected by tomorrow
Reply With Quote
  #24  
Old 26th May 2007, 12:59 PM
strikeforce Offline
Registered User
 
Join Date: Jun 2004
Location: Perth, Western Australia
Age: 40
Posts: 1,464
Thanks for this it works great. The fact that you manually downloaded the packages does that run the risk of being outdated? Is there a repository to upgrade all the parts of compiz/xgl/ beryl?
__________________
- Helping New Users
Fedora Solved

- How to pay forward
Fedora Help Wanted

- Need a quick guide
Fedora Guide
Reply With Quote
  #25  
Old 26th May 2007, 02:05 PM
leigh123linux
Guest
 
Posts: n/a
Quote:
Originally Posted by strikeforce
Thanks for this it works great. The fact that you manually downloaded the packages does that run the risk of being outdated? Is there a repository to upgrade all the parts of compiz/xgl/ beryl?

I have had a quick look at the script and the packages seem to be provided by this repository

http://fedoraxgl.tuxfamily.org/repos...0-3.noarch.rpm

So they should get any updates when released
Reply With Quote
  #26  
Old 26th May 2007, 02:23 PM
strikeforce Offline
Registered User
 
Join Date: Jun 2004
Location: Perth, Western Australia
Age: 40
Posts: 1,464
Beauty I think I have to turn it on because when I do a
Code:
yum check-update
It doesn't get the repo's data it just goes to my regular repo's
__________________
- Helping New Users
Fedora Solved

- How to pay forward
Fedora Help Wanted

- Need a quick guide
Fedora Guide
Reply With Quote
  #27  
Old 26th May 2007, 02:40 PM
leigh123linux
Guest
 
Posts: n/a
Quote:
Originally Posted by strikeforce
Beauty I think I have to turn it on because when I do a
Code:
yum check-update
It doesn't get the repo's data it just goes to my regular repo's
The repo is installed in a disabled state

Quote:
[fedora-xgl]
name=Fedora $releasever - $basearch - Base Xgl repository
baseurl=
http://fedoraxgl.tuxfamily.org/repository/$releasever/$basearch
http://users.telenet.be/quenta/$releasever/$basearch
gpgcheck=1
enabled=0
#gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AL-CAPCOM

[fedora-xgl-source]
name=Fedora Xgl tmp testing repository
baseurl=
http://fedoraxgl.tuxfamily.org/repository/$releasever/SRPMS
http://users.telenet.be/quenta/repository/$releasever/SRPMS
gpgcheck=1
enabled=0
#gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AL-CAPCOM
To enable this repo try

Quote:
yum --enablerepo=fedora-xgl check-update
Reply With Quote
  #28  
Old 27th May 2007, 11:13 AM
tokegee Offline
Registered User
 
Join Date: Apr 2007
Location: EU
Posts: 76
Hi
I cound not install fglrx driver for my ati card. Although I have i686 kernel, it showed me error. My PC has ATi 9800 SE. How can I do that?

Best regards
Reply With Quote
  #29  
Old 27th May 2007, 11:25 AM
leigh123linux
Guest
 
Posts: n/a
Quote:
Originally Posted by tokegee
Hi
I cound not install fglrx driver for my ati card. Although I have i686 kernel, it showed me error. My PC has ATi 9800 SE. How can I do that?

Best regards

You have a i585 kernel and need to swap it for a i686 kernel as described in section 1

to check

Quote:
rpm -qa --queryformat "%{NAME}-%{VERSION}-%{RELEASE}.%{ARCH}\n"|grep kernel|sort
to fix

Quote:
su -c "yum install yum-utils"
Quote:
yumdownloader kernel.i686
Quote:
su -c "rpm -ivh --replacefiles --replacepkgs kernel-2*.i686.rpm"
reboot

then run these commands again

Quote:
su -
yum install kmod-fglrx xorg-x11-drv-fglrx xorg-x11-drv-fglrx-libs-32bit
yum update kmod-fglrx xorg-x11-drv-fglrx xorg-x11-drv-fglrx-libs-32bit
service fglrx restart
fglrx-config-display enable
You will need to read my howto carefully as all the steps are required

Last edited by leigh123linux; 27th May 2007 at 07:36 PM.
Reply With Quote
  #30  
Old 28th May 2007, 03:43 PM
tokegee Offline
Registered User
 
Join Date: Apr 2007
Location: EU
Posts: 76
Hi leigh123
Thank you .. leigh123, I got fglrx driver installed and Beryl too. Well .. please let me ask more questions.
After installing them, I lost my desktop effects. Although I tried with Beryl Manager, I got nothing effects.
And all resolutions were changed from my current resolution 1024x768 to the 1280x1024. Although I could change my destop resolution to 1024x768, but Starting screen and Login screen are in 1280x1024. So how can I fix it and How can I get Desktop Effects?

Best regards

PS: have a nice day
Reply With Quote
Reply

Tags
ati, fglrx, howto

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ATI Catalyst fglrx driver manual install on Fedora 12 Jeff72 Guides & Solutions (Not For Questions) 15 13th August 2010 09:17 PM
ATI Catalyst™ Display Driver v9.12 rich52 Hardware & Laptops 1 31st December 2009 05:59 AM
HOWTO - make less noise from video card while using fglrx driver multescugeorge@ Guides & Solutions (Not For Questions) 2 3rd October 2009 08:02 AM
ATI Catalyst 9.x fglrx driver manual install on Fedora 11 Jeff72 Guides & Solutions (Not For Questions) 25 30th August 2009 08:29 PM


Current GMT-time: 03:40 (Saturday, 23-09-2017)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat