Fedora Linux Support Community & Resources Center
  #1  
Old 18th May 2017, 03:21 AM
lemeza Offline
Registered User
 
Join Date: Oct 2010
Location: Gilbert, AZ
Posts: 3
linuxfedorafirefox
F25 and NFS (unable to mount fs from dev board)

Good evening everyone, sorry for the long-winded explanation, but I've been trying to figure this out for a couple weeks now, so any help is greatly appreciated...

I dusted off an old development board (mini2440), and it needs to mount a file system over NFS, but I'm failing to get the host & client configured properly, the client refuses to mount the file system. I'm using minicom as terminal into the board. Here's the nfs-related output of the bootup (see attached for entire output):
---------------------------------------------------------------------------
...
Kernel command line: console=ttySAC0,115200 root=/dev/nfs nfsroot=192.168.1.2:/home/target_fs ip=192.168.1.50
...
RPC: Registered udp transport module.
RPC: Registered tcp transport module.
RPC: Registered tcp NFSv4.1 backchannel transport module.
...
eth0: link down
IP-Config: Guessing netmask 255.255.255.0
IP-Config: Complete:
device=eth0, addr=192.168.1.50, mask=255.255.255.0, gw=255.255.255.255,
host=192.168.1.50, domain=, nis-domain=(none),
bootserver=255.255.255.255, rootserver=192.168.1.2, rootpath=
Looking up port of RPC 100003/2 on 192.168.1.2
eth0: link up, 100Mbps, full-duplex, lpa 0xCDE1
Root-NFS: Unable to get nfsd port number from server, using default
Looking up port of RPC 100005/1 on 192.168.1.2
VFS: Unable to mount root fs via NFS, trying floppy.
VFS: Cannot open root device "nfs" or unknown-block(2,0)
Please append a correct "root=" boot option; here are the available partitions:
1f00 256 mtdblock0 (driver?)
1f01 128 mtdblock1 (driver?)
1f02 5120 mtdblock2 (driver?)
1f03 125568 mtdblock3 (driver?)
1f04 131072 mtdblock4 (driver?)
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(2,0)
Backtrace:
[<c0035270>] (dump_backtrace+0x0/0x10c) from [<c03958f0>] (dump_stack+0x18/0x1c)
r7:c39230cb r6:c0503ed0 r5:c3923000 r4:c3823f40
[<c03958d8>] (dump_stack+0x0/0x1c) from [<c0395940>] (panic+0x4c/0x134)
[<c03958f4>] (panic+0x0/0x134) from [<c0008e9c>] (mount_block_root+0x178/0x234)
r3:00000000 r2:c3802dac r1:c3823f40 r0:c0453700
[<c0008d24>] (mount_block_root+0x0/0x234) from [<c0009008>] (mount_root+0xb0/0xf4)
[<c0008f58>] (mount_root+0x0/0xf4) from [<c0009144>] (prepare_namespace+0xf8/0x190)
r7:c05038a0 r6:c0021808 r5:c0021808 r4:c0021818
[<c000904c>] (prepare_namespace+0x0/0x190) from [<c00084c0>] (kernel_init+0xf0/0x124)
r7:00000000 r6:c00200dc r5:c00205d4 r4:c00205d4
[<c00083d0>] (kernel_init+0x0/0x124) from [<c004d1a4>] (do_exit+0x0/0x62c)
r7:00000000 r6:00000000 r5:00000000 r4:00000000



My NFS server is running Fedora 25 with the following:
---------------------------------------------------------------------------
1) Disabled firewall using "systemctl stop firewalld"
2) Disabled SELinux using "SELINUX=diabled" in /etc/selinux/config
3) Created a symlink "target_fs"->"/home/user/target_fs" in /home directory

[root@localhost ~]# uname -a
Linux localhost.localdomain 4.10.15-200.fc25.x86_64 #1 SMP Mon May 8 18:46:06 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

[root@localhost ~]# cat /proc/fs/nfsd/versions
+2 +3 +4 +4.1 +4.2

[root@localhost ~]# /usr/sbin/exportfs -r -v
exporting 192.168.1.50:/home
exporting 192.168.1.50:/home/user
exporting 192.168.1.50:/home/user/target_fs

[root@localhost ~]# ls -la /home/user | grep target_fs
drwxrwxrwx. 17 root root 4096 Aug 2 2010 target_fs

[root@localhost ~]# ls -la /home | grep target_fs
lrwxrwxrwx. 1 root root 22 May 6 15:19 target_fs -> /home/user/target_fs

[root@localhost ~]# rpcinfo -s
program version(s) netid(s) service owner
100000 2,3,4 local,udp,tcp,udp6,tcp6 portmapper superuser
100024 1 tcp6,udp6,tcp,udp status 29
100005 3,2,1 tcp6,udp6,tcp,udp mountd superuser
100003 4,3,2 tcp6,tcp nfs superuser
100227 3,2 tcp6,tcp nfs_acl superuser
100021 4,3,1 tcp6,udp6,tcp,udp nlockmgr superuser

[root@localhost ~]# rpcinfo -p
program vers proto port service
100000 4 tcp 111 portmapper
100000 3 tcp 111 portmapper
100000 2 tcp 111 portmapper
100000 4 udp 111 portmapper
100000 3 udp 111 portmapper
100000 2 udp 111 portmapper
100024 1 udp 55605 status
100024 1 tcp 54363 status
100005 1 udp 20048 mountd
100005 1 tcp 20048 mountd
100005 2 udp 20048 mountd
100005 2 tcp 20048 mountd
100005 3 udp 20048 mountd
100005 3 tcp 20048 mountd
100003 2 tcp 2049 nfs
100003 3 tcp 2049 nfs
100003 4 tcp 2049 nfs
100227 2 tcp 2049 nfs_acl
100227 3 tcp 2049 nfs_acl
100021 1 udp 59460 nlockmgr
100021 3 udp 59460 nlockmgr
100021 4 udp 59460 nlockmgr
100021 1 tcp 35383 nlockmgr
100021 3 tcp 35383 nlockmgr
100021 4 tcp 35383 nlockmgr

[root@localhost ~]# ifconfig
enp0s31f6: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 192.168.1.2 netmask 255.255.255.0 broadcast 192.168.1.255
inet6 fe80::728b:cdff:fe4f:9447 prefixlen 64 scopeid 0x20<link>
ether 70:8b:cd:4f:94:47 txqueuelen 1000 (Ethernet)
RX packets 4658 bytes 3523513 (3.3 MiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 3672 bytes 494133 (482.5 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
device interrupt 16 memory 0xdf800000-df820000


As far as I can tell, all required services are running on the server, but the client looks like it can't do a port lookup of RPC 100005/1, then it crashes. Again, any help is greatly appreciated. Let me know if I should provide any other info, and thanks in advance!
Attached Files
File Type: txt mini2440_nfs_fail.txt (19.6 KB, 19 views)
Reply With Quote
Reply

Tags
board, dev, f25, mount, nfs, unable

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
unable to mount dvd Lewish Hardware & Laptops 17 22nd June 2012 02:05 AM
USB hd - unable to mount SarahShreeve Hardware & Laptops 7 20th November 2007 03:07 PM
NFS server: can't mount export from developer board tselmeci Servers & Networking 2 23rd August 2007 01:51 PM
On board Display of Foxconn P4M800P7MA-RS2 mother board hosammy Hardware & Laptops 1 9th March 2007 08:38 PM
Unable to mount DVD iso thesource Using Fedora 15 11th October 2006 12:06 PM


Current GMT-time: 00:33 (Sunday, 20-08-2017)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat