Fedora Linux Support Community & Resources Center
  #1  
Old 10th June 2009, 06:43 PM
wvn's Avatar
wvn Offline
Registered User
 
Join Date: Jul 2008
Location: Mir space station
Age: 39
Posts: 737
Python(abi) dependency missing

Hi all, the installation of lottanzb stalls since the python(abi) dependency is not satisfied. Did a bit of search and found out that this is in fact a dummy python package. Any ideas how can i get it installed on F11?

thanks again
Reply With Quote
  #2  
Old 10th June 2009, 06:55 PM
PabloTwo's Avatar
PabloTwo Offline
"Registered User" T-Shirt Winner
 
Join Date: Mar 2007
Location: Seville, FL
Posts: 7,562
On my F8 install:
Code:
~/> rpm -q --provides python | grep abi
python(abi) = 2.5
python-abi = 2.5
What does that command produce on your F11 install?
Reply With Quote
  #3  
Old 10th June 2009, 07:29 PM
wvn's Avatar
wvn Offline
Registered User
 
Join Date: Jul 2008
Location: Mir space station
Age: 39
Posts: 737
Quote:
[home@localhost Desktop]$ rpm -q --provides python | grep abi
python(abi) = 2.6
python-abi = 2.6
i guess i need 2.5 version
Reply With Quote
  #4  
Old 10th June 2009, 07:42 PM
PabloTwo's Avatar
PabloTwo Offline
"Registered User" T-Shirt Winner
 
Join Date: Mar 2007
Location: Seville, FL
Posts: 7,562
How are you installing lottanzb? Is it an rpm package or source tarball or what?

If it's a an rpm package, then do the following on it:
Code:
rpm -qp --requires <rpm_package_name_in_full>
The "requires" may or may not show a version for python(abii) and python-abi. If it does specify a version, it would be either explcit, like: python(abi) 2.5 (or =2.5), which would cause the problem since you have 2.6. If it's like: python(abi) >=2.5, then that means 2.6 would satisfy the dependency, as it's saying equal to v2.5 or greater.

edit: Also, if there was no version requirement in the 'requires' for lottanzb, then any version of python(abi) would be acceptable, so my guess is that it's asking for a specific version.

Last edited by PabloTwo; 10th June 2009 at 07:47 PM.
Reply With Quote
  #5  
Old 10th June 2009, 07:54 PM
wvn's Avatar
wvn Offline
Registered User
 
Join Date: Jul 2008
Location: Mir space station
Age: 39
Posts: 737
TY pablotwo, did it and it turns out it has to be =2.5. so i will search for that

EDIT

Found 2.5.1 but system says "no transaction" when i attempt to install.

Last edited by wvn; 10th June 2009 at 07:57 PM.
Reply With Quote
  #6  
Old 10th June 2009, 07:59 PM
PabloTwo's Avatar
PabloTwo Offline
"Registered User" T-Shirt Winner
 
Join Date: Mar 2007
Location: Seville, FL
Posts: 7,562
OK.. you could just try a forced install of lottanzb and see if it played OK. If not, then, well, deal with that later.
Code:
rpm --nodeps -ivh lottanzb*
To get the python(abi) =2.5 and python-abi =2.5 "provides", you would need to install a lower version of python than you have now.
Another way: get the src.rpm package of lottanzb and modify the %Requires section of the spec file to accept higher versions of *abi, then build the rpm.
Or maybe you could locate a newer version lottanzb that would work?

Last edited by PabloTwo; 10th June 2009 at 08:07 PM.
Reply With Quote
  #7  
Old 10th June 2009, 08:31 PM
wvn's Avatar
wvn Offline
Registered User
 
Join Date: Jul 2008
Location: Mir space station
Age: 39
Posts: 737
Yeah, it installed but wont run.
Reply With Quote
  #8  
Old 10th June 2009, 08:33 PM
PabloTwo's Avatar
PabloTwo Offline
"Registered User" T-Shirt Winner
 
Join Date: Mar 2007
Location: Seville, FL
Posts: 7,562
Here's a link to a Mandriva package of lottanzb that requires python 2.6, which is what F11 is now using. Looks like this might install/work in F11 without complaint.

edit: The possible snag to this is, sometimes a different distros use different names for the same package, which also leads to different names for the "requires" in the rpm packages. So, even though you might actaully have all the right (Fedora) packages to satisfy the requires to install, if they don't display the right name(s) that, say, the Mandriva package is looking for, then there's trouble. I ran into this lately when I took a Mandriva src.rpm package and used it as a base to build a Fedora rpm package from. I had to do some dectective work to figure out what package names to change in the Mandriva spec file so it would build properly for a Fedora package.

Last edited by PabloTwo; 10th June 2009 at 08:47 PM.
Reply With Quote
  #9  
Old 10th June 2009, 09:19 PM
Lantash Offline
Registered User
 
Join Date: Jun 2009
Posts: 13
Hi there,

I'm one of the developers of LottaNZB and the one who created the Fedora package in a virtual machine running Fedora. LottaNZB works with any recent 2.x version of Python, but I was unable to fix the dependency issue because I just don't know enough about RPM packaging in combination with Python's distutils or RPM in general. We might not provide RPM packages in the future, as it looks as they cannot even be installed ;-).

Please note that installing LottaNZB using the source package should work just fine on Fedora: http://www.lottanzb.org/downloads/source_code/ It will create an entry in the application menu, file associations etc and it's possible to cleanly uninstall it later on.

If anyone is interested in fixing these packaging issues, I'd love to hear from you! You can find the source repository here (the source package does not contain all files related to packaging): https://code.launchpad.net/lottanzb

Regards,
Lantash

Last edited by Lantash; 10th June 2009 at 09:21 PM.
Reply With Quote
  #10  
Old 10th June 2009, 09:27 PM
Lantash Offline
Registered User
 
Join Date: Jun 2009
Posts: 13
The "requires" property is set correctly in setup.py:

Code:
class BuildRPM(bdist_rpm.bdist_rpm):
        [...]
        
        elif isfile("/etc/fedora-release"):
            dist_release = open("/etc/fedora-release").read().split(" ")[2]
            
            self.distribution_name = "Fedora %s" % dist_release
            self.release = "%s.fc%s" % (self.release, dist_release)
            self.requires = "python >= 2.4 hellanzb >= 0.13 " + \
                "pygtk2 >= 2.12 python-kiwi >= 1.9.9"
But the "python == 2.5" dependency has been added automatically when I built the package on Fedora 9 because the files are installed to a version-specific location (/usr/lib/python2.x/site-packages/lottanzb*). I guess one would just need to build a package for each recent version of Fedora (let's say 9 - 11).
Reply With Quote
  #11  
Old 10th June 2009, 11:08 PM
PabloTwo's Avatar
PabloTwo Offline
"Registered User" T-Shirt Winner
 
Join Date: Mar 2007
Location: Seville, FL
Posts: 7,562
Hello Lantash-

Very nice of you to drop in and add your knowledgeable input to this thread. I haven't even bothered to research what lottanzb does , just attempting to help wvn get a working install of it. I also have no clue as to from what source wvn obtained the original lottanzb rpm package he was having difficulties with.

You're link to the source code tarball will no doubt solve the problem for wvn. I'm currently downloading the F9 rpm package just to have a look at it. Though I play around a bit, and am still learning, with creating rpm packages for Fedora (I'm still running F8), my only attempt at building an rpm package from a Python based source code package was pretty short lived, as that quickly got way above my pay grade and level of experience. I ended up just using the 'setup.py' for the install of QuodLibet.

Last edited by PabloTwo; 10th June 2009 at 11:16 PM.
Reply With Quote
  #12  
Old 10th June 2009, 11:42 PM
Lantash Offline
Registered User
 
Join Date: Jun 2009
Posts: 13
Just added a note to the Fedora download page at lottanzb.org so that Fedora 11 users won't download the package and fail to install it. I'll get back to you tomorrow, I'm too tired to keep on typing. ;-)
Reply With Quote
  #13  
Old 11th June 2009, 12:32 AM
PabloTwo's Avatar
PabloTwo Offline
"Registered User" T-Shirt Winner
 
Join Date: Mar 2007
Location: Seville, FL
Posts: 7,562
@wvn- well, a lot learned from Lantash. For one, doing the 'forced install' of the rpm package you had without pulling in any dependencies guaranteed failure. The download website Lantash pointed to clearly states that hellanzb is a required dep, not to mention a whole host of others. Just for kicks, I also downloaded the F9 version of hellanzb and did a yum localinstall of the two packages.
Code:
~/> ls downloads/
hellanzb-0.13-1.fc9.noarch.rpm  lottanzb-0.4.1-1.fc9.noarch.rpm
~/> sudo yum --nogpgcheck localinstall downloads/*.fc9.noarch.rpm
Setting up Local Package Process
   ---<snip>---
Dependencies Resolved

==============================================================================================================
 Package                   Arch       Version             Repository                                     Size
==============================================================================================================
Installing:
 hellanzb                  noarch     0.13-1.fc9          downloads/hellanzb-0.13-1.fc9.noarch.rpm      1.0 M
 lottanzb                  noarch     0.4.1-1.fc9         downloads/lottanzb-0.4.1-1.fc9.noarch.rpm     4.9 M
Installing for dependencies:
 PyXML                     i386       0.8.4-8.fc8         updates-newkey                                1.1 M
 SOAPpy                    noarch     0.11.6-7.fc8        updates-newkey                                234 k
 par2cmdline               i386       0.4-12.fc8          fedora                                        111 k
 pyOpenSSL                 i386       0.6-1.p24.9         fedora                                        1.6 M
 python-fpconst            noarch     0.7.3-3.fc8.1       updates-newkey                                 15 k
 python-kiwi               noarch     1.9.19-1.fc8        updates-newkey                                435 k
 python-twisted-core       i386       2.5.0-2.fc8         fedora                                        1.9 M
 python-twisted-web        i386       0.7.0-1.fc8         fedora                                        597 k
 python-zope-interface     i386       3.0.1-8.fc8         fedora                                        223 k

Transaction Summary
==============================================================================================================
Install     11 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

Total download size: 12 M
Is this ok [y/N]: n
Exiting on user Command
Complete!
As you can see, on my F8 install, that was a bunch of missing deps.
Reply With Quote
  #14  
Old 11th June 2009, 01:04 PM
wvn's Avatar
wvn Offline
Registered User
 
Join Date: Jul 2008
Location: Mir space station
Age: 39
Posts: 737
There arent many newsreaders for linux and Lottanzb together with hellanzb are the ones make usenet possible for linux. Correct rpm's should be made imho.
Reply With Quote
  #15  
Old 11th June 2009, 06:46 PM
PabloTwo's Avatar
PabloTwo Offline
"Registered User" T-Shirt Winner
 
Join Date: Mar 2007
Location: Seville, FL
Posts: 7,562
@Lantash- Is it possible for you to post a link to the lottanzb-0.4.1-1.fc9.src.rpm file? I've been hacking all morning at converting the spec file from a mandriva src.rpm package (lottanzb-0.4.1-2mdv2009.1.src.rpm) to build for Fedora (including F11). I've got the basics done for that, but am currently stumped at overcoming errors at getting the lottanzb-0.4.1-py2.x.egg-info file to write into the tmp build environment from that package.

Since I'm not a python coder I haven't looked into any of the setup.py or other build scripts to see if the problem lies there, only diddling with the spec file. I think I would be way ahead by starting with a src.rpm package and it's spec file that was designed for Fedora in the first place.
Reply With Quote
Reply

Tags
dependency , missing , pythonabi

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Python 2.6 Missing Dependency in Fedora 10 Update sweleys Using Fedora 3 9th February 2009 06:27 PM
Python dependency conflict jvroig Using Fedora 0 19th June 2007 01:06 AM
yumex error - missing dependency python abi 2.4 needed by yumex mikewainwright Installation, Upgrades and Live Media 0 3rd January 2007 03:00 PM
Python update 2.4.3 update missing dependency? GrayFox Using Fedora 1 14th June 2006 03:51 AM
FC3 python dependency problem Maiyah Using Fedora 5 10th November 2004 04:13 AM


Current GMT-time: 07:50 (Tuesday, 24-10-2017)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat