Fedora Linux Support Community & Resources Center
  #1  
Old 12th February 2014, 05:26 PM
joeyjojo Offline
Registered User
 
Join Date: Feb 2014
Location: UK
Posts: 3
windows_vistafirefox
Function keys and sound not working on Asus Eee PC 1015PX since upgrade

Hi,

I recently upgraded from 18 to 20 on my Asus Eee PC 1015PX using fedup, and although it appears to have been mostly successful, the speakers and some of the function keys have stopped working. I'm not sure what information is needed but this should get the ball rolling.

Below is a list of the function keys, what they should do, and if they work for me:

F1: sleep, working
F2: wifi toggle, working (or at least, turns airplane mode on/off)
F3: supposed to do something with the aspect ratio? not working
F4: supposed to do something with the screen resolution? not working
F5: screen brightness decrease, working in MATE, not in GNOME
F6: screen brightness increase, working
F7: turn display off, not working
F8: clone/span display mode toggle, working in MATE, not in GNOME, and always triggers a crash notification
F9: process viewer? not working
F10: sound off, seems to work
F11: sound volume decrease, seems to work
F12: sound volume increase, seems to work

Not all of these worked in 18 either! But I'm pretty sure F1, F2, F5-F8, and F10-12 did.

F8 is an interesting one, as in MATE it does switch correctly between cloned and spanning views, but with a "kernel crashed" warning every time (in drivers/gpu/drm/i915/intel_display.c). It used to do this more reliably (but still with the odd panic!).

I did find this http://fedoraproject.org/wiki/Eee_PC but it hasn't been updated in some years. Typing
Code:
lsmod|grep eee
as suggested tells me I have
Code:
eeepc_wmi
loaded.

In terms of audio devices, in MATE I can see "HDA Intel (Alsa mixer)" and "Playback: Built-in Audio Analog Stero (PulseAudio Mixer)".

Looking forward to advice.
Reply With Quote
  #2  
Old 12th February 2014, 05:50 PM
joeyjojo Offline
Registered User
 
Join Date: Feb 2014
Location: UK
Posts: 3
windows_vistafirefox
Re: Function keys and sound not working on Asus Eee PC 1015PX since upgrade

I've just been trying some of the commands in post 2 at http://forums.fedoraforum.org/showthread.php?t=297256:

Code:
[me@my-netbook ~]$ pacmd list-sinks | egrep -i 'index|name|volume|muted'
  * index: 0
	name: <alsa_output.pci-0000_00_1b.0.analog-stereo>
	flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY FLAT_VOLUME DYNAMIC_LATENCY
	volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
	base volume: 65536 / 100% / 0.00 dB
	volume steps: 65537
	muted: no
		alsa.name = "ALC269VB Analog"
		alsa.subdevice_name = "subdevice #0"
		alsa.card_name = "HDA Intel"
		alsa.long_card_name = "HDA Intel at 0xf7cf8000 irq 45"
		alsa.driver_name = "snd_hda_intel"
		device.vendor.name = "Intel Corporation"
		device.product.name = "NM10/ICH7 Family High Definition Audio Controller"
		device.profile.name = "analog-stereo"
		alsa.mixer_name = "Realtek ALC269VB"
		device.icon_name = "audio-card-pci"
				device.icon_name = "audio-speakers"
				device.icon_name = "audio-headphones"
[me@my-netbook ~]$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC269VB Analog [ALC269VB Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
[me@my-netbook ~]$ amixer get Master
Simple mixer control 'Master',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 65536
  Mono:
  Front Left: Playback 65536 [100%] [on]
  Front Right: Playback 65536 [100%] [on]
Reply With Quote
  #3  
Old 14th February 2014, 06:18 PM
joeyjojo Offline
Registered User
 
Join Date: Feb 2014
Location: UK
Posts: 3
linuxfirefox
Re: Function keys and sound not working on Asus Eee PC 1015PX since upgrade

So I sat down today with a *nix guru and we fixed my issues!

First I did I fresh install of the LXDE spin of FC 20.

The brightness function keys were fixed by following/adapting the instructions on the page I linked above, specifically adding:
Code:
acpi_osi=Linux
to /etc/default/grub in GRUB_CMDLINE_LINUX (before "rhgb quiet"), then typing
Code:
grub2-mkconfig -o /boot/grub2/grub.cfg
and rebooting.

For the volume keys, he explained that they are interpreted by the desktop environment, so for me using LXDE I followed the instructions here, namely adding:
Code:
  <keybind key="XF86AudioMute">
    <action name="Execute">
     <command>amixer sset Master toggle</command>
    </action>
  </keybind>
   <keybind key="XF86AudioRaiseVolume">
    <action name="Execute">
     <command>amixer sset Master 5%+</command>
    </action>
  </keybind>
   <keybind key="XF86AudioLowerVolume">
    <action name="Execute">
     <command>amixer sset Master 5%-</command>
    </action>
  </keybind>
to ~/.config/openbox/lxde-rc.xml
I learned that the command sev is useful for sniffing these keystrokes (XF86...).

Maybe this will help someone. It would probably make sense to update the EEE PC wiki page too.
Reply With Quote
  #4  
Old 4th August 2017, 07:42 PM
Almaro Offline
Registered User
 
Join Date: Jul 2017
Location: Seattle, WA
Posts: 1
windows_98_nt_2000firefox
Re: Function keys and sound not working on Asus Eee PC 1015PX since upgrade

Thanks Joey, that helped me.
Reply With Quote
Reply

Tags
1015px , asus , eee , eeepc , function , keys , sound , speaker , upgrade , working

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Function (fn) keys not working on Asus laptop with Fedora 18 zltippett Hardware & Laptops 0 29th June 2013 08:59 PM
Asus EEE 1001p: No two finger scrolling or hot keys cyclone5uk Hardware & Laptops 0 9th July 2010 10:58 AM
Yet another function keys thread! FC9 Asus G1S roamfree Hardware & Laptops 2 25th February 2009 10:47 PM
Asus G1Sn Function Keys Jeff91 Hardware & Laptops 0 23rd January 2009 08:08 PM


Current GMT-time: 01:15 (Saturday, 21-10-2017)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat