Fedora Linux Support Community & Resources Center
  #1  
Old 17th May 2008, 09:50 PM
jmarg Offline
Registered User
 
Join Date: Jan 2008
Location: Volos, Greece
Age: 46
Posts: 34
Unhappy keyboard problem in Fedora 9

I have installed Fedora 9 (gnome desktop) in an intel pc and I encounter the following problem with a Microsoft Comfort curve Keyboard 2000 v 1.0:

After log in, the number keys in the right do not work . Only "enter" and "Num Lock" keys work. It is a usb keyboard attached in a Belkin switch. I had not such problems when I had installed Fedora 7 or 8 on the same PC previously.

The same problem appears also when I use another keyboard (not usb) attached directly to the PC.

You help is very much appreciated.

Thanks,
John

Last edited by jmarg; 18th May 2008 at 12:30 PM.
  #2  
Old 21st May 2008, 03:56 PM
madopal's Avatar
madopal Offline
Registered User
 
Join Date: Nov 2004
Location: Chicago, IL, USA
Posts: 86
Ran into this problem, and after scouring the general Linux boards, I came across something on the Ubuntu forums. Try using <CTRL><SHIFT><NUMLOCK> once to see if that changes something. According to the post, that toggles the numeric keypad between a keypress & mouse cursor mode. So perhaps something changed in Xorg or the kernel to make that universal. I'm guessing a default setting got changed in the main branch, and now it defaults to mouse cursor.

Worked for me. I did it once and checked, and the behavior was normal after doing it. It's a toggle, so make sure to do it once and then check.
  #3  
Old 21st May 2008, 04:38 PM
udovdh Offline
Registered User
 
Join Date: Dec 2007
Posts: 17
Thanks, worked for me!
How can I configure this so that it doesn't stop working anymore?
  #4  
Old 21st May 2008, 04:59 PM
madopal's Avatar
madopal Offline
Registered User
 
Join Date: Nov 2004
Location: Chicago, IL, USA
Posts: 86
Dunno, haven't rebooted machine yet to see if the state is sticky. There is a setting in System->Preferences->Hardware->Keyboard under "mouse keys" labeled "allow to control the pointer using keyboard," but mine is disabled, and I've had the problem. Not even sure when/where this setting crept in from. Gnome? Xorg? Kernel?

Welcome to the wonderful world of Linux:
RTFM...if you're head-bruisingly persistent enough to figure out which M to R. Oh, and sometimes, even if you KNOW which M you're supposed to be R, you can't find it.

It was probably buried in a changelog somewhere that I didn't notice. Either that or it's a bug.
  #5  
Old 21st May 2008, 05:44 PM
jmarg Offline
Registered User
 
Join Date: Jan 2008
Location: Volos, Greece
Age: 46
Posts: 34
Thanks, <CTRL><SHIFT><NUMLOCK> works for me too.
  #6  
Old 26th September 2008, 03:37 PM
rshendershot Offline
Registered User
 
Join Date: Jun 2005
Posts: 28
Thanks a million! worked for me also. I rebooted and numlock is working correctly.

X86_64. I also have numlockx installed but not sure if that plays a role here. fyi.
  #7  
Old 19th January 2009, 09:16 PM
jfprieur Offline
Registered User
 
Join Date: Aug 2008
Location: Montreal, QC, CAN
Age: 47
Posts: 61
Thanks a lot for this, it was driving me bonkers!
  #8  
Old 2nd April 2009, 05:10 PM
akvino's Avatar
akvino Offline
Registered User
 
Join Date: Mar 2007
Posts: 73
Thanks

This worked for me too. Thanks a bunch.....
  #9  
Old 15th July 2009, 03:34 AM
MALDATA Offline
Registered User
 
Join Date: Apr 2005
Posts: 65
Had the same problem... in Gentoo, actually. Thanks!
  #10  
Old 23rd August 2009, 05:13 PM
paddy_dev Offline
Registered User
 
Join Date: Mar 2009
Location: Belgium - Willebroek
Age: 32
Posts: 18
linuxfedorafirefox
Thank you again madopal, your post helped me as well from this annoying change.

Digging into the yum log I found the following related updates:

Running distro: Fedora 10

Code:
$ cat /var/log/yum.log | grep 'Aug 22' | grep -v 'pidgin\|libpurple\|mysql\|neon\|elfutils\|ql2400\|1:qt'
Aug 22 09:37:48 Updated: kernel-firmware-2.6.27.30-170.2.82.fc10.noarch
Aug 22 09:38:11 Updated: selinux-policy-3.5.13-69.fc10.noarch
Aug 22 09:38:41 Installed: kernel-devel-2.6.27.30-170.2.82.fc10.x86_64
Aug 22 09:39:10 Updated: selinux-policy-targeted-3.5.13-69.fc10.noarch
Aug 22 09:39:14 Updated: kernel-headers-2.6.27.30-170.2.82.fc10.x86_64
Aug 22 09:39:59 Installed: kernel-2.6.27.30-170.2.82.fc10.x86_64
Aug 22 09:40:25 Installed: kernel-2.6.27.30-170.2.82.fc10.x86_64
It was after this batch of updates that I started experiencing the numpad problem, so probably one of these is the culprit for changing the default setting you described.
__________________
Smolt Public UUID: pub_fa9bf31e-0b2b-41ec-bf38-df8ccf77f0fd

Last edited by paddy_dev; 23rd August 2009 at 05:17 PM.
  #11  
Old 10th November 2009, 05:49 PM
madopal's Avatar
madopal Offline
Registered User
 
Join Date: Nov 2004
Location: Chicago, IL, USA
Posts: 86
linuxfedorafirefox
And it just happened to me again on an update, probably the past week or two. I wish there was some way to get more info when things like this change. Honestly, it's my only complaint with yum/PackageKit. Stuff just changes.
  #12  
Old 4th July 2010, 08:30 PM
ZzarkLinux Offline
Registered User
 
Join Date: Jul 2010
Posts: 2
linuxfedorafirefox
Re: keyboard problem in Fedora 9

Thanks again for posting this solution !!! You just made my day.

My numeric pad was not working.
Pressing a number key on the the number pad eventually froze my system.

By pressing <CTRL><SHIFT><NUMLOCK> , the problem is solved.
  #13  
Old 14th July 2010, 11:48 AM
Peterkorse12 Offline
Registered User
 
Join Date: Jul 2010
Posts: 5
linuxubuntufirefox
Re: keyboard problem in Fedora 9

I had the same problem of my keyboard which was not working properly just some the keys were working like ctrl,alt,number key,caps lock key and esc key. But after the shared solution I came out from this trouble. But one thing I want to share that still when I start my system first time it doesn't work. To make it working I have to restart my system. If anyone has the solution than share it here.
__________________
investment tips
  #14  
Old 27th September 2012, 01:49 AM
walterjprice8 Offline
Registered User
 
Join Date: Sep 2012
Location: Fair Oaks, CA
Posts: 1
linuxfirefox
Re: keyboard problem in Fedora 9

the number key pad on key board won't work. even when I log in. can"t not type the password with the number pad. I have Fedora 17 regular 32
  #15  
Old 27th September 2012, 03:03 AM
Dan's Avatar
Dan Offline
Administrator
 
Join Date: Jun 2006
Location: Paris, TX
Posts: 24,099
linuxfedorafirefox
Re: keyboard problem in Fedora 9

This thread is over a year old, so you may have better luck starting a fresh thread.

Necrotic thread closed.
Closed Thread

Tags
fedora , keyboard , problem

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Keyboard layout problem with Fedora 11 fedoranoob87 Using Fedora 1 9th September 2009 11:20 PM
Fedora 10 laptop keyboard problem Anger Hardware & Laptops 13 28th May 2009 05:38 PM
Konsole and keyboard problem on Fedora 10 jeszy Using Fedora 0 29th November 2008 10:59 AM
Fedora Core 5 Keyboard problem edouard_lauer Installation, Upgrades and Live Media 1 28th October 2006 10:01 AM


Current GMT-time: 02:49 (Sunday, 22-10-2017)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat