Fedora Linux Support Community & Resources Center
  #1  
Old 22nd November 2012, 07:50 PM
nutznboltz Offline
Registered User
 
Join Date: Sep 2010
Location: Washington, DC
Posts: 47
linuxfirefox
Gnome Shell / libmutter can't handle real 24-bit visual

When you are using a real 24-bit display Gnome shell (probably via libmutter) currently displays stippled and striped patterns on the root window (desktop background) and title bar of focused window like this:



Various other visual elements are also distorted in this way.

Versions:
Code:
$ lsb_release -d
Description:	Fedora release 18 (Spherical Cow)

gnome-shell-3.6.2-2.fc18.x86_64
mutter-3.6.2-1.fc18.x86_64
Unfortunately, how to determine the true bitmap depth is difficult. The only way I currently know is to try running X with the -pixmap32 option and see if it fails.

as root:
Code:
yum install xterm
systemctl stop gdm
xinit -- -pixmap32

Fatal server error:
[   477.402] Screen(s) can't use the required depth 24 pixmap format (32).  Exiting

Last edited by nutznboltz; 22nd November 2012 at 10:38 PM.
  #2  
Old 22nd November 2012, 11:51 PM
AdamW's Avatar
AdamW Offline
Fedora QA Community Monkey
 
Join Date: Dec 2008
Location: Vancouver, BC
Posts: 4,327
linuxfirefox
Re: Gnome Shell / libmutter can't handle real 24-bit visual

That may well not be Fedora-specific, and may possibly be related to your hardware/graphics driver. I'd suggest filing it against upstream mutter, mesa or (your graphics driver) and seeing where you get.
__________________
Adam Williamson | awilliam AT redhat DOT com
Fedora QA Community Monkey
IRC: adamw | Twitter: AdamW_Fedora | identi.ca: adamwfedora
http://www.happyassassin.net
  #3  
Old 23rd November 2012, 02:00 AM
nutznboltz Offline
Registered User
 
Join Date: Sep 2010
Location: Washington, DC
Posts: 47
linuxfirefox
Re: Gnome Shell / libmutter can't handle real 24-bit visual

Thanks.

It's not real graphics hardware. It's qemu -vga cirrus

A little more poking around makes me think llvm can't grok 24-bits-in-24-bits only 24-bits-in-32-bits.

Quote:
Features/Gnome shell software rendering (link)
Software rendering for gnome-shell

Summary

Make gnome-shell work with software-rendering on most hardware
llvm does not show up in ldd /usr/bin/gnome-shell output probably because it is dlopen()ed.

It does show up in lsof output of a running gnome-shell
Code:
$ sudo lsof -p 2450 | grep llvm
gnome-she 2450 nutz  mem       REG              253,1  21320968   7443 /usr/lib64/llvm/libLLVM-3.1.so
llvm-libs-3.1-11.fc18.x86_64

I switched to qemu -vga vmware and that works.

Plus there already is a bug report:
https://bugs.freedesktop.org/show_bug.cgi?id=23525

Last edited by nutznboltz; 23rd November 2012 at 02:45 AM.
  #4  
Old 23rd November 2012, 03:04 AM
AdamW's Avatar
AdamW Offline
Fedora QA Community Monkey
 
Join Date: Dec 2008
Location: Vancouver, BC
Posts: 4,327
linuxfirefox
Re: Gnome Shell / libmutter can't handle real 24-bit visual

ah, yeah, now I recall ajax bitching about how cirrus uses 24-bit but almost nothing else does. I'll try and get his take on this if I remember. are you using xorg-x11-drv-cirrus or xorg-x11-drv-modesetting ? the latter is the New Hotness.
__________________
Adam Williamson | awilliam AT redhat DOT com
Fedora QA Community Monkey
IRC: adamw | Twitter: AdamW_Fedora | identi.ca: adamwfedora
http://www.happyassassin.net
  #5  
Old 23rd November 2012, 01:59 PM
nutznboltz Offline
Registered User
 
Join Date: Sep 2010
Location: Washington, DC
Posts: 47
linuxfirefox
Re: Gnome Shell / libmutter can't handle real 24-bit visual

The xorg-x11-drv-cirrus package is not installed.

The logs show modesetting is in use and the depth is 24-bits-in-24-bits.

Code:
[    11.989] (--) Depth 24 pixmap format is 24 bpp
[    12.019] (==) modesetting(0): Backing store disabled
I think the only reason libvirt defaults to cirrus is that win95 and other legacy systems have native support for it.

Last edited by nutznboltz; 23rd November 2012 at 02:05 PM.
  #6  
Old 23rd November 2012, 05:24 PM
AdamW's Avatar
AdamW Offline
Fedora QA Community Monkey
 
Join Date: Dec 2008
Location: Vancouver, BC
Posts: 4,327
linuxfirefox
Re: Gnome Shell / libmutter can't handle real 24-bit visual

if you've no particular reason to use it, try KVM/spice. it's much better...
__________________
Adam Williamson | awilliam AT redhat DOT com
Fedora QA Community Monkey
IRC: adamw | Twitter: AdamW_Fedora | identi.ca: adamwfedora
http://www.happyassassin.net
 

Tags
24-bit , 24bit , gnome , gnome shell , handle , libmutter , real , shell , visual

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I tell if my graphics card can handle gnome 3? leonardevens Hardware & Laptops 8 31st August 2012 12:18 PM
How to handle a gnome-shell lock up? Mariusz W Guides & Solutions (Not For Questions) 2 7th June 2011 06:28 PM
turn off shell/vi beeps to some sort of visual blink gold Using Fedora 6 29th January 2008 08:10 PM
How to access local display for non-visual opengl program from remote shell? billrobertson42 Using Fedora 0 9th July 2006 09:22 PM
Create your own real-time visual effects dickinsd Linux Chat 0 21st January 2006 01:33 PM


Current GMT-time: 03:56 (Tuesday, 24-10-2017)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat