Fedora Linux Support Community & Resources Center
  #1  
Old 9th January 2008, 01:06 AM
calberto Offline
Registered User
 
Join Date: Jan 2008
Posts: 5
Compiz not showing title bars

I updated my fedora installation from 6 to 8 (not error/warnings during installation, so I can say it went fine).

Then tried to use compiz (using the 'desktop-effects'), but the title bars were lost. The conditions at the time:

* Compiz out of box
* Intel card (which worked just fine with compiz en fedora 6).
* Trying to use emerald to replace didn't work at all (killing gtk-window-decorator and calling ti again from command line does not show any error, not at all).
* Tried ALL the things I could find in google: nothing worked.

Then I tried with a geforce 8400 card:

* Compiz out of box nor Compiz fusion work.
* Nvidia card, same problem.
* Emeral nor gtk-window-decorator show errors.
* Calling 'desktop-effects' directly from bash does not show any error.
* Added all the options 'needed' for xorg.cong were added (AddARGBGLXVisuals, AllowGLXWithComposite, ...)

Not a single error message, and still, I just can't get this thing working, which makes me nuts, based on the fact that _seems_ nobody is getting this error in fedora with intel cards.

Any clue? Any information I could take a look at?

Thanks,
Carlos.
Reply With Quote
  #2  
Old 9th January 2008, 01:14 AM
calberto Offline
Registered User
 
Join Date: Jan 2008
Posts: 5
# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
EndSection

Section "Module"
Load "glx"
Load "extmod"
EndSection

Section "InputDevice"

# generated from data in "/etc/sysconfig/mouse"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "es"
EndSection

Section "Monitor"
Identifier "Monitor0"
ModelName "LCD Panel 1280x1024"
HorizSync 31.5 - 64.0
VertRefresh 56.0 - 65.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
Option "AddARGBGLXVisuals" "True"
Option "AllowGLXWithComposite" "True"
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection
Reply With Quote
  #3  
Old 9th January 2008, 01:16 AM
calberto Offline
Registered User
 
Join Date: Jan 2008
Posts: 5
Pasted my xorg.cong file, probably it will help...
Reply With Quote
  #4  
Old 9th January 2008, 06:33 AM
jdeslip Offline
Registered User
 
Join Date: May 2006
Location: Berkeley, CA
Posts: 621
You xorg.conf looks ok I think. (But I am not the best expert)

In my humble opinion, the compiz/compiz-fusion in the f8 repositories is complete garbage. I would uninstall and install leigh's version (which can do through yum). See the following thread: http://forums.fedoraforum.org/forum/...d.php?t=171130
Reply With Quote
  #5  
Old 9th January 2008, 01:46 PM
seby Offline
Registered User
 
Join Date: Apr 2005
Location: Australia
Posts: 36
Yes. Follow leighs version and use the fusion icon to set the widows decorator to emerald.
Reply With Quote
  #6  
Old 11th January 2008, 12:57 AM
calberto Offline
Registered User
 
Join Date: Jan 2008
Posts: 5
It's now working nice, but emerald is re-starting every time I try to open a new application.

I get the next errors:

compiz (core) - Warn: Plugin 'core' already active
compiz (cube) - Warn: Failed to load slide: freedesktop

And then, a lot of:

A handler is already registered for the path starting with path[0] = "org"

Any idea?

Thanks.
Reply With Quote
  #7  
Old 11th January 2008, 01:19 AM
leigh123linux
Guest
 
Posts: n/a
Try


Code:
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildmeister@builder26)  Thu Dec 13 18:56:19 PST 2007



Section "ServerLayout"
    Identifier     "single head configuration"
    Screen      0  "Screen0" 0 0
    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
    ModulePath      "/usr/lib/xorg/modules/extensions/nvidia"
    ModulePath      "/usr/lib/xorg/modules"
EndSection

Section "Module"
EndSection

Section "ServerFlags"
    Option          "AIGLX" "on"
    Option	    "blank time" "0"
    Option	    "standby time" "0"
    Option	    "suspend time" "0"       
    Option	    "off time" "0"
    Option          "Xinerama" "0"
EndSection

Section "InputDevice"
     Identifier "Mouse0"
     Driver "mouse"
     Option "Protocol" "IMPS/2"
     Option "Device" "/dev/input/mice"
     Option "Emulate3Buttons" "no"
     Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
      Driver "kbd"
      Option "XkbModel" "pc105"
      Option "XkbLayout" "es"
EndSection

Section "Monitor"
      Identifier "Monitor0"
      ModelName "LCD Panel 1280x1024"
      HorizSync 31.5 - 64.0
      VertRefresh 56.0 - 65.0
      Option "dpms"
EndSection



Section "Device"
	Identifier  "Videocard0"
	Driver      "nvidia"
	VendorName  "nVidia Corporation"
	Option	    "DPI" "96 x 96"
	Option	    "coolbits" "1"
	Option	    "TripleBuffer" "true"
	Option	    "RenderAccel" "True"
	Option	    "AddARGBGLXVisuals" "True"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Videocard0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "metamodes" "1280x1024 +0+0; 640x480 +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Extensions"
    Option         "Composite" "Enable"
EndSection
I believe this option is causing your issues " Option "AllowGLXWithComposite" "True" "

Last edited by leigh123linux; 11th January 2008 at 01:22 AM.
Reply With Quote
  #8  
Old 13th January 2008, 11:55 PM
calberto Offline
Registered User
 
Join Date: Jan 2008
Posts: 5
Thanks for the answer,

Removing that option from my xorg.conf actually did the trick :-D

But two things:
a) your xconf file is not working here.
b) I'm having a bad time re-sizing windows, as well as maximizing/minimizing them, since its just TOO slow.

Any idea?
Reply With Quote
Reply

Tags
bars, compiz, showing, title

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Lost window title bars after yum update on F9 jsalvo Using Fedora 6 5th November 2008 01:06 PM
compiz FC6: Loose all window title bars cwebster EOL (End Of Life) Versions 27 29th July 2008 08:43 PM
No Window Title Bars 3dee Hardware & Laptops 6 17th April 2008 11:46 AM
Title bars disapear, need a fix! Rev_Flibble Using Fedora 1 10th September 2007 11:51 AM
Title bars hiding under Panel chrisindallas Using Fedora 4 22nd February 2007 02:47 AM


Current GMT-time: 16:53 (Saturday, 19-08-2017)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat