Fedora Linux Support Community & Resources Center
  #1  
Old 23rd December 2010, 02:42 PM
326bd935
Guest
 
Posts: n/a
linuxfedorafirefox
totem requres aditional plugins (still): audioconvert...

had a computer with fedora 14 cd 32bit gnome installed - worked good
got a new disk so installed the dvd version (pretty much all the packages) onto it - this is the problem installation

after installation i added the rpmfusion repositories and installed all codecs
Code:
yum install gstreamer-ffmpeg gstreamer-plugins* -x *devel*
(same as last time although i may have let totem search for some prior to this command)

###the problem###
when opening a video (not just one type of audio/vidoe codec) with totem it opens up the whole extra codecs are required... the following plugins are required:
GStreamer element audioconvert
GStreamer element deinterlace
GStreamer element videoscale.
want to search?

if you search it wont find anything, if you close it plays perfect,,, but. when loading previews in nautilus it has the loading icon/clock and then just shows the totem icon

also i have realised that it cant play wma giving error "The playback of this movie requires a GStreamer element audioconvert plugin which is not installed." - the rythmbox preview works though.



********solution**************
remove ~/.gstreamer-0.10/registry.i386.bin

Last edited by 326bd935; 24th December 2010 at 12:15 PM.
Reply With Quote
  #2  
Old 24th December 2010, 11:39 AM
326bd935
Guest
 
Posts: n/a
linuxfirefox
Cool Re: totem requres aditional plugins (still): audioconvert...

found this here on a gentoo site:
http://bugs.gentoo.org/122735

basically remove the ~/.gstreamer-x.x/registry*.*
(in my case ~/.gstreamer-0.10/registry.i386.bin
Reply With Quote
  #3  
Old 27th December 2010, 05:47 AM
dona74 Offline
Registered User
 
Join Date: Dec 2010
Posts: 1
linuxfedorafirefox
Re: totem requres aditional plugins (still): audioconvert...

I removed registry.i386.bin but it does not work.
and I reinstall gstreamer-plugins-good,base as fc14 not update version
I checked in rpmfind.net.
if you need, you can reinstall
#rpm -Uvh gstreamer-plugins-good-x.x.x-.rpm --force --nodeps
#rpm -Uvh gstreamer-plugins-base-0.10.30-2.fc14.i686.rpm --force --nodeps

Last edited by dona74; 27th December 2010 at 06:10 AM.
Reply With Quote
  #4  
Old 27th December 2010, 10:15 AM
leigh123linux
Guest
 
Posts: n/a
linuxfedorafirefox
Re: totem requres aditional plugins (still): audioconvert...

Quote:
Originally Posted by dona74 View Post
I removed registry.i386.bin but it does not work.
and I reinstall gstreamer-plugins-good,base as fc14 not update version
I checked in rpmfind.net.
if you need, you can reinstall
#rpm -Uvh gstreamer-plugins-good-x.x.x-.rpm --force --nodeps
#rpm -Uvh gstreamer-plugins-base-0.10.30-2.fc14.i686.rpm --force
--nodeps

Please don't post improper solutions


Quote:
When Answering Questions
  1. Don't be cruel. We have all been newbies at one point and no one needs someone telling them how stupid they are.
  2. Don't use jargon in your instructions if it can be avoided, newbies may not understand. If you don't have any better answer than RTFM (Read the fine manual), just be quiet.
  3. Point the user to existing resources if they can provide useful information. Use community sites like Fedora Set-Up Guides and fedoraNEWS.org in your answers; searching the Red Hat Bugzilla is a good idea as well.
  4. Always assume the the user has a default installation unless you're told otherwise. This means that you can't tell anyone to use APT without providing instructions on how to install APT or at least link to an APT tutorial, as APT isn't included in the default installation. If you tell people to use an application outside of Core, give instructions on how to install it.
  5. Always assume that the user is a newbie unless you're certain the user is not. Give detailed instructions.
  6. Use proper formatting, use[CODE] tags around terminal commands. You can attach files and pictures that you think might help.
  7. Do things the Fedora-way. There are always more than one solution to a problem, choose the one you think will be the easiest for the user. Automatic package installation (using YUM, PackageKit or Yumex) over manual installation. RPM over source. Where possible get people to use the official Fedora repositories and the related RPMFusion. They are of higher quality. Don't replace any Core packages and never instruct users to do anything that might break their system, this includes using --force and --nodeps when installing an RPM. Try to think as a newbie and choose the simplest solution.
  8. Explain each step of the solution. The ideal solution to a problem should be able to teach the user how to solve similar problems in the future. Teach people to fish, don't just throw them a salmon.
Posting Rules


The proper way is

Code:
su
yum reinstall gstreamer-plugins-base gstreamer-plugins-good
If you want the older version

Code:
su
yum downgrade gstreamer-plugins-base* gstreamer-plugins-good
Reply With Quote
  #5  
Old 9th March 2011, 06:31 PM
szilagyic Offline
Registered User
 
Join Date: Aug 2008
Posts: 193
windows_7firefox
Re: totem requres aditional plugins (still): audioconvert...

Having the exact same problem here, anybody found a solution to this yet? My issue is that when trying to play an mp3, Rhythmbox says "the following plugin is required: GStreamer element audioconvert". But, gst-inspect -b shows "libgstaudioconvert.so" as blacklisted. I tried reinstalling gstreamer-plugins-base, and gstreamer-plugins-good, and also removing ~/.gstreamer/registry.i386.bin and running "gst-inspect", and still the same problem.

Last edited by szilagyic; 9th March 2011 at 06:35 PM.
Reply With Quote
  #6  
Old 9th March 2011, 11:44 PM
bonedome Offline
Registered User
 
Join Date: Apr 2010
Location: uk
Posts: 726
linuxfedorafirefox
Re: totem requres aditional plugins (still): audioconvert...

Hello
have you tried gstreamer-ffmpeg and ffmpeg itself some media players use ffmpeg's libs as a fallback if the decoder is not built in.
have you tried vlc ? it has mp3 built in, I always use vlc to play music
__________________
fedora 14 fluxbox and gnome2 hp compaq nx9030 laptop 2Gb ram, helicopter landing pad, jacuzzi, mini fridge, gateway to alternative dimension
Reply With Quote
  #7  
Old 14th March 2011, 06:28 PM
szilagyic Offline
Registered User
 
Join Date: Aug 2008
Posts: 193
windows_7firefox
Re: totem requres aditional plugins (still): audioconvert...

I have not tried VLC yet, we would really like to get Rhythmbox working because of some nice features. Yes, gstreamer-ffmpeg and ffmpeg are both installed. In fact, I've also found that Totem complains about missing gstreamer plugins as well. I am hoping to fix the gstreamer issue, which will fix both Rhythmbox and Totem. Just for the record, the output of "gst-inspect -b" is:

Quote:
Blacklisted files:
libgstvideobox.so
libgstvideoscale.so
libgstadder.so
libgstpython.so
libgstvolume.so
libgstaudioconvert.so
libgstvideomixer.so
libgstvideotestsrc.so
libgstdeinterlace.so

Total count: 9 blacklisted files
Thanks!

Last edited by szilagyic; 14th March 2011 at 06:43 PM.
Reply With Quote
  #8  
Old 14th March 2011, 09:09 PM
sunson Offline
Registered User
 
Join Date: Mar 2011
Location: Germany, Hamburg
Age: 38
Posts: 1
linuxfedorafirefox
Missing plugin: gstreamer|0.10|totem|

Hello everybody,
i 've got the same problem here, and no, sorry, in my case it's still not solved.
The problem occurs after Upgrading from Fedora 13 to Fedora 14 using preupgrade and upgrade.

So here some necessary facts about my environment:
Fedora 14
Quote:
2.6.35.11-83.fc14.i686
GraphicCard (But I think that doesn't matter in this case)
Quote:
[sunson@tagliatelle ~]$ lspci | grep VGA
01:00.0 VGA compatible controller: nVidia Corporation NV43 [GeForce 6600 GT] (rev a2)
Totem
Quote:
yum list totem
Geladene Plugins: presto, refresh-packagekit
Installierte Pakete
totem.i686 1:2.32.0-1.fc14 @fedora
all codecs are installed as described above and, for example, VLC and gnome-mplayer work without errors.
totem started in terminal gives following error messages (only example, error occurs on every file format, or better, codec:
Quote:
[sunson@tagliatelle ~]$ totem
** Message: pygobject_register_sinkfunc is deprecated (GstObject)

** (totem:3902): WARNING **: chapters: failed to load CMML file file:///home/sunson/Desktop/Teil_25_Die_dreibeinigen_Herrscher_Die_letzte_Etap pe.cmml: Fehler beim Öffnen der Datei: Datei oder Verzeichnis nicht gefunden
** Message: Missing plugin: gstreamer|0.10|totem|DivX MPEG-4 Version 4-Decoder|decoder-video/x-divx, divxversion=(int)4 (DivX MPEG-4 Version 4-Decoder)
** Message: PackageKit: xid = 94371844
** Message: PackageKit: Codec nice name: DivX MPEG-4 Version 4-Decoder
** Message: PackageKit: field is: divxversion, type: gint
** Message: PackageKit: structure: gstreamer0.10(decoder-video/x-divx)(divxversion=4)
** Message: PackageKit: Did not install codec: did not agree to search

(totem:3902): GStreamer-CRITICAL **: _gst_util_uint64_scale_int: assertion `denom > 0' failed
I removed the
Quote:
~/.gstreamer-0.10/registry.i386.bin
yes, even the whole folder.

I reinstalled totem and every gstreamer-plugin i've found. I Reinstalled Gstreamer itself, too (It took me a while to figure out the "reinstall" parameter and I'm wondering why it's not mentioned in the man page, but that's another topic =D)

So my suggestion is, that totem only doesn't find the plugins to use, for some reasons.
But I don't know where and how to configure that. Totem plays the sound of the file and uses the visualisation plugin.

So that's everything I have.
Hope together we'll fix that, but I'm still not sure if all issues mentioned in this post have the same reason.

greetz
sunson

Last edited by sunson; 14th March 2011 at 09:42 PM. Reason: Hit enter too early, post wasn't finished yet.
Reply With Quote
  #9  
Old 15th March 2011, 10:11 PM
Tantuja Offline
Registered User
 
Join Date: Mar 2010
Posts: 7
linuxfedorafirefox
Re: totem requres aditional plugins (still): audioconvert...

system is not properly shutdown in fedora14 when click in shutdown button, it halted for infinite time
Reply With Quote
  #10  
Old 15th March 2011, 11:08 PM
kurtdriver Offline
Registered User
 
Join Date: Jul 2005
Location: Looking over your shoulder.
Posts: 1,881
linuxfedorafirefox
Re: totem requres aditional plugins (still): audioconvert...

Quote:
Originally Posted by Tantuja View Post
system is not properly shutdown in fedora14 when click in shutdown button, it halted for infinite time
May I suggest that you start a new thread on this topic? Hijacking threads is frowned upon.
Reply With Quote
Reply

Tags
codecs, totem, video, wma

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
totem plugins lauwers Using Fedora 1 11th March 2008 02:07 AM
Totem codecs/plugins simon_r2d2 Using Fedora 1 21st April 2006 10:15 AM
Totem plugins? sn0wf0x Using Fedora 2 11th April 2006 07:40 PM


Current GMT-time: 01:35 (Sunday, 24-09-2017)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat