FC5 Hangs on System Message Bus
FedoraForum.org - Fedora Support Forums and Community
Page 1 of 3 1 2 3 LastLast
Results 1 to 15 of 34
  1. #1
    pHx Guest

    FC5 Hangs on System Message Bus

    Hello,

    Just recently installed FC5, Booted fine etc started setting up samba and putting it on my windows domain, I put the correct information in the "Autherisation" Prefrances thing. Rebooted and now it hangs on "Starting System Message Bus", You can still move the mouse etc but the thing wont boot.

    Formatted and tryed this again, happened again.

    Installed on a Intel 2ghz Celeron, 256 DDR Ram.

    Any help, possible bug?

    Cheers
    Ollie

  2. #2
    pHx Guest
    After booting into runlevel 2 and trying to start X with the command "startx" it gave me this error

    Fatal server error:

    could not open default font "fixed"

    X10: fatal IO error 104 on X server ":0.0" after 0 requests.

    Above that it says something about the XKEYBOARD keymap compiler about ONE_LEVEL has 1 levels but <RALT> has 2 symbols Ignoring extra symbols.

    Errors from xkbcomp are not fatal to the X Server.

    Can anyone hepl with this at all?

    Cheers
    Ollie

  3. #3
    overlord Guest
    Hi,
    got the same problem ater upgrading FC4->FC5.
    All fine til reboot and starting SMB........

    any new cognitions??.....

  4. #4
    Join Date
    Jun 2005
    Posts
    17
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I have the same problem. Odd thing is that I was able to login, configure the system as a server for as a server for dhcpd, named, ntpd, kerberos, and ldap and then the thing hangs. Forces me to retreat to FC4. The only way to avoid the hanging is to not have system message bus start up, by using the Interactive Start Up (press I).

    I booted from CD1, linux rescue, chroot, and yum update. And still the problem persists.

    Sad to say, such things didn't happen when I was using Red Hat. As it is, my end user machines (which has X installed) are running Ubuntu,and I was hoping my network router would be able to remain a Fedora Core machine, but looks like when FC4 is no longer supported, I'll have to switch to Ubuntu, Gentoo, or Slackware.

    Sigh.

  5. #5
    Join Date
    Jun 2005
    Posts
    17
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Resolved by ;

    1. selinux=0 in grub.conf
    2. remove mention of ldap and ldaps in /etc/nsswitch.conf (wierd, in FC4 they are there but named starts fine).
    3. sent *.* to /dev/tty12 in /etc/syslog.conf helped debugged the problem

    Whew!

  6. #6
    cspencer Guest
    mswoon:

    Just temporarily edit the grub boot loader to tell it to boot to run level 1 (push e when grub comes up, then e the 2nd line, add a 1 to the end of the line)

    When it comes to the prompt edit /etc/nsswitch.conf and edit just the three uncommented lines with ldap. (files ldap)...leave the files.

    You don't need to disable selinux.

  7. #7
    lxgamer Guest
    I've come with with exactly same problem in FC5
    i've set up SE linux = 0
    after setting up samba the system wont boot
    it hangs on the message Starting System Message Bus

    Now I edited the grub by pressing 'e' and system boots into command now please tell me how to edit /etc/nsswitch.conf from that command prompt.

    regards.

  8. #8
    lxgamer Guest
    need help urgent or I should install fc5 again?

  9. #9
    Mikie Guest
    Similar problem here.

    I remember fiddling with the administration tools in GUI, enabled LDAP authorization, SMB, etc. Now FC5 won't boot, or it takes hours, and when it starts there is no panels on the desktop, so impossible to reconfigure through GUI.

    It hangs on the following services: named, system message bus, snortd, mysqld (it fails to start in the end), dhcpd and smb.

    I got rid of LDAP by editing the /etc/sysconfig/authconfig file, but it is still slow as hell (takes about 40 mins to boot up). I'll try disabling Samba, let you know about the result.

  10. #10
    Mikie Guest
    Whoa! Fixed!

    It may be that SMB wasn't the culprit after all, but it was LDAP all along. Just removing it from /etc.sysconfig/authconfig wasn't enough, but when it was removed (commented out) from /etc/nsswitch.conf as well, everything is back to normal. No interactive startup either.

    Thanks for your help, guys.

  11. #11
    speedy21 Guest

    same probleme

    hy,
    i have the same problème, can't boot FC5 with authconfig = LDAP
    i upgrade FC4 to FC5 and configure all service ; dhcp, samba, smbldap-tools, LDAP, for FC5.

    the authconfig modifie the /etc/pam.d/system-auth and the /etc/nsswitch.conf.

    the solution for the moment :

    - Copy the system-auth and nnswitch.conf in /root/ with the ldap option
    - authconfig : don't use ldap
    - the system can reboot fine !
    - emacs the /etc/rc.local and add :

    cp -af /root/system-auth /etc/pam.d/
    cp -af /root/nnswitch.conf /etc/


    richard@vienneinfo.org

  12. #12
    manulesurfeur Guest
    I have the same problem.
    I have configured samba as à PDC.
    I need ldap for authentification.
    What I can do???

  13. #13
    Mikie Guest
    The solution is in my previous post. Find a way to boot the system off a floppy, mount the filesystem, and change those two files removing or commenting all references to LDAP, Kerberos and other "remote" authorization systems, leaving only local ones.

  14. #14
    Join Date
    Sep 2005
    Location
    Chicago
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Try letting machine boot overnight, then go to authentication configuration, un-check LDAP support. Takes a day, but worked for me.

  15. #15
    carlsan Guest
    Hello!
    Is this problem already solved? Editing the /etc/nsswitch.conf before/after rebooting can't be a solution......
    With kind regards,
    Carl

Page 1 of 3 1 2 3 LastLast

Similar Threads

  1. Replies: 4
    Last Post: 28th May 2009, 02:29 PM
  2. diskquota warning message system
    By sudhir_rao in forum Programming & Packaging
    Replies: 0
    Last Post: 29th June 2007, 04:57 AM
  3. evolution: message preview hangs, can't kill
    By jhegge in forum Using Fedora
    Replies: 0
    Last Post: 14th May 2007, 09:23 PM
  4. FC2 hangs with python message
    By danielsender in forum EOL (End Of Life) Versions
    Replies: 2
    Last Post: 8th July 2004, 11:53 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •