Getting nVidia cards to work in Fedora Core - Page 42
FedoraForum.org - Fedora Support Forums and Community
Page 42 of 76 FirstFirst ... 32 40 41 42 43 44 52 ... LastLast
Results 616 to 630 of 1129
  1. #616
    Join Date
    Dec 2004
    Location
    Canada
    Age
    28
    Posts
    9,221
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Many minor mods:
    Code:
        Option         "AddARGBGLXVisuals" "True"
    That should come last in the "Device" section.
    Code:
        Load           "glx"
    Also add underneath that:
    Code:
        Load           "dbe"
        Load           "extmod"
    Are you using the Livna packaged drivers or the ones directly from nVidia?

    Also, have you installed the libs-32bit package?
    Firewing1

    Quote Originally Posted by Thecowking
    Hmm after I had a biref adventure with beryl I lost the ability to have direct openGl rendering. I even bought a new Gfx card and formatted my hdd, but for some reason the bug followed me.

    I've got a Geforce 6200 in my box now, set it up on a clean Fedora install just like this thread says, but for some reason, I cannot get it to renger opengl directly. Which mean none of my games work properly. As we say in manchester, it's a bit of a bugger.

    So I'm appealing to the infinite wisdom of this forum in the hopes it can save me. For your viewing pleasure I'll throw down my xorg.conf file here too

    Here's hoping someone can spot the glaring error I've missed and will provide the one stop solution which makes me lok like an idiot but solves my problems
    [+] My open source software and blog
    [+] Some of my howtos: (for full list, click here)

  2. #617
    Join Date
    Jan 2006
    Location
    Utah
    Age
    53
    Posts
    301
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Firewing, I am having the same problem as Thecowking except when I reboot I have to run the command
    Code:
    metacity --replace&
    to get my window borders back. I have a GForce 200 MX with the 96xx drivers installed I am on kernel version 2.6.19-1.2895.fc6xen #1 SMP Wed Jan 10 19:47:12 EST 2007 i686 athlon i386 GNU/Linux. Here is my xorg.conf file:
    [/CODE]# Xorg configuration created by system-config-display

    Section "ServerLayout"
    Identifier "single head configuration"
    Screen 0 "Screen0" 0 0
    InputDevice "Keyboard0" "CoreKeyboard"
    EndSection

    Section "InputDevice"
    Identifier "Keyboard0"
    Driver "kbd"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us"
    EndSection

    Section "Device"
    Identifier "Videocard0"
    Driver "nv"
    EndSection

    Section "Screen"
    Identifier "Screen0"
    Device "Videocard0"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    Modes "1024x768" "800x600" "800x600" "640x480" "640x480"
    EndSubSection
    EndSection
    [/CODE]
    let me know if you see anything wrong please.
    thanks
    Tim :eek:
    Smolt profile

  3. #618
    Thecowking Guest
    Quote Originally Posted by Firewing1
    Code:
        Load           "glx"
    Also add underneath that:
    Code:
        Load           "dbe"
        Load           "extmod"
    Are you using the Livna packaged drivers or the ones directly from nVidia?

    Also, have you installed the libs-32bit package?
    Firewing1
    Which section do these mods go? inserting them into device causes a no screen error, so I think I got that one wrong :P

    I'm using the pre-packaged drivers from linva, just a yum install job, just like in the main post.
    Last edited by Thecowking; 8th February 2007 at 09:13 AM.

  4. #619
    Malebolgia Guest
    Quote Originally Posted by Firewing1
    Unless you're doing virtualization, you don't need xen... You can remove it like this:
    Code:
    su -
    yum remove kernel-xen
    Reboot and things should turn out better.
    Firewing1

    Well, I tried it out, but now my system locks up right before the fedora loading screen gets to 100% This would be the screen right before you log in.

  5. #620
    Malebolgia Guest

    Update

    Looks like I tracked it down to a IRQbalance issue. I uninstalled and reinstalled and that seems to have fixed it. I am enjoying twinview as we speak. Thanks a lot!

  6. #621
    Join Date
    Dec 2006
    Location
    Malaysia
    Age
    34
    Posts
    266
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    How to install NVIDIA GeForce 7100 gs driver to my computer with using of FC 6. Not only that, how to enable or activate the 3D desktop effects on FC 6.

    Your help is greatly appreciated by me and others.


    Thanks in advance.

  7. #622
    leigh123linux Guest
    Quote Originally Posted by Peter_APIIT
    How to install NVIDIA GeForce 7100 gs driver to my computer with using of FC 6. Not only that, how to enable or activate the 3D desktop effects on FC 6.

    Your help is greatly appreciated by me and others.


    Thanks in advance.
    I suggest that you read post #1 of this thread
    No one is going to do it for you so get looking.

  8. #623
    Join Date
    Dec 2004
    Location
    Canada
    Age
    28
    Posts
    9,221
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Thecowking
    Which section do these mods go? inserting them into device causes a no screen error, so I think I got that one wrong :P

    I'm using the pre-packaged drivers from linva, just a yum install job, just like in the main post.
    Into the "Module" section
    Quote Originally Posted by tmick
    Firewing, I am having the same problem as Thecowking except when I reboot I have to run the command
    Code:
    metacity --replace&
    to get my window borders back. I have a GForce 200 MX with the 96xx drivers installed I am on kernel version 2.6.19-1.2895.fc6xen #1 SMP Wed Jan 10 19:47:12 EST 2007 i686 athlon i386 GNU/Linux. Here is my xorg.conf file:
    [/CODE]# Xorg configuration created by system-config-display

    Section "ServerLayout"
    Identifier "single head configuration"
    Screen 0 "Screen0" 0 0
    InputDevice "Keyboard0" "CoreKeyboard"
    EndSection

    Section "InputDevice"
    Identifier "Keyboard0"
    Driver "kbd"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us"
    EndSection

    Section "Device"
    Identifier "Videocard0"
    Driver "nv"
    EndSection

    Section "Screen"
    Identifier "Screen0"
    Device "Videocard0"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    Modes "1024x768" "800x600" "800x600" "640x480" "640x480"
    EndSubSection
    EndSection
    [/CODE]
    let me know if you see anything wrong please.
    thanks
    It seems the driver hasn't configured your xorg.conf, which is why there are no window borders... What happens when you type:
    Code:
    su -
    service nvidia-glx restart
    Firewing1
    [+] My open source software and blog
    [+] Some of my howtos: (for full list, click here)

  9. #624
    Join Date
    Jan 2006
    Location
    Utah
    Age
    53
    Posts
    301
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    service nvidia-glx restart
    Disabling nvidia-glx driver [ OK ]
    Checking for nvidia kernel module [ OK ]
    Enabling nvidia-glx driver [ OK ]
    My xorg.conf now looks like :

    # Xorg configuration created by system-config-display

    Section "ServerLayout"
    Identifier "single head configuration"
    Screen 0 "Screen0" 0 0
    InputDevice "Keyboard0" "CoreKeyboard"
    EndSection

    Section "Files"
    ModulePath "/usr/lib/xorg/modules/extensions/nvidia"
    ModulePath "/usr/lib/xorg/modules"
    EndSection

    Section "InputDevice"
    Identifier "Keyboard0"
    Driver "kbd"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us"
    EndSection

    Section "Device"
    Identifier "Videocard0"
    Driver "nvidia"
    Option "AddARGBGLXVisuals" "True"
    EndSection

    Section "Screen"
    Identifier "Screen0"
    Device "Videocard0"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    Modes "1024x768" "1024x768" "800x600" "800x600" "640x480" "640x480"
    EndSubSection
    EndSection

    but still has jerky performance with 3 d games but the borders seem to work
    Last edited by tmick; 9th February 2007 at 03:37 AM. Reason: adding new xorg.conf
    Tim :eek:
    Smolt profile

  10. #625
    Thecowking Guest
    Hmm I tried disabling SE linux, and it worked!

    So I'll not touch it again, lest it explode and kill me

  11. #626
    leigh123linux Guest
    Quote Originally Posted by tmick
    service nvidia-glx restart
    Disabling nvidia-glx driver [ OK ]
    Checking for nvidia kernel module [ OK ]
    Enabling nvidia-glx driver [ OK ]
    My xorg.conf now looks like :

    # Xorg configuration created by system-config-display

    Section "ServerLayout"
    Identifier "single head configuration"
    Screen 0 "Screen0" 0 0
    InputDevice "Keyboard0" "CoreKeyboard"
    EndSection

    Section "Files"
    ModulePath "/usr/lib/xorg/modules/extensions/nvidia"
    ModulePath "/usr/lib/xorg/modules"
    EndSection

    Section "InputDevice"
    Identifier "Keyboard0"
    Driver "kbd"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us"
    EndSection

    Section "Device"
    Identifier "Videocard0"
    Driver "nvidia"
    Option "AddARGBGLXVisuals" "True"
    EndSection

    Section "Screen"
    Identifier "Screen0"
    Device "Videocard0"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    Modes "1024x768" "1024x768" "800x600" "800x600" "640x480" "640x480"
    EndSubSection
    EndSection

    but still has jerky performance with 3 d games but the borders seem to work
    Try adding this to your xorg.conf it should help

    Section "Module"
    Load "extmod"
    Load "glx"
    EndSection

  12. #627
    Join Date
    Feb 2006
    Location
    Tampa, Fl. USA
    Posts
    336
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I just got my Geforce Fx5500 working (mostly) using this and other resources. The only thing left is to change the resolution from 800x600 to something higher. I haven't been able to do that through nvidia-settings, because it does not offer anything other than 800x600 for some reason. I'm still working it.

    A couple notes:

    1) I never did find a libs-32bit package in livna.org ( I use the 96xx version.), but I did install the devel.
    2) FC6 (apparently) enables "compiz", by default. This has been reported to be cleared by disabling SELinux, however you can also add a short section in xorg.conf to disable it. That is the method I used.
    3) When selecting the video card in display-config (?), I selected the line that spells out "nvidia", but described a generic card vs the one the abbreviated "nv" and listed my class of video card.
    The only thing more dangerous than action without thought is thought without action.

  13. #628
    Join Date
    Dec 2004
    Location
    Canada
    Age
    28
    Posts
    9,221
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Dubious Dave
    I just got my Geforce Fx5500 working (mostly) using this and other resources. The only thing left is to change the resolution from 800x600 to something higher. I haven't been able to do that through nvidia-settings, because it does not offer anything other than 800x600 for some reason. I'm still working it.

    A couple notes:

    1) I never did find a libs-32bit package in livna.org ( I use the 96xx version.), but I did install the devel.
    Quote Originally Posted by Dubious Dave
    2) FC6 (apparently) enables "compiz", by default. This has been reported to be cleared by disabling SELinux, however you can also add a short section in xorg.conf to disable it. That is the method I used.
    Sometimes adding "Mode" lines in your Screen section can help - I know for example listing all the modes manually is needed sometimes for Wine to work on non-native resolutions.
    Quote Originally Posted by Dubious Dave
    3) When selecting the video card in display-config (?), I selected the line that spells out "nvidia", but described a generic card vs the one the abbreviated "nv" and listed my class of video card.
    I'm not sure, but I think this is system-config-display issue - I'll take a look into it either way
    Firewing1
    [+] My open source software and blog
    [+] Some of my howtos: (for full list, click here)

  14. #629
    Join Date
    Jan 2006
    Location
    Utah
    Age
    53
    Posts
    301
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    @ leigh123:
    tried adding suggested code and restarted then checked the xorg.conf file it now looks like:
    Code:
    # Xorg configuration created by system-config-display
    
    Section "ServerLayout"
    	Identifier     "single head configuration"
    	Screen      0  "Screen0" 0 0
    	InputDevice    "Keyboard0" "CoreKeyboard"
    EndSection
    
    Section "Files"
    	ModulePath   "/usr/lib/xorg/modules"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Keyboard0"
    	Driver      "kbd"
    	Option	    "XkbModel" "pc105"
    	Option	    "XkbLayout" "us"
    EndSection
    
    Section "Device"
    	Identifier  "Videocard0"
    	Driver      "nv"
    EndSection
    
    Section "Screen"
    	Identifier "Screen0"
    	Device     "Videocard0"
    	DefaultDepth     24
    	SubSection "Display"
    		Viewport   0 0
    		Depth     24
    		Modes    "1024x768" "1024x768" "800x600" "800x600" "640x480" "640x480"
    	EndSubSection
    EndSection
    and my xorg.conf.backup file looks like:

    Code:
    # Xorg configuration created by system-config-display
    
    Section "ServerLayout"
    	Identifier     "single head configuration"
    	Screen      0  "Screen0" 0 0
    	InputDevice    "Keyboard0" "CoreKeyboard"
    EndSection
    
    Section "Files"
    	ModulePath   "/usr/lib/xorg/modules"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Keyboard0"
    	Driver      "kbd"
    	Option	    "XkbModel" "pc105"
    	Option	    "XkbLayout" "us"
    EndSection
    
    Section "Device"
    	Identifier  "Videocard0"
    	Driver      "nv"
    EndSection
    
    Section "Screen"
    	Identifier "Screen0"
    	Device     "Videocard0"
    	DefaultDepth     24
    	SubSection "Display"
    		Viewport   0 0
    		Depth     24
    		Modes    "1024x768" "1024x768" "800x600" "800x600" "640x480" "640x480"
    	EndSubSection
    EndSection
    
    Section "Module"
    Load "extmod"
    Load "glx"
    EndSection
    I think I'm going to try Thecowking's trick and disable SELinux and see if that straightens it out. I have gone through this with each kernel upgrade and in reviewing my notes on past upgrades there has been an nvidia-glx selinux policy update after each one. I was hoping they got that resolved but maybe not
    @Firewing:
    I seem to remember reading you are part of a project that concerns the nvidia drivers and xorg could you check into the possibility of SElinux conflicts and what was done in the past to resolve them?
    @Thecowking:
    If disabling SELinux allowed the games to work would you please file a bug on it in bugzilla so they can get this fixed?
    Tim :eek:
    Smolt profile

  15. #630
    Join Date
    Jan 2006
    Location
    Utah
    Age
    53
    Posts
    301
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I found a partail answer, I posted this question http://forums.fedoraforum.org/showth...098#post741098 and recieved this link: http://www.nvnews.net/vbulletin/showthread.php?t=72490
    and recieved these results: [root@red1 ~]# chcon -t texrel_shlib_t /usr/lib/xorg/modules/drivers/nvidia_drv.so
    [root@red1 ~]# chcon -t texrel_shlib_t /usr/lib/xorg/modules/extensions/libglx.so.1.0.9631
    chcon: /usr/lib/xorg/modules/extensions/libglx.so.1.0.9631: No such file or directory
    [root@red1 ~]# chcon -t texrel_shlib_t /usr/lib/tls/libnvidia-tls.so.1
    chcon: /usr/lib/tls/libnvidia-tls.so.1: No such file or directory
    [root@red1 ~]# chcon -t texrel_shlib_t /usr/lib/libGLcore.so.1.0.9631
    chcon: /usr/lib/libGLcore.so.1.0.9631: No such file or directory
    [root@red1 ~]# locate libGLcore.so.*
    [root@red1 ~]# locate libglx.so.*
    [root@red1 ~]# locate libglx.so
    /usr/lib/xorg/modules/extensions/libglx.so
    /usr/lib/xorg/modules/extensions/nvidia/libglx.so
    /usr/lib/xorg/modules/extensions/nvidia/libglx.so.1.0.9631
    [root@red1 ~]# locate libGLcore.so
    /usr/lib/nvidia/libGLcore.so
    /usr/lib/nvidia/libGLcore.so.1
    /usr/lib/nvidia/libGLcore.so.1.0.9631
    /usr/lib/nvidia/libGLcore.so.1.0.9631.#prelink#.CvswVs
    /usr/lib/xorg/modules/extensions/libGLcore.so
    [root@red1 ~]#
    [root@red1 ~]# chcon -t texrel_shlib_t /usr/lib/xorg/modules/extensions/nvidia/libglx.so.1.0.9631
    [root@red1 ~]# locate libnvida
    [root@red1 ~]# chcon -t texrel_shlib_t /usr/lib/nvidia/libGLcore.so.1.0.9631

    I think it's SELinux blocking the glx stuff again
    Tim :eek:
    Smolt profile

Page 42 of 76 FirstFirst ... 32 40 41 42 43 44 52 ... LastLast

Similar Threads

  1. Getting ATi cards to work in Fedora
    By Firewing1 in forum Guides & Solutions (Not For Questions)
    Replies: 785
    Last Post: 24th January 2010, 08:30 PM
  2. Replies: 2
    Last Post: 14th September 2007, 03:34 PM
  3. can't get Fedora Core 6 to work with nvidia cards, help
    By sf_basilix in forum Installation, Upgrades and Live Media
    Replies: 16
    Last Post: 18th January 2007, 03:49 PM
  4. Wireless cards work with Fedora core 5
    By axiom in forum Using Fedora
    Replies: 0
    Last Post: 27th July 2006, 08:04 PM
  5. Nvidia cards on Fedora Core 3
    By ravalox in forum Fedora Core 3 Test Releases
    Replies: 8
    Last Post: 7th November 2004, 03:53 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •