FedoraForum.org - Fedora Support Forums and Community
Results 1 to 10 of 10
  1. #1
    Join Date
    Mar 2006
    Posts
    1

    yum/pup problems

    I, having problems updating my system from yum or pup

    firstly yum

    Code:
    # yum update
    Loading "installonlyn" plugin
    Setting up Update Process
    Setting up repositories
    developmen: #########################                          1/2Cannot open/read repomd.xml file for repository: development
    failure: repodata/repomd.xml from development: [Errno 256] No more mirrors to try.
    Error: failure: repodata/repomd.xml from development: [Errno 256] No more mirrors to try.
    then pup just hangs for 3 minutes then displays a pop-up error message

    Code:
    Component: Software Updater
    Summary: TB86fdcb55 repos.py:431:check:RepoError: Cannot find a valid baseurl for repo: development
    
    Traceback (most recent call last):
      File "/usr/sbin/pup", line 356, in ?
        main()
      File "/usr/sbin/pup", line 352, in main
        pup.run()
      File "/usr/sbin/pup", line 328, in run
        self.doRefresh()
      File "/usr/sbin/pup", line 160, in doRefresh
        self.reposSetup(pbar)
      File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 131, in reposSetup
        self.doRepoSetup()
      File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 244, in doRepoSetup
        repo.baseurlSetup()
      File "/usr/lib/python2.4/site-packages/yum/repos.py", line 550, in baseurlSetup
        self.check()
      File "/usr/lib/python2.4/site-packages/yum/repos.py", line 431, in check
        raise Errors.RepoError, \
    RepoError: Cannot find a valid baseurl for repo: development
    
    Local variables in innermost frame:
    self: development
    I'm behind a company firewall and use a proxy, and have configured "Network Proxy Preferences" to use an automatic proxy configuration file.

    Thanks
    Steve

  2. #2
    Join Date
    Feb 2006
    Location
    Berkshire, UK
    Posts
    123
    Hi,

    I had to set the following up to get yum to work through a proxy.

    To set for shell to use proxy server, by creating two following files in /etc/profile.d

    #proxy.sh
    export http_proxy=http://proxy-server:port-number/
    export ftp_proxy=http://proxy-server:port-number/
    export no_proxy=domain
    export HTTP_PROXY=http://proxy-server:port-number/
    export FTP_PROXY=http://proxy-server:port-number/

    #proxy.csh
    setenv http_proxy http://proxy-server:port-number/
    setenv ftp_proxy http://proxy-server:port-number/
    setenv no_proxy domain
    setenv HTTP_PROXY http://proxy-server:port-number/
    setenv FTP_PROXY http://proxy-server:port-number/

    Once done above must log out of shell and open new shell before doing yum update. Should work then.

    I think there are other ways, but the above certainly works for me.

    Neil.
    Last edited by neilloffhagen; 7th March 2006 at 12:59 PM.

  3. #3
    Join Date
    May 2005
    Posts
    24
    Quote Originally Posted by neilloffhagen
    #proxy.sh
    export http_proxy=http://proxy-serverort-number/
    export ftp_proxy=http://proxy-serverort-number/
    export no_proxy=domain
    export HTTP_PROXY=http://proxy-serverort-number/
    export FTP_PROXY=http://proxy-serverort-number/

    #proxy.csh
    setenv http_proxy http://proxy-serverort-number/
    setenv ftp_proxy http://proxy-serverort-number/
    setenv no_proxy domain
    setenv HTTP_PROXY http://proxy-serverort-number/
    setenv FTP_PROXY http://proxy-serverort-number/

    .
    Neil,

    this works for me in FC3/4 with yum, wget, apt-get, smart, synaptic, smart --gui (both started from the command line), but not for rpm (for example to retrieve GPG keys) nor yumex.

    Some GUI programs (e.g., synaptic) leave the possibility to enter the proxy parameters using the proxy, but, to my knowledge, it is not (yet?) the case for yumex (I tested v. 0.44). In fact, I have found no way to let yumex work through a proxy. Any idea ?

    PE

  4. #4
    Join Date
    Feb 2006
    Location
    Berkshire, UK
    Posts
    123
    Quote Originally Posted by sylvestre
    In fact, I have found no way to let yumex work through a proxy. Any idea ?
    Yep. If you open yumex under the Edit menu there is Preferences then at the bottom of that window, where Mirror Detection is should be a tick box for "Use proxy". If you put in there your proxy server address it should work. But you have to put the full name in, as in http://proxy_name Don't need to put the :port-number at the end though. Guess yumex must do that bit itself?

    I do find this very slow compared to yum in accessing the repos.

    Neil.

  5. #5
    Join Date
    May 2005
    Posts
    24
    Quote Originally Posted by sylvestre
    In fact, I have found no way to let yumex work through a proxy.
    PE
    Mmm, I should have done some search before. Here are two solutions :
    http://linux.rasmil.dk/cms/modules/n...php?storyid=19

    PE

  6. #6
    Join Date
    May 2005
    Posts
    24
    Quote Originally Posted by neilloffhagen
    Yep. If you open yumex under the Edit menu there is Preferences then at the bottom of that window, where Mirror Detection is should be a tick box for "Use proxy". If you put in there your proxy server address it should work. But you have to put the full name in, as in http://proxy_name Don't need to put the ort-number at the end though. Guess yumex must do that bit itself?
    Neil.
    Thanks. However, since the "Autorefresh option on start" is by default activated, yumex starts to find the repos first, preventing me to access to the Edit menu itself. The way I found was to type ^C (I started yumex from a terminal) : after that, I was able to access the Edit menu, and to set the proxy parameters. I restarted yumex and and everything went OK. You are right, it does not need the ort-number at the end (maybe that it is the same for yum).

    For the two other solutions listed here :
    http://linux.rasmil.dk/cms/modules/n...php?storyid=19

    1) to add "proxy=http://serverortnumber" in '/etc/yum.conf' file does not work for yumex nor yum if a mirror list is used (it is the default FC4 configuration). See
    https://devel.linux.duke.edu/bugzill...bug.cgi?id=407

    2) to add "export http_proxy=http://serverortnumber/" in '/usr/share/yumex/yumex' script file works fine (it is a bash script file). However, this environment variable was already setup in my configuration. Does it mean that it is not passed via the script file ? I have a poor knowledge about script programming.

    PE

    NB : means : p without a blank

  7. #7
    Join Date
    Jun 2004
    Posts
    233
    In yumex 0.44 and later you can specify a proxy in the perferences.
    See section 9.2 in the userguide.
    http://yumex.python-hosting.com/wiki/UserGuide
    You have to set the mirrordetection to 'default' because the mirrordetection don't work behind a proxy.
    Try using the latest yumex development edition, it is working better.
    check here for installation instructions.
    http://yumex.python-hosting.com/wiki/InstallYumex

  8. #8
    Join Date
    May 2005
    Posts
    24
    Thanks MIT.

    The last development version appears to be far improved.

    PE

  9. #9
    Join Date
    Jun 2008
    Posts
    1
    same problem with the proxy, if i put an http proxy into gnome settings. its slow as hell and actually get no connection. with export http_proxy it works fine. bug?

  10. #10
    leigh123linux Guest
    Thread closed !

Similar Threads

  1. Replies: 3
    Last Post: 23rd July 2008, 04:56 PM
  2. Wifi Problems, BCM4312. Connection problems
    By jackbrennan7757 in forum Hardware & Laptops
    Replies: 4
    Last Post: 18th January 2008, 09:32 PM
  3. Stupid nOOb with boot up problems, internet problems...the works.
    By phearthepenguin in forum Servers & Networking
    Replies: 30
    Last Post: 23rd August 2006, 05:33 PM
  4. Firefox problems and problems with Laptop sound card.
    By j_villa1983 in forum Hardware & Laptops
    Replies: 3
    Last Post: 22nd August 2006, 05:54 AM
  5. Replies: 0
    Last Post: 11th August 2006, 04:31 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •