FedoraForum.org - Fedora Support Forums and Community
Results 1 to 14 of 14
  1. #1
    Join Date
    Feb 2006
    Posts
    19

    Unhappy openoffice.org locked settings...

    The language settings show a little padlock next to thm and when you hover over it it says "this setting is protected by the administrator". Tried running as root, same thing happens.

    At the moment it is stuck on English (US) i wan't it to be just English/English (UK)...

    Anyone else had this problem? I can't find anything ANYWHERE about how to solve it...

  2. #2
    Join Date
    Apr 2005
    Location
    italia
    Posts
    157
    Is there really that much difference in a computer world never really looked at them, I know in general conversation there is a little difference. With exception to metric system and maybe date format what is the difference.

    This is not trying to pick at nationalities it's a legit question, because with exception of few things being called different, (truck)(lorry) things like that everything else is close except some of the backwoods irish, I have hard time understanding some of them........
    Last edited by centos_x; 26th February 2006 at 03:03 PM.

  3. #3
    Join Date
    Dec 2005
    Location
    England
    Posts
    470
    Is that under Options->Languages?
    Does 'Local setting' say English (UK)?

    You should be able to check the box 'For current document only' ... I'll have a look and see if I can find any way of changing it. (I also have the padlocks...bur mine is set as English (UK))
    -- M$ cater for the lowest common denominator --

  4. #4
    Join Date
    Dec 2005
    Location
    England
    Posts
    470
    This is taken from the OpenOffice.org help file:

    Default languages for documents
    Specifies the languages for spellchecking, thesaurus and hyphenation.
    Selecting the Document Language


    The spellcheck for the selected language only functions when you have installed the corresponding language module. A language entry has a check mark in front of it if the spellcheck is activated for this language.
    -- M$ cater for the lowest common denominator --

  5. #5
    Join Date
    Mar 2005
    Location
    Barcelona
    Posts
    372
    I have the same problem, I installed a language package but I only can change the language for the current document, I can't set it as the default language

  6. #6
    Join Date
    Dec 2004
    Location
    Canada
    Age
    26
    Posts
    9,224
    Update your OO.o:
    Code:
    yum update -y
    it's a known bug an has been fixed in the newest version. if you don't want to upgrade, a workaround is highlight all text, [menu]Format > Character and set the language.
    Firewing1
    [+] My open source software and blog
    [+] Some of my howtos: (for full list, click here)

  7. #7
    Join Date
    Mar 2005
    Location
    Barcelona
    Posts
    372
    What version is it? I have 2.0 and Yum says nothing to update

  8. #8
    Join Date
    Dec 2004
    Location
    Canada
    Age
    26
    Posts
    9,224
    Code:
    [admin@FC5T3 ~]$ rpm -qf /usr/bin/openoffice.org-2.0
    openoffice.org-core-2.0.1.1-11.2.2
    Firewing1
    [+] My open source software and blog
    [+] Some of my howtos: (for full list, click here)

  9. #9
    Join Date
    Feb 2006
    Posts
    19
    Where do we get the updated version from? Yum thinks openoffice.org-core-2.0.1.1-5.1 is the latest.

  10. #10
    Join Date
    Dec 2004
    Location
    Canada
    Age
    26
    Posts
    9,224
    I'm using FC5T3 -- So a
    Code:
    su -
    yum update openoffice.org-draw openoffice.org-core openoffice.org-calc openoffice.org-writer openoffice.org-impress openoffice.org-base openoffice.org-math --enablerepo=development --enablerepo=extras-development
    I'm not sure if this will have the massive dep problem, but that's the new OO.o
    Firewing1
    [+] My open source software and blog
    [+] Some of my howtos: (for full list, click here)

  11. #11
    Join Date
    Feb 2006
    Posts
    19
    Ahhh from the devlopement repo. Thanks!

  12. #12
    Join Date
    Dec 2004
    Location
    Canada
    Age
    26
    Posts
    9,224
    Did it bring in the gazillion other dev packages or did it only update OO.o?
    Firewing1
    [+] My open source software and blog
    [+] Some of my howtos: (for full list, click here)

  13. #13
    Join Date
    Mar 2005
    Location
    Barcelona
    Posts
    372
    ARGHHH!!!
    too many dependencies. I guess I'll wait for the upgrade in the usual repos. In the meantime, I've improved your workaround:
    In OOwriter, assuming you have installed the language package(s) you want:
    1. Open a new document
    2. Go to styles and set the fonts with the language of your choice for every style you use
    3. Save as default template in your home folder
    4. Go to File > New > Documents and Templates > Organize
    5. Rightclick on your default template and set 'make it default'. All new documents will be created in the new language

    Thanks,

  14. #14
    Join Date
    Dec 2004
    Location
    Canada
    Age
    26
    Posts
    9,224
    I think I said it before, but an easier workaround:
    Select > All
    Format > Character
    Choose your language
    Firewing1
    [+] My open source software and blog
    [+] Some of my howtos: (for full list, click here)

Similar Threads

  1. OpenOffice.org forgets changes to settings
    By mpolo in forum Using Fedora
    Replies: 0
    Last Post: 13th August 2005, 10:11 AM
  2. OpenOffice locale settings
    By linuxfj in forum Using Fedora
    Replies: 1
    Last Post: 27th February 2005, 09:54 PM
  3. openoffice.org and mozilla ignore font settings
    By stoty in forum Using Fedora
    Replies: 4
    Last Post: 18th August 2004, 07:46 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •