hddtemp
FedoraForum.org - Fedora Support Forums and Community
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 22
  1. #1
    ferd Guest

    hddtemp

    I cannot get hddtemp to install. I know that I need to install it as SUID root. It would help if I knew exactly what that meant. I have used yum to install it and when I reboot, there is no indication that it is running in gkrellm or ksensors. Yes, I also installed gkrellm-hddtemp. I tried installing it using <su - > console with no success. Any help appreciated. I did have it working in my previous install, but I don't remember exactly how.

  2. #2
    Join Date
    Feb 2004
    Location
    Indiana, USA
    Age
    63
    Posts
    428
    Are you installing the rpm or via source? '$yum install hddtemp" as root should do it for you.
    -----------------------------------------------------------
    :cool:Registered Linux User #270764
    Folding@home Team: 37988 FedoraFolders
    Author: GFHCM Folding@Home Monitor
    Author: GapcMon - UPS Status Monitor
    Contributor: GIW - Gtk Instrumentation Library

  3. #3
    ferd Guest
    Thanks James. When I try this I get "too few arguments".

  4. #4
    Join Date
    Feb 2004
    Location
    Indiana, USA
    Age
    63
    Posts
    428

    Cool Deeper help

    That meant to change to user root, or signon as user root, before runing the install command, but you said you used YUM which did that for you. Otherwise you would have got an error message from yum.
    Quote Originally Posted by ferd
    I cannot get hddtemp to install. I know that I need to install it as SUID root. It would help if I knew exactly what that meant.
    Try the cmd '$ ps -fC hddtemp' to verify its running. if its not use the system service manager to enable it. '$ system-config-services' and be sure to file.save your change. after your wuote is an example of out from my ps command. If you need to configure it. its config file is in /etc/sysconfig/hddtemp .
    Quote Originally Posted by ferd
    I have used yum to install it and when I reboot, there is no indication that it is running in gkrellm or ksensors. Yes, I also installed gkrellm-hddtemp. I tried installing it using <su - > console with no success.
    Code:
    [jscott@homedev ~]$ ps -fC hddtemp
    UID        PID  PPID  C STIME TTY          TIME CMD
    root      3129     1  0 Oct29 ?        00:00:01 /usr/sbin/hddtemp -d /dev/hda /dev/hdc /dev/hdd -l 127.0.0.1
    
    
    [jscott@homedev ~]$ cat /etc/sysconfig/hddtemp
    #
    # hddtemp options, for both command line and daemon use.
    # Put at least the disk(s) you want to monitor here.
    #
    HDDTEMP_OPTIONS="/dev/hd[acd]"
    
    #
    # Options used only in daemon mode (when invoked by the init script).
    #
    HDDTEMP_DAEMON_OPTIONS="-l 127.0.0.1"
    [jscott@homedev ~]$
    You did not need to install gkrellm-hddtemp, but it can't hurt. goto GKrellm's configuration panel (press F1 after clicking gkrellm) and look at the this SCREENSHOT-1. Thats where you tell gkrellm where to display the disk temps. If hddtemp write a message that it can't find your disk type in its database - its database is here - /usr/share/misc/hddtemp.db.
    Quote Originally Posted by ferd
    Yes, I also installed gkrellm-hddtemp. I tried installing it using <su - > console with no success.
    Did I answer all your questions ?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Screenshot-1.png 
Views:	258 
Size:	430.1 KB 
ID:	6475  
    -----------------------------------------------------------
    :cool:Registered Linux User #270764
    Folding@home Team: 37988 FedoraFolders
    Author: GFHCM Folding@Home Monitor
    Author: GapcMon - UPS Status Monitor
    Contributor: GIW - Gtk Instrumentation Library

  5. #5
    ferd Guest

    Still later

    Wow, that is exemplary help. Rebooting now to check. Thanks James. No luck. I am not knowledgable enough to make this work. Thanks anyway. I have tried editing sysconfig to mimic your script as closely as posible and conform to my system, but I am now getting an error during log in that I don't remember. Enough is enough. Not worth the hassle.
    Last edited by ferd; 31st October 2005 at 01:39 AM. Reason: Later

  6. #6
    Join Date
    Feb 2004
    Location
    Indiana, USA
    Age
    63
    Posts
    428
    If you want help post the exact error messsage and the contents of the file you have question on. note: its not too much stuff to post. Right now you have 99% of the work done.
    1. What are you trying to do? possible answer - monitor your hard disk temps via gkrellm!
    2. How many disk do you have? possible answer 3, WD, IBM, and a white label
    3. Do you have hddtemp and gkrellm installed? yes (show output from this cmd "$ rpm -qa | grep -e hddtemp -e gkrellm" )
    4. What your configuration? post the results of this command. "$ cat /etc/sysconfig/hddtemp" and a screen snapshot is possible"
    5. Then I or someone else will post an answer or help you look for one? BUT YOU CAN'T give up, which wastes our time!


    Ready when you are.
    -----------------------------------------------------------
    :cool:Registered Linux User #270764
    Folding@home Team: 37988 FedoraFolders
    Author: GFHCM Folding@Home Monitor
    Author: GapcMon - UPS Status Monitor
    Contributor: GIW - Gtk Instrumentation Library

  7. #7
    ferd Guest
    1. Monitor hard disk temp with gkrellm and/or ksensors.
    2. 1 disk. hda.
    3.gkrellm-2.2.5-0.2.fc4.rf
    gkrellm-freq-0.1.1-2.fc4
    gkrellm-daemon-2.2.5-0.2.fc4.rf
    gkrellm-weather-2.0.7-1
    gkrellm-hddtemp-0.2-0.4.beta
    hddtemp-0.3-0.6.beta14.fc4
    4.#
    # hddtemp(8) daemon options. Add at least the disk(s) you want to monitor here.
    #
    HDDTEMP_OPTIONS="-l 127.0.0.1"
    5. OK. My point is that I don't have the knowledge to make these commands work because I don't have the unwritten knowledge you do that you assume I do.

  8. #8
    Join Date
    Feb 2004
    Location
    Indiana, USA
    Age
    63
    Posts
    428

    Cool

    Q's 1-3 = great
    Q4: We need to edit your config file, follow these command step by step.
    Code:
    "$ su -'     -- it will ask you to enter your real root password; this is what is means to switch to the root user -- 
                    -- notice the $-# prompt changes,  $=regular user, #=super user or su
    '# gedit /etc/sysconfig/hddtemp'   -- make sure these two lines (between the --- marks) are the same then file.save  
                                                          -- you seem to be missing HDDTEMP_OPTIONS so this will FIX it.
    ----
    HDDTEMP_OPTIONS="/dev/hda"
    HDDTEMP_DAEMON_OPTIONS="-l 127.0.0.1"
    ---
    
    Then restart hddtemp with this command "# /sbin/service hddtemp restart'
    Then restart GKrellm (i.e quit the current one, and start it again)
    Now you need to tell gkrellm to use the data and put it on the disk display. Here are two screenshots from my laptop. If it doesn't work send me your screenprints (press PrintScreen key) and the output from this command "$ ps -fC hddtemp'.

    Q5: Nobody knows starting out, we all learn from others - just hold on and you will have this one done...
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Disk.png 
Views:	159 
Size:	252.7 KB 
ID:	6476   Click image for larger version. 

Name:	Sensors.png 
Views:	165 
Size:	260.9 KB 
ID:	6477  
    Last edited by skoona; 31st October 2005 at 06:51 PM. Reason: added screenshots
    -----------------------------------------------------------
    :cool:Registered Linux User #270764
    Folding@home Team: 37988 FedoraFolders
    Author: GFHCM Folding@Home Monitor
    Author: GapcMon - UPS Status Monitor
    Contributor: GIW - Gtk Instrumentation Library

  9. #9
    ferd Guest
    [bruce@localhost ~]$ su
    Password:
    [root@localhost bruce]# gedit /etc/sysconfig/hddtemp
    [root@localhost bruce]# /sbin/service hddtemp restart
    Stopping hard disk temperature monitor daemon (hddtemp): [FAILED]
    Starting hard disk temperature monitor daemon (hddtemp): Too few arguments: you must specify one drive, at least.
    [FAILED]
    [root@localhost bruce]# gedit /etc/sysconfig/hddtemp
    [root@localhost bruce]# /sbin/service hddtemp restart
    Stopping hard disk temperature monitor daemon (hddtemp): [FAILED]
    Starting hard disk temperature monitor daemon (hddtemp): Too few arguments: you must specify one drive, at least.
    [FAILED]
    [root@localhost bruce]#
    [root@localhost bruce]# ps -fC hddtemp
    UID PID PPID C STIME TTY TIME CMD
    That is what I get. I don't know how to get print screen to work in Linux.

  10. #10
    Join Date
    Feb 2004
    Location
    Indiana, USA
    Age
    63
    Posts
    428
    show us the output of these commands
    A. "# cat /etc/sysconfig/hddtemp'
    B. '# cat /etc/init.d/hddtemp'

    It seems like the changes you made to /etc/sysconfig/hddtemp are not being picked up. So let us look at your config file(A) and the file(B) that should be reading it.

    Your config file should contain these statements. anything begining with a "#" is treated as a comment to hddtemp.
    Code:
    File /etc/sysconfig/hddtemp
    HDDTEMP_OPTIONS="/dev/hda"
    HDDTEMP_DAEMON_OPTIONS="-l 127.0.0.1"
    If it does not include the above edit it with "# gedit /etc/sysconfig/hddtemp" and type or change those two statements into the file, so they match the above quotes and all, then save it. restart hddtemp, and send use the output of the restart command.

    Here is something else you can do just to test it quickly. This command should start it to prove it can be started.
    "# /usr/sbin/hddtemp /dev/hda'
    Last edited by skoona; 31st October 2005 at 09:28 PM.
    -----------------------------------------------------------
    :cool:Registered Linux User #270764
    Folding@home Team: 37988 FedoraFolders
    Author: GFHCM Folding@Home Monitor
    Author: GapcMon - UPS Status Monitor
    Contributor: GIW - Gtk Instrumentation Library

  11. #11
    Join Date
    Feb 2004
    Location
    Indiana, USA
    Age
    63
    Posts
    428
    Looking ahead we will need this program "SmartMonTools". Its at this url http://smartmontools.sourceforge.net/
    You can download it to any directory the RPM from here http://prdownloads.sourceforge.net/s...6.rpm?download

    If your browser ask to install it for you --- let it do it!.

    change to that directory and Install it using "rpm -ivh smartmontools-5.33-1.i386.rpm'

    The use it with this command "# smartctl -a /dev/hda" and post its output, so I can see it.
    -----------------------------------------------------------
    :cool:Registered Linux User #270764
    Folding@home Team: 37988 FedoraFolders
    Author: GFHCM Folding@Home Monitor
    Author: GapcMon - UPS Status Monitor
    Contributor: GIW - Gtk Instrumentation Library

  12. #12
    ferd Guest

    Reboot

    I found the problem. When I make a change using gedit, it automatically makes a backup of the original file identified with '~'. I removed the '~' file with the rm command and the "# smartctl -a /dev/hda" command resulted in this: /dev/hda: ST3200822A: 30C. Progress at last. As far as smartmontools: [root@localhost bruce]# smartctl -a /dev/hda
    bash: smartctl: command not found
    When I tried to install I got a message that it was already installed.
    I rebooted and I'm still not getting any indication in either gkrellm or ksensors that hddtemp is operating.
    Last edited by ferd; 1st November 2005 at 12:32 AM. Reason: Update

  13. #13
    Join Date
    Feb 2004
    Location
    Indiana, USA
    Age
    63
    Posts
    428

    Show us the output from 1 & 2

    Quote Originally Posted by ferd
    I found the problem. When I make a change using gedit, it automatically makes a backup of the original file identified with '~'. I removed the '~' file with the rm command and the "# smartctl -a /dev/hda" command resulted in this: /dev/hda: ST3200822A: 30C. Progress at last. As far as smartmontools: [root@localhost bruce]# smartctl -a /dev/hda
    bash: smartctl: command not found
    When I tried to install I got a message that it was already installed.
    I rebooted and I'm still not getting any indication in either gkrellm or ksensors that hddtemp is operating.
    OK, reboots are not normally required - so save yourself some time.

    this command "# locate smartctl | grep bin' should produce this "/usr/sbin/smartctl" you need to use the whole path when executing commands: UNLESS you switch to super user using the dash "$ su - ". using the dash causes the switch to superuser to also switch to root's path. regular user paths don't include "/usr/sbin' among others. I noticed that you didn't use the dash...

    We will use smartctl later when we need to know the exact disk type and code for temps. For now set it aside. please remember to post all the output from these commands - you can't post too much. i.e. i will need to see the output from smartctl

    OK, back to hddtemp.

    2. What's in your /etc/sysconfig/hddtemp file? It the one configuration file I need to see! post the output of this "# cat /etc/sysconfig/hddtemp'
    3. also post the startup file via this cmd "# cat /etc/init.d/hddtemp'

    Again, this is what mine looks like
    Code:
    [B][root@homedev ~]# cat /etc/sysconfig/hddtemp
    #
    # hddtemp options, for both command line and daemon use.
    # Put at least the disk(s) you want to monitor here.
    #
    HDDTEMP_OPTIONS="/dev/hd[acd]"
    
    #
    # Options used only in daemon mode (when invoked by the init script).
    #
    HDDTEMP_DAEMON_OPTIONS="-l 127.0.0.1"
    [root@homedev ~]#
    -----------------------------------------------------------
    :cool:Registered Linux User #270764
    Folding@home Team: 37988 FedoraFolders
    Author: GFHCM Folding@Home Monitor
    Author: GapcMon - UPS Status Monitor
    Contributor: GIW - Gtk Instrumentation Library

  14. #14
    ferd Guest
    OK, first command "# cat /etc/sysconfig/hddtemp" got no response.
    Second command"# cat /etc/init.d/hddtemp" got this:#!/bin/sh
    #
    # hddtemp This shell script takes care of starting and stopping hddtemp.
    #
    # chkconfig: - 90 10
    # description: hddtemp provides information about hard drives' temperature
    # processname: hddtemp
    # config: /etc/sysconfig/hddtemp

    . /etc/sysconfig/hddtemp

    # Source function library.
    . /etc/rc.d/init.d/functions

    # Source networking configuration.
    . /etc/sysconfig/network

    # Check that networking is up.
    [ "$NETWORKING" = "no" ] && exit 0

    # Backwards compatibility.
    [ -z "$HDDTEMP_OPTIONS" -a -n "$HDDTEMPARGS" ] && \
    HDDTEMP_OPTIONS="$HDDTEMPARGS"
    HDDTEMP_OPTIONS="$HDDTEMP_OPTIONS $HDDTEMP_DAEMON_OPTIONS"

    exec="/usr/sbin/hddtemp"
    prog=$(basename $exec)
    lockfile=/var/lock/subsys/$prog

    start() {
    echo -n $"Starting hard disk temperature monitor daemon ($prog): "
    daemon $exec -d $HDDTEMP_OPTIONS
    retval=$?
    echo
    [ $retval -eq 0 ] && touch $lockfile
    return $retval
    }

    stop() {
    echo -n $"Stopping hard disk temperature monitor daemon ($prog): "
    killproc $prog
    retval=$?
    echo
    [ $retval -eq 0 ] && rm -f $lockfile
    return $retval
    }

    restart() {
    stop
    start
    }

    # See how we were called.
    case "$1" in
    start|stop|restart)
    $1
    ;;
    reload|force-reload)
    restart
    ;;
    status)
    status $prog
    ;;
    try-restart|condrestart)
    [ ! -f $lockfile ] || restart
    ;;
    *)
    echo $"Usage: $0 {start|stop|status|restart|try-restart|reload|force-reload}"
    exit 2
    esac
    [root@localhost bruce]# locate smartctl | grep bin
    warning: locate: could not open database: /var/lib/slocate/slocate.db: No such file or directory
    warning: You need to run the 'updatedb' command (as root) to create the database.
    Please edit /etc/updatedb.conf to enable the daily cron job.
    [root@localhost bruce]# updatedb
    [root@localhost bruce]# locate smartctl | grep bin
    /usr/sbin/smartctl
    And that is my result for the smartctl command.

  15. #15
    Join Date
    Feb 2004
    Location
    Indiana, USA
    Age
    63
    Posts
    428
    Well the first command is the majic key. Lets create it. edit the file (say yes to create if asked) and add these two lines, save it and restart hddtemp

    1. "# gedit /etc/sysconfig/hddtemp'
    Code:
    HDDTEMP_OPTIONS="/dev/hda"
    HDDTEMP_DAEMON_OPTIONS="-l 127.0.0.1"
    2. "# /sbin/service hddtemp restart'
    -----------------------------------------------------------
    :cool:Registered Linux User #270764
    Folding@home Team: 37988 FedoraFolders
    Author: GFHCM Folding@Home Monitor
    Author: GapcMon - UPS Status Monitor
    Contributor: GIW - Gtk Instrumentation Library

Page 1 of 2 1 2 LastLast

Similar Threads

  1. Logwatch and hddtemp
    By CrazyCaver in forum Using Fedora
    Replies: 2
    Last Post: 7th January 2009, 03:03 AM
  2. hddtemp and gnome sensors
    By barf in forum Installation, Upgrades and Live Media
    Replies: 0
    Last Post: 30th April 2008, 11:50 AM
  3. Hd hot according to hddtemp
    By lazlow in forum Hardware & Laptops
    Replies: 5
    Last Post: 9th December 2007, 02:01 AM
  4. HDDTemp Problem
    By praveenpious in forum Using Fedora
    Replies: 2
    Last Post: 6th December 2007, 04:20 PM
  5. hddtemp boot problem
    By lazlow in forum Using Fedora
    Replies: 2
    Last Post: 20th June 2006, 10:16 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •