error: array type has incomplete element type
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 5 of 5
  1. #1
    jattoo Guest

    error: array type has incomplete element type

    Hello every one,
    I am learning my way thru' linux FC distro's, I have been trying to install php but got the following error
    make
    gcc -Iext/libxml/ -I/home/contehm/mydownloads/php-5.0.3/ext/libxml/ -DPHP_ATOM_INC -I/home/contehm/mydownloads/php-5.0.3/include -I/home/contehm/mydownloads/php-5.0.3/main -I/home/contehm/mydownloads/php-5.0.3 -I/home/contehm/mydownloads/php-5.0.3/Zend -I/usr/include/libxml2 -I/home/contehm/mydownloads/php-5.0.3/TSRM -g -O2 -c /home/contehm/mydownloads/php-5.0.3/ext/libxml/libxml.c -o ext/libxml/libxml.o && echo > ext/libxml/libxml.lo
    In file included from /home/contehm/mydownloads/php-5.0.3/Zend/zend_API.h:26,
    from /home/contehm/mydownloads/php-5.0.3/main/php.h:38,
    from /home/contehm/mydownloads/php-5.0.3/ext/libxml/libxml.c:28:
    /home/contehm/mydownloads/php-5.0.3/Zend/zend_modules.h:34: error: array type has incomplete element type
    /home/contehm/mydownloads/php-5.0.3/Zend/zend_modules.h:35: error: array type has incomplete element type
    /home/contehm/mydownloads/php-5.0.3/Zend/zend_modules.h:36: error: array type has incomplete element type
    /home/contehm/mydownloads/php-5.0.3/Zend/zend_modules.h:37: error: array type has incomplete element type
    /home/contehm/mydownloads/php-5.0.3/Zend/zend_modules.h:38: error: array type has incomplete element type
    make: *** [ext/libxml/libxml.lo] Error 1

    If any one have any clues, Please help me, I am about to give up on Fedora.
    Thanx
    Please give specific instructions on resolving this issue, cause I am a wannabe expert.

  2. #2
    mjman Guest
    why not just `yum install php` ?

  3. #3
    jattoo Guest
    I have tried that but I always got the following:
    Added 37 new packages, deleted 0 old in 24.81 seconds
    Parsing package install arguments
    Nothing to do
    All I want to do is istall a home webserver just for learning and I have been following one of the post on the forum by someone, but I could not get php to install right.

  4. #4
    mjman Guest
    The "Nothing to do" message means that you already have php installed. What is the output of
    Code:
    rpm -q php
    ?

  5. #5
    jattoo Guest
    This is what I got

    php-5.0.4-10.4, I guess its not configure then

Similar Threads

  1. expecting a reference package element found type 0
    By Raskula in forum Hardware & Laptops
    Replies: 4
    Last Post: 4th January 2009, 02:31 PM
  2. error: dereferencing pointer to incomplete type
    By Maninder in forum Servers & Networking
    Replies: 0
    Last Post: 11th May 2008, 10:23 AM
  3. BCM43xx Device Type Error
    By leflores80 in forum Servers & Networking
    Replies: 0
    Last Post: 4th June 2007, 11:49 PM
  4. Error: mount: you must specify the filesystem type
    By panamaszr12 in forum Using Fedora
    Replies: 8
    Last Post: 24th January 2006, 09:47 PM
  5. evolution error ( can't type in Calendar section )
    By ferlin in forum Using Fedora
    Replies: 0
    Last Post: 16th July 2005, 04:31 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •