FedoraForum.org - Fedora Support Forums and Community
Results 1 to 14 of 14
  1. #1
    Join Date
    Aug 2005
    Posts
    3

    Scrambled X Windows

    I have recently installed FC4 PPC on a PowerMac Dual 1.25, ATI 9000 Pro, 512 MB Ram, etc...nothing non-stock. The installer produces crisp graphic. Even the first graphicial boot is fine. However, as soon as X Windows starts, the graphics become scrambled, like a blocked cable channel. Even Alt-Clt-F2 brings up a command line that has some graphic problem. If I change the defaul runlevel to 3 in the inittab file so that X Windows will not start automatically, the command prompt is fine. If I let Fedora setup up the graphics with the first boot wizard, and it seems to select the hardware fine (ATI Radeon 9000 Pro with Apple 17' LCD Display).

    Any ideas?

  2. #2
    Join Date
    Aug 2005
    Posts
    19
    Quote Originally Posted by PuzzledGuy
    I have recently installed FC4 PPC on a PowerMac Dual 1.25, ATI 9000 Pro, 512 MB Ram, etc...nothing non-stock. The installer produces crisp graphic. Even the first graphicial boot is fine. However, as soon as X Windows starts, the graphics become scrambled, like a blocked cable channel. Even Alt-Clt-F2 brings up a command line that has some graphic problem. If I change the defaul runlevel to 3 in the inittab file so that X Windows will not start automatically, the command prompt is fine. If I let Fedora setup up the graphics with the first boot wizard, and it seems to select the hardware fine (ATI Radeon 9000 Pro with Apple 17' LCD Display).

    Any ideas?
    I am new to Linux and Mac, but I'll share what I found with my PowerBook G3 install. I was having a similar problem except I couldn't even use Anaconda during the install, I had to use text mode. After scouring the internet for awhile I finally found out that I should be looking at /etc/X11/xorg.conf. I tried changing my video driver to something else (I'm sorry, I can't remember what I tried to change it to...) and that worked until I tried to change the resolution from the Fedora desktop. I made the same change again (it seemed that the change I made from the desktop overwrote the xorg.conf file) and again I could get to a graphical desktop, but the resolution and color depth left much to be desired.

    I then found a post that suggest downloading Xautoconfig that comes with Yellow Dog Linux by default. I believe that I installed in by yum install Xautoconfig, but I might have had to go find it instead. So I ran Xautoconfig and I got a good resolution and color depth, but the colors were wrong. The blues were showing up as reds etc... It looked nice actually until you hit the web or looked at any actual pictures.

    I then went into xorg.conf again and changed something that made X completely unusable again. I tried changing the video driver like I described earlier, but still no go. I ran Xautoconfig again and noticed that it made some mention of XF86Config. When I rebooted, I still could not start X so I looked for XF86Config and found it to also be in the X11 directory (or whatever they are called in Linux...). I looked at XF86Config and noticed that it looked very similar to xorg.conf, so I saved a copy of xorg.conf and then saved XF86Config as xorg.conf. I rebooted and everything looks great now, although I am staying away from the display preferences from now on...
    Last edited by haymann; 18th August 2005 at 04:10 AM.

  3. #3
    Join Date
    Aug 2005
    Posts
    3
    I have found the answer to my problem and maybe someone with a little more knowledge can help me out.

    After installing both Yellow Dog Linux 4.0.1 and Ubuntu 5.04, both which had no graphical problem on my machine, I compared the xorg.conf file from /etc/X11 to FC4 PPC. After playing around with some of the Fedora Core 4 PPC xorg.conf file lines, I found the graphics corruption to be due to the line Load "dri". Simply commenting this line out with a # and rebooting fix my issuse with the scrambled display.

    However, after reading, the dri module has to do with opengl and acceleration. Does anyone know if acceleration is still possible on a Radeon 9000 AGP 64MB (stock PowerMac video card there) with this line commented out?

    Thanks

    PuzzledGuy

  4. #4
    Join Date
    Sep 2005
    Posts
    19
    I have nearly the same problem, and opened up a bug on bugzilla site # 152204. https://bugzilla.redhat.com/bugzilla....cgi?id=152204

    However, the quick fix seems to just press Ctrl-Alt-BackSpace.
    Also disabling DRI in xorg.conf could help.

  5. #5
    Join Date
    Sep 2005
    Posts
    19
    The best fix seems to be :

    adding line to /etc/rc.d/rc.local
    /sbin/modprobe radeon

  6. #6
    Join Date
    Mar 2005
    Location
    England
    Posts
    867
    However, after reading, the dri module has to do with opengl and acceleration. Does anyone know if acceleration is still possible on a Radeon 9000 AGP 64MB (stock PowerMac video card there) with this line commented out?
    Yes, if you install their (proprietary) drivers.

  7. #7
    Join Date
    Sep 2005
    Posts
    19
    It seems that I the following patch fixes it:

    https://bugzilla.redhat.com/bugzilla....cgi?id=118943

  8. #8
    Join Date
    Sep 2005
    Posts
    19
    Quote Originally Posted by PuzzledGuy
    I have found the answer to my problem and maybe someone with a little more knowledge can help me out.

    After installing both Yellow Dog Linux 4.0.1 and Ubuntu 5.04, both which had no graphical problem on my machine, I compared the xorg.conf file from /etc/X11 to FC4 PPC. After playing around with some of the Fedora Core 4 PPC xorg.conf file lines, I found the graphics corruption to be due to the line Load "dri". Simply commenting this line out with a # and rebooting fix my issuse with the scrambled display.

    However, after reading, the dri module has to do with opengl and acceleration. Does anyone know if acceleration is still possible on a Radeon 9000 AGP 64MB (stock PowerMac video card there) with this line commented out?

    Thanks

    PuzzledGuy
    On my mac 3D acceleration is working, and the screen is not scrambled after applying the patch

  9. #9
    Join Date
    Apr 2004
    Posts
    29
    I have the exact same problem with the Mac Mini. How do I go about applying this patch? Would doing an update with yum just fix this problem, or do I have to do it manually?

  10. #10
    Join Date
    Sep 2005
    Posts
    19
    Quote Originally Posted by jx3000
    I have the exact same problem with the Mac Mini. How do I go about applying this patch? Would doing an update with yum just fix this problem, or do I have to do it manually?
    you can either recompile xorg-x11 rpms, modifying spec file so it includes the patch, or just change file /usr/X11R6/lib/modules/drivers/radeon_drv.o
    Also, check xorg .conf for section "Device"

    Section "Device"
    Identifier "Videocard0"
    Driver "radeon"
    VendorName "Videocard vendor"
    BoardName "ATI Radeon 9200"
    Option "UseFBDev" "true"
    Option "AGPMode" "4"
    Option "AGPFastWrite" "true"
    Option "RenderAccel" "true"
    EndSection


    I'm attaching version with patch applied
    Attached Files Attached Files

  11. #11
    Join Date
    Apr 2004
    Posts
    29
    thanks savel.

    I know it is offtopic, but I gotta say the PPC version feels faster than x86 version. I mean it feels more responsive.

  12. #12
    Join Date
    Sep 2005
    Posts
    19
    Quote Originally Posted by jx3000
    thanks savel.

    I know it is offtopic, but I gotta say the PPC version feels faster than x86 version. I mean it feels more responsive.
    Well, openoffice seems more responsive on fedora than on macosx. I just upgraded to the last one in updates - openoffice.org-core-2.0.1.1-4.1 - and it is _very_ fast. Probably it just needs much memory - I have 1 gig

  13. #13
    Join Date
    Mar 2006
    Posts
    1

    Mac Mini Color

    Hi,

    I am running fedora core 4 on a mac mini. I originally had the garbled graphics problems.
    I removed the load dri line from xorg.conf and then applied the patch abve and added the lines above to my xorg.conf.

    Accelleration is now working but my colors are all inverted. Any ideas on how I can fix this?

  14. #14
    Join Date
    Sep 2005
    Posts
    19
    Quote Originally Posted by Nimsoft
    Hi,

    I am running fedora core 4 on a mac mini. I originally had the garbled graphics problems.
    I removed the load dri line from xorg.conf and then applied the patch abve and added the lines above to my xorg.conf.

    Accelleration is now working but my colors are all inverted. Any ideas on how I can fix this?
    may be you're runnig fbdev driver instead of ati/radeon

    please send us you /etc/X11/Xorg.conf, it should be something like


    Section "Device"
    Identifier "Videocard0"
    Driver "radeon"
    VendorName "Videocard vendor"
    BoardName "ATI Radeon 9200"
    Option "AGPMode" "2"
    Option "UseFBDev" "true"
    EndSection


    also may be you have a newer mac mini with radeon 9250? may be something has changed there? you can attach the logs from /var/log/X11

Similar Threads

  1. Fried or scrambled?
    By Dan in forum Wibble
    Replies: 30
    Last Post: 21st May 2008, 09:03 AM
  2. scrambled text in X apps
    By leaf in forum Using Fedora
    Replies: 3
    Last Post: 27th November 2007, 08:06 PM
  3. Video Scrambled in all Red Hat Based Distros
    By Starmage187 in forum Hardware & Laptops
    Replies: 7
    Last Post: 15th May 2007, 05:32 PM
  4. Video display scrambled... help!
    By peliroja1313 in forum Hardware & Laptops
    Replies: 2
    Last Post: 7th May 2007, 04:30 AM
  5. Gnucash Texts Scrambled
    By protoflux in forum Fedora Core 5 - Dev
    Replies: 4
    Last Post: 13th March 2006, 03:33 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •