<---- template headericclude ----->
smb error
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 9 of 9
  1. #1
    Join Date
    Jun 2005
    Location
    Wisconsin
    Age
    44
    Posts
    241
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    smb error

    Hello,
    I have just setup a samba share and tried to start the smb service and it fails. If I try to start it from the command line I get this error:

    Starting SMB services: /etc/init.d/functions: line 83: 16565 Aborted $nice $*

    Any ideas?
    Thanks,

    Chris.

  2. #2
    Join Date
    Jun 2005
    Location
    Wisconsin
    Age
    44
    Posts
    241
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hello,
    This was found to be a bug and the work around is to for now uncheck the enforcing checkbox in the selinux gui.
    Thanks,

    Chris.

  3. #3
    scarab02 Guest
    Hello,

    Do you happen to have a link to the bug report??? I am running Fedora as a CLI only... I couldn't find the bug report via bugzilla. I am starting to feel like a hopeless case... Never had a problem with starting Samba before now - jesh.

    thanks,
    chris

  4. #4
    scarab02 Guest
    Found answer on Bugzilla: (https://bugzilla.redhat.com/bugzilla....cgi?id=158802)

    Samba can be started manually using /usr/sbin/smbd -D. I have become to complacent using 'server X stop/start/status'.

    -c.

  5. #5
    nveteran Guest

    Talking strange...

    I solved this problem, but it's strange.

    I did following.

    # cd /etc/init.d/

    # cp smb samba
    # mv smb smb.bak
    # mv samba smb --> just swap

    # diff smb smb.bak --> same

    # service smb restart
    root 5566 1 0 12:58 ? 00:00:00 smbd -D
    root 5567 5566 0 12:58 ? 00:00:00 smbd -D
    root 5569 1 0 12:58 ? 00:00:00 nmbd -D

  6. #6
    hollymcr Guest

    Thumbs up

    Quote Originally Posted by nveteran
    I solved this problem, but it's strange.
    Odd, but it just worked for me too (thanks for posting it, and I'm glad I didn't follow my first instinct to ignore it because it shouldn't have made a difference).

    Only thing I can think of is that the file date will have changed by doing this. If so, "touch smb" should have worked (too late to check now).

  7. #7
    macob Guest
    The "copy then rename" trick is essentially changing the selinux context.
    If you did an 'ls -Z smb' before doing this, you would see that the context was:
    system_u:object_r:initrc_exec_t

    When you copied the smb file, you created a new file which got the default contex of:
    root:object_r:etc_t

    You then renamed the copy back to smb. You could have accomplished the same thing with the command:
    Code:
    chcon root:object_r:etc_t smb
    But, alas, this still didn't solve the problem. Sure I could now start smb manually, but I still get the same "Aborted" error on system startup.

    The solution for me was to indeed turn off selinux enforcement for smb.
    Since I don't have a GUI installed, I used the command line command:
    Code:
    setsebool -P smbd_disable_trans 1
    (I got the command line directions from here )

  8. #8
    seamus Guest
    Thanks to macob for resolving my problem.
    Also nveteran helped me a lot.

  9. #9
    superkun Guest
    Thanks to nveteran for giving a workaround solution.
    Thanks to macob for explaning the real reason hidden behind, or I would be confused for some time.

Similar Threads

  1. Replies: 7
    Last Post: 5th February 2013, 12:00 PM
  2. Replies: 4
    Last Post: 12th April 2009, 02:29 PM
  3. madman error freshrpm error repository error!
    By ilbh in forum Using Fedora
    Replies: 5
    Last Post: 1st June 2006, 10:52 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
[[template footer(Guest)]]