Asus L3800C laptop plus Asus Wl-100g pcmcia wifi working (ndiswrapper with broadcom)
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 2 of 2
  1. #1
    andre@home Guest

    Asus L3800C laptop plus Asus Wl-100g pcmcia wifi working (ndiswrapper with broadcom)

    At first I did bot get it to work on the internet, locally it worked pretty fast with FC3.
    I could ping my whole network but not outside it.
    So there seemed to be some resolving problem but where?

    Down my story. Suggestions on improvement are very welcome !

    My experiences:
    system-config-network as http://www.fedoraforum.org/forum/sho...ht=ndiswrapper
    did not work as only known drivers are in the list, not ndiswrapper. So I could not add a connction with Networktools....

    So Ive done it completely manual: ndiswrapper v1.2
    make distclean
    make
    make install
    ndiswrapper -i bcmwl5.inf
    dmesg ndiswrapper
    ndiswrapper (iw_set_bitrate:480): setting bit rate failed (C00000BB)
    ip_tables: (C) 2000-2002 Netfilter core team
    wlan0: no IPv6 routers present
    ndiswrapper (iw_set_bitrate:480): setting bit rate failed (C00000BB)
    ip_tables: (C) 2000-2002 Netfilter core team
    ip_tables: (C) 2000-2002 Netfilter core team
    wlan0: no IPv6 routers present
    route del -net 192.168.0.1 gw 0.0.0.0 netmask 255.255.255.0
    route add -host 192.168.0.1 netmask 0.0.0.0 gw 192.168.0.1
    route add -host 192.168.0.203 netmask 0.0.0.0 gw 192.168.0.1
    ifdown eth0
    ifup wlan0
    ifconfig
    lo .................
    wlan0 Link encap:Ethernet HWaddr 0p:0d:A7:6D:AE:A2
    inet addr:192.168.0.203 Bcast:192.168.0.255 Mask:255.255.255.0
    inet6 addr: fe80::20e:a6ff:fe9d:aea3/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:7954 errors:0 dropped:0 overruns:0 frame:0
    TX packets:10154 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:1281055 (1.2 MiB) TX bytes:963279 (940.7 KiB)
    Memory:21000000-21001fff
    iwconfig
    wlan0 IEEE 802.11g ESSID:"default" Nickname:"mobail"
    Mode:Managed Frequency:2.412GHz Access Point: 0p:0d:A7:6D:AE:A2
    Bit Rate=2Mb/s Tx-Power:25 dBm
    RTS thr=2347 B Fragment thr=2346 B
    Encryption key:off
    Power Management:off
    Link Quality:99/100 Signal level:-92 dBm Noise level:-256 dBm
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:1258 Invalid misc:4375 Missed beacon:0
    routing table:
    [root@mobail ~]# route
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    192.168.0.0 * 255.255.255.0 U 0 0 0 wlan0
    169.254.0.0 * 255.255.0.0 U 0 0 0 wlan0
    default 192.168.0.1 0.0.0.0 UG 0 0 0 wlan0
    Added the script manually!!!
    file:///etc/sysconfig/network-scripts/ifcfg-wlan0
    PV6INIT=no
    ONBOOT=no
    USERCTL=yes
    PEERDNS=yes
    GATEWAY=192.168.0.1
    TYPE=Wireless
    DEVICE=wlan0
    HWADDR=0a:0e:66:9e:ae:b3
    BOOTPROTO=static
    NETMASK=255.255.255.0
    DHCP_HOSTNAME=
    IPADDR=192.168.0.203
    DOMAIN=
    ESSID=default
    CHANNEL=6
    MODE=
    # RATE=54Mb/s
    RATE=auto
    and testing the connection with my provider
    [root@mobail ~]# ping www.chello.nl
    PING www.chello.nl (213.46.242.72) 56(84) bytes of data.
    64 bytes from www.chello.nl (213.46.242.72): icmp_seq=0 ttl=248 time=11.6 ms
    64 bytes from www.chello.nl (213.46.242.72): icmp_seq=1 ttl=248 time=12.1 ms
    64 bytes from www.chello.nl (213.46.242.72): icmp_seq=2 ttl=248 time=11.7 ms
    64 bytes from www.chello.nl (213.46.242.72): icmp_seq=3 ttl=248 time=11.7 ms
    64 bytes from www.chello.nl (213.46.242.72): icmp_seq=4 ttl=248 time=13.3 ms
    64 bytes from www.chello.nl (213.46.242.72): icmp_seq=5 ttl=248 time=13.3 ms
    PS: well see if I van get it into a script ....
    Now Networktools does see my wlan0.... so the presence of ifcfg-wlan0 seems essential..
    I can mod it now even better.
    If I ran ndiswrapper -m before the systems crashes, thats why I want a post script...
    Lucky me I had an image as it took the whole systems down...
    Security: not installed yet, my access point does not reach far....
    If I added wlan0 in the routing table with eth0 down Ie got a SIOCDELRT error, eth0 up and I could complete the addition.
    So I will have to test whether it is a one time event or it must be put into the script.
    Ive used the dirver/inf form XP (2004 version).
    Last edited by andre@home; 26th June 2005 at 10:18 AM.

  2. #2
    andre@home Guest
    After a restart I only had to give the command:
    modprobe ndiswrapper
    ..... so that will be put in the last startup script from Fedora itself... rc.local (so far I recall)

Similar Threads

  1. Fedora8 loses WiFI and cannot reconnect; asus p5k-e wifi-ap
    By a_simple_system in forum Servers & Networking
    Replies: 1
    Last Post: 10th December 2007, 05:51 PM
  2. Replies: 0
    Last Post: 11th November 2007, 12:34 PM
  3. ASUS WiFi-TV Card not working.. HELP!
    By tfindlay in forum Hardware
    Replies: 4
    Last Post: 14th November 2006, 09:41 PM
  4. ASUS A1 laptop + Fedora 4 = non stop working fan
    By linuxben in forum Hardware
    Replies: 0
    Last Post: 12th August 2005, 12:48 PM
  5. Ndiswrapper - ASUS PCMCIA
    By Sniffer in forum Servers & Networking
    Replies: 2
    Last Post: 9th November 2004, 11:57 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •