VSFTPD using V_users can not log in
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 4 of 4
  1. #1
    knightdog Guest

    VSFTPD using V_users can not log in


    I have gone thru and tried to set up v users. my local users can log in over the network(intranet) but the v users can not log in. here is my vsftpd.conf file:

    # Example config file /etc/vsftpd/vsftpd.conf
    # The default compiled in settings are fairly paranoid. This sample file
    # loosens things up a bit, to make the ftp daemon more usable.
    # Please see vsftpd.conf.5 for all compiled in defaults.
    # READ THIS: This example file is NOT an exhaustive list of vsftpd options.
    # Please read the vsftpd.conf.5 manual page to get a full idea of vsftpd's
    # capabilities.
    # Allow anonymous FTP? (Beware - allowed by default if you comment this out).
    # Uncomment this to allow local users to log in.
    # Uncomment this to enable any form of FTP write command.
    # Default umask for local users is 077. You may wish to change this to 022,
    # if your users expect that (022 is used by most other ftpd's)
    # Uncomment this to allow the anonymous FTP user to upload files. This only
    # has an effect if the above global write enable is activated. Also, you will
    # obviously need to create a directory writable by the FTP user.
    # Uncomment this if you want the anonymous FTP user to be able to create
    # new directories.
    # Activate directory messages - messages given to remote users when they
    # go into a certain directory.
    # Activate logging of uploads/downloads.
    # Make sure PORT transfer connections originate from port 20 (ftp-data).
    # If you want, you can arrange for uploaded anonymous files to be owned by
    # a different user. Note! Using "root" for uploaded files is not
    # recommended!
    # You may override where the log file goes if you like. The default is shown
    # below.
    # If you want, you can have your log file in standard ftpd xferlog format
    # You may change the default value for timing out an idle session.
    # You may change the default value for timing out a data connection.
    # It is recommended that you define on your system a unique user which the
    # ftp server can use as a totally isolated and unprivileged user.
    # Enable this and the server will recognise asynchronous ABOR requests. Not
    # recommended for security (the code is non-trivial). Not enabling it,
    # however, may confuse older FTP clients.
    # By default the server will pretend to allow ASCII mode but in fact ignore
    # the request. Turn on the below options to have the server actually do ASCII
    # mangling on files when in ASCII mode.
    # Beware that turning on ascii_download_enable enables malicious remote parties
    # to consume your I/O resources, by issuing the command "SIZE /big/file" in
    # ASCII mode.
    # These ASCII options are split into upload and download because you may wish
    # to enable ASCII uploads (to prevent uploaded scripts etc. from breaking),
    # without the DoS risk of SIZE and ASCII downloads. ASCII mangling should be
    # on the client anyway..
    # You may fully customise the login banner string:
    #ftpd_banner=Welcome to blah FTP service.
    # You may specify a file of disallowed anonymous e-mail addresses. Apparently
    # useful for combatting certain DoS attacks.
    # (default follows)
    # You may specify an explicit list of local users to chroot() to their home
    # directory. If chroot_local_user is YES, then this list becomes a list of
    # users to NOT chroot().
    # (default follows)
    # You may activate the "-R" option to the builtin ls. This is disabled by
    # default to avoid remote users being able to cause excessive I/O on large
    # sites. However, some broken FTP clients such as "ncftp" and "mirror" assume
    # the presence of the "-R" option, so there is a strong case for enabling it.

    #enable for standalone mode

    i set it up as the example said @:

    Thanks in advance for any suggestions.

  2. #2
    Join Date
    Jan 2005
    Geneve, Switzerland
    0 Post(s)
    0 Thread(s)



  3. #3
    knightdog Guest

    500 OOPS: cannot locate user entry:tom

    Thanks for the help SStone. I made the change and not when i open up a terminal window on the local machine and type
    ftp localhost
    and login with tom and foo i get

    500 OOPS: cannot locate user entry:tom
    Login failed.
    421 Service not available, remote server has closed connection

  4. #4
    knightdog Guest

    Got It!!!

    sstone, thanks for the help. when I did what you suggested i went back to the read me file @


    and it tells you to copy your vsftpd.conf to /etc and i did. but the full install of FC3 puts the vsftpd.conf in /etc/vsftpd so i changed what you said and added the banner to make sure i was working on the correct .conf file and it worked. now to change it again. this server will be a web server so i want vsftpd to work with apache and have it so i can log in to vsftpd and update my web sites.

Similar Threads

  1. vsftpd help
    By jjordan2004 in forum Servers & Networking
    Replies: 8
    Last Post: 31st March 2006, 11:14 PM
  2. VSFTPD and XFS
    By raypitt in forum Using Fedora
    Replies: 1
    Last Post: 23rd March 2006, 05:46 PM
  3. vsftpd help
    By fnord in forum Using Fedora
    Replies: 0
    Last Post: 21st March 2006, 11:22 PM
  4. how to set /etc/vsftpd/vsftpd.conf
    By talkstock888 in forum Servers & Networking
    Replies: 4
    Last Post: 15th March 2005, 11:04 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts