Installing FLTK, missing x11 libraries
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 5 of 5
  1. #1
    sharpstones Guest

    Installing FLTK, missing x11 libraries

    Hello. I am relativily new to linux to please bear with me if this seems obvious.

    I am trying to install the Fast Light Toolkit on my comp. I'm running FC3 and I download the tar and unpacked it and everything. The documentation says to first run the command:

    [root@localhost fltk-1.1.6]# ./configure -enable-shared -enable-gl

    and then run the "make" command. For both commands it goes through and does all the checks for gcc and everything fine. But then it gets to this spot in both commands where I get the error:

    checking for X... no
    configure: error: Configure could not find required X11 libraries
    ./configure: line 8268: exit: aborting.: numeric argument required
    ./configure: line 8268: exit: aborting.: numeric argument required
    make: *** [makeinclude] Error 255

    I guess I am unsure of how to go about solving this. I am not exactly sure what X11 is (i would assume it somehow relates to X-window? ?) If someone could please englighten me as to how to solve this problem it would be greatly appreciated.

  2. #2
    Woad_Warrior Guest
    you're missing the xorg-x11-devel package most likely.
    fltk is available through yum or apt in the dag, dries, and ccrma repositories. (and probably a few others)
    yum install fltk
    or
    apt install fltk
    if you haven't tried either of these package managers yet, there's a number of threads in the forum that can lead you through getting them set up with some of the better repositories available. plus they both will take care of dependencies in almost all cases.
    BTW when building a program from source code, if ./configure returns an error, you'll be unable to run make until you fix whatever caused the error.
    Last edited by Woad_Warrior; 4th March 2005 at 11:42 PM.

  3. #3
    Woad_Warrior Guest
    oh yeah, when installing from rpm, you normally won't need the development packages. those are for when you want to compile source code.

  4. #4
    sharpstones Guest
    Thank you very much, that worked great.

  5. #5
    Woad_Warrior Guest
    no problem. glad to have been of service.

Similar Threads

  1. many missing libraries
    By ACiD GRiM in forum Linux Chat
    Replies: 10
    Last Post: 28th December 2008, 04:46 AM
  2. Why are so many libraries missing?
    By clanker1 in forum Using Fedora
    Replies: 15
    Last Post: 12th February 2006, 06:35 PM
  3. [FC4] missing libraries..but i have them O_o
    By Knudson in forum Using Fedora
    Replies: 2
    Last Post: 19th June 2005, 10:08 PM
  4. libraries missing in C
    By Clunixchit in forum Programming & Packaging
    Replies: 5
    Last Post: 24th April 2005, 03:45 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •