Error building RPM: Installed (but unpackaged) file(s) found
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 6 of 6
  1. #1
    dgurram Guest

    Error building RPM: Installed (but unpackaged) file(s) found

    Hi,

    I have Fedora Core 3 with 2.6.10-1.741_FC3 kernel. My RPM version is 4.3.2. I am trying to install a couple of programs using RPM from the tarball. These programs are:
    * log4cpp - http://log4cpp.sourceforge.net/
    * Xerces C++ - http://xml.apache.org/xerces-c/build-misc.html#RPMLinux

    However, doing rpmbuild -ta <tarball> in both cases results in a Installed (but unpackaged) file(s) found error.

    I have looked at this thread: http://www.fedoraforum.org/forum/showthread.php?t=28691, but what is suggested there does not seem to work (if I have interpreted it correctly). I tried it with the log4cpp since I could locate the spec file for it in the tar ball (whereas for xerces I could not). I am working on the assumption that it is this spec file that RPM uses to build, but please correct me if you think otherwise. The "unpackaged" file that it was complaining about is /usr/share/aclocal/log4cpp.m4.

    Here is an excerpt from the original (i.e unmodified) spec file:

    Code:
    %files
    %defattr(-,root,root,755)
    %attr(755,root,root) %prefix/lib/lib*.so.*
    %doc AUTHORS COPYING INSTALL NEWS README THANKS ChangeLog
    
    %files devel
    %defattr(-,root,root,755)
    %prefix/include/*
    %prefix/man/*
    %attr(755,root,root) %prefix/bin/log4cpp-config
    %attr(755,root,root) %prefix/lib/lib*.so
    %attr(644,root,root) %prefix/lib/*.*a
    
    %files doc
    %doc %prefix/doc/*
    According to the solution suggested in the other thread I referred to above, adding the missing file to the %files section should solve the problem, so I added the following line to both the %files and %files devel sections:
    %attr(644,root,root) %{_datadir}/aclocal/log4cpp.m4
    (Apparently the /usr/share dir maps to the %{_datadir} RPM macro).

    I then repacked the modified spec file into the tar ball and tried rpmbuild -ta again but unfortnately, same error. Can anyone see what I am doing wrong? I am quite a noob so some accompanying explanations with any ideas would be hugely appreciated!

    Thanks,
    dgurram

  2. #2
    Void Main Guest
    Rather than repackaging the tarball just put the original tarball in your redhat/SOURCES directory and put a copy of the spec file in redhat/SPECS. Then in the SPECS dir use "rpmbuild -ba package.spec". You can modify the spec file and rerun the build command without repackaging the original tarball (which really isn't proper rpmbuilding etiquette anyway). When you do get your package to build, your version of the spec file will be included in the *.src.rpm.

    EDIT: I just downloaded and built the log4cpp package by adding:

    Code:
    %attr(644,root,root) %prefix/share/aclocal/log4cpp.m4
    right under:
    Code:
    %attr(755,root,root) %prefix/lib/lib*.so.*
    in the %files section.
    Last edited by Void Main; 30th January 2005 at 05:48 PM.

  3. #3
    Void Main Guest
    Heh heh, just out of curiosity I tried what you tried as well (with the %{_datadir}) and it worked for me. :) I'm not sure what you might have done differently. Here's my spec file:

    http://voidmain.is-a-geek.net/files/specs/log4cpp.spec

  4. #4
    Void Main Guest
    One last note if you didn't already get it. I have specs that should work for you on both packages.

    SPEC for log4cpp-0.3.4b.tar.gz:
    http://voidmain.is-a-geek.net/files/...pp-0.3.4b.spec

    SPEC for icu-3.2.tgz:
    http://voidmain.is-a-geek.net/files/specs/icu-3.2.spec

    Again, put these spec files in the redhat/SPECS dir and the the tgz files I mention go in redhat/SOURCES and then in the SPECS dir do an "rpmbuild -ba specfile" and everything should build under FC3.

    The spec that is included with icu-3.2 as actually icu-3.0 specific (it's common for source distributions to not keep up their spec files). I updated all the version numbers accordingly and added a few new included files.

  5. #5
    dgurram Guest
    Thanks Void Main, you're a champ. It helps a lot to know the right way to do things.

    I copied the tar over to the /usr/src/redhat/SOURCES dir, but I found the log4cpp.spec file in the /usr/src/redhat/SPECS dir already there. And what's more, it was the original spec file, i.e without the "%attr(644,root,root) %{_datadir}/aclocal/log4cpp.m4" line. My suspiscion is that the first time I tried to build off the tarball, it must have copied the spec file from the tarball into the SPECS dir and from then on, it somehow failed to over-write the spec file after mods (although I'm not sure why it would not over-write).

    So anyway, I modified the spec file in the SPECS dir to include the extra line the %files section and it worked like a charm.

    Thanks again. I didn't think anyone would actually download and install those packages just to help me out, so your effort is doubly appeciated.

    Cheers,
    dgurram

  6. #6
    Void Main Guest
    My pleasure.

Similar Threads

  1. Error building nzbget - ctime_r not found
    By dpfletch in forum Using Fedora
    Replies: 2
    Last Post: 6th July 2008, 11:38 AM
  2. Replies: 0
    Last Post: 22nd June 2006, 05:50 PM
  3. FC5: Installed, but File Not Found on boot
    By ChapkoM in forum EOL (End Of Life) Versions
    Replies: 1
    Last Post: 25th March 2006, 06:02 AM
  4. "Installed (but unpackaged) file(s) found" ???
    By Turnip in forum Using Fedora
    Replies: 3
    Last Post: 5th December 2004, 08:32 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •