EXT3 file system disk from other server
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 6 of 6
  1. #1
    jvdbossc Guest

    EXT3 file system disk from other server

    Hello,

    I have a question. For about 2 years I have been running a SOFTWARE MIRROR on a mitel 5 linux distro (based on red hat)

    It lost some files. (contents from directories was not shown OVER NETWORK SMB)

    After a file system check at boot it was marked READ ONLY. Therefore the distro could not boot. (a repair was run 10 x and result was FAILED)

    I hooked it up to my FEDORA CORE 3 desktop, on the second IDE. (instead of cdrom drive)

    It was detected by the BIOS and by WINDOWS XP. (i did not write anything to it with windows xp, also not with disk manager)

    During boot FEDORA CORE 3 did the same thing as the mitel server, just stopping and complain about READ ONLY file system.

    I do not understand why this happens, because the system is running perfectly without the extra disk from the file server and the FEDORA CORE 3 installation is running perfect.

    It looks very frustrating that data can't be copied from another disk and that a distro on a perfect disk does not boot because some EXT3 disk with "damage" is hooked up to it.

    By now I am coping all data from one of the disks using EXT2FS (read only driver) for WINDOWS to another disk. ALL DATA IS THERE!!! (using robocopy for windows because there are some file name probs)

    I would like to know how to get FEDORA CORE 3 booting even if there is some new disk with READ ONLY MARK attached to the computer.

    I know how to mount an extra disk and even managed in the past to format and edit fstab so I had new disk in linux.

    Anybody an explanation for this behaviour? I am a little upset that I need to fall back to another OS just to copy data there is to find

    Thanks,

  2. #2
    Join Date
    Oct 2004
    Posts
    1,227
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    What does your "/etc/fstab" look like?

    I am pretty certain that the problem you are running into is that BOTH the FC3 disk, and the previously "mirrored" disk both have a partition "labeled" as "/" (root).

    That is a problem.

    you can avoid this by either changing the "/etc/fstab" root device to use a physical device instead of the partition label.

    To boot FC3, with two partitions labeled as "/" (root), you have to explicitly tell the grub bootloader which one to use. At the "grub" boot menu, hit the "a" key for "appending" to the kernel boot line. Then add "root=/dev/whateveryourrootpartitionishere" to the end of the kernel parameters line.

    You can will then have to relabel one or the other of the two partitions that are labeled as "/" (root), and update your "/etc/fstab" accordingly.
    Only dead fish go with the flow....

    Hmmm, what did I miss?

  3. #3
    jvdbossc Guest
    Thanks for the respons. I started grub with the A option. Then I changed the line with line with LABEL=/ to root=/dev/hdb1. This is the partition where the root file system should be from fedora.

    It is the second hard disk, with the first partition having the /root label. I will check this evening with the other hard disk disconnected (then it boots) using fdisk, because now I have no result, and it does NOT BOOT just as before, COMPLAINING ABOUT READ ONLY AND MANY CANT TOUCH... but I want to make sure that HDB1 is correct and that I am not messing up numbers (but I don't think so because I always create as many primary partitions as possible, and since there is only the / partition and a swap on the fedora core 3 disk...)

    This is how it is logically:

    IDE:0 PRIMARY 80 GB --- 40 GB NTFS PART 1 (WINDOWS XP HOME)
    --- 40 GB NTFS PART 2 (WINDOWS XP PROFF)
    SLAVE 10 GB ---- / 8 GB EXT3 (WITH THE WORKING FEDORA CORE3!)
    ---- / 2 GB SWAP

    THE DISK THAT DOES PREVENT FEDORA CORE FROM BOOTING:

    IDE:1 PRIMARY 160 GB -- EXT3 DISK FROM OTHER SERVER (with "damage" or read only system)







    Regards,

  4. #4
    Join Date
    Oct 2004
    Posts
    1,227
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Can you post your "/etc/fstab" (from your primary slave "hdb1") FC3 install???

    and also the results of "fdisk -l /dev/hdb", "fdisk -l /dev/hda", and "fdisk -l /dev/hdc" (assuming you can boot with that drive connected)???

    changing the boot line to use a partition instead of a label SHOULD have pointed the bootloader to the right partition for booting. And the boot process SHOULD ignore filesystems that are not in the "/etc/fstab" file.
    Only dead fish go with the flow....

    Hmmm, what did I miss?

  5. #5
    jvdbossc Guest

    This is the FSTAB output

    Hello, thanks for the help,

    I am going to post the fstab output before I try another time with the disk connected.

    (did try, hope I mistiped somehow)

    [root@EARTH ~]# cat /etc/fstab
    # This file is edited by fstab-sync - see 'man fstab-sync' for details
    LABEL=/ / ext3 defaults 1 1
    none /dev/pts devpts gid=5,mode=620 0 0
    none /dev/shm tmpfs defaults 0 0
    none /proc proc defaults 0 0
    none /sys sysfs defaults 0 0
    LABEL=SWAP-hdb2 swap swap defaults 0 0
    /dev/fd0 /media/floppy auto pamconsole,fscontext=system_u:object_r:removable_t ,exec,noauto,managed 0 0
    [root@EARTH ~]#




    [root@EARTH ~]# fdisk -l /dev/hda

    Schijf /dev/hda: 80.0 GB, 80026361856 bytes
    240 koppen, 63 sectoren/spoor, 10337 cylinders
    Eenheden = cylinders van 15120 * 512 = 7741440 bytes

    Apparaat Boot Start End Blocks Id System
    /dev/hda1 * 1 4748 35894848+ 7 HPFS/NTFS
    /dev/hda2 4749 10337 42252840 5 Uitgebreid
    /dev/hda5 4749 10337 42252808+ 7 HPFS/NTFS
    [root@EARTH ~]# fdisk -l /dev/hdb

    Schijf /dev/hdb: 10.2 GB, 10242892800 bytes
    240 koppen, 63 sectoren/spoor, 1323 cylinders
    Eenheden = cylinders van 15120 * 512 = 7741440 bytes

    Apparaat Boot Start End Blocks Id System
    /dev/hdb1 * 1 1151 8701528+ 83 Linux
    /dev/hdb2 1152 1323 1300320 82 Linux wisselgeheugen

    Post further results in a minute (hopefully)

    Regards!

  6. #6
    jvdbossc Guest

    Did not boot...

    I tried with various ways of trying to get grub to boot from the 10gb hard disk

    I am just hoping that i made a syntax mistake, tried so many different ways.

    Could you, just to make sure say wath the line should be changed to?

    this is what grub suggests:

    ro root=LABEL=/ rhgb quit

    i tried:

    ro root=LABEL=/ rhgb quit "root=/dev/hdb1"

    ro root=LABEL=/ rhgb quit root=/dev/hdb1

    ro root=LABEL=/ rhgb quit root=dev/hdb1

    root=/dev/hdb1
    (kernel panic)

    root=dev/hdb1
    (kernel panic)

    I thin I am missing the correct syntax here?

    Grub accepts anything?

    Thanks for your help,

Similar Threads

  1. How to mount ext3 file system in RAM?
    By viklahan in forum Using Fedora
    Replies: 4
    Last Post: 23rd October 2008, 11:57 PM
  2. File system ext3 going down
    By ququ in forum Using Fedora
    Replies: 7
    Last Post: 23rd October 2008, 09:56 PM
  3. ext3 file system on usb disk is corrupted
    By icthy in forum Using Fedora
    Replies: 6
    Last Post: 7th September 2005, 05:18 PM
  4. Problem in ext3 file system
    By brunoadm in forum Using Fedora
    Replies: 0
    Last Post: 10th August 2005, 12:05 AM
  5. ext3 file system
    By ShibbyCoder in forum Using Fedora
    Replies: 6
    Last Post: 17th February 2005, 08:07 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •