Installing Oracle Database 18c
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 1 of 1
  1. #1
    Join Date
    Sep 2019
    Location
    Bandung
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Installing Oracle Database 18c

    Hello so im trying to install oracle database 18c but it keeps giving me errors and i use fedora 30

    i followed many tutorials on the internet but it keeps giving me the same error. the steps i took are:

    installing campat-libcap1 heres the result
    <code>
    dnf install compat-libcap1-1,10-1.x86_64.rpm
    Last metadata expiration check: 0:04:57 ago on Sun 08 Sep 2019 10:06:04 AM WIB.
    Can not load RPM file: compat-libcap1-1,10-1.x86_64.rpm.
    Could not open: compat-libcap1-1,10-1.x86_64.rpm
    [root@localhost Downloads]# dnf install compat-libcap1-1.10-1.x86_64.rpm
    Last metadata expiration check: 0:05:13 ago on Sun 08 Sep 2019 10:06:04 AM WIB.
    Dependencies resolved.
    ================================================== ===========================
    Package Architecture Version Repository Size
    ================================================== ===========================
    Installing:
    compat-libcap1 x86_64 1.10-1 @commandline 17 k

    Transaction Summary
    ================================================== ===========================
    Install 1 Package

    Total size: 17 k
    Installed size: 29 k
    Is this ok [y/N]: y
    Downloading Packages:
    Running transaction check
    Transaction check succeeded.
    Running transaction test
    Transaction test succeeded.
    Running transaction
    Preparing : 1/1
    Installing : compat-libcap1-1.10-1.x86_64 1/1
    Running scriptlet: compat-libcap1-1.10-1.x86_64 1/1
    Verifying : compat-libcap1-1.10-1.x86_64 1/1

    Installed:
    compat-libcap1-1.10-1.x86_64

    Complete!
    </code>


    Installing oracle-database-preinstall heres the result
    <code>
    yum localinstall oracle-database-preinstall-18c-1.0-1.el7.x86_64.rpm
    Last metadata expiration check: 0:05:28 ago on Sun 08 Sep 2019 10:06:04 AM WIB.
    Dependencies resolved.
    ================================================== ===========================
    Package Arch Version Repository Size
    ================================================== ===========================
    Installing:
    oracle-database-preinstall-18c
    x86_64 1.0-1.el7 @commandline 18 k
    Installing dependencies:
    ksh x86_64 1:2020.0.0-0.2.fc30 updates 817 k
    libstdc++-devel x86_64 9.2.1-1.fc30 updates 2.1 M
    compat-libstdc++-33 x86_64 3.2.3-68.16.fc26.1 fedora 190 k
    libaio-devel x86_64 0.3.111-4.fc30 fedora 10 k
    sysstat x86_64 11.7.3-3.fc30 fedora 413 k

    Transaction Summary
    ================================================== ===========================
    Install 6 Packages

    Total size: 3.6 M
    Total download size: 3.5 M
    Installed size: 18 M
    Is this ok [y/N]: y
    Downloading Packages:
    (1/5): compat-libstdc++-33-3.2.3-68.16.fc26. 611 kB/s | 190 kB 00:00
    (2/5): libaio-devel-0.3.111-4.fc30.x86_64.rp 126 kB/s | 10 kB 00:00
    (3/5): sysstat-11.7.3-3.fc30.x86_64.rpm 1.1 MB/s | 413 kB 00:00
    (4/5): ksh-2020.0.0-0.2.fc30.x86_64.rpm 773 kB/s | 817 kB 00:01
    (5/5): libstdc++-devel-9.2.1-1.fc30.x86_64.r 1.2 MB/s | 2.1 MB 00:01
    -----------------------------------------------------------------------------
    Total 627 kB/s | 3.5 MB 00:05
    Running transaction check
    Transaction check succeeded.
    Running transaction test
    Transaction test succeeded.
    Running transaction
    Preparing : 1/1
    Installing : sysstat-11.7.3-3.fc30.x86_64 1/6
    Running scriptlet: sysstat-11.7.3-3.fc30.x86_64 1/6
    Installing : libaio-devel-0.3.111-4.fc30.x86_64 2/6
    Installing : compat-libstdc++-33-3.2.3-68.16.fc26.1.x86_64 3/6
    Running scriptlet: compat-libstdc++-33-3.2.3-68.16.fc26.1.x86_64 3/6
    Installing : libstdc++-devel-9.2.1-1.fc30.x86_64 4/6
    Installing : ksh-1:2020.0.0-0.2.fc30.x86_64 5/6
    Running scriptlet: ksh-1:2020.0.0-0.2.fc30.x86_64 5/6
    Running scriptlet: oracle-database-preinstall-18c-1.0-1.el7.x86_64 6/6
    Installing : oracle-database-preinstall-18c-1.0-1.el7.x86_64 6/6
    Running scriptlet: oracle-database-preinstall-18c-1.0-1.el7.x86_64 6/6
    Verifying : ksh-1:2020.0.0-0.2.fc30.x86_64 1/6
    Verifying : libstdc++-devel-9.2.1-1.fc30.x86_64 2/6
    Verifying : compat-libstdc++-33-3.2.3-68.16.fc26.1.x86_64 3/6
    Verifying : libaio-devel-0.3.111-4.fc30.x86_64 4/6
    Verifying : sysstat-11.7.3-3.fc30.x86_64 5/6
    Verifying : oracle-database-preinstall-18c-1.0-1.el7.x86_64 6/6

    Installed:
    oracle-database-preinstall-18c-1.0-1.el7.x86_64
    ksh-1:2020.0.0-0.2.fc30.x86_64
    libstdc++-devel-9.2.1-1.fc30.x86_64
    compat-libstdc++-33-3.2.3-68.16.fc26.1.x86_64
    libaio-devel-0.3.111-4.fc30.x86_64
    sysstat-11.7.3-3.fc30.x86_64

    Complete!
    </code>

    and here the Database 18c

    Installing with dnf
    <code>
    dnf install oracle-database-xe-18c-1.0-1.x86_64.rpm
    Last metadata expiration check: 0:06:59 ago on Sun 08 Sep 2019 10:06:04 AM WIB.
    Dependencies resolved.
    ================================================== ===========================
    Package Arch Version Repository Size
    ================================================== ===========================
    Installing:
    oracle-database-xe-18c x86_64 1.0-1 @commandline 2.4 G

    Transaction Summary
    ================================================== ===========================
    Install 1 Package

    Total size: 2.4 G
    Installed size: 5.2 G
    Is this ok [y/N]: y
    Downloading Packages:
    Running transaction check
    Transaction check succeeded.
    Running transaction test
    Error: Transaction check error:
    package oracle-database-xe-18c-1.0-1.x86_64 does not verify: no digest

    Error Summary
    -------------
    </code>

    installing with yum localinstall
    <code>
    yum localinstall oracle-database*18c*
    Last metadata expiration check: 0:10:16 ago on Sun 08 Sep 2019 10:06:04 AM WIB.
    Package oracle-database-preinstall-18c-1.0-1.el7.x86_64 is already installed.
    Dependencies resolved.
    ================================================== ===========================
    Package Arch Version Repository Size
    ================================================== ===========================
    Installing:
    oracle-database-xe-18c x86_64 1.0-1 @commandline 2.4 G

    Transaction Summary
    ================================================== ===========================
    Install 1 Package

    Total size: 2.4 G
    Installed size: 5.2 G
    Is this ok [y/N]: y
    Downloading Packages:
    Running transaction check
    Transaction check succeeded.
    Running transaction test
    Error: Transaction check error:
    package oracle-database-xe-18c-1.0-1.x86_64 does not verify: no digest

    Error Summary
    -------------
    </code>

    i dont really know how to fix this cause i cant seem to find the same error after searching through google and im kinda new to fedora transferring from neon.
    im still a student in a university the assignment told me to install this not specificly on linux but i prefer it here so please help

    * EDIT *
    i tried rpm -i --nodigest and heres the result
    <code>
    sudo rpm -i --nodigest oracle-database-xe-18c-1.0-1.x86_64.rpm
    warning: oracle-database-xe-18c-1.0-1.x86_64.rpm: Header V3 RSA/SHA256 Signature, key ID ec551f03: NOKEY
    </code>
    Last edited by husinzz; 8th September 2019 at 09:55 AM.

Similar Threads

  1. Replies: 3
    Last Post: 30th September 2013, 06:55 PM
  2. trouble with Oracle Database ...
    By creeping death in forum Programming & Packaging
    Replies: 2
    Last Post: 17th October 2009, 08:53 PM
  3. php_oci8 with oracle database
    By hal9000a in forum Using Fedora
    Replies: 0
    Last Post: 3rd October 2008, 05:50 PM
  4. Convert oracle database to PostgresSQL on fedora
    By BlackBone in forum Servers & Networking
    Replies: 1
    Last Post: 17th November 2007, 09:19 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •