Okular - always in full screen
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 7 of 7
  1. #1
    Join Date
    Mar 2018
    Location
    Vermont, USA
    Posts
    125
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Okular - always in full screen

    Hello - I have KDE fedora. PDF's open in Okular ... but always in Full Screemn mode...can I change this to a normal screen

    (or maybe a better kDE PDF viewer ? )

    THX,
    ***********************
    * Bill Clark Windham, VT *
    ***********************

  2. #2
    Join Date
    Jun 2004
    Location
    Maryland, US
    Posts
    7,663
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)

    Re: Okular - always in full screen

    press:

    ctrl+shift+F

    When it's back to non-full screen take a look in the "Settings" (Alt+S) menu, you'll see the "Full Screen Mode" in there

  3. #3
    Join Date
    Mar 2018
    Location
    Vermont, USA
    Posts
    125
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Okular - always in full screen

    Thanks, Marko == I did that after opening the pdf, then closed it..opened it again, and it showed the menu. It seems that the program will remember the full screen setting if you close the program (Alt-F4) while in that mode.

    Is there an easy way to force it to always open up with the menu showing (non full-screen mode ? ) I checked settings and didn't see an option for this ...
    ***********************
    * Bill Clark Windham, VT *
    ***********************

  4. #4
    Join Date
    Jun 2007
    Location
    Aubagne France
    Age
    64
    Posts
    668
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Okular - always in full screen

    In okular go to configuration and and look if full screen mode is cheked, and uncheck it.

  5. #5
    Join Date
    Jun 2004
    Location
    Maryland, US
    Posts
    7,663
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)

    Re: Okular - always in full screen

    Quote Originally Posted by chepioq
    In okular go to configuration and and look if full screen mode is cheked, and uncheck it.
    I don't think there is such a setting in "Settings -> Configure Okular...", the only option he would have is "Settings-> Full Screen Mode" (check it off). Apparently it remembers the full screen mode it was on the last time when it's restarted.

    There's no command line option for preventing full screen:

    Code:
    okular --help
    
    Usage: okular [options] urls
    Okular, a universal document viewer
    
    Options:
      -h, --help                 Displays this help.
      -v, --version              Displays version information.
      --author                   Show author information.
      --license                  Show license information.
      --desktopfile <file name>  The base file name of the desktop entry for this
                                 application.
      -p, --page <number>        Page of the document to be shown
      --presentation             Start the document in presentation mode
      --print                    Start with print dialog
      --print-and-exit           Start with print dialog and exit after printing
      --unique                   "Unique instance" control
      --noraise                  Not raise window
    
    Arguments:
      urls                       Documents to open. Specify '-' to read from stdin.

  6. #6
    Join Date
    Feb 2005
    Location
    London, UK
    Posts
    1,109
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)

    Re: Okular - always in full screen

    Okular remembers the previous full screen setting for me, although I'm using Window maker rather than Gnome. However, when I launch it after a previous "not-full-screen" session the window decoration is off the screen which looks a bit like full screen (e.g: the title bar is off the top of the screen) - very odd.

    As a work around you can use a launch script to open okular, wait for it to be running and then remove fullscreen and add maximisation (or however you want it to open). wmctrl *should* work under Wayland, this definitely works under X:

    Code:
    #!/bin/bash
    okular &
    while test -z "$(wmctrl -l |grep Okular)"; do :; done
    wmctrl -R Okular -b remove,fullscreen
    wmctrl -R Okular -b add,maximized_vert,maximized_horz
    p.s: you may have to install wmctrl using dnf.

  7. #7
    Join Date
    Jun 2007
    Location
    Aubagne France
    Age
    64
    Posts
    668
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Okular - always in full screen

    You can also use window 's property:
    right click in the top bar ==> additional actions ==> special application settings ==> and in Size and position you can fix the size for okular

Similar Threads

  1. Replies: 10
    Last Post: 29th February 2016, 04:03 AM
  2. gnome-screen-shot creates only full-screen screenshot from
    By theking2 in forum Hardware & Laptops
    Replies: 1
    Last Post: 26th September 2014, 09:21 PM
  3. Replies: 0
    Last Post: 26th April 2014, 05:49 AM
  4. Geeqie full screen not filling screen anymore
    By JacekZ in forum Using Fedora
    Replies: 0
    Last Post: 16th November 2011, 10:10 PM
  5. Full screen on a single screen of a dual setup
    By daviddoria in forum Using Fedora
    Replies: 0
    Last Post: 22nd June 2010, 03:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •