Dispay issues since kernel 5.2.x with Ryzen 3400G | Fedora 30 - Page 2
FedoraForum.org - Fedora Support Forums and Community
Page 2 of 2 FirstFirst 1 2
Results 16 to 25 of 25
  1. #16
    Join Date
    Jun 2004
    Posts
    106
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Dispay issues since kernel 5.2.x with Ryzen 3400G | Fedora 30

    If fedora 31 comes out with one of the broken kernels(coming soon), I guess we are stuck where we are....

  2. #17
    Join Date
    Mar 2019
    Location
    Netherlands
    Posts
    20
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Dispay issues since kernel 5.2.x with Ryzen 3400G | Fedora 30

    New Kernel 5.2.9 still the same issues. Now I start to get worried that I still get a black screen. Still on 5.1.20.

  3. #18
    Join Date
    Jun 2004
    Posts
    106
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Dispay issues since kernel 5.2.x with Ryzen 3400G | Fedora 30

    Well, if you look at the bug report: https://bugzilla.kernel.org/show_bug.cgi?id=204325
    It shows it it labeled " Importance: P1 blocking"....

    I thought P1 means that they can't release the next version until it is solved....
    But I guess that is not the next version of 5.2.x - But the first 5.3 version(in about a month)????

  4. #19
    Join Date
    Oct 2005
    Location
    Puerto Rico
    Posts
    601
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Dispay issues since kernel 5.2.x with Ryzen 3400G | Fedora 30

    Hi everyone. I was about to post a new thread but think I have this same issue. I upgraded my wife's workstation with a AMD motherboard and a SSD HD. F30 live usb and initial install went OK. After a full update I started getting video distortions. The new video card is a Ryzen 5 2400g. I am attaching screenshots shown the distortions and some additional info.
    Click image for larger version. 

Name:	photo_2019-08-23_11-43-22.jpg 
Views:	7 
Size:	99.7 KB 
ID:	30519Click image for larger version. 

Name:	photo_2019-08-23_11-43-32.jpg 
Views:	5 
Size:	100.9 KB 
ID:	30520Click image for larger version. 

Name:	photo_2019-08-23_11-43-45.jpg 
Views:	4 
Size:	42.2 KB 
ID:	30521
    Can anyone confirm this to be the same issue? Further, there is another thread in this same forum that looks similar:
    HTML Code:
    https://forums.fedoraforum.org/showthread.php?322167-Display-garbled-after-Upgrade-FC28-to-FC29
    Suspecting a kernel problem, I found no way to make the workstation to boot using the original installation kernel in order to wait for a fix, but Plymouth does not allow me to choose the appropriate one. Any advice? Thanks.
    I found out how to boot with the original kernel and the distortions are now gone.
    Last edited by Boricua; 23rd August 2019 at 06:31 PM. Reason: Additional info

  5. #20
    Join Date
    Mar 2019
    Location
    Netherlands
    Posts
    20
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Dispay issues since kernel 5.2.x with Ryzen 3400G | Fedora 30

    I had the same issues after 5.1.20. But latest 2 kernels I only get a black screen after login.

  6. #21
    Join Date
    Jul 2004
    Location
    Wake Forest, NC
    Age
    65
    Posts
    1,468
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Dispay issues since kernel 5.2.x with Ryzen 3400G | Fedora 30

    Are you using nomodeset in your grub.cfg? When I installed F30 on my new HP laptop with Ryzen 3 processor, I had to use the basic graphics to get a screen. After installing though, I was only getting 1024x768 screen resolution. Then I looked at the grub parameters at boot time and noticed that it included nomodeset. I removed that and got a lot better resolution of 1366x68 which looks a whole lot better.

    I was also getting the black screen upon waking up the laptop from suspension. The latest kernel and verifying that the amdgpu kernel module was there seems to have fixed it, bu it is a bit soon to say for sure. I did install xorg-x11-drv-amdgpu-19.0.1-1.fc30.x86_64 which also likely helped.
    StephenH

    "We must understand the reality that just because our culture claims certain things are true it does not mean they are!" --M. Liederbach

    http://pilgrim-wanderings.blogspot.com

  7. #22
    Join Date
    Mar 2019
    Location
    Netherlands
    Posts
    20
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Dispay issues since kernel 5.2.x with Ryzen 3400G | Fedora 30

    At Kernel 5.2.11 still not solved. For the time being I switched from XFCE to Cinnamon desktop.

  8. #23
    Join Date
    Oct 2005
    Location
    Puerto Rico
    Posts
    601
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Dispay issues since kernel 5.2.x with Ryzen 3400G | Fedora 30

    Hmmm... My wife's workstation seems to be doing just find after installing the 5.2.11 kernel. I installed it along with a bunch of updates including video drivers, so not sure if this is a combination of factors.

  9. #24
    Join Date
    Mar 2019
    Location
    Netherlands
    Posts
    20
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Dispay issues since kernel 5.2.x with Ryzen 3400G | Fedora 30

    Quote Originally Posted by Boricua
    Hmmm... My wife's workstation seems to be doing just find after installing the 5.2.11 kernel. I installed it along with a bunch of updates including video drivers, so not sure if this is a combination of factors.
    I have a 3400G - ASRock B450 Pro4 with latest uefi - 2x8Gb Corsair Vengeance LPX CMK16GX4M2B3000C15. Only issues with XFCE. Cinnamon and KDE works well. I don't think I need to install seperate video drivers.

    My main pc with a 2700x, MSI Tomahawk, Radeon RX 580 8gb and G.Skill Ripjaws V F4-3200C14D-16GVK no issues. That works well with XFCE.

  10. #25
    Join Date
    Jun 2004
    Posts
    106
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Dispay issues since kernel 5.2.x with Ryzen 3400G | Fedora 30

    Quote Originally Posted by Boricua
    Hmmm... My wife's workstation seems to be doing just find after installing the 5.2.11 kernel. I installed it along with a bunch of updates including video drivers, so not sure if this is a combination of factors.
    I just tried 5.2.11 with all the updates - and still NO GO....

    5.3.x will be out in a couple of weeks.... If it still isn't fixed I will be Very Disappointed - to say the least....

    as previously stated - the bug is labeled " Importance: P1 blocking", which I believe(correct me if I am wrong) means MUST BE FIXED before releasing next version(5.3.x)....

Page 2 of 2 FirstFirst 1 2

Similar Threads

  1. Fedora 27, AMD Ryzen 2400G, and Gigabyte AB350N issues
    By aleahy in forum Hardware & Laptops
    Replies: 6
    Last Post: 4th March 2018, 11:25 AM
  2. Running Fedora 26 in Ryzen 7 1700
    By pingwu in forum Hardware & Laptops
    Replies: 38
    Last Post: 29th November 2017, 09:04 PM
  3. Install Ryzen 7 1700 with Fedora 26
    By nobody in forum F26 Development Forum
    Replies: 20
    Last Post: 5th June 2017, 05:51 PM
  4. Ryzen first experiences SUSE user has Ryzen
    By lsatenstein in forum Linux Chat
    Replies: 2
    Last Post: 22nd April 2017, 08:50 PM
  5. Install Ryzen 1700 with Fedora 25
    By samphar in forum Installation, Upgrades and Live Media
    Replies: 9
    Last Post: 24th March 2017, 06:18 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •