Fedora Grub not properly detecting other OS's
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 5 of 5
  1. #1
    Join Date
    Aug 2019
    Location
    UK
    Posts
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Fedora Grub not properly detecting other OS's

    I am new to Fedora since starting a new job, I have tried using the mkconfig and grub customizer to no avail (it says it and/or the kernel wasn't loaded properly on customizer). I have Mint and Ubuntu partitioned on a separate hard drive and Windows 10 on an SSD - all coming from the SATA bus. Fedora is installed on a M.2 drive, I'm not sure why it isn't detecting them - I haven't had this issue before on the other distros but do wonder whether it is a bus issue.

  2. #2
    Join Date
    Aug 2007
    Posts
    514
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Fedora Grub not properly detecting other OS's

    The most reliable thing to do is not rely on Fedora's os-prober at all. If you know where your other installations are you can create custom entries for all of them in custom.cfg or 40_custom. You can load the configfile of the other distributions. I have four Linux installations on my SSD and a fifth on another SSD. I have a separate 100MB grub partition that has custom entries for all of them. I don't use os-prober.

    Code:
    menuentry 'Fedora 29 using configfile' {
        insmod part_gpt
        insmod lvm
        insmod ext2
        set root='lvmid/6e7kNf-Qzt9-nFTg-6sxh-zCcj-KYsW-cHnYM2/Psd5iL-AqSi-C3yS-3dUQ-E8QA-cJBM-S634D4'
        search --no-floppy --set=root --label root_fedora29
        configfile /boot/grub2/grub.cfg
    }
    
    menuentry 'Manjaro KDE using configfile' {
        insmod part_gpt
        insmod ext2
        search --no-floppy --set=root --label root_manjaro
        configfile /boot/grub/grub.cfg
    }
    
    menuentry 'Fedora 16 on Other SSD' {
        insmod part_gpt
        set root='(hd1)'
        drivemap -s hd0 hd1
        chainloader (hd1)+1
    }

  3. #3
    Join Date
    Aug 2019
    Location
    UK
    Posts
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Fedora Grub not properly detecting other OS's

    Do I set up Windows as a chainloader? And if so, how do I reorder the list to change it from auto selecting fedora each time?

  4. #4
    Join Date
    Aug 2007
    Posts
    514
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Fedora Grub not properly detecting other OS's

    Do I set up Windows as a chainloader?
    If you are using UEFI you need to use a different type of chainloading. The chainloading example in my post will not work with UEFI as you aren't booting up a drive as you are with legacy BIOS where the MBR has the first stage of the bootloader. With UEFI it is best to search for the Windows EFI System Partition such as follows:

    Code:
    menuentry "Windows 10 UEFI/GPT" {
        insmod part_gpt
        insmod search_fs_uuid
        insmod chain
        search --fs-uuid --no-floppy --set=root UUID_of_Windows_ESP
        chainloader ($root)/EFI/Microsoft/Boot/bootmgfw.efi
    }
    You would need to find the UUID of your Windows ESP with fdisk -l and blkid. The following explains how:

    https://ihaveabackup.net/article/gru...indows-10-uefi

    Where D464-A236 is the UUID of your windows UEFI partiton. You can find this by doing fdisk -l, and looking for a partition called "EFI System", but also make sure you are looking at the correct drive, you might have 2 or more EFI partitions, if you have multiple OSes. You want the one that is on the same device as the "Windows recovery environment". After you have the device, you can query the UUID with blkid, eg. blkid /dev/sda2.

    Leave the chainloader line as it is, grub will evaluate the (${root}) part. If you want to make extra sure, you can mount the aforementioned EFI partition, and verify that the path to bootmgfw.efi is correct. Don't forget to run grub-mkconfig -o /boot/grub.cfg after making the modification.
    And if so, how do I reorder the list to change it from auto selecting fedora each time?
    You only have to set the default entry to the Windows menu entry string. If you use the string then its position in the list does not matter. For example I have

    Code:
    GRUB_DEFAULT="Fedora (4.19.32-1.lts.fc29.x86_64) 29 (Twenty Nine)"
    Last edited by amiga; 7th August 2019 at 06:16 PM. Reason: detail added

  5. #5
    Join Date
    Aug 2019
    Location
    UK
    Posts
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Fedora Grub not properly detecting other OS's

    After a lot of headache, I went back to my Mint install which worked a lot better with grub-customizer to allow me to get access to my other distros, the main issue I was having using a separate grub was that it was actually booting by default into the rescue/live cd portion of the drive each time - causing it to hang as I'd disabled the Nouveau drivers to get my Nvidia GPU working! Since Mint's Grub named all the Fedora options the same I didn't realise until I looked in the code which one was the latest release I had been using. I copied some commands over from the Fedora Grub menu to get it and Ubuntu to stop showing the ugly text on boot up with the 'rhgb quiet' command. I was unable to get Fedora's boot screen logo but I can live with a simple dot animation if it means I don't see the text garbage each time I boot into it.
    With the customizer, I got to reorder the list with Windows on top and deleted unnecessary shortcuts to ancient kernel versions, I wasn't unable to reuse the BIOS option that was given in the Fedora Grub menu but I put a reboot option there instead, so if I do mess up the hotkeys then I don't have to reach over to my PC each time!
    Thanks for the kind support with this distro, this is definitely one of the most friendly Linux forums out there for noobs like me!

Similar Threads

  1. F14 grub not properly installed
    By wavieira in forum Installation, Upgrades and Live Media
    Replies: 1
    Last Post: 30th April 2011, 12:45 AM
  2. Grub Loader is not detecting WinXP
    By Snitz in forum Using Fedora
    Replies: 2
    Last Post: 24th July 2007, 09:25 AM
  3. cannot get grub to work properly
    By nigel_c in forum Installation, Upgrades and Live Media
    Replies: 1
    Last Post: 1st January 2007, 06:28 AM
  4. Fedora 5 not detecting CPU properly
    By pjviitas in forum Using Fedora
    Replies: 2
    Last Post: 17th November 2006, 01:19 AM
  5. GRUB not properly installing on HDA
    By epolson in forum Installation, Upgrades and Live Media
    Replies: 1
    Last Post: 15th September 2005, 03:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •