DNF Update Error/Conflict chromium-libs docker moby-engine chromium cockpit-docker
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 5 of 5
  1. #1
    Join Date
    Jul 2018
    Location
    India
    Posts
    18
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Question DNF Update Error/Conflict chromium-libs docker moby-engine chromium cockpit-docker

    Hello,
    Dnf update on my Fedora 30 system is giving errors with following packages :
    • chromium-libs
    • docker
    • moby-engine
    • chromium
    • cockpit-docker



    The dependency resolving gives following error :

    Problem 1: package chromium-libs-media-freeworld-75.0.3770.100-2.fc30.x86_64 requires chromium-libs(x86-64) = 75.0.3770.100-2.fc30, but none of the providers can be installed
    - cannot install both chromium-libs-75.0.3770.100-3.fc30.x86_64 and chromium-libs-75.0.3770.100-2.fc30.x86_64
    - cannot install the best update candidate for package chromium-libs-media-freeworld-75.0.3770.100-2.fc30.x86_64
    - cannot install the best update candidate for package chromium-libs-75.0.3770.100-2.fc30.x86_64
    Problem 2: package cockpit-docker-199-1.fc30.x86_64 requires (docker or moby-engine), but none of the providers can be installed
    - package docker-ce-3:18.09.8-3.fc28.x86_64 conflicts with docker provided by docker-2:1.13.1-67.git1185cfd.fc30.x86_64
    - package docker-ce-3:18.09.8-3.fc28.x86_64 conflicts with docker-io provided by docker-2:1.13.1-67.git1185cfd.fc30.x86_64
    - package docker-ce-3:18.09.8-3.fc28.x86_64 conflicts with docker provided by docker-2:1.13.1-66.git1185cfd.fc30.x86_64
    - package docker-ce-3:18.09.8-3.fc28.x86_64 conflicts with docker-io provided by docker-2:1.13.1-66.git1185cfd.fc30.x86_64
    - package moby-engine-18.06.3-2.ce.gitd7080c1.fc30.x86_64 conflicts with docker-ce provided by docker-ce-3:18.09.8-3.fc28.x86_64
    - cannot install the best update candidate for package docker-ce-3:18.09.8-3.fc28.x86_64
    - cannot install the best update candidate for package cockpit-docker-198-1.fc30.x86_64
    Problem 3: problem with installed package chromium-libs-media-freeworld-75.0.3770.100-2.fc30.x86_64
    - package chromium-libs-media-freeworld-75.0.3770.100-2.fc30.x86_64 requires chromium-libs(x86-64) = 75.0.3770.100-2.fc30, but none of the providers can be installed
    - cannot install both chromium-libs-75.0.3770.100-3.fc30.x86_64 and chromium-libs-75.0.3770.100-2.fc30.x86_64
    - package chromium-75.0.3770.100-3.fc30.x86_64 requires chromium-libs(x86-64) = 75.0.3770.100-3.fc30, but none of the providers can be installed
    - cannot install the best update candidate for package chromium-75.0.3770.100-2.fc30.x86_64
    Skipping packages with conflicts:
    (add '--best --allowerasing' to command line to force their upgrade):
    chromium-libs x86_64 75.0.3770.100-3.fc30 updates 71 M
    docker x86_64 2:1.13.1-66.git1185cfd.fc30 fedora 26 M
    docker x86_64 2:1.13.1-67.git1185cfd.fc30 updates 26 M
    moby-engine x86_64 18.06.3-2.ce.gitd7080c1.fc30 fedora 54 M
    Skipping packages with broken dependencies:
    chromium x86_64 75.0.3770.100-3.fc30 updates 31 M
    cockpit-docker x86_64 199-1.fc30 updates 363 k


    Could you please suggest what could be the root cause for the conflict. Do I need to refresh the repos ?

    Regards,
    LuckyDudeThakur
    ----------------------------------------------------------------
    https://twitter.com/@LuckyDudeThakur
    https://www.linkedin.com/in/luckydudethakur

  2. #2
    Join Date
    Aug 2019
    Location
    Sydney, Australia
    Posts
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: DNF Update Error/Conflict chromium-libs docker moby-engine chromium cockpit-docke

    I am seeing the same issue, albeit only the docker conflicts (I don't have chromium installed).

    I have docker-ce-3:19.03.1-3.fc30.x86_64 installed which updated recently, however this does not satisfy the requirements for the latest cockpit-docker package.

  3. #3
    Join Date
    Jul 2018
    Location
    India
    Posts
    18
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: DNF Update Error/Conflict chromium-libs docker moby-engine chromium cockpit-docke

    Hello ,
    Posted as a bugzilla request as well:
    https://bugzilla.redhat.com/show_bug.cgi?id=1739369

    Regards,
    LuckyDudeThakur
    ----------------------------------------------------------------
    https://twitter.com/@LuckyDudeThakur
    https://www.linkedin.com/in/luckydudethakur

  4. #4
    Join Date
    Mar 2004
    Location
    In your closet
    Posts
    15,781
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Re: DNF Update Error/Conflict chromium-libs docker moby-engine chromium cockpit-docke

    I wouldn't call it a bug personally. As for docker-ce, you have the Fedora 28 version installed . Remove that and all associated packages before attempting to install the Fedora 30 version. Remove chromium-libs-media-freeworld. That should get you past the chromium error.
    Glenn
    The Bassinator

  5. #5
    Join Date
    Jul 2018
    Location
    India
    Posts
    18
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: DNF Update Error/Conflict chromium-libs docker moby-engine chromium cockpit-docke

    I am not looking for work-around , but trying to find the root cause and solution for this problem . Root cause analysis gives you a better understanding of how that piece of software works.

    Regards,
    LuckyDudeThakur
    ----------------------------------------------------------------
    https://twitter.com/@LuckyDudeThakur
    https://www.linkedin.com/in/luckydudethakur

Similar Threads

  1. chromium update error after upgrading to F27
    By milhan in forum Installation, Upgrades and Live Media
    Replies: 2
    Last Post: 16th November 2017, 11:11 PM
  2. [SOLVED]
    Latest Chromium update removed whole chromium
    By yigit in forum Using Fedora
    Replies: 7
    Last Post: 24th June 2017, 05:47 PM
  3. docker-io/docker-registry
    By stevea in forum Using Fedora
    Replies: 0
    Last Post: 13th May 2014, 08:05 PM
  4. Replies: 7
    Last Post: 6th April 2013, 05:16 AM
  5. Replies: 28
    Last Post: 28th December 2009, 06:58 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •