Stumped: ISO's Burned in UEFI Mode Boot In BIOS Mode
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 7 of 7
  1. #1
    Join Date
    May 2012
    Location
    NC
    Posts
    2,326
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Stumped: ISO's Burned in UEFI Mode Boot In BIOS Mode

    Why are the install images I'm burning to USB on a machine booted in UEFI mode booting in BIOS mode?

    In this case it's a machine running Mint that boots UEFI. Secure boot is OFF. Compatibility mode is ON/UEFI only.

    If I create a new GPT partition on the USB stick, reboot, then burn the install image on it, when I boot off that image a UEFI option is not shown. If I boot off the USB, the USB stick is shown as MBR, not GPT. Anaconda offers no option to create a an EFI (/boot/efi) partition.

    When I reboot back into Mint, the USB stick is shown as MBR.

    Behavior is the same using dd, Fedora Media Writer, and Mint's USB writer. I'm using the current Live Respin images.

    I'm stumped. I've been burning and booting UEFI images for eons and now all of a sudden I can't.

    [MORE: Created new GPT partition on the USB stick, formatted it as Fat32, flagged it BOOT and ESP. burned a Fedora install image to it, immediately checked and the stick is MBR, not GPT. )
    Last edited by joncr; 3rd August 2019 at 03:18 PM.

  2. #2
    Join Date
    Aug 2007
    Posts
    514
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Stumped: ISO's Burned in UEFI Mode Boot In BIOS Mode

    Why are the install images I'm burning to USB on a machine booted in UEFI mode booting in BIOS mode?
    All modern .iso image files are hybrid boot with two bootloaders. They can boot in either UEFI mode or with legacy BIOS. They usually have an /EFI directory with grub-efi for UEFI mode and the isolinux bootloader from the syslinux family for BIOS mode with the first stage in the iso file's first sector. It doesn't matter which mode to which mode a computer is booted (UEFI or BIOS) it is the same .iso image that is written to USB which is hybrid mode and has two bootloaders.

    I don't know why this .iso keeps booting in BIOS mode on a specific machine but it has nothing to do with what software was used to write it to USB or how the computer was booted. It is the same data, the same .iso file that is written to USB each time.

    Behavior is the same using dd, Fedora Media Writer, and Mint's USB writer.
    This is to be expected as it is the same data written to USB each time.

    I'm stumped. I've been burning and booting UEFI images for eons and now all of a sudden I can't.
    Actually you haven't. You have been burning hybrid mode images as all modern .iso files are hybrid mode. Just because these images booted up in UEFI mode before does not mean that the images themselves were not hybrid with two bootloaders.

    [MORE: Created new GPT partition on the USB stick, formatted it as Fat32, flagged it BOOT and ESP. burned a Fedora install image to it, immediately checked and the stick is MBR, not GPT. )
    This makes sense as if you write an install image to a USB by the normal methods such as dd you overwrite the partition table that was there before. Since .iso files have a type of MBR in their first sector they come up as MBR. However UEFI itself has no problems booting from MBR drives as it can still find the /EFI directory where the grub-efi bootloader is stored.

    When I reboot back into Mint, the USB stick is shown as MBR.
    All .iso images written to USB will come up as MBR as they have an MBR-type partition table in their first sector. This is normal. However they still have an /EFI directory with an EFI bootloader so can boot in EFI mode.
    Last edited by amiga; 3rd August 2019 at 04:15 PM.

  3. #3
    Join Date
    May 2012
    Location
    NC
    Posts
    2,326
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Stumped: ISO's Burned in UEFI Mode Boot In BIOS Mode

    I thought a USB stick needs to be GPT, not MBR, to install in UEFI mode? Burning onto a GPT stick converts it to MBR.

    In any case, I've tried multiple images of Fedora and other distributions, burning them the same way I have all along on a machine with no hardware of UEFI config changes, and they all boot in BIOS mode. No UEFI option is listed. When I run the partitioners in their respective installers after booting, there's no option to create an EFI boot partition. (And I don't want to delete the existing EFI partition on the drive because I'd be left with an unbootable machine if the new install fails.)
    Last edited by joncr; 3rd August 2019 at 05:06 PM.

  4. #4
    Join Date
    Aug 2007
    Posts
    514
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Stumped: ISO's Burned in UEFI Mode Boot In BIOS Mode

    I thought a USB stick needs to be GPT, not MBR, to install in UEFI mode? Burning onto a GPT stick converts it to MBR.
    No, this is something you likely just assumed due to MS Windows restrictions. EFI itself has no problems booting from an MBR drive. As I said all modern .iso images are hybrid with two bootloaders, one for each mode. All iso images are MBR as they have an MBR-like first sector. When you write an .iso image to a USB drive using a method such as dd you overwrite the existing partition table so it doesn't matter if the stick was GPT as the PT is overwritten. EFI firmware has no problems booting from MBR as it can find the /EFI partition on an MBR partition table.

    In fact with Linux you can even have a UEFI/MBR system. There is blog post where an Ubuntu user with a standard BIOS/MBR system simply created a FAT ESP on their MBR sda drive and installed grub-efi. They switched their MB over to UEFI mode and their system booted up in UEFI mode. UEFI itself will work with MBR which is why it works with iso images which have a MBR partition table in their first sector.
    Last edited by amiga; 5th August 2019 at 12:43 AM. Reason: wording changed

  5. #5
    Join Date
    May 2012
    Location
    NC
    Posts
    2,326
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Stumped: ISO's Burned in UEFI Mode Boot In BIOS Mode

    Quote Originally Posted by amiga
    No this is something you just made up in your head. You never read up on how things work and so just made up stuff.
    Thanks for the insulting condescension. Much appreciated. Amazing you know me so well.

  6. #6
    Join Date
    Aug 2007
    Posts
    514
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Stumped: ISO's Burned in UEFI Mode Boot In BIOS Mode

    I'm stumped. I've been burning and booting UEFI images for eons and now all of a sudden I can't.
    You never burned a UEFI image. They were all hybrid mode isos that you wrote to USB, which overwrote the partition table. Since the .iso format has an MBR table in the first sector all of these drives were seen as MBR. Since you were succesfully booting UEFI images for 'eons' this means that UEFI previously had no problems booting from MBR formatted drives and found the /EFI partition with grubx64.efi.

    I don't know what your current issue is as I don't have your MB. You will have to play with all of the settings in your firmware. However it never had anything to do with whether a stick was GPT or not. The images you are writing now are the same you were writing before. Your machine is simply interpreting them differently.

    I don't know if you have any other UEFI computers around but you could try some of the isos you wrote on them.
    Last edited by amiga; 5th August 2019 at 12:50 AM.

  7. #7
    Join Date
    Jun 2005
    Location
    Montreal, Que, Canada
    Posts
    6,169
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Re: Stumped: ISO's Burned in UEFI Mode Boot In BIOS Mode

    Quote Originally Posted by amiga
    In all those 'eons' you never read up on what was actually happening and how it was working. So now that things aren't working you are stumped basically since you never understood the basics. You never burned a UEFI image. They were all hybrid mode isos that you 'burned' to USB, which overwrote the partition table. Since the .iso format has an MBR table in the first sector all of these drives were seen as MBR. Since you were booting UEFI images for 'eons' this means that UEFI previously had no problems booting from MBR formatted drives and found the /EFI partition with grubx64.efi.

    I don't know what your current issue is as I don't have your MB. However it never had anything to do with whether a stick was GPT or not.
    Shame on you. You have a criticism of a person, carry it off line. You are letting people know how you are in life.

    I hope the admin wipes out your response andine after you read my post.
    Leslie in Montreal

    Interesting web sites list
    http://forums.fedoraforum.org/showth...40#post1697840

Similar Threads

  1. [SOLVED]
    Will not boot in any way. Recovery mode nor emergency mode works.
    By pimancat3457 in forum Using Fedora
    Replies: 1
    Last Post: 17th April 2019, 08:04 AM
  2. [SOLVED]
    I can't boot Fedora 22 in BIOS mode
    By franciel in forum Installation, Upgrades and Live Media
    Replies: 5
    Last Post: 27th July 2015, 09:32 PM
  3. Install F19 in UEFI mode no F19 options
    By dashesy in forum Installation, Upgrades and Live Media
    Replies: 6
    Last Post: 25th August 2013, 02:36 AM
  4. [SOLVED]
    Graphical Error During install of AMD64 in UEFI mode
    By alphaamanitin in forum Installation, Upgrades and Live Media
    Replies: 1
    Last Post: 9th February 2012, 04:06 AM
  5. Change boot to text mode from graphic mode
    By qhasxeem in forum Installation, Upgrades and Live Media
    Replies: 1
    Last Post: 10th July 2004, 02:33 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •