Upgrade from F29 to F30 fails to boot
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 3 of 3
  1. #1
    Join Date
    Dec 2010
    Posts
    8
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Upgrade from F29 to F30 fails to boot

    I have a machine that I have been upgrading since F25. All of them went smoothly from F25-F29.

    I did the upgrade from F29 to F30 yesterday and it seemed to go OK till the boot after installing everything.

    I guess the naming I am using for my root partition is confusing the upgrade, although it has not changed since all the previous upgrades that worked fine. From the /boot/grub2/grub.cfg the F29 boot options show that my LVM root partition ends with roota:

    linux16 /vmlinuz-5.1.18-200.fc29.x86_64 root=/dev/mapper/fedora-roota ro rd.lvm.lv=fedora/roota rd.lvm.lv=fedora/swap rhgb quiet LANG=en_US.UTF-8

    You will notice the appended "a" in the logical volume name appears in two places. The definition of root and the definition of the logical volume device that root is mounted on.

    This works in F29 and all the previous upgrades have worked fine.

    However, for F30 after the installation when it tries to reboot it complains that it can't find roota so it can't mount root and goes into a very minimal mode. I mounted the /boot partition in this restricted mode to look around.

    The new F30 kernel wants to install a 5.1.19 kernel, but there is no line for that version in grub.cfg, although it shows up as the first option during boot.

    I noticed a file called grubenv that has this line:

    kernelopts=root=/dev/mapper/fedora-roota ro rd.lvm.lv=fedora/root rd.lvm.lv=fedora/swap rhgb quiet

    Notice it has roota for the root variable, but not roota for the rd.lvm.lv value.

    I added an "a" to the rd.lvm.lv value in grubenv and tried a reboot and it rebooted the 5.1.19 kernel just fine and came up as F30.

    I am confused why this upgrade didn't add the "a" to the rd.lvm.lv value but always did in the previous upgrades?

    Also, I am not sure that the upgrade is fully complete as there is still no entry in grub.cfg for the 5.1.19 kernel.

    How do I get the 5.1.19 entry into the grub.cfg file?

    This machine is a test machine for a production machine. It is configured the same way as the production machine. I apply patches on this machine first then the production machine. Likewise for upgrades. I would like to not have to do any hack like this if there is something that can be done that will result in a smooth upgrade on the production machine. This machine is a VM and I took an image of it prior to the upgrade attempt. I have no problem reinstalling the image prior to the upgrade and trying it again if there is a way to get a clean upgrade.

    My overriding concern is that this is something I will continue to run into in future upgrades.

    Thanks
    Chris K

  2. #2
    Join Date
    Apr 2018
    Location
    bash shell
    Posts
    76
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Upgrade from F29 to F30 fails to boot

    It looks like a bug, why not open a bug report?

    https://bugzilla.redhat.com/


    About grub entries, the final grub2.cfg & grub2-efi.cfg configuration files are generated based on the scripts/rules found under /etc/grub.d/ and the kernel entries are automatically added. So maybe the bug is related to changes in those scripts? Just a guess.

    Also, the default grub options are in /etc/default/grub

  3. #3
    Join Date
    Feb 2005
    Location
    London, UK
    Posts
    1,109
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)

    Re: Upgrade from F29 to F30 fails to boot

    There's a known bug with the F30 upgrade, try recreating the grub config by following these steps first: https://fedoraproject.org/wiki/Commo...ter_an_upgrade

Similar Threads

  1. Boot fails at GDM after upgrade from Fedora 27 to 28
    By TheRoark in forum Installation, Upgrades and Live Media
    Replies: 9
    Last Post: 8th June 2018, 09:01 PM
  2. [SOLVED]
    DNF upgrade 24 > 25 fails: can't mount /boot/efi
    By BuckleSwasher in forum Installation, Upgrades and Live Media
    Replies: 4
    Last Post: 9th December 2016, 03:26 AM
  3. FC19 fedup upgrade to FC20 fails (won't boot System Upgrade)
    By wernermaes in forum Installation, Upgrades and Live Media
    Replies: 0
    Last Post: 15th January 2014, 02:21 PM
  4. System upgrade fails to boot
    By kdv666 in forum Installation, Upgrades and Live Media
    Replies: 2
    Last Post: 12th April 2006, 05:53 PM
  5. FC4 upgrade from FC3: boot fails
    By unapproved in forum EOL (End Of Life) Versions
    Replies: 3
    Last Post: 1st September 2005, 03:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •