long boot time due to start job for uuid
FedoraForum.org - Fedora Support Forums and Community
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 23
  1. #1
    Join Date
    Jul 2004
    Location
    Wake Forest, NC
    Age
    65
    Posts
    1,469
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    long boot time due to start job for uuid

    My boot time is being held up for 1-1/2 minutes while the message, "A start job is running for /dev/disk/by-uuid/(UUID string of letters and numbers). The problem is that there is no entry in my fstab or crypttab or that I can spot when looking at the disks with the gdisks utility that corresponds with the UUID specified in the message. After it times out, the boot process finishes and the system is working correctly. I don't see this UUID in the /boot/grub2/grub.cfg

    Edit: I found the command lsblk --fs and the UUID that is hanging is not in the list generated by that command.

    How do I get rid of this UUID so that the boot times don't hang. Is there some place I should be looking that I don't know about?
    StephenH

    "We must understand the reality that just because our culture claims certain things are true it does not mean they are!" --M. Liederbach

    http://pilgrim-wanderings.blogspot.com

  2. #2
    Join Date
    Jun 2005
    Location
    Montreal, Que, Canada
    Posts
    6,226
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Re: long boot time due to start job for uuid

    This is an easy fix when you know the problem. The swap file for suspend/hibernate was reformatted and has a new UUID.

    The way to start is to identify a swap drive and to pick off a UUID= value. The rest is done in terminal mode.

    sudo blkid [enter] | grep swap
    The following is my list from my computer:
    Code:
    /dev/sda2: LABEL="sda2hibernate" UUID="0dad6e79-4575-4d05-9d6f-c25469ed1ac1" TYPE="swap" PARTLABEL="sda2hybernate" PARTUUID="f9f408a7-0a47-47a0-ace0-7a9ba61402dd"
    /dev/sda6: LABEL="sda6swap" UUID="e6bbcf90-d9d8-48b0-a3dc-3e674a59d57d" TYPE="swap" PARTLABEL="F30Swap" PARTUUID="cbb40315-5554-41c5-a350-de5ef4372a55"
    /dev/sdb2: LABEL="sdb2swap" UUID="95f05924-2bdf-43f8-a994-eab9e8e30b96" TYPE="swap" PARTLABEL="SDB2swap" PARTUUID="21f5d906-b8a7-4ed0-b624-09115cdf7b31"
    /dev/sdc8: LABEL="sdc8Swap" UUID="51379b90-bf2a-46d1-87a3-dea7abd1de31" TYPE="swap" PARTLABEL="SDC8swap" PARTUUID="ff4c6634-474a-47d1-bdec-f897d74336bd"
    /dev/sdd4: LABEL="sdd4swap" UUID="9f5d3fb9-07be-4694-9d5c-978620dc4315" TYPE="swap" PARTLABEL="sdd4swap" PARTUUID="5e10cbd6-52b7-44ee-bca3-5eae344017b9"
    /dev/sde7: LABEL="sde7swap" UUID="ffa0517f-e97e-4191-8f14-e5fb082b2c78" TYPE="swap" PARTLABEL="SDE7Swap" PARTUUID="81e692fd-4175-4f3c-b44c-453c93204e39"
    /dev/sdf5: LABEL="sdf5Swap" UUID="7115a980-8d49-4e84-9511-66965be05b26" TYPE="swap" PARTLABEL="sdf5Swap" PARTUUID="9836a2fd-0bc0-4c6b-b16d-dbf9dc32faf5
    I run many different Distributions.
    if you have only one swap file then you can use it but I suggest if you have disk space, to create a second swap file of equal size to the one you have. In my case sda2 above is my swapfile set aside for suspend/hibernate.

    edit the /etc/default/grub file and search for the line containing resume= and replace the resume=UUID=xxxxx
    Here is mine
    GRUB_CMDLINE_LINUX="resume=UUID=0dad6e79-4575-4d05-9d6f-c25469ed1ac1 rhgb quiet"

    Once you save that change, you need to run one command
    sudo grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg

    With the above... problem is solved.
    The second swap file that you set aside for hibernate/suspend should not be within the file /etc/fstab. You rarely need more than one swap file (64gigs ram??) within /etc/fstab.

    If your system is short of diskspace for a second swap, then use the one from the /etc/fstab
    Leslie in Montreal

    Interesting web sites list
    http://forums.fedoraforum.org/showth...40#post1697840

  3. #3
    Join Date
    Jul 2004
    Location
    Wake Forest, NC
    Age
    65
    Posts
    1,469
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: long boot time due to start job for uuid

    Thank you for the reply. My swap file is encrypted so the results of the blkid | grep swap are:
    /dev/mapper/luks-7dcb2ed2-2e0c-491b-bcc6-c01efa9ffa74: UUID="877f6ca7-adbf-4bed-a068-b5cbf1d6a07c" TYPE="swap"

    /etc/default/grub shows this:
    GRUB_CMDLINE_LINUX="resume=/dev/mapper/luks-7dcb2ed2-2e0c-491b-bcc6-c01efa9ffa74 rd.luks.uuid=luks-2429af2a-1ad8-4c66-b5b3-c662d5cbb949 rd.luks.uuid=luks-7dcb2ed2-2e0c-491b-bcc6-c01efa9ffa74 rhgb quiet"

    I don't even see an entry for uuid=66a98c2d-1a89-44a6-aa94-d7200ed07bde, which is what is showing up as the start job that hangs for 1.5 minutes.

    When it does finally boot up, I can open gparted and see the swap partition but it is listed as inactive. The partition is sdb2 and the LUKS uuid and uuid are the same as the results for the blkid command.

    In gparted, I can see that the luks container is open but the swap partition is listed as not active.

    Edit: I see in gparted that there is a menu option for "New UUID." Would I be able to enter the uuid that is hanging in the boot process there? Edit: Ι answered my own question. I will generate a new random uuid, not allow me to enter one.
    Last edited by StephenH; 22nd July 2019 at 06:32 PM.
    StephenH

    "We must understand the reality that just because our culture claims certain things are true it does not mean they are!" --M. Liederbach

    http://pilgrim-wanderings.blogspot.com

  4. #4
    Join Date
    Jun 2005
    Location
    Montreal, Que, Canada
    Posts
    6,226
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Re: long boot time due to start job for uuid

    Run "sudo grub2-mkconfig -o /tmp/grub.cfg" and look for the resume therein. This is what I get from my grub.cfg...
    sudo grep resume /boot/efi/EFI/fedora/grub.cfg

    set default_kernelopts="root=UUID=1a692b22-171f-4d13-811a-0236f058503a ro resume=UUID=0dad6e79-4575-4d05-9d6f-c25469ed1ac1 rhgb quiet "


    What does your say? Can you comment out that line and add one with your
    ...... ro resume=UUID=877f6ca7-adbf-4bed-a068-b5cbf1d6a07c rhgb quiet "
    and then do sudo grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg
    Leslie in Montreal

    Interesting web sites list
    http://forums.fedoraforum.org/showth...40#post1697840

  5. #5
    Join Date
    Jul 2004
    Location
    Wake Forest, NC
    Age
    65
    Posts
    1,469
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: long boot time due to start job for uuid

    If I am not suspending or hibernating this computer, do I need the part for resume in the grub.cfg? This desktop stays on 24/7 and the only time it get shut down or rebooted is for kernel updates or if there is a power outage that is longer than my UPS can support.
    StephenH

    "We must understand the reality that just because our culture claims certain things are true it does not mean they are!" --M. Liederbach

    http://pilgrim-wanderings.blogspot.com

  6. #6
    Join Date
    Jun 2005
    Location
    Montreal, Que, Canada
    Posts
    6,226
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Re: long boot time due to start job for uuid

    Quote Originally Posted by StephenH
    If I am not suspending or hibernating this computer, do I need the part for resume in the grub.cfg? This desktop stays on 24/7 and the only time it get shut down or rebooted is for kernel updates or if there is a power outage that is longer than my UPS can support.
    Answer = NO
    Leslie in Montreal

    Interesting web sites list
    http://forums.fedoraforum.org/showth...40#post1697840

  7. #7
    Join Date
    Jul 2004
    Location
    Wake Forest, NC
    Age
    65
    Posts
    1,469
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: long boot time due to start job for uuid

    Thank you.
    This is the /etc/default/grub file:

    GRUB_TIMEOUT=5
    GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
    GRUB_DEFAULT=saved
    GRUB_DISABLE_SUBMENU=true
    GRUB_TERMINAL_OUTPUT="console"
    GRUB_CMDLINE_LINUX="resume=/dev/mapper/luks-7dcb2ed2-2e0c-491b-bcc6-c01efa9ffa74 rd.luks.uuid=luks-2429af2a-1ad8-4c66-b5b3-c662d5cbb949 rd.luks.uuid=luks-7dcb2ed2-2e0c-491b-bcc6-c01efa9ffa74 rhgb quiet"
    GRUB_DISABLE_RECOVERY="true"
    GRUB_ENABLE_BLSCFG=true

    Do I just substitute rd. for the "'resume=/dev/mapper/' . . . " part of the line or do I just eliminate the 'resume=' part? I don't want to do something that will leave me with an unbootable system.
    StephenH

    "We must understand the reality that just because our culture claims certain things are true it does not mean they are!" --M. Liederbach

    http://pilgrim-wanderings.blogspot.com

  8. #8
    Join Date
    Jun 2005
    Location
    Montreal, Que, Canada
    Posts
    6,226
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Re: long boot time due to start job for uuid

    Jf you comment out the line, the resume=value will continue to be within the /boot/efi/EFI/fedora/grub.cfg.

    I would comment out the line containing the resume value, from within the /etc/default/grub
    Then run sudo grub2-mkconfig .... (as above. to create a new grub.cfg file.
    For Fedora 30, one line in the grub.cfg file can be edited.
    Mine looks like the following:

    set default_kernelopts="root=UUID=7a629c01-6eb2-4241-89f9-d7909097a4bf ro resume=UUID=0dad6e79-4575-4d05-9d6f-c25469ed1ac1 rhgb quiet"

    Duplicate the line, comment out the original and then eliminate the part resume= until rhgb quiet" If that solves your problem, you are home free.
    Leslie in Montreal

    Interesting web sites list
    http://forums.fedoraforum.org/showth...40#post1697840

  9. #9
    Join Date
    Jul 2004
    Location
    Wake Forest, NC
    Age
    65
    Posts
    1,469
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: long boot time due to start job for uuid

    I was concerned that I would end up with an unbootable system. I finally got up the courage to try your suggestion to eliminate the "resume= section. It did not work. I am still getting the same message and the same wait time with the same non-existent uuid. Is there something else I should check?
    StephenH

    "We must understand the reality that just because our culture claims certain things are true it does not mean they are!" --M. Liederbach

    http://pilgrim-wanderings.blogspot.com

  10. #10
    Join Date
    Jul 2004
    Location
    Wake Forest, NC
    Age
    65
    Posts
    1,469
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: long boot time due to start job for uuid

    Still no resolution for this issue. Where are the settings that call for these UUIDs during boot? The ones I see during the long wait do not appear in either my crypttab or fstab. I have tried to regenerate that grub.cfg with no change. I have tried dracut -f, also with no change. Where do I look to find out hat is calling for these non-existing UUIDs?
    StephenH

    "We must understand the reality that just because our culture claims certain things are true it does not mean they are!" --M. Liederbach

    http://pilgrim-wanderings.blogspot.com

  11. #11
    Join Date
    Dec 2015
    Location
    Brazil
    Posts
    29
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: long boot time due to start job for uuid

    Quote Originally Posted by StephenH
    Still no resolution for this issue. Where are the settings that call for these UUIDs during boot? The ones I see during the long wait do not appear in either my crypttab or fstab. I have tried to regenerate that grub.cfg with no change. I have tried dracut -f, also with no change. Where do I look to find out hat is calling for these non-existing UUIDs?
    Check /boot/grub2/grubenv

  12. #12
    Join Date
    Jul 2004
    Location
    Wake Forest, NC
    Age
    65
    Posts
    1,469
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: long boot time due to start job for uuid

    Neither of the two UUIDs that I see in the 90 second wait appear here either.
    StephenH

    "We must understand the reality that just because our culture claims certain things are true it does not mean they are!" --M. Liederbach

    http://pilgrim-wanderings.blogspot.com

  13. #13
    Join Date
    Mar 2006
    Posts
    758
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Re: long boot time due to start job for uuid

    Well the persistence of the this issue is leading me to believe that maybe this stray UUID resides in the MBR. If that is the case then doing a grub-install to your boot device might clear it up. I get these wait jobs usually after large updates and they can occur on shut down as well as startup but they never persist.
    jbkt23
    Thinkpads Depends on era T23 - X2xx
    AMD & Intel Boxes

  14. #14
    Join Date
    Jul 2004
    Location
    Wake Forest, NC
    Age
    65
    Posts
    1,469
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: long boot time due to start job for uuid

    Quote Originally Posted by jbkt23
    Well the persistence of the this issue is leading me to believe that maybe this stray UUID resides in the MBR. If that is the case then doing a grub-install to your boot device might clear it up. I get these wait jobs usually after large updates and they can occur on shut down as well as startup but they never persist.
    Thank you. That might be what is happening since I can't find that UUID anywhere else. How does one go about doing the grub-install? The man page for grub-install has a lot of options and I did not find it very helpful. The last thing I want to do is to break my system trying to fix this issue. Also, the man page seems to be for grub, not grub2 since the description has that the target directory is usually /boot/grub, not /boot/grub2. I realize that the man pages may not be up to date, but want to be sure.
    Last edited by StephenH; 7th September 2019 at 02:47 PM.
    StephenH

    "We must understand the reality that just because our culture claims certain things are true it does not mean they are!" --M. Liederbach

    http://pilgrim-wanderings.blogspot.com

  15. #15
    Join Date
    Mar 2006
    Posts
    758
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Re: long boot time due to start job for uuid

    Reading back through your posts I don't know what rd.luks are. In the bios boot world the command would be:

    grub2-install /dev/sdx

    where sdx represents the boot device (sda, sdb) or disk that is listed in the bios to boot from. This gets more complicated when the system is UEFI based. I'm sure someone has a setup similar to yours and can walk you through the steps in a follow up post here.
    jbkt23
    Thinkpads Depends on era T23 - X2xx
    AMD & Intel Boxes

Page 1 of 2 1 2 LastLast

Similar Threads

  1. dolphin and gwenview take a LONG time to start
    By labatts in forum Using Fedora
    Replies: 5
    Last Post: 3rd June 2014, 04:41 AM
  2. After boot .take long time to start GDM
    By mfaridi in forum Using Fedora
    Replies: 18
    Last Post: 23rd June 2013, 11:30 PM
  3. firefox takes long time to start up
    By nkd in forum Hardware & Laptops
    Replies: 3
    Last Post: 14th March 2008, 07:58 PM
  4. Long XGL Sever start-time with ATI-card
    By vagabund in forum Using Fedora
    Replies: 0
    Last Post: 27th August 2006, 05:51 PM
  5. the start process took a long time
    By yifli in forum Using Fedora
    Replies: 4
    Last Post: 7th May 2006, 03:39 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •