Fedora upgarde GRUB resume option (laptop)
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 8 of 8
  1. #1
    Join Date
    Sep 2013
    Location
    HU
    Posts
    92
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Fedora upgarde GRUB resume option (laptop)

    Hi!
    After Fedora upgrade (kernel update) the system does not update the grub settings with resume option. Why?
    In file "/boot/loader/entries/*.conf" is missing the resume option.
    For example:
    # ----------------------------------------------------------------------------------------------------
    title Fedora (5.0.17-300.fc30.x86_64) 30 (Thirty)
    version 5.0.17-300.fc30.x86_64
    linux /boot/vmlinuz-5.0.17-300.fc30.x86_64 resume=UUID=xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
    initrd /boot/initramfs-5.0.17-300.fc30.x86_64.img
    options $kernelopts
    grub_users $grub_users
    grub_arg --unrestricted
    grub_class kernel
    # ----------------------------------------------------------------------------------------------------
    The option resume is needed for hibernate.

  2. #2
    Join Date
    Dec 2015
    Location
    Brazil
    Posts
    29
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Fedora upgarde GRUB resume option (laptop)

    Maybe you need to set it in the kernelopts.

    As root, run
    Code:
    # grub2-editenv list
    to see which are your current settings.

    Then you can add the 'resume=****' like this
    Code:
    # grub2-editenv set kernelopts="resume=****"
    If you have already other kernelopts parameters (like 'quiet', 'rhgb' etc.), maybe you put all of them in the command above and just add the 'resume=****'.

  3. #3
    Join Date
    Sep 2013
    Location
    HU
    Posts
    92
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Fedora upgarde GRUB resume option (laptop)

    It adds an entry to file "/boot/grub2/grubenv".
    I think I tried it, but no effect.
    It is:
    ...
    kernelopts=root=UUID=714b5931-6379-4a7b-9e47-daf1504372f9 ro vconsole.font=latarcyrheb-sun16 rhgb quiet resume=UUID=bfbbd3b6-0fc2-4dcc-a81d-a28b1be67e5f
    ################################################## ################################################## ###################

  4. #4
    Join Date
    Dec 2015
    Location
    Brazil
    Posts
    29
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Fedora upgarde GRUB resume option (laptop)

    That's right. I think now new kernels will add that to their entries when installed.

    For the already installed kernels, I think the way to add the arguments are described in https://fedoramagazine.org/setting-k...ith-fedora-30/

  5. #5
    Join Date
    Jun 2005
    Location
    Montreal, Que, Canada
    Posts
    6,230
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Re: Fedora upgarde GRUB resume option (laptop)

    What do you have in /etc/default/grub with the line GRUB_CMDLINE_LINUX=

    This is mine.
    GRUB_CMDLINE_LINUX="resume=UUID=0dad6e79-4575-4d05-9d6f-c25469ed1ac1 rhgb quiet"

    The UUID points to a Swap partition. In a multi-disk environment, I have set aside one swapfile of about 4gigs in size (my ram is 16gigs)

    Use "sudo blkid" to list all the partitions on your system and from that list, extract the swapfile's UUID value.
    You can also get the UUID value using gparted or other.
    After you fill in the /etc/default/grub with the correct info, you need to run sudo grub2-mkconfig -o /tmp/grub.cfg

    I then review the /tmp/grub.cfg ( I run 6 distros) and if it has them all listed sudo cp /tmp/grub.cfg to /boot/efi/EFI/fedora
    If you are using other than fedora, locate the current grub.cfg, copy it to grub.bak and use the one you created from /tmp to replace the grub.cfg.

    On reboot, everything should be OK
    Leslie in Montreal

    Interesting web sites list
    http://forums.fedoraforum.org/showth...40#post1697840

  6. #6
    Join Date
    Dec 2015
    Location
    Brazil
    Posts
    29
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Fedora upgarde GRUB resume option (laptop)

    Quote Originally Posted by makgab
    Hi!
    After Fedora upgrade (kernel update) the system does not update the grub settings with resume option. Why?
    In file "/boot/loader/entries/*.conf" is missing the resume option.
    For example:


    The option resume is needed for hibernate.
    Now, reading better your first question, in fact the 'resume' option isn't written to the loader entry because it uses '$kernelopts', which I think means that it reads the 'kernelopts' line in grubenv file.

  7. #7
    Join Date
    Sep 2013
    Location
    HU
    Posts
    92
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Fedora upgarde GRUB resume option (laptop)

    The "option" entry is in the file grubenv. But it has no effect during update.

  8. #8
    Join Date
    Jun 2005
    Location
    Montreal, Que, Canada
    Posts
    6,230
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Re: Fedora upgarde GRUB resume option (laptop)

    With f29 grub, the resume= parameter was copied to every menu line. In more a recent grub version there is a one line entry for the resume statement and it is picked up by Fedora's grub version for each menu entry.
    After correcting the /etc/default/grub run. Grub2-mkconfig.
    Leslie in Montreal

    Interesting web sites list
    http://forums.fedoraforum.org/showth...40#post1697840

Similar Threads

  1. Replies: 2
    Last Post: 26th September 2018, 04:40 PM
  2. Fedora 20 upgarde rsyslog 100% cpu usage
    By makgab in forum Installation, Upgrades and Live Media
    Replies: 5
    Last Post: 19th February 2014, 07:11 PM
  3. [SOLVED]
    tboot Option in Grub in Fedora 19
    By sunveer in forum Using Fedora
    Replies: 3
    Last Post: 11th July 2013, 05:01 AM
  4. [SOLVED]
    WOL g option clearing after resume
    By mineral4x in forum Using Fedora
    Replies: 0
    Last Post: 16th June 2012, 03:42 PM
  5. FC5 Is there a resume option
    By Mesu in forum EOL (End Of Life) Versions
    Replies: 8
    Last Post: 9th May 2006, 10:15 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •