Egyptian Hieroglyph letters don't show up in some applications
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 2 of 2
  1. #1
    Join Date
    May 2011
    Posts
    251
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Egyptian Hieroglyph letters don't show up in some applications

    I installed NewGardiner Egyptian hieroglyphs font (free for non-commercial use) with letters in the unicode block (0x13XXX). I ran fc-cache and even rebooted, and fc-list shows the font in the list.

    The letters show up correctly in Character Map, Libreoffice, firefox, xfce4-terminal, gimp, etc. even without rebooting so I guess the font mapping is working correctly.

    But they show up as square blocks in emacs for X11, and konsole complains of non-printable character when trying to paste a character there, and if I force paste, it shows up as blank square. Emacs run as text mode inside xfce4-terminal shows the letters correctly though. Others i've tried that don't show the letters include VLC, Krusader, and unfortunately LyX (although I can view Cherokee, Osmanya, etc.).

    How do I make emacs for X11 show the font letters correctly?

    I use emacs for taking notes (I couldn't find any decent text editor that can do what org-mode can do) so emacs is a must. I am using Fedora 30. I don't want to use fonts that take up basic Latin unicode block.
    Last edited by osce0; 11th July 2019 at 05:04 AM.

  2. #2
    Join Date
    May 2011
    Posts
    251
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Egyptian Hieroglyph letters don't show up in some applications

    Some more info.

    I was able to set the default font for emacs to NewGardiner Egyptian Hieroglyphs using the menu Options -> Set Default Font, and it does show the letters correctly (in both the font-choosing dialog and in the buffer). Of course this is not what I want, since it forces all other letters to be viewed as blank squares.

    It looks like somehow emacs (and others listed above) don't seem to follow freetype's font mapping for new fonts I've installed.

    BTW, the font was installed in /usr/local/share/fonts and symlinked to /usr/share/fonts, if that makes any difference.

Similar Threads

  1. Replies: 1
    Last Post: 27th September 2015, 09:51 PM
  2. F20 Show Applications is broken on my system
    By lsatenstein in forum Using Fedora
    Replies: 2
    Last Post: 21st December 2013, 05:08 PM
  3. [SOLVED]
    Installed Applications doesn't show up in activity list?
    By krimano in forum Using Fedora
    Replies: 9
    Last Post: 24th August 2013, 08:53 AM
  4. Fedora 16 Fresh Install does not show applications or Places button on Panel
    By snakehorse in forum Installation, Upgrades and Live Media
    Replies: 1
    Last Post: 2nd December 2011, 06:58 AM
  5. bottom panel dont show running applications
    By FireMac in forum Using Fedora
    Replies: 2
    Last Post: 10th July 2006, 09:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •