Err_connection_refused
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 5 of 5
  1. #1
    Join Date
    Jul 2019
    Location
    Santiago
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Err_connection_refused

    Hi y'all

    I am kinda new and have been for a while trying to set up a PC with fedora 29 as server, and have already installed Apache, PHP, Mysql and Samba. My main problem is that while I have all installed when I try to connect from a Windows 10 in a LAN to the server I keep getting "ERR_CONNECTION_REFUSED" so I was hoping someone would be able to enlight me in what I am missing. Maybe I am configuring wrongly my httpd.conf? or the hosts file? Or may be something else? hosts.odthttpd_conf.odt

    Much appreciatted,

    Regards,

  2. #2
    Join Date
    Oct 2010
    Location
    Canberra
    Posts
    3,148
    Mentioned
    1 Post(s)
    Tagged
    1 Thread(s)

    Re: Err_connection_refused

    Connection refused would imply either there is nothing listening on the port (have you started the service) or a firewall is blocking access.

    User error. Please replace user and try again

  3. #3
    Join Date
    Jul 2019
    Location
    Santiago
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Err_connection_refused

    Quote Originally Posted by ocratato
    Connection refused would imply either there is nothing listening on the port (have you started the service) or a firewall is blocking access.
    Hi the services are always on and I do not have any firewall, do i still need to configure something else I am missing?

    Thanks!

  4. #4
    Join Date
    Oct 2010
    Location
    Canberra
    Posts
    3,148
    Mentioned
    1 Post(s)
    Tagged
    1 Thread(s)

    Re: Err_connection_refused

    Perhaps SELinux ?

    Try disabling it for a test:
    sudo setenforce 0

    User error. Please replace user and try again

  5. #5
    Join Date
    Aug 2016
    Location
    spring, tx
    Posts
    93
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Err_connection_refused

    Fedora has a firewall installed by default, so unless you explicitly disabled it or allowed port 80, its going to block traffic. a quick test to help trouble shoot, run the following command:
    Code:
    /usr/bin/python -m SimpleHTTPServer
    This will start an HTTP server listening on port 8000 that requires absolutely no config, so connect to your fedora 29 server in a web browser from your windows 10 machine like so:

    http://your_server_ip_here:8000

    If it does not work you likely have firewalld running (im running selinux and connect via this method just fine, so i dont think selinux is the culprit here)

    to confirm:

    Code:
    systemctl status firewalld
    if its running, GOOD. keep it running, just allow port 80:

    Code:
    sudo firewall-cmd --permanent --add-port=80/tcp
    Code:
    sudo firewall-cmd --reload

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •