No audio via headphone jack - Page 2
FedoraForum.org - Fedora Support Forums and Community
Page 2 of 2 FirstFirst 1 2
Results 16 to 23 of 23
  1. #16
    Join Date
    Jul 2017
    Location
    IL
    Posts
    645
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)

    Re: No audio via headphone jack

    Hope you not trying here to make Ego issue from your end part.
    As one that made few Multimedia System in his life....you are way way wrong.

    So I will say again even about alsa I had to convince you that you need it !!!
    Let's try again.
    Go to dnfdragora ,now that we know you after the server and desktop part.
    first under pulseaudio - leave the just the package of alsa-pulseaudio,
    and remove all the rest aff the packages.

    Under alsa you will find -alsa-jack package and allot more packages+mixer that you need to add.
    That will get the alsa to be the server/Desktop sound server and it will work.


    You will need most of the alsa support to be install ,
    and to allow the jack to communicate with the server/and Desktop.
    Then will see if you will configure right alsa to work = the jack will work.
    FFedora

    fedoraforum.org-Wallpapers
    https://forums.fedoraforum.org/group.php?discussionid=304&do=discuss

  2. #17
    Join Date
    Aug 2019
    Location
    India
    Posts
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: No audio via headphone jack

    Hi GlandularHeadge.

    I too faced the same issue, I am using Fedora30 Gnome desktop in my HP dv6 pavillion.

    I have pulse audio installed. But the problem not solved and as suggested in one of the fedora forum I had tried the below command.
    $> sudo dnf remove alsa-plugins-pulseaudio

    Then I open Pulse Audio and followed the below steps.
    1. Open pulse audio volume control
    2. Goto Configuration tab and under Built-in Audio
    3. Choose profile as "Analog Stereo Output"
    4. Then in output Devices Tab you can see your "Headphones (unplugged)" select the same. Note (if the headphones hot shown in profile then in the same tab below you can see show list box in that select "All Output Devices".

    The above steps fixed my problem. Hope this helps for you as well.

    Thanks and Good Luck !

  3. #18
    Join Date
    Aug 2018
    Location
    NY
    Posts
    21
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: No audio via headphone jack

    Thank you for posting stkrishna but this didn't work sadly I get the same results. Funnily enough removing that package had no effect whatsoever, even though I would think it should affect something. I do use Fedora KDE though so maybe I need to remove something different?

  4. #19
    Join Date
    Aug 2018
    Location
    NY
    Posts
    21
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: No audio via headphone jack

    Quote Originally Posted by GlandularHeadge
    Fedora 30 KDE
    Dell Inspiron 1500 laptop.
    It is at the top.

  5. #20
    Join Date
    May 2005
    Posts
    66
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: No audio via headphone jack

    Quote Originally Posted by GlandularHeadge
    I'm not getting any audio from the headphone jack. I get audio as expected from my laptop speakers and bluetooth headphones but not via the headphone jack, using either my bt headphone adapter or just a regular run of the mill in-ear headphone. I don't use the headphone jack regularly but I didn't get any audio from it when I tried to use it on F29. Before upgrading, I tried the F30 live CD and I did get audio through the headphone jack but I'm not getting any after upgrading to F30 so I'm thinking that I messed up a setting and now can't remember which. Interestingly, I get the same issue using a brand new user session with no settings changed. When I am using the headphones and go to settings>multimedia I can see that the "headphones" are selected as audio output but I don't get anything from it regardless. Anyone has a clue what could be the issue?

    Fedora 30 KDE
    Dell Inspiron 1500 laptop.
    This may seem a stupid question, but sometimes the headphone and microphone jacks sit side by side, and many are not well labeled.
    Are you by any chance hooked to the mic input instead?
    Having done the very same thing myself.
    If not, you've got a good puzzle there.
    You can't fix something till you break it.
    (It's a hobby, but I like it)

  6. #21
    Join Date
    Jun 2005
    Location
    Montreal, Que, Canada
    Posts
    6,226
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Re: No audio via headphone jack

    You may also want to try with amixer application.

    I had that problem and the following script solved it.

    Code:
    #!/bin/bash
    if [ $# -ne 0 ]; then
       if [ $1 -gt 0 ]; then
       sleep $1
       fi
    fi
    mkdir /tmp/lock -p
    chmod 1777 /tmp/lock
    iam=$(whoami)
    if [[ "x${iam}" = x ]];
    then
      echo "what"
      out=/tmp/lock/amixer_unknown_today.txt
    else
      out=/tmp/lock/amixer_${iam}_today.txt
    fi
    rm -f $out >/dev/null 2>&1
    touch $out
    chown $iam:$iam $out
    chmod 1777 $out
    echo "$0 $(date)" >>${out}
    AMIXER=$(which amixer)
    ${AMIXER} -c0 set Headphone unmute 100% >>${out} 2>&1
    ${AMIXER} -c1 set Headphone unmute 100% >>${out} 2>&1
    The amixer -c1 ... lines may help to resolve your problem.
    Leslie in Montreal

    Interesting web sites list
    http://forums.fedoraforum.org/showth...40#post1697840

  7. #22
    Join Date
    Aug 2018
    Location
    NY
    Posts
    21
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: No audio via headphone jack

    Quote Originally Posted by DaleDonofrio
    This may seem a stupid question, but sometimes the headphone and microphone jacks sit side by side, and many are not well labeled.
    Are you by any chance hooked to the mic input instead?
    Having done the very same thing myself.
    If not, you've got a good puzzle there.
    You can't fix something till you break it.
    (It's a hobby, but I like it)
    Thank you for posting DaleDonofrio. My laptop model doesn't have a separate mic input jack, maybe that's the problem? The driver doesn't know how to treat it?

    Quote Originally Posted by lsatenstein
    You may also want to try with amixer application.

    I had that problem and the following script solved it.

    Code:
    #!/bin/bash
    if [ $# -ne 0 ]; then
       if [ $1 -gt 0 ]; then
       sleep $1
       fi
    fi
    mkdir /tmp/lock -p
    chmod 1777 /tmp/lock
    iam=$(whoami)
    if [[ "x${iam}" = x ]];
    then
      echo "what"
      out=/tmp/lock/amixer_unknown_today.txt
    else
      out=/tmp/lock/amixer_${iam}_today.txt
    fi
    rm -f $out >/dev/null 2>&1
    touch $out
    chown $iam:$iam $out
    chmod 1777 $out
    echo "$0 $(date)" >>${out}
    AMIXER=$(which amixer)
    ${AMIXER} -c0 set Headphone unmute 100% >>${out} 2>&1
    ${AMIXER} -c1 set Headphone unmute 100% >>${out} 2>&1
    The amixer -c1 ... lines may help to resolve your problem.
    I will try it and let you know. Thanks. UPDATE: nope. Didn't work. I think I've fiddled with the amixer console before posting here in order to try and solve this with no luck

  8. #23
    Join Date
    Aug 2018
    Location
    NY
    Posts
    21
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: No audio via headphone jack

    I found something interesting. If I right click on the volume icon, click "Configure audio volume" -> Audio volume -> advanced tab and change profile to "digital stereo (hdmi) ..." and take the headphone jack out and insert it again I get audio. However, if I take it out and insert it once more I don't get audio and I have to perform the same operation again to get audio :/

Page 2 of 2 FirstFirst 1 2

Similar Threads

  1. problem with headphone jack
    By shahrokhshahi in forum Hardware & Laptops
    Replies: 9
    Last Post: 24th September 2016, 01:35 PM
  2. dual headphone/mic jack works only as headphone jack
    By yummmm in forum Hardware & Laptops
    Replies: 0
    Last Post: 13th December 2015, 08:13 PM
  3. 3.9.x Kernel Audio - Headphone Jack Stops Working
    By dbt816 in forum Hardware & Laptops
    Replies: 0
    Last Post: 27th May 2013, 02:34 PM
  4. audio problem - headphone jack
    By rodent octoham in forum Hardware & Laptops
    Replies: 0
    Last Post: 16th September 2011, 10:45 PM
  5. Headphone jack turned off???
    By chiefreborn in forum Hardware & Laptops
    Replies: 2
    Last Post: 15th June 2005, 12:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •