No audio via headphone jack
FedoraForum.org - Fedora Support Forums and Community
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 23
  1. #1
    Join Date
    Aug 2018
    Location
    NY
    Posts
    21
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    No audio via headphone jack

    I'm not getting any audio from the headphone jack. I get audio as expected from my laptop speakers and bluetooth headphones but not via the headphone jack, using either my bt headphone adapter or just a regular run of the mill in-ear headphone. I don't use the headphone jack regularly but I didn't get any audio from it when I tried to use it on F29. Before upgrading, I tried the F30 live CD and I did get audio through the headphone jack but I'm not getting any after upgrading to F30 so I'm thinking that I messed up a setting and now can't remember which. Interestingly, I get the same issue using a brand new user session with no settings changed. When I am using the headphones and go to settings>multimedia I can see that the "headphones" are selected as audio output but I don't get anything from it regardless. Anyone has a clue what could be the issue?

    Fedora 30 KDE
    Dell Inspiron 1500 laptop.

  2. #2
    Join Date
    Jul 2017
    Location
    IL
    Posts
    645
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)

    Re: No audio via headphone jack

    Hello GlandularHeadge.

    1 - have you Enable on your Repositories the vendor+test Update?

    2 - run the command to cover the vendors it can be firmware issue,just Apply with (Y) to the key+repos.

    Code:
    sudo dnf install \*-firmware
    After you done with that process,check and see of you have changes.
    If not,check if all your codecs install on the system.
    FFedora

    fedoraforum.org-Wallpapers
    https://forums.fedoraforum.org/group.php?discussionid=304&do=discuss

  3. #3
    Join Date
    Aug 2018
    Location
    NY
    Posts
    21
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: No audio via headphone jack

    Quote Originally Posted by FFedora
    Hello GlandularHeadge.

    1 - have you Enable on your Repositories the vendor+test Update?
    I don't think so. How can I check this/enable it?

    Quote Originally Posted by FFedora
    2 - run the command to cover the vendors it can be firmware issue,just Apply with (Y) to the key+repos.

    Code:
    sudo dnf install \*-firmware
    After you done with that process,check and see of you have changes.
    If not,check if all your codecs install on the system.
    If you don't mind me asking, doesn't that install a bunch of fw not related to my system? Wouldn't that potentially cause compatibility problems?

  4. #4
    Join Date
    Jul 2017
    Location
    IL
    Posts
    645
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)

    Re: No audio via headphone jack

    Hello GlandularHeadge.

    I don't think so. How can I check this/enable it?
    If you will not Enable it how you will get Update?Update Testing from the vendor?


    If you don't mind me asking, doesn't that install a bunch of fw not related to my system? Wouldn't that potentially cause compatibility problems?
    First of all,it can install just firmware to what you have on your Motherboard.
    And just from the vendor that make the chip so...
    it will not install firmware of vendor that you do not have there.
    and all the firmware that your Motherboard has nothing to do with,
    will not get Any Update.

    After you install them,reboot your machine.
    when you will be back in to your Desktop open terminal and check for Update.

    One thing I have for you from the last few min on that issue to know.
    I have made test to the new package of PulseAudio- pavucontrol.
    And all work just fine with audio/video.
    so that can be issue that you have with Alsa sound server.
    And with the Pulseaudio sound server you can solve that issue.
    Last edited by FFedora; 29th May 2019 at 05:40 PM.
    FFedora

    fedoraforum.org-Wallpapers
    https://forums.fedoraforum.org/group.php?discussionid=304&do=discuss

  5. #5
    Join Date
    Aug 2018
    Location
    NY
    Posts
    21
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: No audio via headphone jack

    Good to know. I forgot to add in my last comment, I already have a bunch of machine specific fw installed.

    Code:
    Package atmel-firmware-1.3-20.fc30.noarch is already installed.
    Package crystalhd-firmware-3.10.0-21.fc30.noarch is already installed.
    Package ipw2100-firmware-1.3-24.fc30.noarch is already installed.
    Package ipw2200-firmware-3.1-17.fc30.noarch is already installed.
    Package iwl100-firmware-39.31.5.1-96.fc30.noarch is already installed.
    Package iwl1000-firmware-1:39.31.5.1-96.fc30.noarch is already installed.
    Package iwl105-firmware-18.168.6.1-96.fc30.noarch is already installed.
    Package iwl135-firmware-18.168.6.1-96.fc30.noarch is already installed.
    Package iwl2000-firmware-18.168.6.1-96.fc30.noarch is already installed.
    Package iwl2030-firmware-18.168.6.1-96.fc30.noarch is already installed.
    Package iwl3160-firmware-1:25.30.13.0-96.fc30.noarch is already installed.
    Package iwl3945-firmware-15.32.2.9-96.fc30.noarch is already installed.
    Package iwl4965-firmware-228.61.2.24-96.fc30.noarch is already installed.
    Package iwl5000-firmware-8.83.5.1_1-96.fc30.noarch is already installed.
    Package iwl5150-firmware-8.24.2.2-96.fc30.noarch is already installed.
    Package iwl6000-firmware-9.221.4.1-96.fc30.noarch is already installed.
    Package iwl6000g2a-firmware-18.168.6.1-96.fc30.noarch is already installed.
    Package iwl6000g2b-firmware-18.168.6.1-96.fc30.noarch is already installed.
    Package iwl6050-firmware-41.28.5.1-96.fc30.noarch is already installed.
    Package iwl7260-firmware-1:25.30.13.0-96.fc30.noarch is already installed.
    Package libertas-usb8388-firmware-2:20190514-96.fc30.noarch is already installed.
    Package linux-firmware-20190514-96.fc30.noarch is already installed.
    Package zd1211-firmware-1.5-4.fc30.noarch is already installed.

    The following is what the command is going to install:

    Code:
    Installing:
     libertas-sd8686-firmware       noarch 20190514-96.fc30           updates            93 k
     libertas-sd8787-firmware       noarch 20190514-96.fc30           updates           311 k
     libertas-usb8388-olpc-firmware noarch 20190514-96.fc30           updates            92 k
     liquidio-firmware              noarch 20190514-96.fc30           updates            16 M
     lulzbot-marlin-firmware        noarch 1:1.1.9.34-5.fc30          updates           2.6 M
     netronome-firmware             noarch 20190514-96.fc30           updates           4.5 M
     alsa-firmware                  noarch 1.0.29-8.fc30              fedora            3.2 M
     alsa-tools-firmware            x86_64 1.1.7-3.fc30               fedora             33 k
     bfa-firmware                   noarch 3.2.21.1-11.fc30           fedora            1.0 M
     iscan-firmware                 noarch 20130319-8.fc30            fedora            205 k
     ivtv-firmware                  noarch 2:20080701-36.fc30         fedora            100 k
     midisport-firmware             noarch 1.2-22.fc30                fedora             26 k
     uhd-firmware                   noarch 3.12.0.0-4.fc30            fedora             89 M
     r5u87x-firmware                x86_64 0.2.0-12.a9b2171d762b.fc30 rpmfusion-nonfree  99 k
    I may try installing all that stuff later but I think my chipset is already covered by what I have installed already.

  6. #6
    Join Date
    Jul 2017
    Location
    IL
    Posts
    645
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)

    Re: No audio via headphone jack

    good luck to you.

    From what I see you have Intel Motherboard right?
    if so,you can see that you have missing alsa-firmware +alsa-tools-firmware.
    Just to point you for the system needs.
    But I'm sure you know what you want.
    FFedora

    fedoraforum.org-Wallpapers
    https://forums.fedoraforum.org/group.php?discussionid=304&do=discuss

  7. #7
    Join Date
    Aug 2018
    Location
    NY
    Posts
    21
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: No audio via headphone jack

    Quote Originally Posted by FFedora
    if so,you can see that you have missing alsa-firmware +alsa-tools-firmware.
    Installed those and restarted. Issue was still there. Then installed all the other \*-firmware packages and restarted. The issue is still here

    If I try to play a song I can hear that the headphones are about to start producing sound, as if alsa makes an attempt at starting the device but the actual sound never comes out of the headphones

  8. #8
    Join Date
    Jul 2017
    Location
    IL
    Posts
    645
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)

    Re: No audio via headphone jack

    Thank you for the info.

    the next step will be to install pavucontrol +QT packages.
    And After that Open terminal and call for Update.
    If you work with software center,then reload the software center - you will have update.
    After the pavucontrol will be install,configure the pulseaudio-pavucontrol just After reboot.
    FFedora

    fedoraforum.org-Wallpapers
    https://forums.fedoraforum.org/group.php?discussionid=304&do=discuss

  9. #9
    Join Date
    Aug 2018
    Location
    NY
    Posts
    21
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: No audio via headphone jack

    I already have pavucontrol installed from several releases ago, what's next?

  10. #10
    Join Date
    Jul 2017
    Location
    IL
    Posts
    645
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)

    Re: No audio via headphone jack

    Do you have pulseaudio-jack install?
    FFedora

    fedoraforum.org-Wallpapers
    https://forums.fedoraforum.org/group.php?discussionid=304&do=discuss

  11. #11
    Join Date
    Aug 2018
    Location
    NY
    Posts
    21
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: No audio via headphone jack

    Quote Originally Posted by FFedora
    Do you have pulseaudio-jack install?
    Apparently not and it's not on the repos.

  12. #12
    Join Date
    Jul 2017
    Location
    IL
    Posts
    645
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)

    Re: No audio via headphone jack

    First here is the Guide for jack:

    https://fedoraproject.org/wiki/JACK_...Connection_Kit

    search under pulseaudio.
    the package name is -
    pulseaudio-module-jack
    FFedora

    fedoraforum.org-Wallpapers
    https://forums.fedoraforum.org/group.php?discussionid=304&do=discuss

  13. #13
    Join Date
    Aug 2018
    Location
    NY
    Posts
    21
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: No audio via headphone jack

    Quote Originally Posted by FFedora
    First here is the Guide for jack:

    https://fedoraproject.org/wiki/JACK_...Connection_Kit

    search under pulseaudio.
    the package name is -
    Seems like it's going to require me to disable pulseaudio altogether, not exactly solving my issue (and maybe even creating its own set of issues. Once I have that installed, what is it supposed to accomplish?

  14. #14
    Join Date
    Jul 2017
    Location
    IL
    Posts
    645
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)

    Re: No audio via headphone jack

    Few things here for you as my Answer.

    1 - you did not mention that all the process is about server and not configure it to work on Desktop.
    That is all the work around not working for you,
    As on server allot of things work deference then Desktop.

    2 - Allot of parts of you tcp dump show that process file because of your own security meters,
    that will not allow the sound server to allow process to be accomplish.

    3 - if you look into the Answer from my end part I made test here that ended great - But not about server!

    4 - and yes about server I will not use pulseaudio,I will use alsa for security meters.

    5 - But even that your part of alsa is not full with all the needed packages to be install in the first place.

    community can help community when they have in the first place all the info that they need to have
    in Advance !! not just by the way when things going west.
    but...ti get help you need to let the supporter know and to have the knowledge in Advance about
    your Desktop/server and so on and what you need to have done,not just to share that info when things fails.
    as I'm the last person on hearth that want User to fail with fixings issues!!!
    Good luck.
    FFedora

    fedoraforum.org-Wallpapers
    https://forums.fedoraforum.org/group.php?discussionid=304&do=discuss

  15. #15
    Join Date
    Aug 2018
    Location
    NY
    Posts
    21
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: No audio via headphone jack

    I can not make sense of what you are saying but it's clear that you have no clue about what to do here. Thanks for trying.

Page 1 of 2 1 2 LastLast

Similar Threads

  1. problem with headphone jack
    By shahrokhshahi in forum Hardware & Laptops
    Replies: 9
    Last Post: 24th September 2016, 01:35 PM
  2. dual headphone/mic jack works only as headphone jack
    By yummmm in forum Hardware & Laptops
    Replies: 0
    Last Post: 13th December 2015, 08:13 PM
  3. 3.9.x Kernel Audio - Headphone Jack Stops Working
    By dbt816 in forum Hardware & Laptops
    Replies: 0
    Last Post: 27th May 2013, 02:34 PM
  4. audio problem - headphone jack
    By rodent octoham in forum Hardware & Laptops
    Replies: 0
    Last Post: 16th September 2011, 10:45 PM
  5. Headphone jack turned off???
    By chiefreborn in forum Hardware & Laptops
    Replies: 2
    Last Post: 15th June 2005, 12:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •