Fedora 29-30 upgrade - no second screen at boot each time - Page 2
FedoraForum.org - Fedora Support Forums and Community
Page 2 of 2 FirstFirst 1 2
Results 16 to 27 of 27
  1. #16
    Join Date
    Jun 2004
    Location
    Maryland, US
    Posts
    7,589
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)

    Re: Fedora 29-30 upgrade - no second screen at boot each time

    Quote Originally Posted by FFedora
    Hello johnsd.

    here is one more thinking from my end part.
    let's try to use lightDM and not GDM.
    so run those 2 commands as ROOT,then when you done reboot the system.

    Code:
    systemctl disable gdm
    Code:
    systemctl enable lightdm
    and please post back.
    or to save time:

    systemctl --now disable gdm
    systemctl --now enable lightdm

    there's probably no need to reboot if you disable and stop plus enable and start the lightdm (which is what the --now flag does)

  2. #17
    Join Date
    Jul 2017
    Location
    IL
    Posts
    645
    Mentioned
    12 Post(s)
    Tagged
    0 Thread(s)

    Re: Fedora 29-30 upgrade - no second screen at boot each time

    Hi marko.

    well not so sure about reboot,
    as you know that the log in screen change as well.
    Log out and in that will do I think.
    FFedora

    fedoraforum.org-Wallpapers
    https://forums.fedoraforum.org/group.php?discussionid=304&do=discuss

  3. #18
    Join Date
    Feb 2005
    Location
    London, UK
    Posts
    1,014
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)

    Re: Fedora 29-30 upgrade - no second screen at boot each time

    Quote Originally Posted by marko
    there's probably no need to reboot if you disable and stop plus enable and start the lightdm (which is what the --now flag does)
    Correct, no need to reboot (this isn't windows!). From what I remember from the last time I did this, it logs you out of your current session and returns you to the new *dm login screen immediately though so make sure any work is saved beforehand.

  4. #19
    Join Date
    Jun 2018
    Location
    Timaru, NZ
    Posts
    27
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Fedora 29-30 upgrade - no second screen at boot each time

    Quote Originally Posted by FFedora
    Hello johnsd.

    here is one more thinking from my end part.
    let's try to use lightDM and not GDM.
    so run those 2 commands as ROOT,then when you done reboot the system.

    Code:
    systemctl disable gdm
    Code:
    systemctl enable lightdm
    and please post back.
    OK - so here is why I really hate playing with things like this. Lightdm was not installed so I installed it and activated it. After a reboot the login screen appeared on the correct display but the login manager will not accept my password. It cycles then re-presents the login screen. It is the correct password since it sort of accepts it and if I put in a wrong one it says.

    So went looking for the append in GRUB at boot time to put "single" - a for append does not exist in Fedora 30 but there is a rescue option but that does not boot. I really do not feel like reinstalling from scratch and am wishing I left it alone!!
    JOhn

  5. #20
    Join Date
    Jun 2018
    Location
    Timaru, NZ
    Posts
    27
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Fedora 29-30 upgrade - no second screen at boot each time

    ... appended "single" to the end of the kernal line and am back to where is was before (phew!!). Still with the hidden login screen so may have to stay like this. It is a bit odd that a different login manager will not accept my password!!
    John

  6. #21
    Join Date
    Jul 2017
    Location
    IL
    Posts
    645
    Mentioned
    12 Post(s)
    Tagged
    0 Thread(s)

    Re: Fedora 29-30 upgrade - no second screen at boot each time

    Hello johnsd.

    OK...can you change in the log in to Gnome Classic,and see if it will let you log in?

    FFedora

    fedoraforum.org-Wallpapers
    https://forums.fedoraforum.org/group.php?discussionid=304&do=discuss

  7. #22
    Join Date
    Jun 2018
    Location
    Timaru, NZ
    Posts
    27
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Fedora 29-30 upgrade - no second screen at boot each time

    Quote Originally Posted by FFedora
    Hello johnsd.

    OK...can you change in the log in to Gnome Classic,and see if it will let you log in?

    Yes - I could try that (and will sometime). But in the interests of time and work I need to get done I will leave it for now and workable but not really solved.
    Thanks for the help.
    Regards
    John

  8. #23
    Join Date
    Feb 2005
    Location
    London, UK
    Posts
    1,014
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)

    Re: Fedora 29-30 upgrade - no second screen at boot each time

    Quote Originally Posted by johnsd
    I have just spotted the reason for this - the login screen has moved to the secondary display - the one that is not active until the login has completed. The screen that is now has the login request is not the primary display. Weird.
    I just re-read this thread and spotted this. Firstly, lets switch back to GDM (systemctl --now disable lightdm && systemctl --now enable gdm) and when you login again select the usual Gnome (not classic) so you're right back to where you're started and we can apply a solution that should fix the problem:

    When you change the display/monitor settings in Gnome it doesn't automatically apply to GDM (I thought it did, maybe that's a newish bug or my memory is wrong). You can copy the Gnome monitor config to GDM by simply copying the monitors.xml file from your users config to GDM as per below (you'll need to append it with "sudo" or be root). I'd try copying the file before making any changes, testing it, if it doesn't work then switch monitors in gnome config, copy the file again and retest.

    Code:
    cp ~/.config/monitors.xml /var/lib/gdm/.config/
    Regards,

    Haydn,

  9. #24
    Join Date
    Jun 2018
    Location
    Timaru, NZ
    Posts
    27
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Fedora 29-30 upgrade - no second screen at boot each time

    Quote Originally Posted by HaydnH
    I just re-read this thread and spotted this. Firstly, lets switch back to GDM (systemctl --now disable lightdm && systemctl --now enable gdm) and when you login again select the usual Gnome (not classic) so you're right back to where you're started and we can apply a solution that should fix the problem:

    When you change the display/monitor settings in Gnome it doesn't automatically apply to GDM (I thought it did, maybe that's a newish bug or my memory is wrong). You can copy the Gnome monitor config to GDM by simply copying the monitors.xml file from your users config to GDM as per below (you'll need to append it with "sudo" or be root). I'd try copying the file before making any changes, testing it, if it doesn't work then switch monitors in gnome config, copy the file again and retest.

    Code:
    cp ~/.config/monitors.xml /var/lib/gdm/.config/
    Regards,

    Haydn,
    Thanks Haydn - my monitors.xml file is full of stuff from ages ago. Am i safe to delete the parts that are old? I do not want to end up with the situation of not being able to log in when now I can even though
    the login is not visible!

    John

  10. #25
    Join Date
    Feb 2005
    Location
    London, UK
    Posts
    1,014
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)

    Re: Fedora 29-30 upgrade - no second screen at boot each time

    If you're unsure you can make a backup of the file (cp monitors.xml monitors.xml.old) and restore it if you break something. Do you have another PC (or tablet?) in the house? It couyld be an idea to setup ssh so that if the worst really does happen and you can't even see to restore the file you could still ssh in, fix the issue and reboot.

  11. #26
    Join Date
    Jun 2018
    Location
    Timaru, NZ
    Posts
    27
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Fedora 29-30 upgrade - no second screen at boot each time

    OK - thanks. I will get to sort this out but in the mean time I have got some serious hours of work to put in so will leave it until I have got some time especially time for something that might go wrong.
    John

  12. #27
    Join Date
    Jun 2004
    Location
    Maryland, US
    Posts
    7,589
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)

    Re: Fedora 29-30 upgrade - no second screen at boot each time

    Quote Originally Posted by HaydnH
    If you're unsure you can make a backup of the file (cp monitors.xml monitors.xml.old) and restore it if you break something. Do you have another PC (or tablet?) in the house? It couyld be an idea to setup ssh so that if the worst really does happen and you can't even see to restore the file you could still ssh in, fix the issue and reboot.
    Or press Ctrl+Alt+F2 to get to the virtual console, log in and move the file back. That console doesn't need the monitors.xml file

Page 2 of 2 FirstFirst 1 2

Similar Threads

  1. Replies: 1
    Last Post: 12th April 2013, 11:19 PM
  2. Screen res. problem at boot time - F6
    By thickbrain in forum Installation, Upgrades and Live Media
    Replies: 3
    Last Post: 19th July 2007, 01:36 AM
  3. Screen res. problem at boot time - F6
    By thickbrain in forum Using Fedora
    Replies: 4
    Last Post: 19th July 2007, 01:30 AM
  4. FC6 x86-64 - Blank screen during boot time. Help!
    By Sword7 in forum EOL (End Of Life) Versions
    Replies: 0
    Last Post: 6th January 2007, 04:27 AM
  5. Screen messed up only on boot time
    By dryicerx in forum Hardware & Laptops
    Replies: 2
    Last Post: 16th September 2005, 07:02 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •